Jump to content

My Browser Builds (Part 3)

Recommended Posts

8 hours ago, NotHereToPlayGames said:

I haven't stumbled into any cases where ProxHTTPSProxy or HTTPSProxy is "needed".  I do not use Windows Updates and it seems that's really the only thing where there is a "need".

Not really! :no: There are a lot of programs using IE8 engine to connect to internet. For example some email clients, the update function of some programs and so on. :yes: Access to WU or MU is only one area of application. If the system itself has to access an url which needs TLS 1.2 protocol, you have to use one of these proxies system-widely. I thought you read my article "ProxHTTPSProxy and HTTPSProxy in Windows XP for future use". slarme.gif I already described it there in detail. Therefore your statement is not correct.

Cheers, AstroSkipper travail-ordi.gif

PS: BTW I wouldn't have started a thread about these proxies and logically I wouldn't have maintained them if there hadn't been any need to preserve and prepare them for future use. And to access MU or WU two other methods exist too where there is no "need" of these proxies. These methods are described in this post: 


Edited by AstroSkipper
Link to comment
Share on other sites

37 minutes ago, Dave-H said:

Many thanks! :thumbup I'd have expected an auto redirection to take place to the new hostname ("thedndsanctuary.eu" -> "dndsanctuary.eu"), but it's probably just me being "grumpy" :P ...

Edited by VistaLover
Link to comment
Share on other sites

5 hours ago, NotHereToPlayGames said:

If you can visit the below website WITHOUT being asked to prove that you are human, then you are PASSING the Cloudflare browser checks.


5 hours ago, VistaLover said:

A definitive "CloudFlare Browser Check" is trying to log-in to GitLab:


I only see raybuck DNS queries when my Proximitron Reborn fails to load that test site, no gitlab DNS queries.

Are you thinking that I only need to bypass gitlab and then Proxomitron Reborn will at least access that test site?

Link to comment
Share on other sites

On 5/12/2022 at 9:39 PM, Fierelier said:


Here's what happened when I tried to compile it on Devuan Chimaera amd64.

I presume the prerequisites are these:

apt install python2 autoconf2.13 build-essential ccache python2-dev unzip uuid zip curl libgtk2-dev libgconf2-dev yasm libasound2-dev libpulse-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libxt-dev
curl https://bootstrap.pypa.io/pip/2.7/get-pip.py -o get-pip.py
python2 get-pip.py

I had to patch up the GST_API_VERSION in the configure script, since it got detected wrongly as 0.10 for some reason. I can't really tell what everything even is, so I just redefined it as 1.0 at line 23036, below the if check under "# Check whether --enable-gstreamer or --disable-gstreamer was given.", this made the build progress further.

Unfortunately, I hit a snag:

 0:04.95 In file included from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/stl_wrappers/new:34,
 0:04.95                  from /usr/include/c++/10/bits/exception_ptr.h:40,
 0:04.95                  from /usr/include/c++/10/exception:147,
 0:04.95                  from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/system_wrappers/exception:3,
 0:04.95                  from /usr/include/c++/10/new:41,
 0:04.95                  from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/system_wrappers/new:3,
 0:04.95                  from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/stl_wrappers/cstdlib:28,
 0:04.95                  from /usr/include/c++/10/stdlib.h:36,
 0:04.95                  from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/system_wrappers/stdlib.h:3,
 0:04.95                  from /home/fierelier/Documents/mozilla45esr/toolkit/crashreporter/google-breakpad/src/common/linux/guid_creator.cc:35,
 0:04.95                  from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/toolkit/crashreporter/google-breakpad/src/common/linux/Unified_cpp_src_common_linux0.cpp:11:
 0:04.95 ../../../../../../dist/include/mozilla/mozalloc.h:184:33: error: ‘bad_alloc’ in namespace ‘std’ does not name a type
 0:04.95   184 | void* operator new(size_t size) MOZALLOC_THROW_BAD_ALLOC
 0:04.95       |                                 ^~~~~~~~~~~~~~~~~~~~~~~~

This seems to have cropped up in newer GCC versions in Linux:

Getting GCC 5.x, which from this, seems to be the only solution I understand, is super difficult on my up to date Linux. @roytam1 maybe you can implement a fix, from what you can read on the bugzilla link? I'm willing to keep building on my system.

@roytam1 any interest? I'd love to see your browsers on Linux as well

Link to comment
Share on other sites

On 4/28/2021 at 4:45 PM, rocknard said:

Hm... i don't know why, but some time ago (actually) i can't see some images and load the comments on this page: 3djuegos.com.

I use Mypal (a little outdated) and Basilisk (serpernt roytam) XP updated to last version and create clean profile to test. Reddit the same, can't load "view the entire discussion".

Any hint or browser to use?


Any possibility of a fix in the near future for Reddit "view entire discussion"?

Thanks sir

Link to comment
Share on other sites

3 hours ago, Fierelier said:

@roytam1 any interest? I'd love to see your browsers on Linux as well

I would also like that too - I've been using Endeavour OS today - overall its impressive and light on resources and I feel Serpent still has a purpose as @roytam1 works hard to maintain it.

EDIT (on XP)

Sadly, though, no matter how hard I try, I just can't be satisfied enough to let go of XP for linux. Overall this was fine, but not a replacement for windows and I Keep going back. Not sure, but for now I'm stuck with it until the time comes and no plans to get anything new anytime soon.



Edited by XPerceniol
Link to comment
Share on other sites

@roytam1 Unfortunately I'm not very familiar with the code base, nor am I very talented with anything C. Could you look at the, I think, related bugzilla thread maybe? https://bugzilla.mozilla.org/show_bug.cgi?id=1269171 -- I will spend the time to build and test on Linux, I wish I could be of more use. It's fine if it's too complex to resolve.


Edited by Fierelier
Link to comment
Share on other sites

You guys (seriously) don't want me in charge of the code or anything. If I were, likely, when you tried to empty the trash, a old lady would barge through your front door with a broom and dustpan, and if you tried to flush the browser cache, your toilet would flush. When I start taking things apart they usually don't go back together, on other words, anything I touch turns to **** :P

Link to comment
Share on other sites

On 5/24/2022 at 10:20 AM, roytam1 said:

the problem is in old libstagefright bundled in UXP as it can't find any tracks from that MP4 file.
I need to dig upstreams to see if there is a fix for this issue.

On 5/25/2022 at 6:55 PM, roytam1 said:

Many thanks indeed for identifying the root cause of that "small annoyance" (I'm not that often on Twitter, anyway :P...), congrats for managing to fix it, after all! :thumbup

However, it seems I "attract" Serpent bugs "like a moth to a flame", because I just bumped on a new regression I consider far more serious :( than the inability to play back a specific GIFV Twitter clip: Currently, Serpent 52's native (JS-based) PDF Viewer (pdf.js) is BROKEN :angry: .


1. Install latest Serpent 52 32-bit build;
package filename: "basilisk52-g4.8.win32-git-20220521-3219d2d-uxp-1e871780f-xpmod.7z"
2. Launch a fresh, pristine, St52 profile
3. Load "about:preferences#applications"; you should be able to verify that the default action (handler) for PDF files is "Preview in Serpent":


4. Open a new tab and try to load the remote PDF file below:


Alternatively, drag-n-drop onto that new tab a locally saved PDF file

5. Expected Behaviour: The PDF file should be rendered in St52's native PDF viewer (pdf.js);
actual result: An empty tab :realmad: :


1 hour ago, roytam1 said:

but I don't have time

I do understand :wub: ; time is also precious here, but to save you some precious time, I narrowed down a regression range:

Last GOOD build: "basilisk52-g4.8.win32-git-20220423-f94c0da-uxp-059e35a46-xpmod.7z":


First BAD build: "basilisk52-g4.8.win32-git-20220430-3219d2d-uxp-cf4e046f9-xpmod.7z":


Hopefully, this can be identified and remedied in time for Saturday's UXP "releases" ;) :) ...

Edited by VistaLover
Link to comment
Share on other sites

10 hours ago, NotHereToPlayGames said:

I haven't stumbled into any cases where ProxHTTPSProxy or HTTPSProxy is "needed".

They're not needed with @roytam1's Mozilla-based browsers, which have their own up-to-date TLS support built in. So the topic doesn't come up often in this thread. But both IE 8 and Chromium-based browsers use the TLS support built into Windows. The only use case for IE 8 these days is Windows/Microsoft Update and the Update Catalog, but the modern Internet often needs a Chromium-based browser on WinXP (to support the increasingly "Googlized" JavaScript language), yet also cryptographic functions that WinXP doesn't support.

Although ProxHTTPSProxy and its brethren were originally designed to use Proxomitron with secure sites, they have the useful side effect of supporting cryptography beyond what WinXP has built in, so you can browse sites that require newer cryptographic functions with Chromium-based browsers.

360EE may be a special case; since it was designed to bring newer Chromium versions to the WinXP platform, it may have more up-to-date TLS support built in. I don't know.

8 hours ago, NotHereToPlayGames said:

Secure DNS (I do not use it and see it as "hype and propaganda").

That's because you don't know its true purpose. It's been sold as a way to prevent eavesdroppers (including your ISP) from learning what sites you visit, and it does do that; but I believe its true purpose is a bit more sinister.

I'm sure lots of folks here have used their "hosts" file to deliberately block telemetry, malware, or advertising servers. It's a simple but often quite effective tactic. There's even a network-wide version of this trick, called a "Pi-Hole," that's a deliberately defective DNS server to block those servers across your entire home network.

These tricks have become a concern for the Googles of the world, whose business models rely on collecting our data and serving ads; so much so that some of them are building their own DNS clients into their adware to bypass any such misdirection. The built-in server always goes to the IP address of a well-known DNS server, thus bypassing any hosts file entries, Pi-Holes, or what have you.

But that trick can be blocked too - at the router! The router can just be programmed to route requests to, say,, over to your local Pi-Hole instead. So the ad servers still get redirected and blocked.

That's where Secure DNS comes in. If you redirect Secure DNS requests, the client will know about it, because the certificate will be incorrect. At that point, the client just says, "if I can't connect to my real DNS server, I'm not going to run at all! You either accept my telemetry and ads, or you get nothing! Good day, sir!"

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...