Jump to content

Fierelier

Member
  • Posts

    8
  • Joined

  • Last visited

  • Donations

    $0.00 
  • Country

    Germany

About Fierelier

Profile Information

  • OS
    Windows 7 x64

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Fierelier's Achievements

4

Reputation

  1. @roytam1 Unfortunately I'm not very familiar with the code base, nor am I very talented with anything C. Could you look at the, I think, related bugzilla thread maybe? https://bugzilla.mozilla.org/show_bug.cgi?id=1269171 -- I will spend the time to build and test on Linux, I wish I could be of more use. It's fine if it's too complex to resolve. https://hg.mozilla.org/mozilla-central/rev/a640e6fa8ab9 https://hg.mozilla.org/mozilla-central/rev/68da139d0866
  2. I think it's not an important fix for as long as this solution exists. I've made a greasemonkey script that automatically changes these URLs, if you're interested: https://git.lumen.sh/Fierelier/fiers-grease/src/branch/master/Reddit - Old layout.user.js - Just click on Raw on top of the code to install it.
  3. @mockingbird Try replacing "www.reddit.com" in the url with "old.reddit.com"
  4. @roytam1 any interest? I'd love to see your browsers on Linux as well
  5. @jmeno I get the same feeling. It was all very sudden, and everyone was on board with it. It's worth remembering that Microsoft is one of Python's biggest backers. @vxiiduu I'm happy to see that, though I'm more worried about the future of TLS. Windows XP seems to be in a bit of rut because of it still and I'm afraid the same will happen to 7.
  6. Here's what happened when I tried to compile it on Devuan Chimaera amd64. I presume the prerequisites are these: apt install python2 autoconf2.13 build-essential ccache python2-dev unzip uuid zip curl libgtk2-dev libgconf2-dev yasm libasound2-dev libpulse-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libxt-dev curl https://bootstrap.pypa.io/pip/2.7/get-pip.py -o get-pip.py python2 get-pip.py I had to patch up the GST_API_VERSION in the configure script, since it got detected wrongly as 0.10 for some reason. I can't really tell what everything even is, so I just redefined it as 1.0 at line 23036, below the if check under "# Check whether --enable-gstreamer or --disable-gstreamer was given.", this made the build progress further. Unfortunately, I hit a snag: 0:04.95 In file included from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/stl_wrappers/new:34, 0:04.95 from /usr/include/c++/10/bits/exception_ptr.h:40, 0:04.95 from /usr/include/c++/10/exception:147, 0:04.95 from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/system_wrappers/exception:3, 0:04.95 from /usr/include/c++/10/new:41, 0:04.95 from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/system_wrappers/new:3, 0:04.95 from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/stl_wrappers/cstdlib:28, 0:04.95 from /usr/include/c++/10/stdlib.h:36, 0:04.95 from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/dist/system_wrappers/stdlib.h:3, 0:04.95 from /home/fierelier/Documents/mozilla45esr/toolkit/crashreporter/google-breakpad/src/common/linux/guid_creator.cc:35, 0:04.95 from /home/fierelier/Documents/mozilla45esr/obj-x86_64-unknown-linux-gnu/toolkit/crashreporter/google-breakpad/src/common/linux/Unified_cpp_src_common_linux0.cpp:11: 0:04.95 ../../../../../../dist/include/mozilla/mozalloc.h:184:33: error: ‘bad_alloc’ in namespace ‘std’ does not name a type 0:04.95 184 | void* operator new(size_t size) MOZALLOC_THROW_BAD_ALLOC 0:04.95 | ^~~~~~~~~~~~~~~~~~~~~~~~ ... This seems to have cropped up in newer GCC versions in Linux: https://bugzilla.mozilla.org/show_bug.cgi?id=1269171 Getting GCC 5.x, which from this, seems to be the only solution I understand, is super difficult on my up to date Linux. @roytam1 maybe you can implement a fix, from what you can read on the bugzilla link? I'm willing to keep building on my system.
  7. @roytam1 Do you think it would be possible to build your Firefox 45 ESR on Linux? If yes, how? How would I decide over SSE2? Thank you.


×
×
  • Create New...