Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


reboot12

YT may not work on old browsers anymore, starting March 2020

Recommended Posts

For several days in WinXP on Google Chrome a message appears (yellow bar) as in the picture in the attachment.

 

chrome_YT_luty_2020.png

Share this post


Link to post
Share on other sites

This is because of Youtube retiring the pre-Polymer layout which was far more snappier than the current Polymer layout which was obviously destined to work perfectly for Chrome only.  This is their apparent reason (thx to spaztron64)

Quote

image.png.3213e84dfef946b173be9f811e43c2db.png

 

Share this post


Link to post
Share on other sites

The message as it appears (in Polish)

Niedługo przestaniemy obsługiwać tę przeglądarkę. Aby zapewnić sobie jak najlepsze wrażenia, zaktualizuj ja.

translates to (in English)

We will soon stop supporting this browser. To get the best experience, update it.

But there is a link in there, where does it go?

  • Like 1

Share this post


Link to post
Share on other sites

The most important advantage of the Classic Layout, especially for old browsers, is that it gets displayed without JS too, for at least seeing what the video is about, description, date, number of downloads, likes etc. And then it's possible to get direct video links with sophisticated userscripts.

But with old system, old browsers, short on RAM etc, and blocked JS (which would only freeze anyway) it's a disaster now: neither Mobile nor "Modern" Layout shows anything ecxept gray fields or black box, zero text, and the direct embed-link only opens an error page. Which doesn't contain even descriptions in the source.

At the moment my only one -lousy- workaround for any non-Classic view is to load the full (300kb) page source with Ctrl+U in Notepad++, then run Plugins > JS Tool > JS Format, and scroll down to almost bottom to finally see some readable text at least. How to get the video download links the future will tell. Perhaps using 3rd-party websites again, or someone can update the userscripts?

  • Like 3

Share this post


Link to post
Share on other sites
4 hours ago, reboot12 said:

For several days in WinXP on Google Chrome a message appears (yellow bar) as in the picture in the attachment.

I cannot reproduce with Firefox 52.9.0. That is Chrome 49.0.2623.112m, correct? Have you tried with Yandex 17.x (which you also use)?

52 minutes ago, Tripredacus said:

But there is a link in there, where does it go?

My guess would be Update your browser for the best viewing experience.

Share this post


Link to post
Share on other sites
4 hours ago, Tripredacus said:

We will soon stop supporting this browser. To get the best experience, update it.

But there is a link in there, where does it go?

it looks like the outdated chrome 49 I don't think to many people are still using it.

Share this post


Link to post
Share on other sites
12 hours ago, Vistapocalypse said:

I cannot reproduce with Firefox 52.9.0

That's because FxESR 52 gets by default the (supported) Polymer v1 (Pm1) layout; only versions of Firefox older than 44 (Fx <=43) are being served the Classic layout, the one to be retired in March; if you use a UAO on FxESR 52 to spoof it as Fx 43, you'll get the older layout with the deprecation infobar: 

rqzJzcn.jpg

BTW, Firefox (Quantum) versions newer than 62 (63 =< Fx) are being served the newer Polymer v2 (Pm2) layout, which, on the outside, looks a lot like Pm1, but on the inside it's quite a different beast... FxESR 52 and the UXP browsers don't currently support it; of course FxESR 52 isn't maintained anymore, but MCP devs are already making talk about "upgrading" UXP to support Pm2 in the coming months; Google have not yet indicated for how long they'll keep supporting Pm1 :dubbio:

Pm1 is considerably more resource hungry compared to the out-going Classic style, and this fact alone will create problems for older browsers capable of handling Pm1 but which are installed on old hardware (which seems to be the case with many XP/Vista users here... :( )

Of course, the forced migration to Pm1 will disable many user YT customisations, in the forms of XUL extensions, userstyles, userscripts etc., which were initially targeting the Classic layout; sadly, it'll be game over for those older browsers (on, perhaps, even older OSes/hardware) that can't cope with Pm1 at all... :}

Some relevant links:

https://support.google.com/youtube/thread/27596769

https://www.reddit.com/r/youtube/comments/eyjy4i/misc_fd_youtube_is_removing_the_old_design_soon/

https://forum.palemoon.org/viewtopic.php?f=3&t=23566

12 hours ago, Vistapocalypse said:

That is Chrome 49.0.2623.112m, correct

9 hours ago, caliber said:

it looks like the outdated chrome 49 I don't think to many people are still using it.

Chrome 49 has adequate support for Pm1, so if OP wants to continue using it for YT past March 2020, OP must:

Install the User Agent Switcher extension from GWS:

https://chrome.google.com/webstore/detail/user-agent-switcher/kchfmpdcejfkipopnolndinkeoipnoia

Set a "Permanent Spoof" for youtube.com domain (aka SSUAO) and pretend to be Firefox 60 (e.g. Mozilla/5.0 (Windows NT 6.3; rv:60.0) Gecko/20100101 Firefox/60.0); then, every time a YT URL is loaded, OP will get the supported Pm1 layout without any nags about an unsupported browser:

sG4KDcj.jpg

However, that workaround will, sadly, come to an end when evil Google decide to remove Pm1, too (which can be anytime, I hazard a guess and predict some time towards the end of this year) :realmad: .

Edited by VistaLover
Fixed PM forum link
  • Like 7

Share this post


Link to post
Share on other sites
11 hours ago, Vistapocalypse said:
12 hours ago, Tripredacus said:

But there is a link in there, where does it go?

My guess would be Update your browser for the best viewing experience.

Actual link is (no surprises there) :

https://www.youtube.com/supported_browsers

InPbvBG.jpg

Except for Firefox Browser (which is simply a Chrome wannabe :angry: ), all three other alternatives are Chromium based... :realmad: 

Edited by VistaLover
Added screenshot

Share this post


Link to post
Share on other sites
1 hour ago, VistaLover said:

That's because FxESR 52 gets by default the (supported) Polymer v1 (Pm1) layout; only versions of Firefox older than 44 (Fx <=43) are being served the Classic layout, the one to be retired in March

Yeah, I decided to test that with dear old Tycho (forked from Firefox 38 if I remember correctly). Is the situation the same for Yandex 17 as for Chrome 49?

2055247918_YTwillstopsupportingthisbrowser.JPG.0d432e52bcd67577681e00a053ddf5f2.JPG

 

 

 

Edited by Vistapocalypse

Share this post


Link to post
Share on other sites
16 minutes ago, Vistapocalypse said:

I decided to test that with dear old Tycho (forked from Firefox 38 if I remember correctly).

Yes, the Tycho (platform) codebase was forked off Mozilla ESR 38 but (official) PM27, IIRC, comes with a native SSUAO for youtube; I don't have it handy ATM, but I believe it is advertising itself as Fx 42 to YT; low enough to make YT nag about it... :}

22 minutes ago, Vistapocalypse said:

Is the situation the same for Yandex 17 as for Chrome 49?

I am delighted to report that YB 17.6.0.1633 (built on Chromium 58.0.3029.1633) gets served, as of this writing, the most recent YT iteration, i.e. Material Design with Polymer version 2 layout: 

r1TEbxi.jpg

(if you place the cursor on a video thumbnail, you get a video preview)

Thus, I expect YB to work on YT for the foreseeable future; BTW, I composed this post using that very browser, so expect details of our exchange to reach President Putin's ears... (joking, of course... :P :D )

Best regards

  • Like 3

Share this post


Link to post
Share on other sites

This is really starting to make me depressed. :( I use Firefox 52, and I don't get any yellow bar about unsupported browser or anything, and the actual "supported browsers" page even says "your up to date, enjoy youtube!" --

But all of a sudden, my own videos wont even load now from as far back as 2009. :( The video player screen says "your browser dont support html5" blah blah. I never used any special codecs or anything like that for my videos. Why would they stop working "now" ? Is it cause of that polymer thing you guys were discussing ??

https://www.youtube.com/user/kujakiller/videos

This is my page.  And for the record, i watch this guy's videos everyday -- https://www.youtube.com/channel/UCAC65YxT-jEDYg0psBcAoOw/videos

and only "now" suddenly the video player wont load cause of that stupid annoying "dont recognize formats, html5" ..but i was just able to watch everything literally yesterday. :(

I tried to change the user agent to firefox 60 but that didnt help.

Share this post


Link to post
Share on other sites
8 hours ago, VistaLover said:

Actual link is (no surprises there) :

https://www.youtube.com/supported_browsers

Except for Firefox Browser (which is simply a Chrome wannabe :angry: ), all three other alternatives are Chromium based... :realmad: 

why is it greyed out when using user agents on F52 ?

screenshot-20.png

 

Share this post


Link to post
Share on other sites

This is really starting to make me depressed. :( I use Firefox 52, and I don't get any yellow bar about unsupported browser or anything, and the actual "supported browsers" page even says "your up to date, enjoy youtube!" --

But all of a sudden, my own videos wont even load now from as far back as 2009. :( The video player screen says "your browser dont support html5" blah blah. I never used any special codecs or anything like that for my videos. Why would they stop working "now" ? Is it cause of that polymer thing you guys were discussing ??

https://www.youtube.com/user/kujakiller/videos

This is my page.  And for the record, i watch this guy's videos everyday -- https://www.youtube.com/channel/UCAC65YxT-jEDYg0psBcAoOw/videos

and only "now" suddenly the video player wont load cause of that stupid annoying "dont recognize formats, html5" ..but i was just able to watch everything literally yesterday. :(

I tried to change the user agent to firefox 60 but that didnt help.

The videos on both your links work fine here on Firefox 52.9.1 ESR.
What HTML5 support do you have in your browser, is it the Adobe Primetime Content Decryption Module?
That's what I'm using.
:)

Edited by Dave-H
Quote added
  • Like 1

Share this post


Link to post
Share on other sites
13 minutes ago, Dave-H said:

The videos on both your links work fine here on Firefox 52.9.1 ESR.
What HTML5 support do you have in your browser, is it the Adobe Primetime Content Decryption Module?
That's what I'm using.
:)

Well i did notice some of my videos are okay, but others not like the oldest one --

8 Way Scrolling Test on Megaman 3 - 2,920 views - 11 years ago -- or my most recent one from 2018 - "Rockman 2 Slide and Charge" :(

I have a greasemonkey script that automatically adds a "?disable_polymer=1" to end of all youtube links, cause that regular screen format they use looks terrible and no images load, etc. That cant be it though, cause i've had that there for at least 2 years already. (i temporarily turned off the greasemonkey script, but that didnt make a difference, still "no format recognized blah blah".

here's a screenshot of the plugins screen

5wnfXr6.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...