Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


roytam1

My build of New Moon (temp. name) a.k.a. Pale Moon fork targetting XP

Recommended Posts

Rightclick context menu appears to have healed in UXP Basilisk.

Edited by 404notfound

Share this post


Link to post
Share on other sites

3 hours ago, 404notfound said:

Rightclick context menu appears to have healed in UXP Basilisk.

Same here, the missing addons are back.

Share this post


Link to post
Share on other sites

''The problem is that reCaptcha started using javascript functions not available on older browsers, they should send different scripts depending on browsers version but they are lazy and decided to stop supporting older browsers.

There is not much we can do, your only choice is to use a newer browser but that will need a newer OS.

Micro$oft is going to start forcing windows 7 users to upgrade to windows 10, they actually pay money to game developers to create games only compatible with windows 10, thats the way it works.

Sooner or later we all get wasted.''

Share this post


Link to post
Share on other sites

That quote was from the browser.taokaizen.com (author of advanced Chrome for XP/Vista, etc.) forum admin. Guess they don't know about @roytam1's work ;)

  • Like 3

Share this post


Link to post
Share on other sites

I run NM 27 and basilisk 55 on multiple machines.

But I tweak the preferences and addons on a single machine, and then copy the profiles over to the other machines.

I'm thinking about using the built-in password manager:  Remember Passwords / Auto Fill In / Master Password

I'm wondering if that will play nice and copy to the other machines, or if I'm going to run into problems.

Any thoughts ?

Share this post


Link to post
Share on other sites
8 hours ago, CoRoNe said:

I may have missed your post on this, but is there a reason you're not releasing sse builds for PM28?

Its javascript engine requires SSE2, it will output SSE2 instructions to processor even you don't use SSE2 to compile it.

Share this post


Link to post
Share on other sites

Understood. I guess it's really about time now for me to buy a new computer.

Happy user of palemoon-27.9.1a1.win32-git-20181215-c581f09b3-xpmod-sse. Thanks!

Share this post


Link to post
Share on other sites

Is it normal that whenever I visit Reddit using the old.reddit.com link, so that I could get old design instead of the sluggish new one, Reddit doesn't remember the language I set it to? It only remembers setting a different language as long as I don't turn off the browser (NM), but when I do, start it again later and visit Reddit, it revert back to English for some reason... I don't recall this behavior in Firefox 52, though I feel like it's the same way on it as well anyway. I didn't set NM to clear cookies/cache whenever I close it so it's definitely not that.

Share this post


Link to post
Share on other sites
16 hours ago, Tamris said:

Is it normal that whenever I visit Reddit using the old.reddit.com link, so that I could get old design instead of the sluggish new one, Reddit doesn't remember the language I set it to? It only remembers setting a different language as long as I don't turn off the browser (NM), but when I do, start it again later and visit Reddit, it revert back to English for some reason...

Merry Christmas to you :)

Your "interface language selection" on old.reddit.com is stored in the form of session browser cookies ; as their name suggests (and in accordance with your findings), they remain valid for the duration of a browser session; once the browser is exited, they auto-expire... If you want your selection to persist across browser sessions, you have to somehow turn the controlling cookie(s) from session to permanent ones...

The above can be accomplished via developer tools, but it's a lot easier via the use of cookie-editing extensions... I personally use CookieKeeper 1.9.3.1 (on New Moon 28.3.0a1): this specific extension is capable of editing cookie properties as well as "protecting" cookies from browser deletion; in the screenshot that follows, I have indicated for you the session cookies (that store language selection) that need to be edited and "protected":

Before:

ME4U6pD.jpg

After:

Z1QjtK6.jpg 

You can find and install CookieKeeper via Classic Add-ons Archive (I posted about it a few pages back), usage info for CK can be retrieved easily online... ;)

Edited by VistaLover
  • Like 1

Share this post


Link to post
Share on other sites

@VistaLover Thanks a lot as usual. :) Did what you said and it Reddit now stays in a language I set it to at all times.

Also seems that the guy behind Aeromoon and a couple other themes updated them to be compatible with NM 28.3 (and he made the address bar a bit too bright but oh well) so if anyone's using any of these and Expose Noisy Tabs addon, it's no longer needed.

Edited by Tamris
  • Like 1

Share this post


Link to post
Share on other sites
On 12/19/2018 at 1:30 PM, Inox said:

I'm not advanced in browsers and I've got old laptop with Windows XP and processor Intel Celeron M 1500MHz (probably with SSE) and 1GB RAM. I use it frequently because i use old utility programs that don't "like" newer systems. Could You give me advice witch browser choose and what version (Palemoon xpmod or Basilisk xpmod) Thank You in advance.

https://en.wikipedia.org/wiki/List_of_Intel_Celeron_microprocessors#Netburst_based_Celerons_2

As you can see on page above - ALL mobile Celerons starting from 1400 Mhz have SSE2 instruction set. Therefore you can use modern browser that require SSE2.

Also you can look at bottom of your laptop to tell us (or me personally) what exact model of laptop you have - because A LOT of laptops allow you to replace processor on more powerful. I know examples when Yonah-based Celeron M was replaced on Core 2 Duo which triple up raw compute power of laptop. Used top processors for laptops from 2004-2009 era usually cost from 6 to 15 bucks and can be easily found in internet.

You also can right-click mouse on My Computer and choose "Properties" to see what processor do you have now. But to tell us what laptop do you have is also desirable if you want to know how upgrade your laptop, because remember - a lot of laptops can be upgraded in many ways. What i advise you, Inox, are simple tasks - no special skills are required for this.

On 12/19/2018 at 2:33 PM, Dibya said:

45 ear or palemoon sse or kmeleon goanna

Km gonna is best bet

Because it is obvious that Inox have SSE2 processor - it is logical to advise him to try new Pale Moon from roytam1.

Edited by Rod Steel

Share this post


Link to post
Share on other sites

Why the multiprocess mode is removed ? In XP only layers.async-pan-zoom.enabled badly works.

Some functions are included in PM28XP and they cannot work, but are included by default:

browser.taskbar.lists.enabled , gfx.direct2d.disabled , gestures.enable_single_finger_input , gfx.work-around-driver-bugs , media.hardware-video-decoding.enabled , media.wmf.enabled , media.windows-media-foundation.allow-d3d11-dxva , webgl.angle.try-d3d11 , webgl.enable-webgl2 , intl.tsf.enable - does not work in Windows XP.

layers.deaa.enabled , layers.gralloc.disable , stagefright.disabled - does not work in Windows.

plugins.rewrite_youtube_embeds - does not work

media.suspend-bkgnd-video.enabled , media.block-autoplay-until-in-foreground , layers.prefer-d3d9 , network.captive-portal-service.enabled - false....why?

Edited by grey_rat

Share this post


Link to post
Share on other sites
7 hours ago, grey_rat said:

Why the multiprocess mode is removed ?

As you probably know, these browsers are all forks from various Firefox releases. AIUI Firefox did not enable multiprocess mode (e10s) until version 53. All these browsers except one (Basilisk 55) were forked from FF versions prior to 53. Multiprocess mode was not "removed;" it was never there in the first place. (I could be wrong about this, but that's my best understanding of the situation.)

I don't know if Basilisk 55 supports multiprocess mode. AIUI it was forked from a pre-release version of FF 53 and I don't know what the status of e10s was at the particular release it was forked from.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...