Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


roytam1

My build of New Moon (temp. name) a.k.a. Pale Moon for XP

Recommended Posts

5 hours ago, caliber said:

I have been recently asked by a software maker why am I still using XP... :lol:

as I don't use any antivirus I actually don't care if the POSready updates will no longer be available within 5 months.

I just am afraid if the FF addons ever get removed from their site so I need to find a way to back up them all

https://www.trishtech.com/2018/10/use-older-firefox-extensions-through-classic-add-ons-archive/

I have pretty much found software alternatives for my needs so I can live with XP for a long time ahead.

 

I agree!! So long as this system is working I see no logical reason to just junk it. Just be cautious is all. There still (and will be for a while) are good software alternatives to use with XP. Just stick with New Moon and you can't go wrong. Even if I do get hacked, Acronis True Image will get me back to right where I am as I write this posting. Mainly your IP is all and avoid shady sites and you should be fine.

Thanks you roytam1 for your hard work and worry not about haters!

Edited by sal here
typo
  • Upvote 2

Share this post


Link to post
Share on other sites

23 hours ago, caliber said:

I have been recently asked by a software maker why am I still using XP... :lol:

Today I booted up XP to run the latest basilisk and can't get over how fast and stable it is, that's usually my answer to those who ask why anyone bothers.

Those having fits over XP are probably software developers who want it to disappear since it means extra work if they have to keep coding for it. Understandable but Microsoft is the one who has been keeping it around as much as anyone. It wouldn't surprise me if they extended POSReady for another year :--)

Share this post


Link to post
Share on other sites
1 hour ago, DanR20 said:

It wouldn't surprise me if they extended POSReady for another year

I, however, would be damn utterly flabbergasted! :yes:

Share this post


Link to post
Share on other sites
22 hours ago, DanR20 said:

Today I booted up XP to run the latest basilisk and can't get over how fast and stable it is, that's usually my answer to those who ask why anyone bothers.

Those having fits over XP are probably software developers who want it to disappear since it means extra work if they have to keep coding for it.

it depends on what you compare the Basilisk to. it's faster than Firefox 52 for sure but it's kind of a snail compared to the other versions that are not compatible with XP

it's not just a matter of extra work but the programs used by developers get renewed and do not support XP anymore that makes it impossible to code anything for XP.
 

Edited by caliber
  • Upvote 1

Share this post


Link to post
Share on other sites
On 11/19/2018 at 6:27 PM, caliber said:

it depends on what you compare the Basilisk to. it's faster than Firefox 52 for sure but it's kind of a snail compared to the other versions that are not compatible with XP

it's not just a matter of extra work but the programs used by developers get renewed and do not support XP anymore that makes it impossible to code anything for XP.
 

When I updated my FF ESR to one with Quantum engine, on win8 x86 work PC with Intel Celeron CPU, it was actually slower :p
I even downgraded it to old ESR and turned off upgrades.

Edited by 404notfound

Share this post


Link to post
Share on other sites

"Quantum" sounds so fast too (even though the term has nothing to do with speed). So much for marketing

Share this post


Link to post
Share on other sites
3 hours ago, 404notfound said:

When I updated my FF ESR to one with Quantum engine, on win8 x86 work PC with Intel Celeron CPU, it was actually slower :p

I honestly hope you did make a back-up of your FxESR 52 profile PRIOR to making the Quantum leap (pun intended) to FxESR 60; and even then, there's so much that has changed going from ESR 52.9.0 to ESR 60.3.0, that, if I were you, I would start by creating a new clean profile in 60.3.0 and then selectively transferring bits (e.g. bookmarks, passwords) from the backed-up 52.9.0 profile; I would re-install and reconfigure only those addons (WE format by default) that are truly Quantum compatible, all other addon stuff used in 52.9.0 should be left behind... Many people posted in the mozillazine forums they had sub-optimal results by doing an on-top upgrade... Though cumbersome, in the case of such major overhauls, it is advised one starts one's profile from scratch...

3 hours ago, 404notfound said:

I even downgraded it to old ESR

60.3.0 profile is not backwards compatible with the previous 52.9.0 one, so, again, a backed-up profile should be used when downgrading... Hopefully you already know all that :) and I'm just pointing the obvious, perhaps only for the benefit of other readers not fully aware...

Cheers

Edited by VistaLover

Share this post


Link to post
Share on other sites

And that's why I chose to make the leap to Basilisk, even on Win 7. Much smoother/simpler upgrade path.

  • Like 1

Share this post


Link to post
Share on other sites

Whats the correct procedure to update and keep existing settings. Is it simply extracting new binaries over your current installation.

Share this post


Link to post
Share on other sites
2 hours ago, ricardrosen said:

Whats the correct procedure to update and keep existing settings. Is it simply extracting new binaries over your current installation.

Yes. But if you're doing update with major version changed (for example v27 to v28), it is better to backup your profile folder in case you might need to downgrade.

If you don't use portable-loader, your PM profiles are located at "%APPDATA%\Moonchild Productions\Pale Moon"

Share this post


Link to post
Share on other sites

New build of basilisk/UXP for XP!

Test binary:
Win32 https://o.rths.cf/basilisk/basilisk52-g4.1.win32-git-20181124-b37e8f87c-xpmod.7z
Win64 https://o.rths.cf/basilisk/basilisk52-g4.1.win64-git-20181124-b37e8f87c-xpmod.7z

diff: https://o.rths.cf/basilisk/UXP-xp-gitdiff-20181110.7z

PM28XP build:
Win32 https://o.rths.cf/palemoon/palemoon-28.2.0a1.win32-git-20181124-b37e8f87c-xpmod.7z
Win64 https://o.rths.cf/palemoon/palemoon-28.2.0a1.win64-git-20181124-b37e8f87c-xpmod.7z

Official repo changes since my last build:
- Add support to libstagefright for AV1 FourCCs (df59d06fd)
- Issue #638 - Part 1: Provide a visual indicator for muting/unmuting tabs (becd71a86)
- Issue #638 - Part 2: Add tooltip to mute/unmute buttons (ae48428aa)
- Issue #638 - Part 3: Add a keyboard shortcut for toggling the tab mute state (15afe6807)
- Issue #638 - Part 4: Add tab sound icon to tab drop-down list (719234847)
- Issue #638 - Part 5: Add mute/unmute option to tab context menu (eff89e1c9)
- Issue #638 - Part 6: Fix up remaining references - Refactor _tabAttrModified to accept two parameters - Modify consumers of _tabAttrModified to pass details - Add missing _soundPlayingAttrRemovalTimer field - Add missing checks for mute/unmute around the tab browser - Tab sound icon should inherit 'selected' attribute instead of 'visuallyselected' (d56c1ceac)
- [PALEMOON] Align the places component with the updated PlacesUtils API (b32323fae)
- Issue #638 - Part 7: Remove hover and active states for sound indicator (66cc7d91a)
- Issue #638 - Part 8: Add overlay sound icon for pinned tabs - This also moves some styles to tabbrowser.css (a6b250b47)
- Issue #638 - Part 9: Add sound icon to all tabs menu (fe4c12e2d)
- Issue #638 - Part 10: Rename all tabs sound icon to be consistent with others - alltabs => allTabs (deb4791e2)
- Follow-up: Add missing getTabFromAudioEvent method (61b21c808)
- Fix undefined isSameDocument (a681891e6)
- Hide mute menu item and disable mute hotkey with existing pref (af0164310)
- Add support to libstagefright for AV1 FourCCs (part 2) (4d8b7a376)
- Add AV1 support to MP4Decoder. (56c26d867)
- Replace toolbar PNG bitmaps with SVG vectors. (a5bdec9a6)
- Cleanup some comments in our media code. (011ec4885)
- Merge pull request #877 from trav90/code-cleanup (181e75728)
- Merge pull request #876 from trav90/add-av1-support (f4908ce99)
- Merge pull request #873 from JustOff/PR_bm_folders_copy_paste (be53c078d)
- Strip Inkscape data from toolbar SVGs and remove obsolete PNGs. (4fd138594)
- Merge pull request #874 from FranklinDM/sound_indicator-work (025b91375)
- Belated new cycle version bump (9ce2c56e1)
- Merge branch 'master' of https://github.com/MoonchildProductions/UXP (a6b9afbee)
- Add a nullcheck on pipelined HTTP connections' pushback. (2c0a30185)
- Update package.json (6a9c2be4e)
- Port WebP decoder changes. (238b430ec)
- Bug 1462355 - Part 1a. Make imgFrame animation parameters threadsafe. (807acf738)
- Bug 1462355 - Part 1b. Update Decoder and SurfacePipe plumbing to use updated imgFrame methods. (622098073)
- Bug 1462355 - Part 1c. Make individual image decoders to use updated Decoder/SurfacePipe methods. (3417e581c)
- Fix pasta error (b9003c9c5)
- Unrefactor mRawVeggies back to mVBuffMeat ;P (5b821064f)
- Split out FrameTimeout into its own header file for re-use. (a51993521)
- Fix blank pixel color for truncated GIFs (25f4c75d6)
- Merge branch 'webp-update' (a3da92549)
- Fix debug assertion. (b37e8f87c)

  • Like 2

Share this post


Link to post
Share on other sites

KmGoanna unable to play ogg file. How can I enable it?

Share this post


Link to post
Share on other sites

Looks like language packs are not compatible with today's update of NM? After updating the browser and starting it, I'm getting this error:

cnb6r0W.png

Then it disappears after a second and NM starts as usual, but it reverts back to the default english language (also the general.useragent.locale pref in about:config reverts back to en-US).

Share this post


Link to post
Share on other sites
7 hours ago, Ropip said:

Is it possible to get POSReady with Windwos XP Professional?

Wrong topic, please read

and ask any questions when in doubt :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×