Jump to content

My browser builds (part 2)


Recommended Posts

7 hours ago, roytam1 said:

Many thanks for still finding the time, between your hectic real life currently, to compile and offer these builds! :thumbup

7 hours ago, roytam1 said:

Official UXP changes since my last build:
(snipped)
Official Basilisk changes since my last build:
(snipped)
Official Pale-Moon changes since my last build:
(snipped)

I think I am one of the very few ;) (possibly the only one?) but I actually read closely and study these official changelogs every week (so rest assured your effort is not in vain...), but I am sorry to say :( this week's is a sorry mess...

7 hours ago, roytam1 said:

Official UXP changes since my last build:
- Issue #1656 - Fix broken comment from Part 1 (a2ed139a4)
- Merge pull request #1660 from g4jc/1656 (4e72f8ed0)
- Issue #1643 - Follow up: Add a null check for mOwner in ResizeObserverNotificationHelper::Unregister (fb086631d)
- Issue #1643 - Follow-up: Make sure things aren't changed while iterating. (bc531bfbb)
- Issue #1647 - Followup: Remove excessive VARIANT_OPACITY statements. (b8c604196)
- Merge pull request #1663 from athenian200/opacity_followup (96736fce7)
- Update CONTRIBUTING.md (15acac52b)

And this is identical to last week's:

On 10/3/2020 at 2:28 AM, roytam1 said:

Official UXP changes since my last build:
- Issue #1656 - Fix broken comment from Part 1 (a2ed139a4)
- Merge pull request #1660 from g4jc/1656 (4e72f8ed0)
- Issue #1643 - Follow up: Add a null check for mOwner in ResizeObserverNotificationHelper::Unregister (fb086631d)
- Issue #1643 - Follow-up: Make sure things aren't changed while iterating. (bc531bfbb)
- Issue #1647 - Followup: Remove excessive VARIANT_OPACITY statements. (b8c604196)
- Merge pull request #1663 from athenian200/opacity_followup (96736fce7)
- Update CONTRIBUTING.md (15acac52b)

I believe the correct changelog for this week is (what is currently listed under this week's PM changelog):

Official UXP changes since my last build:
- Issue #1665 - Take overflow-wrap into account when calculating min-content intrinsic size. (8e18743ab)
- Issue #1666 - Implement overflow-wrap: anywhere (dadef50bd)
- [devtools] Teach devtools about overflow-wrap: anywhere (521f2b476)
- Issue #1606 - Add support for multi-monitor DPI awareness v2 (W10 1706+) (bda6f1a93)

source:
https://github.com/MoonchildProductions/UXP/commits/master

7 hours ago, roytam1 said:

Official Pale-Moon changes since my last build:
- Issue #1665 - Take overflow-wrap into account when calculating min-content intrinsic size. (8e18743ab)
- Issue #1666 - Implement overflow-wrap: anywhere (dadef50bd)
- [devtools] Teach devtools about overflow-wrap: anywhere (521f2b476)
- Issue #1606 - Add support for multi-monitor DPI awareness v2 (W10 1706+) (bda6f1a93)

Correct changelog for this week is:

Official Pale-Moon changes since my last build:
- Back-end branch pointer update (Unstable 2020-10-04) (f6ae5e0)
- [app update] Move update cert entries to branding (b48aee5)
- Issue #1812 - Enable per-monitor DPI v2 in Pale Moon (762408f)
- [SSUAO] Update Yahoo override, since they now throw a fit when seeing anything "Pale Moon" in the UA. (aa3ff77)

source:
https://github.com/MoonchildProductions/Pale-Moon/commits/master

NB: http://rtfreesoft.blogspot.com/2020/10/weekly-browser-binaries-20201010.html is also messed up!... :P

Take the best of care! :)

Edited by VistaLover
  • Like 1
  • Upvote 2
Link to post
Share on other sites

Updated the mirror of Firefox ESR 45 and New Moon 26.5 / 27 / 28
(other builds may follow in the future)

-> https://soggi.org/misc/tools.htm *

* please don't link directly to a file/download as hotlinking is not allowed and older hotlinks won't work anyway (404), because only the latest build is available for download.
 

5 hours ago, VistaLover said:

I think I am one of the very few ;) (possibly the only one?) but I actually read closely and study these official changelogs every week (so rest assured your effort is not in vain...), but I am sorry to say :( this week's is a sorry mess...

I also do, but obviously not as carefully as you...didn't notice the recurrence. ;)

kind regards
soggi

Edited by soggi
  • Like 1
Link to post
Share on other sites

NM28XP Win32
https://github.com/roytam1/UXP/commit/056e62198ae1fe3ab4286e775adc8caaa3b39afa
the default useragent override for youtube.com has not changed with the latest update so you will need to manually change it from:
Mozilla/5.0 (%OS_SLICE% rv:60.0) Gecko/20100101 Firefox/60.0 PaleMoon/28.10.2a1 to:
Mozilla/5.0 (%OS_SLICE% rv:60.0) Gecko/20100101 Firefox/60.0
so that the chat function on live streams works again.
test link: https://www.youtube.com/watch?v=DDU-rZs-Ic4

Edited by rereser
  • Like 1
Link to post
Share on other sites
10 hours ago, VistaLover said:

I think I am one of the very few ;) (possibly the only one?) but I actually read closely and study these official changelogs every week...

i read them also.

BUT i look for ONE key word - "typo".

it wasn't until a "typo" was fixed in v27 correcting an issue dating back to 'at least' 2018 that i *finally* was able to upgrade from 28.1.0a1 2018-09-21.

i never really liked v28 (manage styles in Stylem don't color-code properly) but was kinda "forced" to use it due to a couple of bank account sites.

i wasn't able to upgrade back to v27 until a "typo" causing about:permissions to not work correctly was fixed.

so now i'm using a version from last month where that about:permissions typo was finally fixed.

a small portion of about:permissions is STILL broken - but it's fixed enough to at least return to v27 as my default-for-all.

do not know when the bank account sites started working again in v27 because i waited for the about:permissions page to be fixed before reverting back to it.

Link to post
Share on other sites
13 hours ago, VistaLover said:

Many thanks for still finding the time, between your hectic real life currently, to compile and offer these builds! :thumbup

I think I am one of the very few ;) (possibly the only one?) but I actually read closely and study these official changelogs every week (so rest assured your effort is not in vain...), but I am sorry to say :( this week's is a sorry mess...

And this is identical to last week's:

I believe the correct changelog for this week is (what is currently listed under this week's PM changelog):

Official UXP changes since my last build:
- Issue #1665 - Take overflow-wrap into account when calculating min-content intrinsic size. (8e18743ab)
- Issue #1666 - Implement overflow-wrap: anywhere (dadef50bd)
- [devtools] Teach devtools about overflow-wrap: anywhere (521f2b476)
- Issue #1606 - Add support for multi-monitor DPI awareness v2 (W10 1706+) (bda6f1a93)

source:
https://github.com/MoonchildProductions/UXP/commits/master

Correct changelog for this week is:

Official Pale-Moon changes since my last build:
- Back-end branch pointer update (Unstable 2020-10-04) (f6ae5e0)
- [app update] Move update cert entries to branding (b48aee5)
- Issue #1812 - Enable per-monitor DPI v2 in Pale Moon (762408f)
- [SSUAO] Update Yahoo override, since they now throw a fit when seeing anything "Pale Moon" in the UA. (aa3ff77)

source:
https://github.com/MoonchildProductions/Pale-Moon/commits/master

NB: http://rtfreesoft.blogspot.com/2020/10/weekly-browser-binaries-20201010.html is also messed up!... :P

Take the best of care! :)

thanks for pointing out that I forgot to replace old changelogs (it may because I was too sleepy at that moment), this is first time to do release engineering just before sleeping, maybe this is not a good choice as a result. I usually do release engineering right after wake up, but today I have a bicycle visit to my former teammate's workplace and I have to go in the morning.

  • Like 1
Link to post
Share on other sites
On 9/20/2020 at 1:29 AM, dencorso said:

IIRR, @glnz actually *IS* a lawyer, so I'm hereby asking him to ping in and kindly provide us some advice, which sure'll be much appreciated!

Sorry - just saw this.  As Den says, I actually *AM* a lawyer.  Here's my advice:  Go out, have a beer and buy a used Win 10 machine on racinenorth.com 

Now, where do I send my bill?

OK OK - what's the question?  I'll try.  But if it's about copyright or IP, I'll need to reach out to colleagues.  My own specialty is bad real estate deals and sexual diseases.

  • Like 1
Link to post
Share on other sites
30 minutes ago, glnz said:

Sorry - just saw this.  As Den says, I actually *AM* a lawyer.  Here's my advice:  Go out, have a beer and buy a used Win 10 machine on racinenorth.com

You forgot to say "then install Windows 7 on it"

  • Like 3
Link to post
Share on other sites
11 hours ago, rereser said:

the default useragent override for youtube.com has not changed with the latest update

...Well, @roytam1 is extremely busy and pressed for time currently in RL, that's probably why the recent discussion about broken YT chat on LIVE streams was not acted upon in a due fashion... :(

Upstream have also received similar reports (be it in the Mac subforum) and Moonchild himself was initially oblivious to the solution:

Quote

 If we indicate we are a "newer Firefox" than what we say we are, then they want to use WebComponents we don't support. So there's no way around this. Google refuses to show chat to "older" browsers. we can't tell them we are "newer" because then they will treat us to chrome-specific technology that Firefox copied but we don't have yet.

Most thankfully, @rereser stepped in :worship: to enlighten the browser guru:

https://forum.palemoon.org/viewtopic.php?p=201384#p201384

so I guess that change will soon hit the upstream Pale Moon repo and, hopefully, be merged in next weekend's New Moon 28 builds...

NB: As an unofficial/non-endorsed fork, New Moon isn't entitled access to the "Dynamic SSUAO Updates" service, currently put in place for the stable channel of Pale Moon; so, as you said, a NM28 user has to manually correct/modify the YT SSUAO entry inside about:config...
OT: Thank you again for notifying "upstream" about this; I guess having an account on both "camps" is useful for cases like this one, where both "worlds" can profit from... But it sure was a prudent thing to exclude even the most minute reference to forks/officially unsupported OSes/MSFN in particular, or a "certain" person will have eaten you raw... :angry:
(And I've also noticed how that person has adopted a recent habit of checking official forum posters against the database of MSFN members, once a match is found (via username), then the reporter is treated as dirt... :angry: )

Kind regards :)

  • Like 2
Link to post
Share on other sites

thanks for the kind reply.
keeping track of posted issues on both boards helps me learn.
need the practice as i'm not the youngest anymore.
nobody , in my opinion . using New Moon should be asking for support on the PM board or join in a discussion.
also have to keep in mind that NM28XP is based on the unstable PM version and "solutions" may not yet work in the official PM release.
however , as you stated , posting a tested (new profile) simple fix without browser details helps both.
and most important all of it's users.
example : try this page.
https://music.apple.com/il/album/sentinel/1528162085
you will get : an error observed
direct temp solution was not given as it supposedly poses a security and privacy risk.
dom.enable_performance_observer : bolean : set to true.
now no error and the music plays.
if apple corrects this then the pref should be reset to default.
until such time the site is functional.

Edited by rereser
  • Like 1
Link to post
Share on other sites

I feel like a kid on Christmas morning!

I tested PM v27.6 from October 2017 over the weekend and all 11 of my usually-problematic sites now WORK.

Them not working was the only reason I ever "upgraded" to v28.

A kid in a Candy Store!

I've never been a fan of "feature creep" and I don't like (or need) all of the "features" that have crept into Pale Moon since the days of 27.6.

Truly Ecstatic!

Link to post
Share on other sites

Hello roytam1,
A big thanks (again) for your job on NewMoon, which is my choice for a while, on XP-SP3 (Embedded POSReady2009).
Thanks too to all those who help here.

With the two last editions, I had sometimes a few crashes. "Events" says that faulty module is "xul.dll v4.6.0.7573", address 0x013a0fd0.
No problem with the 20200926 NewMoon edition.
So, I try replacing "xul.dll v4.6.0.7573" par its "v4.6.0.7559", copied from "palemoon-28.10.2a1.win32-git-20200926-9f56811e0-uxp-e0bda2246-xpmod.7z"

OK (?) for now...

Link to post
Share on other sites

Also wan't to say thanks to roytam1 and anyone else involved in keeping New Moon updated! I still use XP every day for various reasons and not having a working browser would be a PITA, thanks again!

 

Edited by KeyCat
Link to post
Share on other sites
9 hours ago, Gargam said:

Hello roytam1,
A big thanks (again) for your job on NewMoon, which is my choice for a while, on XP-SP3 (Embedded POSReady2009).
Thanks too to all those who help here.

With the two last editions, I had sometimes a few crashes. "Events" says that faulty module is "xul.dll v4.6.0.7573", address 0x013a0fd0.
No problem with the 20200926 NewMoon edition.
So, I try replacing "xul.dll v4.6.0.7573" par its "v4.6.0.7559", copied from "palemoon-28.10.2a1.win32-git-20200926-9f56811e0-uxp-e0bda2246-xpmod.7z"

OK (?) for now...

unfortunately I don't have a way to reproduce it so I can't fix it at the moment.

Link to post
Share on other sites
On 10/9/2020 at 10:52 AM, roytam1 said:

since they put their repo in private, it is hard to tell if they have this fixed or not.

if I need to fix it by myself, it will be in very low priority below $dayjob, $movement, and $build.

Interesting, would you suggest posing as a Interlink user there and asking them to fix it?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...