Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


mixit

Enable MP4 (H.264 + AAC) HTML5 video in Firefox on Windows XP without Flash

Recommended Posts

Posted (edited)

I have this set in FF

general.useragent.override                   Mozilla/5.0 (Windows NT 6.2; rv:62.0) Gecko/20100101 Firefox/62.0

general.useragent.overrideprefrence   Mozilla/5.0 (Windows NT 6.2; WOW64;rv:67.0) Gecko/20100101 Firefox/67.0");

pretty sure I have all the gmp gmp.adode and widevine aswell

is there anything i should modify  .?

.

general.useragent.site_specific_overrides;        true

should I changed this to false ?

Edited by DrWho3000
edir

Share this post


Link to post
Share on other sites

general.useragent.site_specific_overrides is set to "true" here.
:yes:

Share this post


Link to post
Share on other sites
4 hours ago, DrWho3000 said:

general.useragent.site_specific_overrides;        true

should I changed this to false ?

It should be "true." However, with FF 52, it won't do anything unless you add some custom Javascript:

On 3/24/2019 at 11:04 AM, VistaLover said:

I was able to restore SSUAO functionality in Firefox 52.9.0[1] 32-bit on my VistaSP2 x86 laptop and bring it on par with the UXP browsers (i.e. SSUAO are now possible natively, without the need for extra extension(s)) :thumbup  

Full Guide (tested only in FxESR52, should work in other Fx versions):

1. Load "about:config?filter=site_specific" in a tab and make sure

general.useragent.site_specific_overrides;true (should be by default)

2. Exit Firefox

3. Create the following text file


pref("general.config.obscure_value", 0);
pref("general.config.filename", "config.js");

rename it to "config-prefs.js" (make sure no hidden .txt extension is present) and place it inside

<FirefoxInstalDir>\defaults\pref\

(a file named "channel-prefs.js" should already be there by default)

4. Create the following text file


// needs to start with a comment line
Components.utils.import("resource://gre/modules/Services.jsm");
Services.obs.addObserver(function (aSubject, aTopic, aData) {
  var chromeWindow = aSubject;
  chromeWindow.setTimeout(function () {
    Components.utils.import("resource://gre/modules/UserAgentOverrides.jsm", chromeWindow);
    chromeWindow.UserAgentOverrides.init();
  }, 1000);
}, "browser-delayed-startup-finished", false);

rename it to "config.js" (make sure no hidden .txt extension is present) and place it inside <FirefoxInstalDir>\ (i.e. in the same directory as firefox.exe). 

5. Launch Firefox; now you are ready to create SSUAOs inside about:config as you would do in New Moon and/or Serpent 52. E.g. I created 

general.useragent.override.browserspy.dk;Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0

and when visiting the test site with FxESR52 I get:

ZCauXYb.jpg

(to re-iterate, this is without any UA modifying extension... :P).

I think you'll find the above to your satisfaction... ;)

 

 

  • Like 1

Share this post


Link to post
Share on other sites

is there a way around with FB vids, to view inline on newsfeed instead of some going to the expanded theatre mode  and NOT play or do

i see some seem to have sound, some not

is this to do how it was encoded, frame or the css/js ??

Share this post


Link to post
Share on other sites

Do any Facebook videos play automatically inline for you as they should do?
As I said to you in another thread, I'm pretty sure that some won't play anyway, IIRC because they are too deeply linked.
:)

Share this post


Link to post
Share on other sites
Posted (edited)

Can we disable the plugin container, in the past I noticed it was mainly needed to help play flash games, and removing it, there was no adverse effect and FF ran smoothly without it, but now If I disable or remove it FF, having Primetime Decryption FF complains Primetime has  has stopped and need to reload page

I found it is a resource hog

I know in older versions it was together but in wisdom was decide to seperate into 2 seperate processes

dom.ipc.plugins (on Firefox 9 there are two, while there are five on some older versions).
Set all of them to false to disable plugin-container:

DISABLING
After disabling it, the usage is more like 35-50% and 25-40%. That’s an improvement from 100-130% to 60-90% ==> ~40% net.

By default, Firefox loads plug-ins in a separate process called plugin-container.exe, which is meant to keep the main Firefox process (firefox.exe) unscathed in the event of a plug-in error or crash.

Plugin-container is known for being resource intensive (CPU and RAM). But fortunately, it can be disabled without disrupting the browser's operation.

Edited by DrWho3000

Share this post


Link to post
Share on other sites
Posted (edited)

hopefully  this is the right thread

Can someone help , when I have Netflix going I get 2 instances of pluging in container, sure I only use to have the one

this seems to be since i did a New profile

is there a way of only having the one, OR does silverlight have its own seperate one ?

should this be dom.ipc.plugins.enabled  true or false

Also I have the exact same settings (or sure I have) in prefs in my other XP SP3 PC, yet when I try to use Netflix I get plugingin container and sliverlight then disappears and get a DRM error,   ...............   is there a componet I could be missing / need or something I need to get DRM working

or be looking for something missing

deffo got all 6 blue ticks in the youtube/html webite

i have Primetime on both XP SP3 PC's works fine on youtube  fine on both

have exactly same Silverlight version on both, have all the same plugins and files (even checked the WMP DRM files)

 

If I go here http://html5test.com/ my other PC scores better than this one yet the other refuses to play Netflix  but this one does

 

 

Edited by DrWho3000

Share this post


Link to post
Share on other sites

SSE-PC Palemoon 27.9.6
Youtube download
After some success with CYS Complete Youtube Saver I was not lucky anymore.
Found luck with Ant Video Downloader 2.4.7.47 but then there were problems during saving.  videos were stored as .webM-files. But only in restricted account. I know i was "working" in the association-settings.
i exchanged old admin-account is now the restricted one and restricted one is admin-account. had to do this since there was access to a certain ebay-store anymore(no videos there).
Could now check this behaviour by setting back the accounts.
In admin-account videos are stored as mp4. Ant will download sound and video seperately and melting them after they are finished.
Both CYS and Ant Video Downloader rely on ffmpeg. there are instructions how to setup. i have two ffmpeg-versions. one with exe in bin-folder the other with no bin-folder. with the latter i was successful finally.
Here i have setup a STICKY for SSE-users maybe also true for others. Its not yet complete.
Since til now nobody told me how installer is running(if ever it will run with sse) i am running Palemoon/Newmoom 27.9.6 directly from the folder.
Question is now: How to solve the webM-files- problem?

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/8/2019 at 12:39 PM, 3dreal said:

Since til now nobody told me how installer is running (if ever it will run with sse)

Only people in the same position as yours can answer that; the maintainer stated already he doesn't have access to an SSE-only machine, so he can't test it himself :(

The installer comprises several binaries and batch files - it can be extracted to a folder with 7-zip (in your case, you'll have to use an SSE compatible 7-zip version, you probably already know what that is...); then try to run the binaries (7z.exe, choice.exe, choice16.com, wget.exe, xxmklink.exe), via command line, on your machine; if they run, good bet is the installer itself will also work... By studying the .bat files in a text editor, you can get a pretty good idea as to what the installer does and where it installs files...

Hope I've helped (in an otherwise off-topic post :angry: )

On 7/8/2019 at 12:39 PM, 3dreal said:

Question is now: How to solve the webM-files- problem?

No; question is in what way is your video-downloading query relevant to this very thread? ... :angry:

Edited by VistaLover

Share this post


Link to post
Share on other sites

OK guys, a lot of good work here - 24 pages!

I am on WinXP SP3 4gb RAM.  FF 52.9 ESR.  Most You Tube videos do not play.  Some do.

 

I downloaded Primetime and put it in the correct FF folder (took a while to find for FF 52.9).  It does not work or show up in Plug-ins..

 

I have looked and Googled for 2 hours and I can not find where the heck "Preferences" are in FF 52.9.  I've looked through all the pages under "Options" and can not find "Preferences". 

Where do I I enter these Preferences in FF 52.9? :

==================================

To be able to install and operate the Primetime CDM, add and/or set the following FF preferences in about:config (be careful, all of these are cAsE sEnSiTiVe!):

media.gmp-eme-adobe.enabled (boolean; true)

media.gmp-eme-adobe.forceSupported (boolean; true; FF 49.0+)

media.gmp-eme-adobe.forcevisible (boolean; true; FF 45-48, no longer used in 49.0+)

media.gmp-eme-adobe.visible (boolean; true; FF 49.0+)

media.gmp-eme-adobe.version (string, not integer; 17; required for manual install now that automatic install is no longer an option)

media.gmp-eme-adobe.abi (string; x86-msvc-x86 (EDIT: x86-msvc-x64 for 64-bit XP users); not required, you can set it if you want to more closely mimic automatic install)

media.gmp-eme-adobe.lastUpdate (integer; 1500000000; not required, you can set it if you want to more closely mimic automatic install)

media.gmp.decoder.enabled (boolean; true)

media.eme.enabled (boolean; true; defaults to false if you downloaded a DRM-free version of FF; thanks @heinoganda for pointing this out)

==================================

 

Thanks! 

 

Tony

 

Share this post


Link to post
Share on other sites
1 hour ago, aoresteen said:

Where do I I enter these Preferences in FF 52.9? :

==================================

To be able to install and operate the Primetime CDM, add and/or set the following FF preferences in about:config (be careful, all of these are cAsE sEnSiTiVe!):

The boldened text is where you add/set the preferences

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...