Jump to content

Enable MP4 (H.264 + AAC) HTML5 video in Firefox on Windows XP without Flash

Recommended Posts

56 minutes ago, Josept said:

we need a new patch for instagram bug

It has to be one of the changes applied to New Moon & Serpent here:

Both browsers play Instagram videos from the linked version forward, but earlier versions do not.

Link to comment
Share on other sites

12 hours ago, Mathwiz said:

It has to be one of the changes applied to New Moon & Serpent here:

Both browsers play Instagram videos from the linked version forward, but earlier versions do not.

i need a new patch for Firefox ESR 52.9.0

Link to comment
Share on other sites

has Twitter changed in format in way it displays / shows videos, as I sied to be able to see All videos, not it is only some.

I have all the correct files in right places,



gmp-widevinecdm /

i used to be allbe to see this now don't

Even GIF's don't work, and sketchy IF some vids play or don't

I've made No chages to Firefox or the config



Edited by DrWho3000
Link to comment
Share on other sites

On 3/18/2019 at 7:09 PM, Josept said:

where can I download the patch, and where should I paste the files for firefox 52.9

Turns out you don't have to patch anything in the browser, just change the page styling:


Link to comment
Share on other sites

32 minutes ago, DrWho3000 said:

has Twitter changed in format in way it displays / shows videos, as I sied to be able to see All videos, not it is only some.

Apparently they've changed something, at least on the @qvcuk page you gave as an example, the latest video https://twitter.com/qvcuk/status/1108737574363754497 doesn't work. It's probably not really a video problem, but they've changed something in the surrounding JS/CSS. At least their earlier GIF https://twitter.com/qvcuk/status/1108698147474341890 and video https://twitter.com/qvcuk/status/1108654509352378369 work fine for me.

Edited by mixit
Link to comment
Share on other sites

After a refresh , restart of FF seems most vids do work and GIF's so it must be as said, its the surrounding area and/or JS/CSS

all files in FF are as should be and Strings / Booleans are correct with right UA

Link to comment
Share on other sites

This plugin is crashing for me when visiting a Facebook page containing one or more videos... when I'm logged in!  The videos subsequently can't be played.
Up till now, I've been using Opera 36 for Facebook (circumventing the freeze on my FB wall/homepage by quickly clicking my username in the middle of the blue menu bar).  Since videos can't be played in Opera 36, I always copied the URL of the video page to Firefox 47.0.2 and played it from there.
Now that I'm switching over to a new PC with WinXP and Firefox 52.9.1, I wanted to switch to Firefox for Facebook.  Everything seemed fine until I logged in to Facebook.  Now, I get a yellow information bar on every FB page that contains a video stating that "The Primetime Content Decryption Module provided by Adobe Systems, Incorporated plugin has crashed."
The videos play fine when I'm logged out of Facebook.  Also, there are no problems playing YouTube videos.
I already tried:
- using a new FF profile with just the Primetime plugin installed
- spoofing the UA
- installing Flash Player (which wasn't installed yet)
Any other suggestions?
*** EDIT ***
I found the source of the problem.  Apparantly, Firefox doesn't work too well if its AppData folders are junction links.  Bummer... I really wanted to avoid unnecessary wear and tear on the system's SSD...

Edited by Tomcat76
Link to comment
Share on other sites

  • 4 weeks later...

from here i copied all relevant steps. they seem to be in this thread see last link above.

but i cannot execute since not the right palemoon.

can only test when SSE2 for PM 28 is ready. The experts must confirm.

Here they are:

  Primetime CDM FF 49+
 To be able to install and operate the Primetime CDM, add and/or set the following FF preferences in about:config (be careful, all of these are cAsE sEnSiTiVe!):

media.gmp-eme-adobe.enabled (boolean; true)

media.gmp-eme-adobe.forceSupported (boolean; true; FF 49.0+)

media.gmp-eme-adobe.visible (boolean; true; FF 49.0+)

media.gmp-eme-adobe.version (string, not integer; 17; required for manual install now that automatic install is no longer an option)

media.gmp-eme-adobe.abi (string; x86-msvc-x86 (EDIT: x86-msvc-x64 for 64-bit XP users); not required, you can set it if you want to more closely mimic automatic install)

media.gmp-eme-adobe.lastUpdate (integer; 1500000000; not required, you can set it if you want to more closely mimic automatic install)

media.gmp.decoder.enabled (boolean; true)

media.eme.enabled (boolean; true; defaults to false if you downloaded a DRM-free version of FF;
 To install the plugin:

    Open your FF profile folder. An easy way to navigate to it is by opening about:support in FF and clicking the Open Folder button next to Profile Folder.
    Inside the profile folder, create subfolder gmp-eme-adobe and open it.
    Inside gmp-eme-adobe, create subfolder 17 and open it.
    Unpack the Primetime ZIP archive into folder 17.
    Folder [your FF profile path]\gmp-eme-adobe\17 should now contain three files: eme-adobe.dll, eme-adobe.info, eme-adobe.voucher.

After this, check the Plugins in your Add-ons list and you should see the Primetime plugin listed and ready for use. If you don't see the plugin there, make sure you've set all of the required preferences as described above and put the files into the correct subfolder. Restarting Firefox to complete the manual install isn't usually required, but try it if the plugin doesn't appear, (Also, remember that if you have more than one Firefox profile, you'll need to repeat these steps for each of them individually.)

Set the Primetime plugin to Always Activate, Flash to Never Activate (not strictly necessary, but better for testing), and go to Youtube HTML5 video player check page. Both H.264 and MSE & H.264 should have blue checkmarks. You may want to try this test page (kindly suggested by @dencorso) or some Twitter videos to quickly make sure H.264 really is working (with Youtube you can get fooled by WebM getting played instead).

In theory, you could uninstall Flash at this point, but realistically it's probably wiser for now to leave it installed and disabled in the browser. Personally, I installed the FlashDisable extension to quickly toggle Flash on some of the sites I frequent that don't support HTML5 video. Some of those insistently serve Flash video to desktop FF without even checking if it can do HTML5 video or not. That can be worked around by faking a different user agent string, but for now I've found it more convenient to just temporarily toggle Flash back on for them. FlashDisable supports the Ask to Activate setting, so you don't have to worry about other sites if you forget to turn Flash off again.
As you've likely heard, FF 52 ESR is the last version of the browser that's going to work on XP (unless some intrepid person forks a special version for us). In a way, this is a blessing in disguise, as Primetime support has been completely excised from FF 53 and Google's Widevine CDM doesn't have our helpful side-effect (and doesn't work on XP), but ESR 52 will be supported well into 2018. So, why not make use of it while we can, right? :)

Note that HLS streaming is not natively supported with this plugin. It does work on sites coded to use some JS library or player to work with HLS, but not for directly playing .m3u8 video sources. You may want to keep an eye on developments with hls.js in general and firefox-hls in particular if a favorite site of yours falls into the latter category.
Adobe CDM
Primetime CDM

 IOW, with his latest updates to Serpent/Moebius, you can now install the Adobe Primetime CDM and use it for HTML5 video, instead of Serpent's built-in support. You may want to try this if you run into issues with the built-in support, such as distorted audio.

If you "cheated" like I did and copied your Serpent/UXP profile over to Serpent/Moebius, and had Primetime installed on UXP, you're probably 90% of the way home. All you need to do is recreate the media.gmp-eme-adobe.visible boolean pref and set it to true. Primetime should appear in about:addons since the other prefs from your UXP install should still be there. Of course, if it doesn't work, check all the prefs mentioned in the Primetime thread.

As with UXP, you'll need to set media.ffvpx.enabled to false to force Moebius to use Primetime for HTML5; otherwise Moebius will use its built-in support by default.
For Moebius to get Primetime working, in addition to the prefs that have to be added in along with the gmp-eme-adobe folder there's a couple of obscure prefs that have to be changed back. Apparently even when copying over the profile from UXP to Moebius they're automatically given new values:


Change these from 0 to 2.

Primetime instructions:


Fortunately for me the built-in decoder works fine and is much preferable to using the buggy plugin-container.exe but it's an extra option to have just in case.

Edited by 3dreal
Link to comment
Share on other sites

I have noticed with alot of videos on facebook, will not play properly seems to be no sound or instead of playing on newsfeed, it goes to the theatre and doesnt play. not sure why some vids play on newsfeed and some goto the theatre (opens a window)

yes I have spkrs and are on lol

I have all the relevant files in Mozilla folder in correct places, and the about:config has correct strings and booleans

wondered if anyone else has seen or noticed it
I wonder if it is the way the videos are encoded or maybe borked when uploaded, or they way it was recorded , I would off thought they are mostly mp4

Edited by DrWho3000
Link to comment
Share on other sites

I've always had that same problem with a few videos on my newsfeed.
The vast majority play automatically inline, but a few don't, and as you say when you click on them they open expanded but still won't play.
I think it's something to do with their sources, and it's an intrinsic problem that's nothing to do with the browser.
Perhaps they're too deeply linked or something.
Next time I'm aware of one in my feed, I'll have a look in Firefox 66 on Windows 10.
If it's the same there there's presumably nothing that can be done about it.

Link to comment
Share on other sites

that is my sentiments, It did cross my mind, just maybe browser and having right strings booleans in config

also did think it maybe well the source, a pain,

I turned off the autoplay for videos in the FB settings
I could see if it is that with sons laptop he has Win7

i have wondered IF "maybe£ someone has a prefs file with all the mods they could share

Link to comment
Share on other sites

I have this set in FF

general.useragent.override                   Mozilla/5.0 (Windows NT 6.2; rv:62.0) Gecko/20100101 Firefox/62.0

general.useragent.overrideprefrence   Mozilla/5.0 (Windows NT 6.2; WOW64;rv:67.0) Gecko/20100101 Firefox/67.0");

pretty sure I have all the gmp gmp.adode and widevine aswell

is there anything i should modify  .?


general.useragent.site_specific_overrides;        true

should I changed this to false ?

Edited by DrWho3000
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...