Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

All Activity

This stream auto-updates     

  1. Past hour
  2. Good ol' Rubber Ducky? http://www.willsoftware.com/rubber-ducky-system-monitor-83269.html http://www.mimarsinan.com/rubberducky.asp jaclaz
  3. Mine one needs integration with nlite and sfc patch
  4. @VistaLover Highly interesting info, thanks! Especially this: > Perhaps Chrome 49 has native support for that cipher suite and only > uses the Windows Store for certificates, NOT using Schannel like IE does So far I thought this Certs+Ciphers stuff were somehow 1:1 related, and all non-Mozilla browsers could only use the same pool. But obviously only IE is completely dependent on the OS. Shocking for me to read: even Vista needs MS updates to get TLS1.2 support? I can understand that Win98 is much too outdated for native TLS1.2, but assumed all newer systems like XP had it long since by default, sigh. And will finally have to store those great ssl-test links!
  5. We got stucked at UI Elements . Then his mid sem started so i never talked about it again.
  6. Today
  7. Well, I expressed myself incorrectly. the MBR is not copied, some parts of it are copied and a new MBR is created using some of this data, correcting it when needed - loosely - the MBR is made of three (actually four, please read as five) parts. 1) Bootcode 440 bytes (0-439) 2) Disk Signature 4 bytes (440-443) 2.a) Unused 2 bytes (444-445) 4) Partition table, 4 entries 16 bytes each=64 bytes (446-509) 5) Magic Bytes 55 AA (510-511) The bootcode can in theory be empty, but some BIOSes/OSes might *want* or *need* some leading bytes The DIsk Signature is only used on NT based systems to "ID" the disk uniquely. The unused bytes are - well - unused an they are normally 00 00. The Partition table's entries contain a byte (either 80 or 00 ) for active/bootable, a byte for partition filesystem ID (not really-really, it is actually a "protective ID", but for years it has been used as ID) some data with the CHS addresses of the extents of the partition and the last 8 bytes are the LBA addresses of the extents of the partition. The boot code cannot be "read" (it can be read but it cannot be interpreted), it could be disassembled, but it is not normally needed/useful, set apart some special code (like grub4dos itself, or - say - MBLDR) there are tens of different MBR bootcodes (including those standard for DOS/Win9x and those for the NT family of OSes) that all essentially do the same, i.e. they parse the partition table contents and chainload the bootsector of the (porimary) partition that is set active. In the example I posted the MBR is completely blank (00's) exception made for the disk signature, the two partition table entries and for the Magic Bytes. What grub4dos does is (on the mem mapped disk MBR) 1) insert a few boot code bytes <- these are not a real boot code but rather some bytes that are needed on some particular BIOSes or OSes, it is only a "compatibility" provision, anyway since you are alreasy in grub4dos you will proceed by-passing the MBR code and either boot the PBR or firectly chainload the OS loader or System file (the io.sys in this case). 2) insert a new disk signature (it cannot be the same as the source) 3) copy the size of the chosen partition and maje an active entry for it with a default offset of 63 sectors 4) write the magic bytes Then on the given partition PBR it corrects the "Sectors Before". Of the partition table, even if you haven't got a parser like (shameless plug) this one for grub4dos: http://reboot.pro/topic/17728-release-mbrviewg4b-a-bat-tool-for-grub4dos/ or (even more shameless plug) Tinyhexer with my Structure viewer: http://reboot.pro/topic/8734-tiny-hexer-scripts/ the relevant parts are easy enough to read manually, namely, for each partition entry: 1) the first byte is active if 80 or non active if 00 2) the fifth byte is the partition (protective) ID 3) the last four bytes are the size of the partition in sectors 4) the 4 bytes preceding the last four are the offset to the beginning of the partition (still in bytes). Now, with this info, let's read the data in the partition table in the screenshots I posted: On the mem drive (hd3) (mapped from the whole disk (hd0), first entry: 1) 00 non active 2) 1C Type 1C 3) B8 0B 00 00 = 0x00000BB8 = size 3000 sectors 4) 3F 00 00 00 =0x0000003F = offset (or starting at LBA or "Sectors Before") 63 sectors Second entry: 1) 80 active 2) 01 Type 01 (this means FAT12) 3) 00 3F 00 00 =0x00003F00 = size 16128 sectors 4) C0 0F 00 00 =0x00000FC0 = offsset (or starting at LBA or "Sectors Before") 4032 sectors The above is exactly the the same as the "original" (hd0) MBR. On the mem drive (hd2) (mapped from only the second partition (hd0,1)), there is only one entry: 1) 80 active 2) 0E Type 0E (this means actually FAT16 LBA mapped [1]) 3) 01 3F 00 00 =0x00003F01 = size 16129 sectors [2] i.e. same size (+1 sector) as the second partition on (hd0) 4) 3F 00 00 00 =0x0000003F = offset (or starting at LBA or "Sectors Before") 63 sectors (which is a "default" offset for first partition in any OS before Vista) Now let's see the bootsectors, the interesting parts are (this is a very small FAT volume): 1) at offset 19 or 0x13 "small sectors" 2 bytes 00 3F= 0x3F00= 16128 sectors 2) at offset 28 or 0x01C "sectors before" 4 bytes, respectively: (hd3,1) - same as (hd0,1) C0 0F 00 00 =0x00000FC0 = 4032 sectors (hd2,0) 3F 00 00 00 =0x0000003F = 63 sectors jaclaz [1] this is a little "bug" of grub4dos, see here for the story of this queer bug: http://reboot.pro/topic/21732-windows-for-workgroups-311-grub4dos-and-protected-mode/ (it won't affect you since you are not going to use Windows 3.1/3.11) [2] strangely enough there is a (rather perverted) reason for this, the partition was originally created in XP and as NTFS, so the "backup bootsector" at the end of the partition (but outside the volume) has been "included" in the volume when it was re-formatted to FAT12.
  8. Is anyone using an equivalent to Conky (Linux) or SysTrayMeter (WindowsXP)? Windows 98 feels a little like night driving without dash lights. Preferably low resource requirement, sits in system tray not desktop, displays CPU/RAM/Network activity. Haven't been able to find anything.
  9. i recommend not to upgrade to windows 10. You should restore your pc to factory settings and never update again. Updating windows 8.1 only result in added telemetry. Or search online for only true security updates. Keep the windows 8.1 market share visible.
  10. i have no idea if this is true or not, but i find it concerning.. https://forums.tomshardware.com/threads/windows-7-kb4524752-forcing-upgrade-to-10.3536973/
  11. IMO, you've mixed too many parts together for starters. If you're using rloew's RAM patch you should not need HIMEMX, and unless you have some specific reason for using it, you most definitely don't need EMM386. Nor do you need to limit MaxPhysPage... (what is burnmem.sys? ) When using PATCHMEM, you can forget about all of the "tweaks and workarounds" used by those without it. re: Slow Boot due to unrecognized Machine Type... I've seen this problem once on an AMD machine. Newer systems don't handle Gate A20 in a 9x-friendly way. Setting /MACHINE:1 on HIMEM.SYS in CONFIG.SYS may solve the issue. I've not used rloew's AHCI driver yet, so I can't address that part specifically... If you have the option on that board to use Native SATA mode (may be labeled as "IDE") then it should work with his SATA patch, but I doubt that option is still present. Maybe someone who has used the AHCI driver can comment on this. Newer motherboard manufacturers no longer care about optimizing their BIOS code for x86 operating systems. They assume everyone will be using x64, so they don't bother to optimize the MMIO RAM allocation to make the most memory available to x86. I had an X99 system where only 1873MB of RAM was available to a 32-bit system when 4GB was installed; this later increased to 2910MB after a BIOS update but I never could manage to get their tech support to understand the problem. A good BIOS modder might be able to help with this, but they're hard to find in my experience. Newer video cards usually use a "memory banking" method to avoid tying up all of the 32-bit RAM.. since your 780GTX is XP compatible it should do this, but who knows what the onboard Intel HD Graphics will do. I've had 9x up and running on my X79 and X99 systems. I have an X299 system that has yet to see any experimentation with any OS... I detest onboard graphics to begin with, and the fact they're no longer supporting XP rules chipsets using them out completely. The "X" series boards and processors may cost more, but it at least rules out one set of legacy compatibility problems.
  12. This problem (Mobility X600 in my case) drove me nuts for a long time on a laptop I was trying to get up and running with 9x. Despite scattered reports of people getting Mobility X600/X700 chips working under 9x, no matter how many times I tried or how many different Catalyst versions I tried, nothing ever changed. Forget Catalyst 4.11, use the last 9x compatible package. 2K/XP WDM (non-.VXD) Display drivers do not work under 9x, so they won't get you anywhere either. If you're having the same problem I did, then this should cure it. Disable PCI Steering on the PCI Bus under Device Manager. The reinstall the ATI Catalyst package if necessary. Manually choose an X700 device from the list, or add your specific VEN&DEV to the INF if you wish.
  13. jaclaz, I was completely fooled by that "dictionary" error! Let me explain why. As a boy I learned electronics from several books by British authors. Instead of saying "transistor" they used the word "valve." There were many other technical words and expressions used by the British, but not commonly used in the USA. When I saw the word "dictionary" I assumed the author was from Europe. Obviously, I did not know he meant to type "directory." IntMD, that tiny patch (64K) from daniel_k is remarkable! After reading about the Diyba patch, I was very concerned about system instability. I've got many full system backups, but no one wants an unstable operating system. Two questions about the WinXPPAE patch from daniel_k. The best way to install this patch is to enable PAE limiting to 4GB. Command line would be -> WINXPPAE /4GB If I installed 12 gigs of RAM with PAE limiting enabled, will I see the correct number (12 GB) under System Properties -> General Tab? System File Protection will restore the original files, unless something is done to stop that process. daniel_k says to integrate all the files on a CD. I don't understand. Just burning files to a CD won't fix the problem. What is the best method for installing the altered files, so they won't be overwritten by System File Protection?
  14. Does anyone have a copy of the English version of the Microsoft Internationalized Domain Name (IDN) Mitigation APIs 1.1 for Windows XP 32-bit? If so, could you please provide me with the download link? All the Microsoft- related ones no longer work and I haven't been able to locate this file elsewhere.
  15. Did your error message show "I/O Disk error status=00003031" ? It is osloader.exe's message.
  16. but miss of classic theme is still a big problem to me. forcing windows to use classic theme by using w8classic.exe will cause other applications look strange.
  17. Since the 56k dial-up days I have used Speed Guide TCP Optimizer (now v3.0.8) on Windows 98. Recently discovered i was doing it wrong for high speed ethernet. Quick selecting 'optimal' and applying changes results in improvement but is not comparable to the same hardware on a modern OS. For high speed connections recommend clicking optimal then adjusting the General Settings -> Connection Speed slider towards max. This is the key to triggering DefaultRvcWindow changes, a huge performance bottleneck. When adjusting the slider and applying changes, the confirmation table pop-up should indicate a significantly larger DefaultRvcWindow setting. So for modern broadband, if it goes to 10 set it for 11 :) Not a sophisticated benchmarker, just downloaded a large file to test and am now matching the ~750 KB/second speed this same hardware gets from my particular ISP on a more modern OS.
  18. Quite interesting to read what everyone used over the years, or in some cases decades. Wish I kept every computer I had in the past, some where Win 95, 98SE and 2000.
  19. @Dave-H : A check of "cote.co.uk" on SSL Labs Server test page https://www.ssllabs.com/ssltest/analyze.html?d=www.cote.co.uk confirms what has already been reported; just scroll down to the Handshake Simulation section: ... and see that IE11 only works on Win10 ! As to why, I think I have some clues: I couldn't help noticing how that server was configured: Only TLS 1.2 version is enabled, and only 3 cipher suites for that protocol version: Now, IE11 uses the cipher suites available in the OS's Microsoft SChannel Provider library; however, different Windows versions support different sets of cipher suites: https://docs.microsoft.com/en-us/windows/win32/secauthn/cipher-suites-in-schannel If one checks the available suites on Win7: https://docs.microsoft.com/en-us/windows/win32/secauthn/tls-cipher-suites-in-windows-7 one cannot find any of the three cipher suites needed for connection to the server in question... OTOH, checking the available cipher suites on Win10 v1903: https://docs.microsoft.com/en-us/windows/win32/secauthn/tls-cipher-suites-in-windows-10-v1903 one can find the first preferred (by the server) cipher suite, TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256, as available, hence the TLS 1.2 handshake succeeds and the site loads in IE11/Win10! However, I don't have answers as to why Chrome 49/WinXP also succeeds, unless, of course, ProxyHTTPProxy is used with it... BTW, Chrome 49 does open the site successfully here, Vista SP2 32-bit, but I do have installed WinServer 2008 updates that enable TLS 1.2 support: Perhaps Chrome 49 has native support for that cipher suite and only uses the Windows Store for certificates, NOT using Schannel like IE does (I'm sorry, my Chrome related knowledge is limited, have only been a Firefox fan from the start!) ... Cheers
  20. My first PC I bought second hand from my sister in the early 1990s. It was a clone 80286 12 MHz CPU, a 40 MB IDE drive, 1 MB of RAM and a Trident 256 KB ISA video adapter. She originally had MS-DOS 4.01 on it, but I replaced it with MS-DOS 5.00 and used DOS Shell on it. Now my second PC was an 80486 DX/2 66 MHz machine with 8 MB of 72 pin RAM, a 540 MB SCSI drive and an Adaptec ISA adapter. I eventually added a 2 GB SCSI disk to it. I had a Trident VESA 512 KB adapter, and a VESA controller. I also added a Mitsumi 2x CD-ROM drive, and a 14.4 modem. I never added a sound card to that machine, until I switched the motherboard. On one primary partition i had MS-DOS 6.2 and Windows 3.1 installed. On the second primary partition, I had OS/2 Warp 3.0, which was my primary OS for three years. I did add a Vibra 16 sound card after I switched the motherboard to a PCI capable one with a Cyrix 5x86/100 MHz and a Cirrus Logic 1 MB PCI video adapter. I also went with 16 MB of RAM.
  21. I described about it. http://blog.livedoor.jp/blackwingcat/archives/1990650.html
  22. UPDATE! I have discovered that the two parameters below: apz.frame_delay.enabled set to True apz.relative-update.enabled set to False contribute to improve the smoothness during scrolling. This, at least on the RDD, has contributed to reduce the infamous stuttering issue that affects Mozilla browsers, regardless of their rendering engine. I have updated all the versions of the UOC Patch to reflect the changes above. Please update to the latest version of the UOC Patch! Thanks!
  23. Yesterday
  24. Hi. So, the extended kernel version cmd.exe was customized from XP version :3
  25. @jaclaz Thank´s a lot for elaborating. As far I can judge your first mapping gives same result like mine, only mapped to (hd2). And a corroboration of mine, isn't it. Your second mapping gives a memdrive with two partitions, second active. Give also very interesting testing-possibilities! Grub4Dos readme states (in update 4): "Here win98.img is a partition image without the leading MBR and partition table in it. Surely GRUB for DOS will build an MBR and partition table for the memdrive (hd0)". I admit I could find my desired mapping nowhere, but by trial-and-error it was a very easy job in comparison to other parts of my project. Can you explain the MBR copy-part? The bootcode-part (before partition table) of my MBR-dump of the Memdrive looks different to the original (but I can't read MBR-code).
  26. Please fix AeroGlass for Windows 10 1909
  27. Mathwiz wrote: "The distorted audio issue seems to be rare, but it does still seem to exist. Has anyone encountered it lately? If so, could you post a link to a video exhibiting the problem?" __________________________ I had these problems, the sound on Twitter videos was distorted as in slow motion. This solution to this audio bug I've found, works here: In about:config click New / string to create this user set new Preference name: general.useragent.override.twitter.com - then value in New Moon 28 is: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:4.2) Goanna/4.0 Firefox/55.0 PaleMoon/28.6.0a1 That's the part that does the trick: "Firefox/55.0" but you can put between Firefox/38.0 to Firefox/69.0 ... or Firefox/99.0 or more... The value in Serpent52/ Basilisk I have: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/52.9 The value in Serpent55/ Moebius I have: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Goanna/4.0 Firefox/55.0 ...and set Firefox compatibility in Preferences/Advanced/General tab, or in about:config set to default true: general.useragent.compatMode.firefox Link to test distorted Twitter video: https://twitter.com/josefkenny/status/974587426676117505 So now, the sound on Twitter videos is OK here, no more distorted audio in these browsers, solved. Thank you!
  1. Load more activity
  • Create New...