Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Leaderboard


Popular Content

Showing content with the highest reputation since 11/12/2019 in Posts

  1. 5 points
    New build of Firefox 45ESR: Test binary: SSE https://o.rths.ml/gpc/files1.rt/firefox-45.9.18-20191207-082eb5b14-win32-sse.7z IA32 https://o.rths.ml/gpc/files1.rt/firefox-45.9.18-20191207-082eb5b14-win32-ia32.7z repo: https://github.com/roytam1/mozilla45esr Changes since my last build: - import changes from tenfourfox: - #578: M1322864 M1585106 M1597043 (7758ebb12) - #578: M1579060 M1586176 (f3f295615) (5a4e033f1) - import UXP change: - [NSS] Bug 1508776 - Remove unneeded refcounting from SFTKSession (836e72e96) (082eb5b14)
  2. 4 points
    @roytam1 It looks like you have now seen your own proof it works without SSE, but here is mine anyway, just in case you want to see. The browser is a bit sluggish, as expected, due to no real GPU and an old budget processor, but it does indeed work on this MMX-only Mendocino CPU.
  3. 4 points
    Hi RoyTam1, tested your Serpent 52 Non-SSE2 test build, It's working beautifully on my Pentium III 1.4GHz. Once I finish tweaking it I expect it to run even better. But even as of now, discord web (which, if you aren't familiar, is very bloated and slow, even a bit sluggish on my Core Duo ThinkPad) is quite usable on the PIII using that browser. It's truly amazing. I'd imagine you may find more optimizations to make, as the build is in it's infancy. Keep up the good work, dude!
  4. 4 points
    The task manager shows not only the memory consumption, but also virtual memory, the swap file. Therefore, applications can use a lot of virtual memory without consuming RAM.
  5. 3 points
    WinNTSetup 4.0 Final - Added Dark Theme support - Added multicore appling of WIM - Added wimlib 1.13.1 - Added bottice 1.3.3.2 - Added Disable Reserved Storage tweak - Added WIM Capture option - Added apply mode Wimboot:WIMCOPY - Added Hotfix uninstall option - Added Driver Export/Import option - Added LegacyBootMenu checkbox - Added exclude section to Tools\Win10Builds.ini - fixed wimlib apply alters WimBootCompress.ini - Boot code UEFI will be selected as default in case of EFI system partition - WOF decompression of \Bootmgr, \EFI\boot\boot*.efi, \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI - WOF decompression of \Boot\BCD, \EFI\microsoft\boot\BCD - Does not delete MountedDevices key for non sysprep images - Allow creation of expandable VHD with any size - Non fitting expandable VHDs will stop from auto expanding on boot - Workaround wimgapi "PrepopulateList" bug
  6. 3 points
    New build of Serpent/UXP for XP! Test binary: Win32 https://o.rths.ml/basilisk/basilisk52-g4.4.win32-git-20191123-21fdc3e93-xpmod.7z Win64 https://o.rths.ml/basilisk/basilisk52-g4.4.win64-git-20191123-21fdc3e93-xpmod.7z source code that is comparable to my current working tree is available here: https://github.com/roytam1/UXP/commits/custom NM28XP build: Win32 https://o.rths.ml/palemoon/palemoon-28.8.0a1.win32-git-20191123-21fdc3e93-xpmod.7z Win64 https://o.rths.ml/palemoon/palemoon-28.8.0a1.win64-git-20191123-21fdc3e93-xpmod.7z Official repo changes since my last build: - Issue #1258 - Part 1: Import mailnews, ldap, and mork from comm-esr52.9.1 (302bf1b52) - Merge branch 'master' into mailnews-work (2d4aca6d0) - Issue #1258 - Part 2: Use binoc-central version of ldap (6513e41cb) - Merge branch 'master' into mailnews-work (a57983a21) - Issue #1258 - Part 3: Make mailnews and friends build (6e7b3df37) - Issue #1258 - Part 4: Remove Add IM Account from Account Manager (1f23280e6) - Issue #1258 - Part 5: Only IceDove cares about Thunderbird's baby mode account creation (5d18a70aa) - Issue #1258 - Part 6: Add MOZ_MOVEMAIL to MOZ_MAILNEWS configure logic (37fbbd447) - Issue #1258 - Part 7: UXP Specific fixes (711a5031d) - Merge branch 'master' into mailnews-work (714afc76f) - Issue #1258 - Part 8: Ifdef MailNews OAuth2 Support (03590a671) - Merge branch 'master' into mailnews-work (b0e23e79e) - Bug 1328847 - Change SEC_NORMAL to SEC_ALLOW_CROSS_ORIGIN_DATA_IS_NULL where system principal is used. (bbf10b909) - Bug 516464 - Remove passwords from cache when password manager contents are changed to prevent stale password attempts. (74e5265d3) - Bug 1461106 - Remove SMTP password from cache when deleted from password manager to prevent stale connection attempts. (58a7cff16) - Bug 1404049 - fix that mail.imap.use_literal_plus set to false may have no effect. (02dc2390e) - Bug 1079280 - Don't transmit email when imap append response is bad. (5393f033b) - Bug 1227761 - Fix logic error in BuildAttachmentList(). (1ec388b23) - Bug 1427732 - fix newline handling when copying messages and compacting folders. (e60090bc9) - Issue #1273 - Remove Telemetry from Gloda (4db1ae892) - Bug 1487082 - Resolve potential for build bustage regarding bad implicit conversion constructors (201683afe) - Bug 646901 - add error checking to fix crash in nsMsgXFVirtualFolderDBView::OnSearchHit(). (818c1df5e) - Bug 1462316 - fix crash in nsAbView::OnItemAdded(). (ba48342fa) - Bug 825513 - Fix crash in nsImapProtocol::GetMessageSize() by adding null check for m_runningUrl && m_hostSessionList. (993a6bc1d) - Bug 1393219 - Code clean-up: Style nits, typos and trailing spaces (9ae2525b9) - Bug 1399756 - (More) Code clean-up: Style nits, typos and trailing spaces (713dca2fd) - Bug 1416033 - remove some unneeded includes in mailnews (a2a658f88) - Revert "Issue #1273 - Remove Telemetry from Gloda" (4d6dbd35f) - Bug 1216951 - Fix broken handling of split CR and LF between chunks. (81dd13387) - Bug 1444389 - Fix crash in nsImapProtocol::HandleMessageDownLoadLine(). (4d20783c0) - Bug 1317117 - call msgStore folder deletion during imap/news empty trash. (1f5f6a4bf) - Bug 1442648 - Fix mismatched types in mingw-w64 builds (const char16_t*/char16ptr_t). (e661493bb) - Bug 145113 - Make "next chunk starts with newline" flag a member variable to fix MOZ_ASSERT(). (fdcb16661) - Bug 1494764 - Removed MOZ_ASSERT but now still process line where it would occur. (05667b0d4) - Bug 1333038 - Use 'modern' pointers to fix crash due to nsMsgLineStreamBuffer object being deleted while still in use. (cea77b76b) - Bug 1257058 - Distinguish 'empty password' from no password received to avoid shutdown crash. (97826b14c) - Bug 344205 - React correctly to NO/BAD tagged response to imap IDLE. (43919ab8c) - Bug 1320475 - Fix broken controllers for cmd_printcard and cmd_printcardpreview. (0a8849ad6) - Bug 1507718 - crash in nsImapProtocol::GetMessageSize(). Make m_hostSessionList an nsCOMPtr. (891ca8709) - Bug 1508046 - return cleanly in LDAP autocomplete search if we are offline. (2fda56a84) - Bug 342632 - Allow defaultAccount to return success with nullptr result when there is no usable account. (5d21f962d) - Bug 1401858 - add null check to avoid crash in EncodedHeader()/DecodedHeader(). (fa9ca98c3) - Bug 1271353 - check own email addresses case-insensitively in correspondents column and ignore plus addressing part. (6d5922ba8) - Bug 809513 - Prevent unread Drafts from showing in new mail notification. (2fa79c837) - Bug 390721 - When parsing headers to cancel an article, also use folded lines. (c5a0af052) - Bugs 1512557 and 1470716 - Convert nsIStringBundle pointers to nsCOMPtrs and release them when shutting down. (66c5b1105) - Bug 906469 - fix maildir crash while parsing a folder. (d80e610cd) - Bug 1517464 - Fix crash in SMTP DTOR by properly initializing/testing pointer. (22973db50) - Bug 393302 - Correct memory handling in MAPISendMail() and CMapiImp::SendMail() to fix "Send to > Mail Recipient" crash. (1d5ec356b) - Bug 1523048 - when copying a filter, copy its triggering events too (filterType). (05b84061f) - Bugs 1402750 and 1490331 - Declare the character set correctly in the 'PGP add-on is missing' message. (544e93daf) - Bugs 1507218 and 1528615 (38fe066bb) - Bug 1525120 - Fix condition for decoding attachments (base64/qp) when saving or forwarding. (fa711799b) - Bug 1495698 - Fix hang when HTML signature references non-existent image. (4b217ebe5) - Bug 1386601 - experimental patch to investigate Thunderbird topcrash, serializes S/MIME verification. (3d9db9cb3) - Bug 1508054 - reduce exposed API of nsMsgHdr. (31fea2bc2) - Bug 1546840 - Allow GloDa queries for read or unread messages (7922314fa) - Bug 1020971 - Port bug 1015664: Remove NS_HIDDEN and friends. (359334f1a) - Bug 971347 - Fix autoconfig vulnerable to active MITM attacks for all domains (including the ones in ISPDB) (4fdd9dac6) - Tails 6156 - Fix outdated error handling in accountcreation and remove buggy debug code (14ef56453) - Bug 522450 - Place mail copy on the correct folder when using Reply to List (bca2de131) - Bug 1167982 - Do charset detection for all text/* attachments in composition, not just text/plain. (0903ef356) - Bug 1423487 - Support multiple authors in RSS feeds. (0707a51ea) - Bug 1528496 - Correctly fix Bug 1023285 and utf8 addressing header display for jsmime. (43db6faf2) - Bug 1480063 - Remove mimeEncodeSubject (encodeMimePartIIStr_UTF8) from feeds. (20aab9e0c) - Bug 1554098 - deduce RSS media enclosures type from extension when missing. (3c41580e7) - Bug 1338715 - Remove Outlook Express import (7047b11cf) - Bug 1315662 - delete SMTP server login credentials when deleting the account or if hostname/username changes. (dc46cd9ec) - Bug 1558595 (2732b1a0b) - Bugs 1437282, 1438590, 1506587, and 1498795 (64f423eb4) - Bug 1568095 - Make morkAtom::GetYarn() static. (a081e71be) - Bug 1580187 - Add null check to avoid crash in nsImapService::NewChannel(). (dc77b707f) - Bug 1240290 (73e14fb70) - Bug 1584473 - Fix several issues (7406d488b) - Bug 786683 - check success of GetFilePath() throughout nsMsgBrkMBoxStore.cpp. (c6df8fffb) - Bug 726655 - Add null check in nsMsgDBView::GetThreadContainingMsgHdr() to avoid crash. (3260f2045) - Bug 1584473 - Follow-up: Remove leftover references to nsIMdbRowCellCursor::MakeCell() in comments. (d59e35c94) - Issue #1258 - Part 9: Add close-icon class to close button in newmailalert.xul (6d6759a78) - Issue #1258 - Follow up to Part 8: Ifdef MailNews OAuth2 Support (73cdfdcf3) - Issue #1258 - Part 10: Remove chat core bits (cc757e4e4) - Issue #1258 - Follow up to Part 8: Ifdef MailNews OAuth2 Support (6c4ed6504) - Manually revert Bug 1494764 - Removed MOZ_ASSERT but now still process line where it would occur. (9f00e5184) - Bug 1494764 - Removed MOZ_ASSERT but now still process line where it would occur. (f3611104b) - Issue #1258 - Follow up to Part 8: Ifdef MailNews OAuth2 Support (ecdfbc692) - Merge branch 'master' into mailnews-work (9308ec68e) - Merge branch 'master' into mailnews-work (1d30f6fa8) - Bug 1592407 - Port OAuth2 decoding fix from gData add-on. (f3d462c60) - Merge branch 'master' into mailnews-work (556349010) - Issue #1259 - Adjust Widewine strings after removing Adobe Primetime support (d03485712) - Issue #1288 - Use NS_DECL_THREADSAFE_ISUPPORTS in HttpBaseChannel.cpp (2f4fdced5) - Merge pull request #1294 from g4jc/bug_1288 (8a64845aa) - Merge pull request #1293 from JustOff/PR_widevine_strings (36c81a978) - Issue #1284 - Implement /s (dotAll) for regular expressions. (f31b04a30) - Revert "Issue #1284 - Implement /s (dotAll) for regular expressions." (bd529c60c) - Issue #457 - Fix typo in ipc/chromium/src/base/sys_info_posix.cc (35cc4c128) - Merge pull request #1297 from athenian200/compiler-warning (62a72e3d2) - Issue #1284 - Implement /s (dotAll) for regular expressions, v2. (122e1ee6c) - Issue #1284 - Update js/src/builtin/TestingFunctions.cpp for /s (dotAll) regular expression changes (0a6ccfaa9) - Merge pull request #1298 from g4jc/b1284 (47ca6f108) - Issue #1242 - Reinstate GPU Accelerated Windows entry in about:support (4f6a779e0) - Issue #447 - Update HSTS preload list (fcea217aa) - Remove duplicate localization note (e97cb2f75) - Issue #1251 - Remove obsolete XP_QSORT reference. (21fdc3e93) My changes since my last build: - restored XP compat in nsMessengerWinIntegration (593762743) - Hidden preference to toggle addon version in addon manager (#10) (#9) (d9fb4e872) - Reverted Bug 1338715 - Remove Outlook Express import (7047b11cf) - applied NSPR Bug 1586070 - Read does not advance file position for files larger than 4GB on Win32. (See also bug 70765.) r=kaie (97ea6ee95) - updated to nss-3.44.3 (eb4044be7)
  7. 3 points
    @Dave-H : A check of "cote.co.uk" on SSL Labs Server test page https://www.ssllabs.com/ssltest/analyze.html?d=www.cote.co.uk confirms what has already been reported; just scroll down to the Handshake Simulation section: ... and see that IE11 only works on Win10 ! As to why, I think I have some clues: I couldn't help noticing how that server was configured: Only TLS 1.2 version is enabled, and only 3 cipher suites for that protocol version: Now, IE11 uses the cipher suites available in the OS's "Microsoft Schannel Provider" library; however, different Windows versions support different sets of cipher suites: https://docs.microsoft.com/en-us/windows/win32/secauthn/cipher-suites-in-schannel If one checks the available suites on Win7: https://docs.microsoft.com/en-us/windows/win32/secauthn/tls-cipher-suites-in-windows-7 one cannot find any of the three cipher suites needed for connection to the server in question... OTOH, checking the available cipher suites on Win10 v1903: https://docs.microsoft.com/en-us/windows/win32/secauthn/tls-cipher-suites-in-windows-10-v1903 one can find the first preferred (by the server) cipher suite, TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256, as available, hence the TLS 1.2 handshake succeeds and the site loads in IE11/Win10! However, I don't have answers as to why Chrome 49/WinXP[SP3] also succeeds, unless, of course, ProxyHTTPSProxy is used with it... BTW, Chrome 49 does open the site successfully here, Vista SP2 32-bit, but I do have installed WinServer 2008 updates that enable TLS 1.2 support: Perhaps Chrome 49 has native support for that cipher suite and only uses the Windows Store for certificates, NOT using Schannel like IE does (I'm sorry, my Chrome related knowledge is limited, have only been a Firefox fan from the start!) ... Cheers
  8. 3 points
    Standalone installers are working fine, updates have been installed.
  9. 2 points
    This night has been very productive. I have managed to make APZ work in 38 ESR, as well as discovering that layers.low-precision-buffer hurts performance if enabled. The 52 ESR version has been set in stone, with the workaround I have applied (apz.desktop.enabled set to true but without enabling apz.drag.enabled as it causes massive lag on 52 ESR). Due to the rendering problems I had when I enabled E10S, that will be scrapped and so, I will no longer develop a separate version for New Moon 28. If the user wants E10S, then he should enable it manually. It's a matter of time before I release the new version. I just need to do some minor test to check if the new parameters stick, otherwise I'll move those to the Enforcer. EDIT: The release of the new version has been postponed again due to bugs found in the 45 ESR version.
  10. 2 points
    Fellow Vista Home Premium SP2 32-bit user here ; on Vista, there seems to be a conflict/incompatibility between the native WMF h264 decoder (not present in XP) and certain gif formats, like the Twitter ones ; the ffmpeg-based h264 decoder present inside @roytam1 's custom-patched ffvpx library is still capable of rendering those gifs though, but has a lower value (in the preferred order) and is thus not used by default on Vista (while it is on XP, which lacks WMF); so, your issue is Vista specific... To view such Twitter gifs on Vista, temporarily set (in about:config) media.wmf.enabled to false and reload the twitter page; the gif should play now (because ffvpx takes over...) NB: I'd advise against making this a permanent pref change, as the WMF framework is better suited for media playback integration with UXP browsers under Vista (e.g., if your gfx card supports hardware (i.e. GPU) h264 decoding, it can make use of that, while ffvpx always uses software (i.e. CPU) decoding) ! Best regards
  11. 2 points
    Warning to users of Adobe's "Flash" plug-in: I have discovered that the 52 ESR version of the UOC Patch sets two preferences that interfere with Flash: privacy.resistFingerprinting dom.ipc.plugins.asyncdrawing.enabled #1 is more serious. For some reason, it prevents Flash from working at all. Luckily, it also has the easiest workaround: set it back to false, or remove the line enabling it from the UOC_Patch_52.js file; instead, use an extension (I use "Canvas Defender" but there are several others) to resist canvas fingerprinting. #2 may, or may not, affect your system. To test, first disable the above preference, then go to https://get.adobe.com/flashplayer/about/. If both the Flash animation and your currently installed Flash version appear, you're fine and can leave this preference set to true. If the page doesn't work properly, you'll have to set this preference to false also. Unfortunately I know of no workaround to retain its function if you have to turn it off. Edit: It turns out that privacy.resistFingerprinting implicitly does lots of things "behind the scenes". Some of these changes, such as user agent overrides, could cause Web sites to malfunction or otherwise affect usability. Luckily, most of the changes didn't land until FF 55 (which won't run on XP) or later FF versions (but Serpent 55 may include some of them). Still, I think it would be best to remove this preference from the UOC Patch. Edit 2: The troublesome privacy.resistFingerprinting also appears in the FF 45 version of the UOC Patch, but that preference doesn't do as much in that version, so it may not cause trouble with Flash there. I haven't tested FF 45 with the UOC Patch and Flash. Edit 3: Found one more. This one's more obscure, but I'm posting it anyway, just in case anyone runs across it. The UOC Patch sets pref apz.allow_zooming, which conflicts with the Multi-Account Containers add-on. That add-on is the main reason I switched to Serpent 55, so my own customized version of the UOC Patch now omits privacy.resistFingerprinting and apz.allow_zooming, and sets dom.ipc.plugins.asyncdrawing.enabled to false to ensure Flash always works. Hopefully I now have everything working again!
  12. 2 points
    That's good; your last post had me worried! My yellow shield was there this AM with the three Office 2010 updates. Since manual installation still works, here are links to their support pages: https://support.microsoft.com/kb/4484164 https://support.microsoft.com/kb/4484127 https://support.microsoft.com/kb/4484160 You can go to each support page, scroll down to "Option 3: Microsoft Download Center," and find links to the standalone installers for both 32- and 64-bit versions of Office 2010. (I would assume the vast majority of folks have 32-bit systems, but just in case....)
  13. 2 points
    This happened to me too. If I remember correctly, what it ended up doing was adding the contribution amount to my existing login. So instead of $5 total donated it shows up as $10 kind of thing. I think this worked out better, because the number of licenses was more for $10 than it was for 2 x $5.
  14. 2 points
    Images often downloaded separately from the email that contains them because they're so large. Outlook uses IE to download these images. If IE can't download an image you'll get the red X, but there are lots of reasons IE might not be able to download from a particular server besides a certificate problem. For example, there may not be a TLS cipher that both the server and IE support. You may find that installing @heinoganda's version of ProxHTTPSProxyMII will resolve many of those download failures.
  15. 1 point
    you may turn on firefox compat mode to see if problem persists.
  16. 1 point
    @Nomen Yes. BTW, these keys conflict with each other: For XP Embedded (no longer supported and should be removed from registry) and for POSReady 2009 (still working on WU/MU, the only proper one nowadays) These keys are obsolete and should be removed also:
  17. 1 point
    https://www.ghacks.net/2019/12/07/someone-found-a-way-to-bypass-windows-7-extended-security-updates-checks/
  18. 1 point
    I'm using Malwarebytes Premium 3.5.1 and it's still automatically updating itself absolutely fine.
  19. 1 point
    Would you be so kind and share the build that works on windows 7? I want to do some experiments.
  20. 1 point
    @alacran There was no such file. If the Win7 USB tweak don't work for you, than should use usb-boot-watcher.
  21. 1 point
    I personally would like to see a build of K-Meleon 1.5.x with TLS 1.2 support, or a build of RZ browser (Firefox Community Edition) 3.6.x. According to ssllabs.com, 63.4% of websites serveyed still have TLS 1.0 enabled (which is required for older K-Meleon, Seamonkey, and Firefox based web browsers). https://www.ssllabs.com/ssl-pulse/ Here is a RetroZilla MSFN forum that would be very interesting for these older browsers.
  22. 1 point
    msfntor said: > At the same time as I was logging in to MSFN via Serpent 55, I had an open Slimjet browser > avec Zenmate enabled (but not functionning - why?), maybe there was any influence on the behavior of Serpent 55... > If Zenmate extension enabled, I've this message page on all websites: > "Your connection is not secure. ..." Click Advanced --> "Peer's certificate has expired." > After disable my proxy extension, restart the page, website's content is here, OK. > This happens to me in all browsers where I've downloaded proxy extension: > Serpent 55, Serpent 52, New Moon 28, Firefox 45. For a long time. Sorry I know hardly anything about proxies, but your problem seems completely independant from browsers. My non-expert impression: the prob is only your systemwide, independant zenmate APP, which connects to its own server directly. Obviously your version is just too old, if it contains only outdated certs/ciphers. Or perhaps it uses the very old ciphers of the system. But the used browsers don't matter, since they get the data only afterwards. After the app has already downloaded them from its own server, using a direct connection and it's own outdated ciphers. Roytam's fresh builds certainly contain modern ciphers. You could try disabling that global app and connect with a normal browser proxy directly to the zenmate server, if knowing the necessary connection data, probably different for each fake country. Zenmate offers own browser addons, but only in WebExt type. For browsers using only 'legacy' power addons, a general proxy addon should work too, if IP etc is known. K-Meleon has a proxy function already built in, configuration in F2>Network/Performance>Proxy
  23. 1 point
    Roger that. I have tested the build and it works wonderfully on the RDD. I still haven't UOC'ed the browser yet, but I will once the new rewrite for 45 ESR SSE is done. If the Patch works as it should and if the extensions I use don't bog Serpent down, I think I might have found a replacement web browser for the RDD... 😏
  24. 1 point
    Well, SM 2.49.5 (last for XP) doesn't, anyway. You either have to install Adobe Primetime or copy some DLL's from one of @roytam1 browsers. We had a bit of an adventure trying to figure this out in the original (now closed) thread, but we eventually did figure it out, and we now have two ways to play HTML5 videos in SM 2.49.5. Note: That only applies to Windows XP. On newer Windows versions SM 2.49.5 can use WMF to play HTML5 videos, but XP lacks WMF.
  25. 1 point
    Aaaand actually I got it. I just not needed the path visible when requesting sharepoint or teams to provide you the link. I opened excel, right-clicked on recently opened file, pressed "copy file location" and I was able to create a shortcut following syntax "path to excel" "path to file" Solved.
  26. 1 point
    -- 1.5.10 (9.12.2018) -- * additional changes to match acrylic design (installer provides option which design to use) HKCU\Software\Microsoft\Windows\DWM - CustomThemeMaterial - file with texture that is rendered (tiled) above glass regions (default is Acrylic noise texture) Aero Glass 1.5.10-1.5.12 ignore any external PNG texture file in CustomThemeMaterial.
  27. 1 point
    The installation is possible, but it does not work at all. .Net 4.5 Binaries were made for Windows 7.
  28. 1 point
    You may want to get @roytam1's Serpent 52 from the XP forum, and also use @heinoganda's Cert_Updater_v1.6 to give XP the latest security certificates.
  29. 1 point
    As long as the distorted audio can always be fixed with a simple user agent change, I see no reason to retain Adobe Primetime support in Serpent. (I'll add the above user agent to myuseragents.js.) Does anyone know of a site with distorted audio that can't be fixed with a different user agent? (If so, that would be a reason to restore Primetime support.)
  30. 1 point
    In Windows 7 decoding works good for me with media.wmf.enabled to true but in Windows XP, where I sometimes go to use older software CPU decoding doesn't cut it on certain sites like Twitter. But I just finally learned a little trick to force lower resolution by adding a mobile tag in the url, for example, https://twitter.com/FireTheFoxxo/status/1196668801489739777 to this: https://mobile.twitter.com/FireTheFoxxo/status/1196668801489739777 Twitter videos are now at least bearable in XP without having to download them. Unless I'm missing it it's apparently beyond the capability of the "Twitter team" to provide resolution options on their player the way youtube and others do. Edit: you can also force mobile twitter by changing the UA to an older browser like Firefox 3.0 but if you're like me and have the UA set in about:config then adding the mobile tag to watch videos is another option.
  31. 1 point
    IIRC, the last Java version with an installer that runs on XP was 8u151/8u152. But any Java version prior to the latest (8u231 as noted above) will trigger Mozilla's security warning. To get the latest version installed on XP, see these posts: BTW if you put those commands into a .bat or .cmd file don't forget to double all the % characters in the for command. You may also want to use a capital F vs. a lowercase f.
  32. 1 point
    Sorry, by EOS I meant end of sale... which is the "Extended" period that included OEM Facilitated Downgrade Rights (Buy Win 10, get Win 7 installed). I do not remember exactly how long ago it was, I wanted to say 2 years but that seems to be too long.
  33. 1 point
    @Tangy, @caliber, Look to change some rule in your extensions, and look to not block javascript entirely... First, to test, disable your JavaScript extension and other defenses: Test your JavaScript Browser Information by browserleaks.com: https://browserleaks.com/javascript JavaScript Inspector Know what JavaScript reveals about your browser: https://webbrowsertools.com/javascript/#javascript-uri Then I don't have problems with youtube.com home page, all videos are here and I could play them all.
  34. 1 point
    Imagine that it wants some parameters on command line. How would you pass them to it? You know like *any* command line tool that expects parameters you could open a command prompt, navigate to the directorywhere the .exe is and then type on the command line the name of the .exe, in this case WINXPPAE,EXE and press [ENTER]. Maybe then it won't close in half a second ... jaclaz
  35. 1 point
    And I do not have this setting, but very good vod.tvp.pl: http://prnt.sc/q063dz http://prnt.sc/q064it NM and serpent are good now.
  36. 1 point
    Caliber said: > the problem is that in some streaming sites the video miniatures are not displayed > with Firefox mode activated. With site-UA: > it has no effect, the problem persists Most likely either: - the page contains elements from other domains too, which must be tweaked too - or you have a useragent addon installed which disabled the native UA-system, but this can easily be tested
  37. 1 point
    will give a try to that patch which I was unaware of If you want another user friendly patch, the following one with a single click it's done. the best thing is that is doesn't ''destroy'' your system files so you can quickly uninstall it in case your system doesn't run properly.
  38. 1 point
    Please fix AeroGlass for Windows 10 1909
  39. 1 point
    It is always worth the five minutes it takes to try and change the major/minor OS in the executable. A number of executables are perfectly fine running in XP BUT they are compiled with a "default" setting targeting 6 (Vista). This results in the error "This is not a valid Win32 application". Get CFF explorer: https://ntcore.com/?page_id=388 Open with it the (copy of the) executable and select "Optional Header". Then change: MajorOperatingSystemVersion to 5 MinorOperatingSystemVersion to 1 MajorSubsystemVersion to 5 MinorSubsystemVersion to 1 and save. No idea if this applies specifically to Inno Setup executables, though. jaclaz
  40. 1 point
    It gave some better performance on my Pentium M laptop, heavy sites load better without hanging the browser :)
  41. 1 point
    https://www.cote.co.uk/ Hehe - LOL!! Am delighted to report that page OPENS in Win98 with roytams old K-Meleon-Goanna74! xD (this is not even KM76, but 74 with engine of Palemoon26/Fox24) And even with all my blocks up, incl blocked global javascript, which means the page looks empty but it does load the source, gets the page title, shows NO security errors, and a mini-content shows up when simply killing stylesheets. And with my usual UA of fake IE7. To avoid misunderstandings, that does NOT mean the page were usable that way, no menus nor FAQ page etc. are displayed, am merely getting a few links to facebook+instagram and phone numbers. It just means the access is not blocked completely. The page is chock full with all sorts of scripts, with interesting source code like using xxx.WRITE (doc.write is blocked at least since FF38, but may be contained due to my old useragent), or html tags "@onclick" Just meaning that pretty much rules out any required modern features or permissions as culprits for the completely denied access. Still suspect the certs, but if true, that makes me wonder if Iron has some embedded ones too? Or (no idea) if weak certs are not disabled in whole system, only by browsers?
  42. 1 point
    With NM28 I use canvas.poisondata set to true. When I need to obfuscate the "ClientRects Fingerprint" *** I use the add-on: https://addons.palemoon.org/addon/canvasblocker-legacy/ *** Test: https://browserleaks.com/rects
  43. 1 point
    Because they decided to. Same reason that anyone uses any program. but I booted my one 7 system with the MSE on it, let it update, no EOL nag there yet, FWIW
  44. 1 point
    Yes, I tested it with the latest PM 28, and it works! E10s remains disabled even with the "standard" FF 52 version of the patch. Thanks! So, the separate NM28 version of the patch is no longer needed.
  45. 1 point
    A lot of normal "legacy" firefox extensions work just fine too...
  46. 1 point
  47. 1 point
    Thinking back about the time when "you know who" made a lot of fuss about the branding of the forked browsers, I noticed mainstream Basilisk still contains strings where the browser is referred to as "Firefox".
  48. 1 point
    New build of Serpent/UXP for XP! Test binary: Win32 https://o.rths.ml/basilisk/basilisk52-g4.4.win32-git-20191109-4a0c734e1-xpmod.7z Win64 https://o.rths.ml/basilisk/basilisk52-g4.4.win64-git-20191109-4a0c734e1-xpmod.7z source code that is comparable to my current working tree is available here: https://github.com/roytam1/UXP/commits/custom NM28XP build: Win32 https://o.rths.ml/palemoon/palemoon-28.8.0a1.win32-git-20191109-4a0c734e1-xpmod.7z Win64 https://o.rths.ml/palemoon/palemoon-28.8.0a1.win64-git-20191109-4a0c734e1-xpmod.7z Official repo changes since my last build: - Issue #1064: Don't get certificate details synchronously. (3252e2200) - No issue: Clean up `exceptionDialog.js` (a63272b53) - MoonchildProductions#1251 - Part 1: Restore initial Solaris support, fixed up. (afc187cc3) - MoonchildProductions#1251 - Part 2: Make the mozconfig loader POSIX-compliant. (9d449ce61) - MoonchildProductions#1251 - Part 3: Finally end the long tradition of casting getpid() to int. (64e03d014) - MoonchildProductions#1251 - Part 4: Core build system changes, lots of libevent/IPC junk. (4105ebb6e) - MoonchildProductions#1251 - Part 5: Fix POSIX compliance issue in process_util.h. (f105b741e) - MoonchildProductions#1251 - Part 6: Solaris needs an audio implementation. (57bfda37a) - MoonchildProductions#1251 - Part 7: All the posix_m* memory-related stuff, gathered together. (3647f42c2) - MoonchildProductions#1251 - Part 8: Align pointer for char_16t. (c0d814c1d) - MoonchildProductions#1251 - Part 9: Look for hypot in the math library (libm). (cf75ede0d) - MoonchildProductions#1251 - Part 10: ipc_channel_posix.cc should use IOV_MAX. (52f2321cb) - MoonchildProductions#1251 - Part 11: libpng uses C89 now to avoid buffer overflows. (7966d22df) - MoonchildProductions#1251 - Part 12: Add Solaris/illumos support to WasmSignalHandlers. (76c55f747) - MoonchildProductions#1251 - Part 13: Redefining abort in C++ requires extern "C" (5c28f10c1) - MoonchildProductions#1251 - Part 14: libstagefright build should avoid _GLIBCXX_OS_DEFINES. (e3fb8bd24) - MoonchildProductions#1251 - Part 15: fdlibm should provide definition for u_int32_t and u_int64_t. (4f6639a1b) - MoonchildProductions#1251 - Part 16: Resolve namespace conflicts with dbm on Solaris. (fca7c45a6) - MoonchildProductions#1251 - Part 17: All the libffi and libxul.so issues, resolved. (beea314ff) - MoonchildProductions#1251 - Part 18: (Hopefully) final version of build system fixes. (7e5ff857e) - MoonchildProductions#1251 - Part 19: Make the unpreprocessed file script work on Solaris. (e51afbcc2) - MoonchildProductions#1251 - Part 20: Add atomic.h to system-headers. (db34ef993) - Fix a bunch of dumb typos and omissions. (575f51a27) - MoonchildProductions#1251 - Part 21: Fix Flash player and some extensions being incompatible. (5a4a4990c) - MoonchildProductions#1251 - Part 22: Remove some unused type declarations from IPC process_util. (7d65eb2b3) - MoonchildProductions#1251 - Part 23: Allow AMD64 build to work. (2f4488521) - MoonchildProductions#1251 - Part 24: Remove temporary GNU M4 workaround. (9cd92944e) - MoonchildProductions#1251 - Part 25: Fix link paths. (21146d0d5) - MoonchildProductions#1251 - Part 26: Oracle Solaris gsed/ICU fix. (e4f90cbb5) - MoonchildProductions#1251 - Part 27: Fix ifdef style. (687a798e6) - Fix nits. (a9dc528a4) - Merge pull request #1262 from athenian200/solaris-work (21b3f6247) - Issue #146 - Part 1: Draw each table's background on their own display list items. (145527207) - Issue #146 - Part 2: Remove custom table painting component. (0de40040f) - Issue #1265 - Expose sndio as a build option for any supporting system (873f2cf8c) - Issue #1267 - Part 1: Update libcubeb to a1200c34. (d162ecbaf) - Issue #1267 - Part 2: fix libcubeb bindings in dom (22b35fa8e) - Merge pull request #1270 from g4jc/libcubeb (b7c6c779e) - Merge pull request #1269 from g4jc/sndio (6ee3467a6) - Issue #146 - Part 3: Create nsDisplayTableFixedPosition to avoid display list collisions when processing the background image of a table. (db98e3eff) - Issue #146 - Part 3: Create nsDisplayTableBackgroundImage to avoid display list collisions when processing the background image of a table. (ee663e293) - Issue #146 - Part 4: Adjust tests for fixes. (f1b043af1) - Issue #146 - Part 5: Treat table row groups as containing blocks. (ce11d5cae) - Issue #146 - Part 6: Allow `position: sticky` on table elements. (5ab2da700) - Issue #146 - Part 7: Remove no longer relevant reftest. (76052e837) - Revert "Issue #1267 - Part 2: fix libcubeb bindings in dom" (732fe3624) - Revert "Issue #1267 - Part 1: Update libcubeb to a1200c34." (1960d6e08) - Bump Goanna version. (ee8c5d387) - Issue #1271 - Fix build failure in current in-tree libcubeb sndio module (ff0f4b11a) - Merge pull request #1272 from g4jc/libcubeb (22b410f31) - Merge branch 'table-sticky-work' (bbc2206a0) - Issue #1252 - Remove fragile fast path. (082670ecb) - Merge branch 'master' into certexception-work (c5c44d120) - Issue #1064 - Part 2: Fix shorthand and services module import. (5f37447ac) - Issue #1064 - Part 3: Fix notifyObservers() call. (6df8aa495) - Issue #1274 - Part 1: Adopt the cairo version as our own. (7efd71616) - Issue #1274 - Part 2: Update Windows prerequisite defines. (45f665b59) - Issue #1274 - Part 3: Update libpixman licensing (620fdbdf4) - Issue #1274 - Part 4: Remove some unnecessary checks for old Windows versions. (7b8a065ea) - Issue #1274 - Part 5: Misc fixes and version update. (5f80c286c) - Issue #1275 - Add pref to disable warning prompts for SuperfluousAuth and AutomaticAuth, and default to not prompting. (7f5d38150) - Merge branch 'master' of https://github.com/MoonchildProductions/UXP (aff468a48) - Issue #1263 - Part 1: Remove DiskSpaceWatcher (60c83971f) - Issue #1263 - Part 2: Remove DiskSpaceWatcher tests (eb35cd108) - Merge pull request #1214 from MoonchildProductions/certexception-work (8bb208397) - Merge pull request #1276 from MoonchildProductions/cairo-work (0f3635dc8) - Issue #1254 - Update SQLite to 3.30.1 (4a0c734e1) My changes since my last build: - Reverted Issue #1274 - Part 2: Update Windows prerequisite defines. - Reverted Issue #1274 - Part 4: Remove some unnecessary checks for old Windows versions. (7b8a065ea)
  49. 1 point
    To curb the error-message that you have to cancel or what are you referring to? We already know the current build of Glass8 works fine on 1909, there's just this error message you have to click away because the build isn't whitelisted.
  50. 1 point
    We all knew this day would come. M$ has really been working overtime this year, killing any old OS features they possibly can. Early in the year they went after XP with a vengeance; now they're doing the same to Win 7. But there's a silver lining: I've read good things about EPG123. The Schedules Direct guide is from Gracenote, which supplies guide data for Zap2It.com and used to supply guide data for WMC before M$ switched to Rovi (which later bought Tivo and took the Tivo name for the merged company). The software is free but (as you noted) the Schedules Direct subscription isn't. The subscription is only $25/year though; a lot less than Tivo (unless you get a Tivo with a "lifetime" subscription), and I've read that you get a 21-day guide for your money; a nice improvement over the 12-day (at best) M$-provided guide.
×
×
  • Create New...