Jump to content

NVidia drivers 82.69


Recommended Posts

  • 4 months later...

While not exactly the subject of this thread, I would like to know whether anyone can help with a problem related to NVIDIA drivers under Windows 98:

I have a computer running Windows 98SE (version number 4.10.2222A).

I installed in it a Nvidia RIVA TNT2 Model 64 video card (VID=10DE, PID=002D).

The card works OK with Microsoft default driver, but in VGA mode (640 x 480 x 16) only.

I tried several drivers from Nvidia archive, from version 40.72 to 66.94. All support the RIVA TNT2 Model 64 under Windows 98, according to their documentation. Every one installs without a glitch but, on reboot, the computer stops during boot and restarts, at last booting in VGA mode. Looking at the log file, I see that, in every case, the driver nvdisp.drv failed to respond, and this caused the the boot process to stop and restart with Microsoft default driver instead. Each install was attempted in plain VGA, after removing the previous Nvidia driver version.

The monitor is a Sony Multiscan G 400, capable of 1280 x 1024 resolution (or better).



Link to comment
Share on other sites

Hi, jassenna! Welcome to MSFN!

I have two suggestions:

1)Don't remove nVidia drivers with Add/Remove applet or unistall, since neither does do a really thorough job, in this case. Do it, instead, by using the great freeware Driver Cleaner Pro Version 1.5 (*NOT* Driver Cleaner .NET !!!).

2)Very old cards require very old drivers... I strongly suggest you try their drivers from the 22.40 up to the 29.42.

Link to comment
Share on other sites

Hello Jassenna

I have tested the Graphics-Card "Fujitsu Siemens GM 1000-16".

Onboard is an Nvidia Riva TNT2 Model 64 GPU and 16 MB of RAM.

Tested on an ASUS P4P800 SE with P4/3.0GHz, 1 GB RAM.

For me working the Drivers 71.84 (98SE) and 66.93 (XP) fine.

Downloaded from the Standard Drivers-Page:


Selection: Legacy - TNT and TNT2 Series - Windows 98 (or XP) - preferred Language...

Download-Adress for 98SE-Driver (Archive):


Then klick on Version 71.84

When the next Page is loaded, press one of the Download-Links in the right Box (International).

Download-Adress for XP-Driver (Archive):


Scroll down and klick on Version 66.93

When the next Page is loaded, press one of the Download-Links in the right Box (International).

Maybe that you have to try some lower or higher Versions...

Good Luck...


*** MUCH THANKS *** to all People here who keeps 98SE alive!


Edited by UnclePaul
Link to comment
Share on other sites

Onboard is an Nvidia Riva TNT2 Model 64 GPU and 16 MB of RAM.

Tested on an ASUS P4P800 SE with P4/3.0GHz, 1 GB RAM.

For me working the Drivers 71.84 (98SE)

I am using the 'ForceWare 71.84' for months with Nvidia Riva TNT2 Model 64 (32 MB RAM) under Win 98SE with no glitch.

It is the last version working with those Graphics cards:

Link to comment
Share on other sites

  • 2 years later...

Hi guys,

sorry for waking up that old thread, but i totally despair in getting my Geforce 7600 GT running in Windows 98 SE.

Windows was installed (a few times) new on a 4 GB FAT32 partition (formatted right before first setup, before later setups just did "deltree programs" and "deltree windows" in DOS) and updated with inofficial Service Pack v2.x, also tried the new beta v3.0b4 Service Pack, or updated not at all, with chipset drivers, without chipset drivers, tried several DX'es (7, 9.0c, 9.30, ...) – i cannot get the 7600GT running in 98SE.

1) installing via the Win32 Cabinet Self-Extractor exe (that thing i downloaded),

2) installing via extracting this package (i used WinRAR) to Desktop and run setup.exe manually

3) installing out of this folder via "Gerätemanager" (=windows device manager? that thing in [win]+[pause] > second tab)

4) downloaded the .zip package and also tried this via windows device manager


1) after extracting and self-starting the setup, i get a bunch of errors. setup window looks badly corrupt. i may click 'OK' but there is no error message... except the last: "no nvidia chip device found"

2) same as 1)

3) installation seems fine, after restart there is no tray icon, and in right-click-on-desktop > display settings i cannot set anything else than 640x480@16 (unfortunately not 16 bits... no, 16 colors -.-)

4) same as 3)

My computer:

- Athlon XP

- a few PATA HDDs (installed on Samsung SP2514N),

- Abit KV7 Mainboard (VIA ethernet+audio+usb)

- RAM tried 256 and 512 MB with performance tweaks out of the SP 3.0b4

I think, i tried pretty much everything, but the 7600GT won't run on more than 'Standard PCI VGA' style ... it is annoying, since it is a fanless board. I don't need fat game 3D graphics power, i just need silence and a resolution of 1280x1024@16bit for a little bit music production in retro style.

Does someone hava an idea to solve this problem?

Thanks and many greetings from Germany,


btw: are any screenshots required?

@ MDGx: do you still have a few older versions of your modded driver? in you write about a NVAGP.INF ... but the newest package contains the NVAML.INF

Link to comment
Share on other sites

Perhaps your 7600GT card has 512MB of RAM, in which case you probably need the RAM patch by Rudolf Loew (shareware, costs $20), AFAIK nVidia series 7 with 512MB require unnoficial 82.69 drivers + RAM patch.

I use a 7950GT 512MB and the only issue I ever had were crashes in certain Java applications using OpenGL which I fixed by downgrading the file nvopengl.dll to the 81.98 version.

AGP aperture size in the BIOS matters as well, (even with 82.69 + patch).

Link to comment
Share on other sites

Excuse me,

loblo,can you tell me what is your config in win98 that make 7950GT 512MB work ?

I also have 7950GT 512MB and RAM Patch,but whether what config I try,they always fail to work.

My mainboard is Gigabyte 8IPE1000-G (Intel 865PE Chipest),

So...I guess even use the RAM Patch, only specific mainboards can run 7950GT 512MB successful in win98 ...

Link to comment
Share on other sites

StarRiver, I use Windows ME on an Asus A8V-Deluxe mobo (VIA Chipset). Look at the loblo (II) entry in the post linked below for full details about my system. There are also three other systems listed which are using a 7950GT in that post.

Edited by loblo
Link to comment
Share on other sites

  • 3 weeks later...

Hi loblo,

yes, my Geforce 7600 GT is a 512 MB AGP device. Can you tell me, where i find that RAM patch from Rudolf Loew? I just found dead links :(

Would like to check out the demo/trial.

Recently i tested a WDM-driver for any Geforce, which i found in web. But it was than a driver for video capturing and such rubbish.

I also tried ZakMcKracken's driver-mod, same as with the 82.69 driver, the installer did not find the Geforce chip, but installation by 'have disk' worked fine. However, when restarting - right before the moment, when desktop should appear - the computer hangs with blinking cursor. :(

Do you still have any ideas? Thanks for your help.

Edited by Kuschelbaerchen
Link to comment
Share on other sites

My website with x10hosting was moved to rloew@x10host.com months ago. The company discontinued the x10hosting.com domain and forced everyone to choose alternate domains.

Use my Web Redirect at rloew1.no-ip.com as it is updated th handle changes or down websites.

Link to comment
Share on other sites

  • 2 weeks later...

PCI-E, 512MB of RAM in the system as of now.

I have a cheapo Geforce 210 and I have a feeling it is based on a really old design..... I should give that ago, but the fact it has 1GB of VRAM makes me a bit nervous...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...