Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


pipalou50

aero glass for version 1803

Recommended Posts

for my part, and with regret, I gave up aero glass, updates as an insider no longer allow me to install and reinstall the software. :(

and I think BigMuscle has to make white hair too !!!  :dubbio: so, no need to harass him ...

I'm not saying that Aero Glass is dead, I'm just saying that the next version is not for now ..  :huh:

thank you to BigMuscle for his great job ... and his deserved to read your comments some of which are hardly encouraging for him !   :realmad:

Share this post


Link to post
Share on other sites

5 hours ago, AdamW said:

How did you get transparency working for Chrome?

 

From a post by @412070391 (which was scrubbed with the msfn server crash):

Quote

After upgrade to 67.0.3396.62, no glass on Chrome title bar.

Here's the method to get back glass:
1. open: chrome://flags/#windows10-custom-titlebar
2. choose "disabled"
restart Chrome and glass is back

 

  • Like 2

Share this post


Link to post
Share on other sites
On 7/14/2018 at 3:02 PM, AdamW said:

How did you get transparency working for Chrome?

I have the same problem with Thunderbird. Is there a solution?

Share this post


Link to post
Share on other sites
2 hours ago, nipponico said:

I have the same problem with Thunderbird. Is there a solution?

I use this in c:\Users\...\appdata\Roaming\Thunderbird\Profiles\.....default\chrome\userChrome.css

 

/* Set the default namespace to XUL */
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

#messengerWindow
{
	background-color: unset !important;
}

#titlebar, #titlebar-content, #titlebar-spacer
{
  background-color: transparent !important;
}

.titlebar-button {
	opacity: 0.25;
	transition: background-color 0.2s ease;
}

.titlebar-button > .toolbarbutton-icon {
	list-style-image: none;
}

 

  • Like 2

Share this post


Link to post
Share on other sites
22 hours ago, bigmuscle said:

I use this in c:\Users\...\appdata\Roaming\Thunderbird\Profiles\.....default\chrome\userChrome.css

Thanky you. Now it's better, but not perfect. Maybe because I use a different theme (Glass Onion)?

Thunderbird.jpg

Share this post


Link to post
Share on other sites
18 hours ago, nipponico said:

Interesting, but doesn't resolve my problem...

I have a 100% perfect and clean method to fix Firefox and Thunderbird but you would have to modify the .exe of both, would you be fine with that?

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, SkyySX said:

I have a 100% perfect and clean method to fix Firefox and Thunderbird but you would have to modify the .exe of both, would you be fine with that?

I am running Thunderbird 52.9.1. with the latest Aero Glass beta, and transparency works just fine, as you can see in the attached screenshot. Perhaps see what happens if/when you use a different theme?

NB - I have tried both an AeroGlass theme atlas and regular msstyle skinning, and the titlebar looked fine in both cases.

Clipboard01.jpg

Share this post


Link to post
Share on other sites
15 hours ago, Aethelflaed said:

I am running Thunderbird 52.9.1. with the latest Aero Glass beta, and transparency works just fine, as you can see in the attached screenshot. Perhaps see what happens if/when you use a different theme?

NB - I have tried both an AeroGlass theme atlas and regular msstyle skinning, and the titlebar looked fine in both cases.

Clipboard01.jpg

In your case it works fine because you use a Theme Atlas, if you use an actual custom-theme the min/max/close buttons will be messed up without the .exe fix.

Share this post


Link to post
Share on other sites

No, that screenshot was taken without the theme atlas.

But here is something to try:

Go to Tools > Options > Advanced > General, then click the config editor, and check whether mail.tabs.drawInTitlebar is set to 'false'. If it is not set to 'false', Thunderbird will attempt to draw the title bar itself, which is likely what causes the problem with the buttons not being skinned properly.

I completely forgot about this setting; IIRC there is a similar one for Firefox.

  • Like 1

Share this post


Link to post
Share on other sites

I sincerely apologize for taking so long to respond to your question, AdamW.

I was away on business.  Sadly, I missed much of the World Cup as well, but I digress.

----------------------------------------------------------------------------------------------

Regarding glass on Chrome, Blonk's post contains precisely that which I would have written for you, so thank you to Blonk :-)

I also recommend that you might consider the following theme, which, is displayed in the included screenshot + linked below:

https://chrome.google.com/webstore/detail/f2b-dark-electrique-neon/dpcngmlhjpglhbdbomhggfdjebkgaoap

I happen to contend that it's good-looking enough to share with y'all :-)

Anyways, have a great day everyone!

Sam-LC_-_07192018_000.jpg

Share this post


Link to post
Share on other sites
On 7/18/2018 at 10:43 PM, SkyySX said:

I have a 100% perfect and clean method to fix Firefox and Thunderbird but you would have to modify the .exe of both, would you be fine with that?

but i only use userchrome in Firefox quantum 61.0.1 you dont need to modified exe, well take a look..
 

RafSNCJ.png
 

KRPFNkH.png
 

https://i.imgur.com/6MyB2XZ.mp4

 

 

Share this post


Link to post
Share on other sites
20 hours ago, Aethelflaed said:

No, that screenshot was taken without the theme atlas.

But here is something to try:

Go to Tools > Options > Advanced > General, then click the config editor, and check whether mail.tabs.drawInTitlebar is set to 'false'. If it is not set to 'false', Thunderbird will attempt to draw the title bar itself, which is likely what causes the problem with the buttons not being skinned properly.

I completely forgot about this setting; IIRC there is a similar one for Firefox.

 

1 hour ago, ZiyaadMuhammad said:

but i only use userchrome in Firefox quantum 61.0.1 you dont need to modified exe, well take a look..
 

RafSNCJ.png
 

KRPFNkH.png
 

https://i.imgur.com/6MyB2XZ.mp4

 

 

Interesting, my method removes the Windows 10 manifest from the .exe making it unable to detect it's running on Windows 10 thus it loads the Windows 7/Windows 8 UI.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...