Jump to content

KernelEx 2022 (Kex22) Test Versions (


Recommended Posts

Windows 7 Ultimate (x86)

gvex=6,1,1DB1,2,Service Pack 1,1,0,100,1,1E

So last character of gvex is different.

Regarding testing Windows 8.1: I'd like to help, but my programming skills are rather low. Maybe you can update Getversion or give some instructions? I don't know what to do with information here:


Edited by deomsh
Link to comment
Share on other sites

Somehow I succeeded with roytam1's manifest as a text-file, renamed to GetVersion.exe.manifest

My earlier reported Windows 10 (x86) gives now:


And Windows 8.1 (64 bit):


Link to comment
Share on other sites

  • 2 weeks later...
KernelEx 4.5.2016.19 delta.7z - 191KB

<! ;-- 4.5.2016.18 --;
!> ;-- 4.5.2016.19 --;

<! SetEnvironmentVariableW

!> RtlImageDirectoryEntryToData
!> RtlImageRvaToSection
!> RtlImageRvaToVa

!> CompleteAuthToken

!> CM_Connect_MachineA
!> CM_Get_Child
!> CM_Get_Child_Ex
!> CM_Get_DevNode_Registry_PropertyW
!> CM_Get_DevNode_Registry_Property_ExA
!> CM_Get_DevNode_Registry_Property_ExW
!> CM_Get_DevNode_Status
!> CM_Get_DevNode_Status_Ex
!> CM_Get_Device_IDA
!> CM_Get_Device_IDW
!> CM_Get_Device_ID_ExA
!> CM_Get_Device_ID_ExW
!> CM_Get_Device_ID_ListW
!> CM_Get_Device_ID_List_SizeW
!> CM_Get_Parent
!> CM_Get_Parent_Ex
!> CM_Get_Sibling
!> CM_Get_Sibling_Ex
!> CM_Locate_DevNodeA
!> CM_Locate_DevNodeW
!> CM_Open_Class_KeyA
!> CM_Set_DevNode_Problem_Ex
!> CM_Setup_DevNode_Ex


!> GlobalMemoryStatusEx
!> InterlockedPushListSList
!> InterlockedPushListSListEx
!> PowerClearRequest
!> PowerCreateRequest
!> PowerSetRequest
!> TryAcquireSRWLockExclusive
!> TryAcquireSRWLockShared

!> DbgPrintEx
!> LdrAccessResource
!> LdrFindResource_U
!> NtQuerySystemTime
!> NtQuerySystemTime
!> RtlAppendUnicodeStringToString
!> RtlAppendUnicodeToString
!> RtlAssert
!> RtlConvertSidToUnicodeString
!> RtlCreateUnicodeString
!> RtlCreateUnicodeStringFromAsciiz
!> RtlFirstEntrySList
!> RtlGUIDFromString
!> RtlGetNtProductType
!> RtlImageRvaToSection
!> RtlImageRvaToVa
!> RtlInitializeSListHead
!> RtlInterlockedPopEntrySList
!> RtlInterlockedPushEntrySList
!> RtlInterlockedPushListSList
!> RtlInterlockedPushListSListEx
!> RtlIpv4StringToAddressW
!> RtlQueryDepthSList
!> RtlSecondsSince1970ToTime
!> RtlSecondsSince1980ToTime
!> RtlTimeToSecondsSince1970
!> RtlTimeToSecondsSince1980
!> RtlUnicodeToMultiByteSize

!> SHQueryUserNotificationState
!> Shell_NotifyIconGetRect

Edited by jumper
Link to comment
Share on other sites

> The *\mfc*u*.dll in KEX registry stopped working for me with K19. I use the full paths now.
I have no idea why. Please provide details on how you came to this conclusion.

I have already added support for eight new OS versions to Kexbases.dll:
+ Windows Vista sp2 (6,0,0x1772)
+ Windows 7 sp1 (6,1,0x1DB1)
+ Windows 8 (6,2,0x23F0)
+ Windows 8.1 (6,3,0x2580)
+ Windows 10 (10,0,0x3AD7)
+ Windows 10 (10,0,0x42EE)
+ Windows 98 (fe) (4,10,0x040A07CE)
+ Windows XP sp3 (5,1,0x0A28)

They are added after the existing functions for compatibility with existing CORE.ini modes.

Please request now any other Windows versions you would like added.

Link to comment
Share on other sites

*\mfc*u*.dll problem occurred after installing core.ini 12th month 2018 vs, the error I found out is not specific to K19 and occurs with K18. I have some other registry errors but not KEX related. Was working just prior to installing core.ini. WinMergeU (NOHEAP) uses mfc90u.dll and I am using a unicode WordPad (NT40) mfc42u.dll.    EDIT : - This Word pad is not fully compatible & consider it experimental here and with later posts in this topic.

Has anyone got a copy of Drugwash's KernelEx 4.5.2015.3, or know where it is located on MSFN, Drugwash? Xrayer? Jumper? I would like to see if netframework still is OK. Once netframework errors, I found it is impossible to get going again by replacing the files or re-installing. 1-1 drive backup required. My tests need be done again. EDIT : - KernelEx is not responsible for my DotNetFX errors. DotNetFX working with KernelEx tested latest KEX24 and earlier.

Edited by Goodmaneuver
Link to comment
Share on other sites

  • 2 weeks later...

I tried the newest KernelEx version.

K-Meleon appears more stable than I remember with this version. Unfortunately, I still need to disable javascript to prevent the browser from crashing. Also, I'm not sure if the new KernelEx update damaged my WinME installation in my VMWare. Suddenly, I could not drag files to the guest, file transfers by shared folders, flash drives would not appear, and cds would fail. Reinstalling VMWare tools did not help.

Link to comment
Share on other sites

> I tried the newest KernelEx version.
In what OS with what service packs?

> K-Meleon appears more stable
What version of KM?

> my WinME installation in my VMWare
Are you running ME in VMWare on SE?

Link to comment
Share on other sites

  • jumper changed the title to KernelEx 2022 (Kex22) Test Versions (

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...