Jump to content

KernelEx 2022 (Kex22) Test Versions (


Recommended Posts

Same in my case.

With the earlier Kernelex.dll Verify.exe is satisfied with the installation. I can see the new compatibility modes in the property sheet and there is a third choice (have'nt tested yet).

No problems with Opera 12.02 or Firefox 3.28.

Earlier problems I reported with MS Office Compatibility Pack & Kex17 with MS Office 2007 Word files seems tot be solved. 

Thanks a lot.

Link to comment
Share on other sites

Did you already write a changelog? What does "Override settings of individual modules" mean? Is Ktree9 still full compatible to version18? I miss many api's and some dll's.

Edited by schwups
Link to comment
Share on other sites

Great to see progress and a new version, thanks! :-)

Jumper said:

More updates are already nearing completion: Ktree, Kexports; SList, SRW, PowerRequest. Specific API requests welcome.

Oh, if that's an invitation for a wishlist, I've been wondering about Merkaartor(.be) It's probably the only openstreetmap-editor for low ressources and a system without Java. Except that I can't get it to start due to a kernel error. No idea but perhaps it just needs a fake stub too?
The error is a "missing Export-Kernel32.dll: AddVectoredExceptionHandler".
Link to comment
Share on other sites

Hi Jumper, regarding some APIs - I don't how important they really are but they sound important :)


Link to comment
Share on other sites

Hi Jumper, just a quick note to let you know that one of the problems that I reported is fixed in v18 !!
The email-client of SeaMonkey now creates correct msf-index-files. At first I was a little bit confused because
the size stayed at 0kB when checking with the Explorer but was then updated when SeaMonkey was closed
for the 'first time' after running under the v18-update. Thx !!

Unfortunately still no progress with printing using SumatraPdf, etc.

best wishes

Link to comment
Share on other sites

  • 3 weeks later...

Hey thank you for your work on this. I am messing around trying to get the latest patch of diablo 2 to work in win98SE and thought I would give kernelex a shot. Making some progress so far :) Either way I just wanted to say thank you.

If anyone is curious the game runs in a window with a voodoo 3 card. I do not have a card with decent directx support to test out full screen. I am also unable to connect online to play on battlenet but I think that has to do with blizzards file checker not working I think it needs wldap32.dll. 

Edited by Novadale
Link to comment
Share on other sites

  • 3 weeks later...


For the longest time I've tried running GTA IV on Windows 98 SE using your KernelEx updates. In theory, it should be possible with DX9, WMP9, XLiveLess, and U98SESP3 installed. I'm using the version of the game, as later ones change the EXE to be even less compatible with 98SE/KEx.

I've installed the latest version of your KEx updated (with the KernelEx.dll file from the previous version).

And still, just like with the older versions, I get either "RESC10 Out of video memory" error after the game shows up its black window, an "illegal operation" error, or the system hangs at the black screen. No command line options for the game helped.

I'm using a GeForce 6600GT 128MB PCI-E GPU with the 82.69 drivers, (it can run the same copy of GTA 4 on Win7), on my Pentium G4560 system on an ASRock H110M-DVS R3.0 motherboard, with 8GB of DDR4 RAM (limited to 1GB with HimemX, and also the R. Loew's AHCI Driver. Since there is no HD Audio driver, I'm using Virtual Audio Cable 3 program to simulate a sound card.

I had other, more compatible hardware in the past, and all showed the same behaviour.

I've noticed a new ApiLog program, was eager to check it out, it shows that the problem lies within the OpenFileMappingW function,. @jumper you know anything about it? Is it problematic?

Hope I can get my dream come true!



OpenFileMappingW - problem chyba.jpg

Edited by MrMateczko
Link to comment
Share on other sites

The call to OpenFileMappingW triggers the dynamic loading of UNICOWS.DLL, then it fails--returning a NULL handle. Likely, a previous call to CreateFileMapping is also failing. Filter ApiLog console output to Include: "Map;View" instead of "*".

File Mappings are often used for sharing memory. This usage requires a paging file. Enable Virtual Memory so that at least 2GB is available (4GB might be necessary).

GTA IV is a known memory hog. If it's trying to create video texture buffers in system memory, limiting 8GB down to 1GB could be the problem. RLoew's memory patch should help. In your GPU's control panel, look for the D3D options and disable every quality enhancement. Run GTA in the lowest resolution possible. Fix GTA 4 Out of Video Memory Error [Solved]

Link to comment
Share on other sites

How do I enable Virtual Memory? Is this done by using Vcache settings?

I have tried the demo version of the RAM Patch.

This is how I have my system right now, and all the current outcomes I experience with the ApiLog filtered as you said, I've tried all your suggestions but nothing has fixed the issues, I've tried other commandline switches before, they do not do anything useful:






Link to comment
Share on other sites

...So my software development window slammed shut on me early last month before I could finish testing and post the promised goods. I'll answer questions now, then try to squeeze out a few incrementals instead of a large package....

@roytam1 - Thanks for the SList encouragement. I've had the code for years (literally!) and finally distilled it down to only what was needed in Win9x.
@MiKl @Nomen @Ath73 - Thanks for the quick testing and feedback that revealed the Kernelex.dll problem and led to better installation instructions.
@aviator - Thanks for the quick confirmation that the workaround works!
@deomsh - Thanks for the extended confirmation including resolution of some old problem reports.

> Is there anything we should especially look at - maybe testing newer browsers, etc ?
All the old working stuff (make sure nothing got broken) + old non-working stuff (might be fixed or showing progress) + new stuff you want to work (like browsers).

> Did you already write a changelog?
Nope. For now, use Kexports on each Kexbase*.dll to see the API changes.

> What does "Override settings of individual modules" mean?
Just what it says, I think. It was already in the Debug build, I just exposed it in the beta Release build. Seems to work as advertised, but of limited value and quite dangerous.

> Is Ktree9 still full compatible to version18? I miss many api's and some dll's.
Ktree9 looks for contents= in [DCFG1], so copy it there from [BASE]. I'll post an updated Core.ini.

> The error is a "missing Export-Kernel32.dll: AddVectoredExceptionHandler".
Already supported as a need-only (import table) stub. Is the error message from the system loader or the app? If the former, the file needs Kex to be enabled on it; else, un-UPX the file if possible or add [Kernel32.dll] AddVectoredExceptionHandler=z2 to Kexstubs.ini. Alphabetically, this error may just be the tip of the iceburg. Test the app in ImportPatcher (sigh...I need to update that tool as well!)

> kernel32.dll:createvirtualbuffer freevirtualbuffer
Noted. Not TDB until needed.

> ntdll.dll:RtlSecondsSince1970ToTime RtlSecondsSince1980ToTime RtlTimeToSecondsSince1970 RtlTimeToSecondsSince1980
Needed by ReactOS, so now fully taken from ReactOS!

> Unfortunately still no progress with printing using SumatraPdf, etc.
ApiHook/ApiLog need improvements before I try to debug this again. I still haven't received any feedback on the multiple versions of PrintDlgExA, PrintDlgExW, and PrintDlgW I added in v.16 (create test modes in Core.ini that inherit from NT2K and specify API version like is done for GetVersion, etc.).

> ...blizzards file checker not working I think it needs wldap32.dll.
98se has wldap32.dll v5.00.1579 with 215 named API's. The Dsclient upgrade package contains v5.00.2168.1 with 235 named and 309 ordinal API's. Are you missing the whole DLL, or just some of the API's?



Edited by jumper
Yet another attempt to attach Core.ini, this time using KM74-g22 w/JS
Link to comment
Share on other sites

  • jumper changed the title to KernelEx 2022 (Kex22) Test Versions (

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...