Jump to content

KernelEx 2022 (Kex22) Test Versions (


Recommended Posts

Too early? Not at all! I've been cleaning out my stubs.ini file with every build to ensure I'm testing with the new native code. In January work stalled on Ktree10 which will highlight duplicates. I'll resume that work asap.

The use of "beta" is just to discourage newbies from expecting miracles! :lol:

Link to comment
Share on other sites

Just now, jumper said:

Too early? Not at all! I've been cleaning out my stubs.ini file with every build to ensure I'm testing with the new native code. In January work stalled on Ktree10 which will highlight duplicates. I'll resume that work asap.

The use of "beta" is just to discourage newbies from expecting miracles! :lol:

Oh really? 

Link to comment
Share on other sites

Installed the kernel extensions on my fresh 98 install:

  • Firefox 3.6.28 crashes on boot
  • Slimboat Portable ALMOST works (out of the box) now. Upon boot it still crashes, but a glitched window now appears.
  • Palemoon XP gives a can't find XPCOM error instead of device not functioning. (Probably a good sign of progression)
  • Opera 12.5 is closer to working, but still doesn't work
Edited by ~♥Aiko♥Chan♥~
Link to comment
Share on other sites

Since KernelEx 45201617 Compatibility Pack for the 2007 Office system (FileFormatConverters ENG, version 12.6500.5000) is no longer converting Word-documents, not doc2docx and not docx2doc (Wordconv.exe and Mso.dll in the by Xeno86  already registered compatibility-mode W2k).

The only error I get is the famous "The converter failed to save the file" when trying to convert with Save As... in Shell Context menu.

Command line conversion doc2docx with Wordconv.exe is not working anymore too.

Excel conversion (xls2xlsx & xlsx2xls) is still working (Excelcnv.exe in obligatory compatibility-mode NT40), also command line conversion ppt2pptx (with Ppcnvconv.exe in compatibility-mode W2k).

In Apilog files from Wordconv.exe I observed there are actually used some new stubs: 4 LoadLibrary stubs and a SetFilePointer stub.

I tried to redirect these to "std" in core.ini, but makes no difference (if I did it right of cause).

Apilog file is bigger than 2 MB, so I cannot upload them. If you have specific questions, I will try to help of cause.


By the way, I have no problems with FireFox 3.6.28.

Thank you for all the hard work.

Link to comment
Share on other sites

Hi Jumper, it looks like as if the new version somehow breaks printing of KernelEx-apps here on my systems.
I noticed it first on SeaMonkey, but printing there was always somewhat unreliable so I did not thought much of it.
But SumatraPDF does not print anymore either.

SUMATRAPDF führte eine ungültige Anweisung in
Modul <Unbekannt> bei 0000:00000103 aus.
EAX=0134ffbc CS=018f EIP=00000103 EFLGS=00010202
EBX=0134ffbb SS=0197 ESP=01250038 EBP=01250058
ECX=012500dc DS=0197 ESI=8235a720 FS=43df
EDX=bff76855 ES=0197 EDI=01250104 GS=0000
Bytes bei CS:EIP:
f0 40 00 a1 f1 65 f0 00 f0 cc e7 ff ff 8a ed 00 
bff76849 01250104 0134ffbc 01250120 012500dc 
01250210 bff76855 0134ffbc 012500ec bff87fe9 
01250104 0134ffbc 01250120 012500dc 00000100 


SUMATRAPDF_ verursachte einen Fehler durch eine ungültige 
Seite in Modul KERNEL32.DLL bei 018f:bff87ede.
EAX=c003098c CS=018f EIP=bff87ede EFLGS=00010212
EBX=0134ffbb SS=0197 ESP=0124ffbc EBP=01250028
ECX=012501dc DS=0197 ESI=8237fdb8 FS=75df
EDX=bff76855 ES=0197 EDI=01250204 GS=0000
Bytes bei CS:EIP:
53 56 57 8b 30 83 7d 10 01 8b 4e 38 89 4d f8 75 
Link to comment
Share on other sites

  • 2 weeks later...

Hi Jumper, I have noticed a strange behaviour of SeaMonkey 2.6.1 that started with v17.
I use also SM's email client and (I am sure you know that) it works in a way that the actual contents of a mail are stored in one file and an index file is created automatically. Usually inbox.msf, sent.msf, etc.
So after deleting some emails one can use compress/compact-function to keep the files as small as possible.
However, now the index files are getting somehow corrupted because SeaMonkey creates msf-files of 0 KB size !!
Nothing that I tried within 98SE fixed this and it happens on all machines.

The only way that I found was to boot, in my case, onto XP install SeaMonkey 2.6.1 and fix the msf-files there !!
Of course, after that I tested it again just in case it was some weird glitch but the 'corruptions' still occur.

Thanks, MiKl

I just booted an old installation running only KernelEx without ReactOS enhancements !!
SeaMonkey 2.0.14 is installed and everything works. But after upgrading to Kex-v17 the msf-problem occur there as well. Hope this helps.

Edited by MiKl
Link to comment
Share on other sites

I had to install DOTNET 2.0 (DOTNETFX20.EXE). This gives an unspecified error on the install dialog. I also tried KEX16: no problems, the installation reaches Install.exe. I copied some Dependy Walker logs, maybe they are helpfull.

With KEX17 just before the installation ends the failure is:

00:00:02.360: LoadLibraryA("C:\WINDOWS\SYSTEM\advpack.dll") caused an exception by thread 1.
00:00:03.400: Second chance exception 0xC0000005 (Access Violation) occurred in "c:\windows\kernelex\KEXBASEN.DLL" at address 0x7D012FE5 by thread 1.


Edited by deomsh
Logs where to big
Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...
  • 2 weeks later...
  • 3 months later...

There is a full functional CopyFileEx() realization. I'm offer it to KernelEx

What we know about:
In WindowsNT:
COPY_FILE_FAIL_IF_EXISTS Ч Work as described in MSDN
COPY_FILE_RESTARTABLE Ч looks like ignored, at least in WinXP+
COPY_FILE_OPEN_SOURCE_FOR_WRITE Ч declared, but no any description.
All other Ц work as MSDN described, if has any audible description.

Win9x Ц basically not supported, added from MSLU.
Practic and Kex:
Works as CopyFile(), no callbacks, no stops, no extras.
Works as CopyFile(), no callbacks, no stops, no extras.
What I offer:
COPY_FILE_RESTARTABLE Ч trying to resume copy. NOT TEST is resumed part of file is a part of original file. In some cases might return immediately, but with no errors (feign as Windows).
0x10 = creates chains of folders, if it not.
0x20 = don't call lpProgressRoutine function, even if it given.
0x8000 = adds to lpProgressRoutine callback extra УtElapsФ parameter, with time, elapsed from previous call of lpProgressRoutine.
In callback StreamSize, StreamBytesTransferred, dwStreamNumber, dwCallbackReason no guarantee that identical to Windows, but on copy local files Ц same.
But remember, setting 0x8000 flag to dwCopyFlags also turn off precise emulation and dwStreamNumber, dwCallbackReason be always 0.

technical limitations:
Not analyze/works as if source and destination files lays in same media. NO speed bust when copying between different medias.
Not work witch vcache, no speed bust if recently same file accessing in same location.
i.e. on the whole it slower as MS original.
Probably has a problem with UNC paths greater then MAX_PATH, i'm not test this.

Function realized in CopyFileEx.cpp, also you need CreateDirectoriesA/W from filewin.cpp (dir chains creater)
Yes, comments on russian.
Any propositions and remarks?
Download: https://www.upload.ee/files/7937215/copyfileex2.zip.html

Link to comment
Share on other sites

@filth: Thanks. No problems have been reported for the current implementation, however.

@MiKl: I use SM2.0.4 but not the email client. Please narrow the problem down to Kexbases.17 or Kexbasen.17. .18 is packaged and awaiting final review. Kexbasen.16 exported 11 new print dialog functions--access them via Kexstubs.

@MERCURY127: due to site changes, I can no longer upload files.

@deomsh: please debug things further with KexApiLog (DebugWindow.exe) and report back.

Link to comment
Share on other sites

  • jumper changed the title to KernelEx 2022 (Kex22) Test Versions (

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...