Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

WinClient5270

Member
  • Posts

    409
  • Joined

  • Days Won

    22
  • Donations

    $20.00 
  • Country

    United States

Posts posted by WinClient5270

  1. Hello everyone. I'm sorry for the long periods of inactivity lately. I've finally gotten around to getting the list up to date. Here's a summary of changes:

    • Updated all links for Windows Vista Service Packs and Platform Update to ones provided by @greenhillmaniac as Microsoft removed these updates.
    • Removed the link to my "Fix Windows Update stuck on Checking for updates in Windows Vista" video since Windows Update on Vista was shut down in August 2020.
    • Fixed last version of eM Client for Vista: changed from version 7.2.36694.0 to slightly older 7.2.35595.0 (thanks to @tweak and @Vistapocalypse for pointing out this error).

    There remain some broken links to Microsoft content, mainly in the Additional Microsoft Software & Utilities & Microsoft Office Add-ins & Tools sections. These were likely purged during the "SHA-1pocoplyse" of August 2020. I will work to restore these the best I can as time goes on. Hopefully they are available at the Wayback Machine/Internet Archive... :unsure:

    • Like 5
  2. Since someone mentioned Google Earth in the Extended Kernel thread, I decided to dig into it again and see if the latest version still works in Vista.

    Unfortunately, versions starting with 7.3.3 do not work in vanilla Windows Vista, requiring Windows 7+ functions (K32EnumProcessModules being the one I received an error about).

    And so, Google Earth 7.3.2 is listed as the last version (thankfully Google still has a download available.. I downloaded both the 32 and 64 bit installers to have on hand for when they will inevitably take them down):

    On 3/1/2016 at 8:31 PM, WinClient5270 said:

    Outer Space Simulation software:

    Google Earth Pro 7.3.2 (FREECS) Download here: 32 bit  64 bit

    I also removed Rocket League from the "Games" section since someone mentioned in the other thread that it hadn't been working on Vista for months now, but fortunately it works with Extended Kernel. I added Goosebumps Dead of Night 2020 as @burd suggested ;)

    • Like 2
    • Upvote 1
  3. On 7/25/2020 at 11:50 AM, jaclaz said:

    As often happens a surely accidental little mistake is (has been, and will be) perpetuated forever until someone actually corrects it EXPLICITLY.

    This:

    is WRONG.

    The correct path is:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\AdvancedOptions\CRYPTO\TLS1.1
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\AdvancedOptions\CRYPTO\TLS1.2

    See this updated thread:

    https://msfn.org/board/topic/181705-solving-vistas-lack-of-tls-11-or-12/

    And this reference one:
    https://www.vistax64.com/threads/ie9-last-supported-browser-for-vista.305228/

    jaclaz

    Oops! Sorry for the mistake. I'm only human ;) I will fix the original post so that others that run across it aren't thrown off by the typo.

    • Like 1
  4. I also find it amusing how that ominous "Windows XP and Vista are no longer supported" message is still shown when Chromium/Chrome are launched under anything below NT 6.1, despite them being dropped over 30 versions and 3 years ago. Google were sure keen on breaking XP/Vista support, but they made sure to let us know they weren't going to tolerate XP/Vista anymore. -_-

    VWTjG6E.png

  5. 37 minutes ago, win32 said:

    And look at that, Aero Glass is back. And it looks much better than the blue window borders in the last official versions.

    Yes! And also, unlike Firefox Quantum, H.264/AAC are working, and after noticing the slightly smoother fonts compared to other browsers, I noticed Directwrite font rendering is working also!

    YJgs3Pq.png

    HLt8Qsa.png

    • Like 1
  6. It would appear that OhSoft oCam now works on vanilla Windows Vista SP2 again (Extended Kernel is not installed on my system; I'm using the localized method to run some software like Firefox Quantum instead of replacing system files), after a brief period of being broken (since version 5.00) due to calling Win7+ functions, but it now works just fine. Happy to see a developer still dedicated to supporting Vista out there :) OhSoft oCam has regained ONG status once again:

    On 3/1/2016 at 8:31 PM, WinClient5270 said:

    OhSoft oCam (FREEOS, ONG

    mZrOSc3.png

    • Like 2
  7. Thanks to those who've provided new additions so far. Added BeamNG.Drive 0.16 and later (0.15.0.6 is last version for vanilla Vista SP2), and Chromium versions 53-73.

    Has anyone tested other Chromium forks, such as Opera? I presume those would work as well, as long as what they're based on falls within the Chromium versions outlined above.

  8. There is one little issue I'm running into with Firefox though. Vista's H.264/Windows Media Foundation codecs are not being fully utilized, and as such, videos on some sites like Twitter and Twitch do not work (although YouTube works fine):

    ciE564d.png

    According to the Video Codec Test Page here, my system supports all formats except for H.264/AAC & MPEG4.

    FWIW, this was also an issue for me when using the (not officially supported) 64 bit build of Firefox 52 ESR x64 in Vista. I've tried every way I know how to get it to fully utilize Vista's system codecs, with no success. Perhaps someone here knows what's going on? :dubbio:

    BTW this is being done with Firefox 64, if that is important.

  9. Finally got around to trying this today (Firefox Quantum), and I must say this is simply amazing. I'm still in awe that this project even exists, after wishing for it for years. Thank you @win32 for all the work you're putting in. I will definitely have to make a video on this project soon. :)

    • Like 1
    • Upvote 3
  10. 1 hour ago, win32 said:

    These shortcomings can be fixed if you copy kernel32 to system32 and delete it from the Firefox folder.

    However, the purpose of listing extended kernel-compatible software in a thread dedicated to indicating vanilla software compatibility is usually discouraged (see 98SE and XP threads). So I think a new thread should be started for extended kernel compatible software.

    I’m on it ;) 

     

    • Like 2
    • Upvote 2
  11. On 6/20/2020 at 10:41 PM, win32 said:

    Once I get a wide array of programs working stable, I hope that you do one of your excellent videos about the kernel's capabilities. You create some great promotional tools for Vista, and this one will explore some uncharted territory for the OS.

    Absolutely! And thank you for the kind words about my YouTube videos. Unfortunately I haven't made another one in a while due to being so busy IRL, but I'll try to make another one soon. I will certainly make one on your kernel extension project for Vista in the future, too. 

    Speaking of getting programs working, I have one that you may be interested in trying: After growing up with the widely-beloved original console game from 2003, I decided to purchase the newly released SpongeBob SquarePants: Battle for Bikini Bottom Rehydrated on Steam. To my dismay (but not to my surprise), it will not run in Windows Vista due to several missing functions. It apparently works with Windows 7 or later according to the Steam page (Win7/8.1 support is claimed in the Additional Notes section), but at least two of these functions are exclusive to Windows 8 or later, so unless these are simply delay load functions that don't prevent the game from running in Windows 7 (I have yet to test it on that OS), then the game will only run in Windows 8 or later. 

    After inspecting the game's executable with Dependency Walker, I came up with this list of missing functions in some DLLs within Windows Vista. Here is a list of missing functions (I know you've already integrated some of these):

    KERNEL32.DLL missing functions:
    GetCurrentPackageId
    GetSystemTimePreciseAsFileTime
    K32EnumProcessModules
    K32GetProcessMemoryInfo
    SetThreadErrorMode
    TryAcquireSRWLockExclusive

    USER32.DLL missing functions:
    CloseTouchInputHandle
    GetTouchInputInfo
    RegisterTouchWindow

    MF.DLL missing functions:
    MFCreateDeviceSource
    MFEnumDeviceSources

    MFPLAT.DLL missing functions:
    MFCreateDXGIDeviceManager
    MFCreateDXGISurfaceBuffer
    MFCreateMFByteStreamOnStream
    MFCreateSourceResolver
    MFPutWaitingWorkItem

    • Like 1
    • Upvote 1
  12. On 6/18/2020 at 10:42 PM, win32 said:

    Actually, 2.10.0 x64 runs on Vista. Download gimp-2.10.0-x64-setup.exe from https://download.gimp.org/mirror/pub/gimp/v2.10/windows/ and you will notice that the installer doesn't block Vista like those for later 2.10 releases. The module that calls SetThreadErrorMode in later releases doesn't call it in this one.

    huh? 404? what a shame since 2.10.2's installer blocks Vista!

    Thank you for clarifying. Updated:

    On 3/1/2016 at 8:31 PM, WinClient5270 said:

    Video & Photo Editing Software:

    ...

    GIMP 2.10.0 (FREEOS) Download from vendor here.

  13. Wow! Am I dreaming?! Vista Extended Kernel is a reality?! 

    Thank you, @win32 for putting work into this project and bringing it to fruition, and creating this tutorial. This is something that has been discussed & yearned for among those of us "old-timers" in the Vista community as early back as 2013/2014, and the closest thing we ever got was @smeezekitty's proxy stub DLL wrappers for Adobe Reader DC & Catalyst Omega, but unfortunately he has been inactive since 2016 :(

    I never thought anyone would ever come forward with a full-blown extended kernel project. This is very exciting & promising as I had planned to stick with Windows Vista indefinitely, but worried for the future as software support (namely browsers) has continued to diminish. I'm not much experienced with any kind of coding, but if I can be of help in any way, do let me know.

    I apologize to everyone here in the Vista community for being so inactive lately. Being an "essential" employee (letter carrier for USPS) during a pandemic is not easy! Package volume is through the roof since no one (understandably) wants to get out :P Hope everyone here is staying safe.

    • Like 4
  14. 5 hours ago, Vistapocalypse said:

    I wonder why 52.9.0 does not simply update to 52.9.1 in the usual way? Perhaps because the 52.9.1 tinderbox build contained no significant changes. I will continue to use 52.9.0 on Vista x86. Are you saying that the 64-bit build works on Vista x64? That would be remarkable.

    Yes, this has been known for quite some time, however the original posts on it were removed following the June 2018 server crash, so allow me to post here how to get it working, since it requires special steps:

    1. Download the 52.9.1 64 bit installer, linked on the list.

    2. Extract it using 7zip. In the extracted folder, open the "core" subdirectory:

    ksmAtDC.png

    3. Download @blackwingcat's "Pemaker" program here. After downloading, be sure to run it as administrator, otherwise the following will not work.

    4. After opening Pemaker, click the "English" checkbox, and then click on the "load" button on the main program window under the "main" tab. After doing this, browse to the "firefox.exe" file in the core subdirectory of the extracted 52.9.1 installer, and open it in Pemaker. After doing this, change the "OSVersion" and "SubSysVersion" values to 6.0 from 6.1:

    wXtMe9o.png

    5. After doing this, click on the "Save" button and save the file to a location different from the "core" subdirectory, such as your desktop. Repeat these steps for all .EXE files in the "core" directory.

    RQi3jwB.png

    6. After doing this, copy and paste all your modified .EXE files to the "core" subdirectory, replacing all original .exe files.

    7. If you did everything correctly, you should now be able to run Firefox 52.9.1 ESR 64-bit just fine in Windows Vista!

    ekmsN3D.png

    KSz9drt.png

    3yyyRdQ.png

    I will update the Firefox list entry to include this guide.

    • Like 3
  15. Hello everyone. Sorry it took me so long to get the list updated again, had a lot going on outside of MSFN lately.

    Anyway, thanks to everyone for the contributions and keeping the topic alive in my absence. March 1 marked 4 years since I originally posted this list back in 2016... I can't believe it has already been that long! :o Time flies...

    SUMMARY OF CHANGES TO THE LIST FOR MARCH 15, 2020:

    • Added updated links for Roytam Browser installer by i430VX, Vivaldi 1.1.443.3 Developer, and last version of Yandex for Windows XP/Vista.
    • Updated Mozilla Firefox 52.9.0 ESR entry to Mozilla Firefox 52.9.1 ESR, along with new links.
    • Added link to addon that allows you to reenable all signed extensions and themes for Mozilla Firefox 52.x.
    • Added last version of Piriform CCleaner (5.64.7577) for Windows Vista (and XP), with download link.
    • Like 2
  16. 19 hours ago, Jaguarek62 said:

    Unfortunately i'm giving up on vista.

    I'm sorry to hear that. It does sound like most of what you do requires at least Windows 7.

    19 hours ago, Jaguarek62 said:

    Rocket league stopped working. Some missing kernel extension.

    Could you specify what exactly is happening with Rocket League? It isn't officially supported on Vista so I'm not surprised to learn that it has stopped working. I'm not much of a gamer by any means, but what few games I do play all work fine on Vista.

    19 hours ago, Jaguarek62 said:

    Skype and teamspeak are no longer a thing. ripcord is somehow useful but looks like a program from the 90's also no screenshare,webcam etc.. 

    As for Skype and Teamspeak, I have never (nor will I ever) use them, so this is a non-issue for me, however, you can still use the web version of Skype and Discord. Discord Voice, Screenshare, and Webcam support can easily be achieved on Vista using the last compatible Yandex version for it, which is based on Chromium 58. It also works on roytam1's Serpent as long as you spoof the useragent to Firefox 68.0.

    19 hours ago, Jaguarek62 said:

    Teamviewer no longer supports Vista and i'm not even talking about browser support and hardware support.

    Roytam1's Serpent and New Moon are still great options for Windows Vista and continue to be updated weekly. I have only encountered a site or two that complained my browser was out of date, however spoofing the UA to Firefox 68.0 always solves the problem and the site works just fine. For the few sites that are Chromium-biased (I don't mean sites that won't work in Firefox-based browsers, just one that work smoother in Chrome-based ones), I use Yandex Browser which still works great, however due to lack of updates I expect this to change eventually. I could install the Chromium 78-based 360 EE if I wanted, but I don't trust it at all due to the plethora of privacy issues it seems to have. So I doubt I'll ever install it.

    Hardware support? On the Intel side of things it has been in a sad state of affairs since Haswell was released. However, the grass is much greener on the other side - AMD's Ryzen platform works with Windows Vista using Windows 7 drivers, as tested by @greenhillmaniac.

    I can understand one's reasons for needing to move to something more compatible, though. But depending on what one needs, Vista (and XP) is still very much usable in 2020 and I don't see that changing for as long as this community is around.

    • Like 2
  17. As Windows 8/8.1 never caught on in the corporate world, I expect history to repeat itself. Not only in the case of Chrome, but I'm sure several other applications will drop support for Windows 7 and 8.x simultaneously, as with what happened back in the early-to-mid 2010s with Windows XP and Vista. There may be an outlier or two that does officially support 8.x but not 7 (there were actually several, where applications supported Vista+ but not XP), or there may be some programs that, despite officially "requiring" Windows 10, may continue to run on Windows 8.x anyway, but I wouldn't count on it. Someone correct me if I'm wrong, but if I had to guess, Windows 8.x is more related to Windows 7 when it comes to APIs (at least on the desktop/win32 side of things, not UWP) so I'd say if something doesn't work with 7, it won't work with 8.x either unless it officially supports it.

    3 hours ago, Vistapocalypse said:

    Chrome support for Windows Vista was terminated a full year before Microsoft's EoL date

    I would argue that Chrome support for Windows Vista was dropped even further back than that, with the release of Chrome 41 in March 2015, when Vista users were royally screwed over. This was the first version of Chromium/Chrome to lack a Windows Vista-exclusive build, when Vista users were simply thrown onto the XP version which caused a lot of Vista-exclusive APIs and features, most notably Windows Aero, to no longer be utilized. This was done apparently "due to lack of user feedback from Vista users", but I still believe they did it to "throw the baby out with the bathwater" so they wouldn't have to worry about supporting anything older than Windows 7. Still makes me furious to think about to this day. :realmad:
    As Vista is much more similar to Win7, delivering its version of Chrome to Vista users would have made much more sense and would have made everyone much happier, but alas... :(

    • Like 1
    • Upvote 3
  18. Like Ripcord, Telegram is also based on QT (except a slightly newer version, 5.12 vs Ripcord being based on 5.9).

    Unfortunately, the latest stable version of Telegram Desktop released just a couple of days ago does not work in Windows Vista :( I receive the following error when attempting to run it:

    AwBSPqI.png

    For this reason, Telegram Desktop 1.8.15 will remain listed as the final version for Windows Vista (and XP, too).

    • Like 3

×
×
  • Create New...