Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


All Activity

This stream auto-updates     

  1. Past hour
  2. @roytam1: I tested and confirm v.2019.12.13 of Serpent 52 again works perfectly with Adobe Primetime. Thank you very much! You do rock!
  3. Today
  4. I would like to report this software to be added to the list of Email-Clients: https://www.oeclassic.com/
  5. I may just keep palemoon in my tree instead. for weekly builds against modified upstream, I'll just clone their tree and build on top. as a result, the palemoon builds will have different archive filename naming to something boc-alike.
  6. @Dylan Cruz Yes, I used Dependency Walker. Opening a local html file gives me a "file not found" error before opening and "Windows Explorer is unable to run the command" with Serpent/New Moon, but not with Internet Explorer. UPDATE: Well, the same installation source that let me successfully install Office 2007 in a VM and on an Optiplex 745 under win2k keeps failing to do so on a ThinkPad T60, as certain reg keys are not added in (specifically dealing with licensing, which means it will stop working in a few days). Weird, since it works on that problematic machine under XP.
  7. You are kindly asked to check the validity of what you post ; the OP asked for a "theme" for his Serpent 52.9.0 copy and what you've linked to is a (lightweight) theme (previously known as persona) packaged in a Web Extension format, targeting at minimum Firefox 53.0; that WE persona won't even install in Serpent 55.0.0, because both UXP and Moebius do not support WE lightweight themes... Most unfortunately, there's currently a very limited choice for Personas compatible with Serpent 52.9.0: https://addons.basilisk-browser.org/personas/
  8. The 12.18 files do not serve any added feature over 12.02 unfortunately. I found for a basic build Opera 12.02 may be better with KernelEx 4.5.1. My idea, 4.5.110 commonly known as 4.5.1 worked well with FF3.6.28 but on later versions did not transfer any data. 4.5.2 or 4.5.120 full name worked up to FF9 just. The freezing will be the TCP/IP not transferring, by turning off JavaScript it makes the pages less huge to render and could be coincidental to not freezing. The glyphs do not always show with latter FF, it all adds up to not enough resources thrown into 4.5.2 to make them work IMO. I have fooled around with buffer sizes from within the omni.ja and it is not only the transfer freezing it all has to integrate with the OS properly. YouTube would play for up to 4 minutes approximately before freezing. If on auto-play then it was OK if video changed within the 4 minutes otherwise it froze. Once a buffer is near full a new allocation would have to be made with the video play back and eventually the original buffer will need to be deleted. Or a couple of FIFO buffers might be OK, one for current video another for new video then back to original when next video is selected. Presto 2 engine was brilliant for its time, YouTube still plays but not all videos now, and is still a good email client. FF caterers for many platforms and therefore has a lot of overheads that are not used. I have upped the size of the KernelEx stack size in CurrentControlSet/Control/MprServices, it seemed to be better.
  9. Oops! Wrong link added ; sorry about that... Remove Pale Moon from the Unified XUL Platform repository => https://github.com/MoonchildProductions/Pale-Moon (this probably means additional hurdles for Roytam1, as he'd have to also fork that new repo and make new arrangements for producing his UXP-based browser forks... )
  10. ... Running XP SP2 32-bit, i.e. without SP3/SP4, does kind of put you in a minority of XP users here; most software still targeted at XP these days assumes SP3 plus all M$ updates until the End of Extended Support (for XP) ... That is why I said you need to be specific... FWIW, from my own recollections many years ago when I was on XP SP2, the Adobe Primetime CDM (which, for some obscure reason, has become quite en vogue in these forums ), does require SP3 to be present (all I know is I was unable to get it working there; it did install, but no MP4 decoding was possible; ofc, I could be wrong - and no way to retest now...).
  11. I checked the GitHub page. Where are you seeing this?
  12. Comodo IceDragon 64-bit, forked from Firefox Quantum v65.0 and run on Windows 7 SP1 64-bit is a tad Off Topic for this thread, IMHO ; be that as it may, per my recent post, CID (Fx 65.0 derived) will download and install Widevine CDM v4.10.1146.0 when Play DRM content (or whatever it's called in Fx 65.0) is ticked in Options; but that specific version is currently DEPRECATED by Google (their Widevine licence servers), so if you visit a media site with DRM that requires the Widevine CDM to play its content (video/audio), then you're out of luck with CID; you must use a version of another browser (FirefoxESR 68.3.0, Firefox release 71.0, Google Chrome latest, Waterfox Classic 56.2.13) that has support for the latest supported version of Widevine, v4.10.1440.19 The CID devs will have to either patch their current browser milestone to enable it with v4.10.1440.19 support (which shouldn't be that easy in itself, but definitely easier than porting v4.10.1440.19 support to UXP ) or rebase their fork to use at least a Firefox 68.3.0/69.0+ codebase, which comes with native support for WVCDM v4.10.1440.19 ... Also, on your Comodo forums post, you wrote: Please, DON'T MIX completely unrelated things! The Adobe Primetime CDM was an older DRM implementation (offered by Adobe) that 1. is no longer used by any media site for DRM purposes, 2. it was only internally supported by Firefox versions up to (and including) v52.x.x; starting with Fx v53.0, all Adobe Primetime CDM support code was obliterated from inside Firefox; so, there's no chance a Firefox 65 based fork would download and install APCDM... I re-iterate: (Google) Widevine and (Adobe) Primetime CDMs are NOT interchangeable! And even if you use a browser that does support APCDM, you don't need it at all (as a h264/aac decoder) under Windows 7+ (see more below...) If you're using Serpent 55.0.0 under Windows 7 SP1 64-bit, you have absolutely no need to even install and use Adobe Primetime CDM there; you can't use it as a replacement to the non-working Widevine CDM v1.4.8.903 that St55 installs under Vista+, and you don't need it as a decoder for h264/aac (html5 MP4 video), because, under Win7, St55 already comes with two such decoders: a.) the OS provided one via WMF framework, media.wmf.enabled;true b.) the one bundled within the browser in a custom ffvpx library, media.ffvpx.enabled;true If you're using Serpent 55.0.0 under Windows XP, then, likewise, APCDM can't be used for DRM purposes... And if you need html5 MP4 video decoding support, then media.ffvpx.enabled;true is still valid... Should you wish to install APCDM as an alternate second decoder in St55, then, a) Serpent 55.0.0 originally was forked from a Firefox 53.0a1 snapshot, where APCDM support code was already removed! b) @roytam1 , at some later point after Basilisk/Moebius was abandoned by upstream, did re-introduce APCDM support in St55: https://github.com/roytam1/basilisk55/commit/8dc3c7f3ece162392af056a3b82ce43105ee8938 (ported change from iceweaselXP-53: Restored eme-adobe plugin support for Windows XP systems) As you can see, that support was imported from another fork (not straight from Firefox <=52.x.x); in any case, Serpent 55.0.0 reports itself as being Firefox 55.0, so its GMP-manager will never download APCDM by default... You can try the trick posted in the APCDM thread (and recently mentioned by @Mathwiz): (which, IMHO, should be modded to read: "52.x.x ESR, Serpent 52.9.0, Serpent 55.0.0 users...") and if that wouldn't work, you'll have to manually download and install APCDM v17 as detailed in the relevant thread; but, again, this won't solve any DRM issues you might be experiencing, on any Windows version you might be running Serpent 55.0.0 I have provided, I hope, very clear and detailed explanations/instructions, so make the best you can with them...
  13. Okay, I admit I don't quite follow but it seems like you know where to go. How did you figure the advapi thing out? Dependency Walker? Interesting A very similar thing just happened in AIM (AOL Instant Messenger). So it doesn't seem to be just the new stuff. I clicked on a link from AIM and it opened up a similar error and also opened the webpage.
  14. @Dylan Cruz The advapi32 from XP has missing dependencies in BWC's kernel32, so it may be possible that we may have to prepare a kernel33 if it uses the missing dependencies for anything Office-related. I got OneNote stabilized, but I could no longer get images to display in the notebooks in my test Office install. I'll look into it. User privileges strike again. New Moon/Serpent struggle with this as they are built for XP and rely on its corresponding routines for that. I wonder if it would complain in Office too if it didn't have any hex edits.
  15. So the one referred to by Office will be advapi33 and that will call what? kernel33? We hex-edited MSO.dll so why would we need a special reference to that? Oh, cool! That'll be fun to see. OneNote seems to work for me. I mainly only use it for the screen capture, tool. Short of the Snipping Tool that debuted in Windows Vista, it's the easiest way to take screen shots, since PRINT SCREEN doesn't seem to work in W2K. Here's something else that's been bugging me. Whenever I click on a link, I get this titleless window that opens with this error: The link itself opens normally. There's no error as far as I can tell, apart from the error dialog! The link opens great in Pale Moon, but I always get this. I usually click links in MailNews, but interestingly, I just created link in Word and it does not do that...
  16. - sent to you from my Windows XP SP2, 3.15 GB of RAM, 2 Intel cores, 1.86 GHz. Very speedy. Some chromium browsers I don't more use, and some Firefox' forks thanks to RoyTam1. Each Firefox fork with 10 - 11 extensions....now
  17. Yesterday
  18. Try this Mussala-856 meters by rositza: https://addons.mozilla.org/en-GB/firefox/addon/mussala-856-meters/
  19. @roytam1 : I smell SERIOUS trouble in the air: Remove Pale Moon from the Unified XUL Platform repository ( ... No need to guess whose work was that... )
  20. Look on suche.org advices on about:config settings for better security: https://suche.org/page/mozillaHelp "Here are about:config settings that help to make mozilla more secure. They are only security related. This mean some pages can become broken by these settings".... Good example: network.http.sendRefererHeader - default set to 2 in Firefox. But, like me, if you like more and more security and privacy, then set it to 0.... The consequences (of "0" setting) are visible on these four examples below: darklaunch.com test referer: https://www.darklaunch.com/tools/test-referer Click to test buttons: no referer was sent - in all four cases, green cause good for security. privacyscore.org site scan: https://privacyscore.org/site/scan/ Forbidden (403): "You are seeing this message because this HTTPS site requires a 'Referer header' to be sent by your Web browser, but none was sent."....and More information is available with "0" set. security preview on zscaler.com: http://securitypreview.zscaler.com/ Your free security scan "Test your network security now" by Zscaler is good, but with our "0" setting above, the test doesn't end very well: gives page Error at the end, if network.http.sendRefererHeader value is set on 0.... And then our famous HTML5 Video Test Page by Tek Eye: https://tekeye.uk/html/html5-video-test-page - on all iframes "No video with supported format and MIME type found" inscription. So all these links are working very good, without problem, if network.http.sendRefererHeader is set on default 2.
  21. Windows 7 x64 - The same problem with the comodo icedragon x64 FF 65. I reported on the comodo forum. They have to fix this in the next version of icedragon browser. https://forums.comodo.com/bug-reports-cid/drm-not-action-t125228.0.html The same problem with the serpent 55 - three weeks primetime won't install Does the primetime adobe server have limitations?
  22. @Dylan Cruz The encryption write process is based on advapi32 calling rsaenh.dll, so I'd start with creating the advapi33 pointer for MSO.dll/Office executables. If that fails due to missing dependencies then you'd try a kernel33 being called by advapi33. At the same time I can look into any sorcery that could get Publisher and OneNote working better (tomorrow, when I'm back to the hex-core Xeon workstation with its 1.5 TB of storage). And one last crack at Office 2010 now that all that needs to be done is to remove the "Office Software Protection" service installation from the MSI. I have low expectations though, especially considering that advapi32 covers many more bases than encryption.
  23. Ah, okay. So is the big picture to have a kernel33 that get's called by Office, rather than kernel32?
  24. @JFX Please update BOOTICE 2016.06.17 v1.3.4.0
  25. That would be v2019.6.27 ; actually, AMO, again , made a big blunder there and marked the extension as Firefox 60.0+ compatible; but if you manually download the .XPI file https://addons.mozilla.org/firefox/downloads/file/3060290/https_everywhere-2019.6.27-an+fx.xpi and manually install it in FirefoxESR 52.9.x (drag-n-drop it in about:addons), you'll find it's still compatible: Nothing to apologise for... Simply another case of being misled by the wreck that Mozilla and AMO have now become...
  26. Thankyou i need to ask one more thing how can i customize the active and inactive tab? Aero glass is not working do i need something else also?
  27. FYI, Firefox versions 49.0.x-55.0.3 will download (and have internal support for) WVCDM v1.4.8.903 56.0.x-59.0.x will download (and have internal support for) WVCDM v1.4.8.1008 60.0.x-63.0.x will download (and have internal support for) WVCDM v1.4.9.1088 64.0.x-67.0.x will download (and have internal support for) WVCDM v4.10.1146.0 68.0.x will download (and has internal support for) WVCDM v4.10.1440.18 69.0.x-71.0.x will download (and have internal support for) WVCDM v4.10.1440.19 (currently supported version by Widevine licence servers; min OS requirement = Win7SP1) This list is only for the Firefox release channel, as the other branches (ESR, Beta/Developer, Nightly) will download different CDM versions... ... Nice detective work, BTW I'd expect you to go about installing Adobe Primetime CDM on browsers installed only in your Windows XP VM (sorry, I lost track: is that on your work or home setup?), as those browsers on Win7 don't need it for decoding purposes ; as Widevine CDM will only install under Vista+, I never considered the case of APCDM parallel install on Win7 ... Yes, that does look as the most plausible scenario! FWIW, my portable installation of FirefoxESR 45.9.1 32-bit under Vista SP2 has no issues automatically downloading/extracting/installing Adobe Primetime CDM v15 (NB, NOT v17) with the default value of about:config pref media.gmp-manager.url: https://aus5.mozilla.org/update/3/GMP/45.9.1/20170613084034/WINNT_x86-msvc-x86/en-US/esr/Windows_NT%206.0%20%28x86%29/default/default/update.xml Best wishes for the coming Holidays
  1. Load more activity
×
×
  • Create New...