Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


mixit

Enable MP4 (H.264 + AAC) HTML5 video in Firefox on Windows XP without Flash

Recommended Posts

You didn't do it exactly as described or it would have worked... those directives are case-sensitive, do re-check case and spelling carefully, please.

Share this post


Link to post
Share on other sites

i did:

media.gmp-eme-adobe.enabled (boolean, true)

media.gmp-eme-adobe.forcevisible (boolean, true)

media.gmp.decoder.enabled (boolean, true)

media.eme.enabled (boolean, true)

exchanged "%VERSION%" with "46.0"

and then i forced a manual addon update.

Edited by thomaz909

Share this post


Link to post
Share on other sites

all "blue" now :)

I had to disable or uninstall the extension "Youtube Flash Video Player".

other question, is hardware acceleration (DXVA) possible?

Share this post


Link to post
Share on other sites

when "primetime content decryption module" is enabled the following soundcloud isnt played:

when i disable "primetime" it is played.

any ideas for a fix?

Share this post


Link to post
Share on other sites
Quote

IMPORTANT: If you're here because MP4 video has stopped working after you upgraded to Firefox 49.0 or higher, that happens because 49.0 introduces a new pair of preferences. You now need to set media.gmp-eme-adobe.visible and media.gmp-eme-adobe.forceSupported to true; media.gmp-eme-adobe.forcevisible is no longer used. Toggle the Primetime plugin to Never Activate and back or restart Firefox for the pref change to take effect. (EDIT September 7, 2016)

Am I to take the "Toggle the Primetime plugin to Never Activate" to mean that the Primetime plugin is no longer required for this?

The other issue is that I don't see media.gmp-eme-adobe.forcevisible in about:config, is that to be found somewhere else?

Someone said that they had to disable the Youtube Flash Video Player extension, which I'm now using to force the use of Flash on Youtube for reasons that are too long to go into and have to do just with the Youtube player interface. Would I have to disable this extension?

Also, I have the problem that twitter and periscope videos don't play in FFox or Opera but DO play in Chrome. Does anyone know how to sort this out in Opera?

Share this post


Link to post
Share on other sites

Hi, I'm just trying to get this to work on Firefox 50 on XP, but I'm not having any luck.

Sorry if I've missed something really obvious, but my main head scratching is over the "media.gmp-eme-adobe.forceSupported" option in the Firefox configuration settings.

It doesn't seem to exist in my Firefox installation!

:unsure:

Edited by Dave-H
Typo

Share this post


Link to post
Share on other sites
On 2016-12-02 at 4:55 AM, Alfred001 said:

Am I to take the "Toggle the Primetime plugin to Never Activate" to mean that the Primetime plugin is no longer required for this?


The other issue is that I don't see media.gmp-eme-adobe.forcevisible in about:config, is that to be found somewhere else?

Someone said that they had to disable the Youtube Flash Video Player extension, which I'm now using to force the use of Flash on Youtube for reasons that are too long to go into and have to do just with the Youtube player interface. Would I have to disable this extension?

Also, I have the problem that twitter and periscope videos don't play in FFox or Opera but DO play in Chrome. Does anyone know how to sort this out in Opera?

Sorry for quoting this whole post but I can't figure out how to edit it; it seems like the interface has changed to be nonstandard, i.e., there is no way to turn off "preview" mode!

I love the MSFN community, but the forum software is just too much!  I wish they'd let the users CHOOSE how they'd like it to work! </rant>

Anyway, sorry for the delayed reply!

I believe you need both plugins; the toggle it just to get things to reset.

Disabling the YouTube Flash Video Player extension is not necessary.

I personally recommend the YouTube Center extension, as it does a lot more than just specify "HTML5" or Flash player; you can customize many features you didn't even know existed!
I actually find performance to be quite a lot better in the HTML5 player, and it also has the speed adjustment feature, but we all have our own setup! :)

Firefox 50 has completely blocked unsigned extensions with no override, which means the old extension doesn't work anymore, but you can download the UserScript version which can be installed in the GreaseMonkey extension!

I have gone through the whole Internet Explorer/Firefox/Opera/Chrome thing so here's the deal, as I understand it:

MP4 Video is now being embedded DIRECTLY by Twitter and other sites, instead of calling a plugin like Apple QuickTime, Windows Media Player, Macromedia Flash Player, etc.  This means that they either expect the Web browser or the operating system to be able to handle the video.

Because H.264 MP4 video has been added to the new "Media Foundation", the new multimedia platform in Windows Vista and later, it can handle video by itself.  This is the replacement for DirectShow/ActiveMovie (used in Windows 95 to present), which was designed for MPEG-1 and as an ActiveX plugin for Internet Explorer, which itself is the replacement for the Video for Windows platform which uses AVI.

Firefox however, has these wonderful plugins which allow these videos to be played on computers running OSes without Media Foundation.

Google Chrome also has video codecs built in so it can play videos on Twitter, one of the proprietary components it adds to the open-source Chromium base.

Even though Opera is based on Chromium, it lacks the codecs that Google has when it builds its version of the browser.

I hope that helps!

11 hours ago, Dave-H said:

Hi, I'm just trying to gett his to work on Firefox 50 on XP, but I'm not having any luck.

Sorry if I've missed something really obvious, but my main head scratching is over the "media.gmp-eme-adobe.forceSupported" option in the Firefox configuration settings.

It doesn't seem to exist in my Firefox installation!

:unsure:

I think someone earlier had this question too.

If any of the configuration settings in about:config do not exist, you must create them!

After adding all those necessary, restarting a couple of times, toggling the plugins on and off, and dancing under the full moon, all videos should play without a hitch!

Thomas

Edited by ThomasW

Share this post


Link to post
Share on other sites
56 minutes ago, ThomasW said:

If any of the configuration settings in about:config do not exist, you must create them!

After adding all those necessary, restarting a couple of times, toggling the plugins on and off, and dancing under the full moon, all videos should play without a hitch!

Thomas

Thank you!
That fixed it.
:thumbup
I hadn't realised that the option wouldn't be there by default.
All working great now.
Cheers, Dave.
:)
 

Share this post


Link to post
Share on other sites
6 hours ago, ThomasW said:

After adding all those necessary, restarting a couple of times, toggling the plugins on and off, and dancing under the full moon, all videos should play without a hitch!

Usually one should also howl to the moon throughout the dance, which most perform in the buff... but this later part is said to be optional...

  • Upvote 1

Share this post


Link to post
Share on other sites
On 12/12/2016 at 6:05 PM, ThomasW said:

 [...] and dancing under the full moon, all videos should play without a hitch!

Thomas

Yes, especially the full moon; that's mandatory. XD

Serious mode: on. I didn't have the chance to try it yet, but I'm gonna try it soon. :)

Share this post


Link to post
Share on other sites

Starting with Firefox 52, Adobe Primetime will no longer be downloaded at all in Firefox. The browser will be released on March 7, 2017 if the schedule holds.

Share this post


Link to post
Share on other sites

Does that mean that it will stop working for those of us who already have it installed if we install the update to Firefox 52?
I see they are dropping support for some other plugins with that version too.
Can we use Google's Widevine Content Decryption Module, which seems to now be the supported alternative?
Does it work in Windows XP?
:unsure:
 

Share this post


Link to post
Share on other sites
2 hours ago, Dave-H said:

Does that mean that it will stop working for those of us who already have it installed if we install the update to Firefox 52?
I see they are dropping support for some other plugins with that version too.
Can we use Google's Widevine Content Decryption Module, which seems to now be the supported alternative?
Does it work in Windows XP?  :unsure:

No.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×