Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Tommy

ATI Widescreen support for Win9x?

Recommended Posts

nVidia doesn't set squat except for what the monitor definitions are. That's why it's important to use an INF file for the monitor in question. IOW there's Video Drivers (INF and porgrams) and Monitor Drivers (INF files only). You're being misled in your understanding. Each Device must have some sort of driver to properly function. For funsies, try mine. (BTW, the Range is for H/V Frequencies.)

 

HTH

 

edit - If you use mine, remove the "ICM" line (that's Colors, whuch I didn't ptovide, since it's a Non-Text File). Also not there's no CAT file (unsigned).

Edited by submix8c

Share this post


Link to post
Share on other sites

Has anyone found a solution for this yet?

I have a Radeon 9550 in my machine, and can't seem to get out of 1024x768 mode, despite my monitor having a resolution of 1440x900. If I set a higher resolution than 1024x768, it does that stupid panning, even though my monitor has more than enough space to display the whole thing. 1440x900 shows up in the slider on Windows XP, but not on Windows 98.

Share this post


Link to post
Share on other sites

i have exactly this problem on my pcie Radeon X600 (some powercolor oem) on VGA connection.
my monitor is benq bl2411, 1920x1200. monitor wrongly detected as 1920x1440.
when i try set res 1920x1200 - i get vertical panning...
but if i use DVI - then 1920x1200 work good. but mon anyway detected as 1920x1440.
98SE, Catalyst 6.2 or 5.9 - no diffs.

Share this post


Link to post
Share on other sites
15 hours ago, CamTron said:

I have a Radeon 9550 in my machine, and can't seem to get out of 1024x768 mode, despite my monitor having a resolution of 1440x900.

If you are going to use the Catalyst v6.2 do this:

1. Open the "C9_30314.INF" in your text editor.

2. Go to "[RV350_AddReg]" section and replace it with this:

[RV350_AddReg]
HKR,"INFO\INFO\DAL",GCOOPTION_DigitalCrtInfo,1, A3,38,61,C1,A3,38,61,B1
HKR,"INFO\INFO\VXD",DynamicClockBypass,0x10001,1
HKR,"INFO\INFO\DAL",GCORULE_FracFbDivSupport,1,00,00,00,00
HKR,"INFO\INFO\DAL",GCOOPTION_MaxTmdsPllOutFreq,1, 50,c3,00,00
HKR,"INFO\INFO\atidxhal",PrimaryTiling,,"1"
HKR,"INFO\INFO\DAL",GCORULE_FlickerWA,1, 01,00,00,00
HKR,"MODES\8\640,480",,,"60,72,75,85,90,100,120,160,200"
HKR,"MODES\8\800,600",,,"56,60,70,72,75,85,90,100,120,160,200"
HKR,"MODES\8\848,480",,,"60,88"
HKR,"MODES\8\1024,768",,,"60,70,72,75,85,90,100,120,150,160,200"
HKR,"MODES\8\1152,864",,,"60,70,75,85,100"
HKR,"MODES\8\1280,768",,,"56,60,75,85"
HKR,"MODES\8\1280,960",,,"60,70,72,75,85,100,120,160,200"
HKR,"MODES\8\1280,1024",,,"60,70,75,85,90,100,120,160"
HKR,"MODES\8\1440,900",,,"60,70,75,85,100"
HKR,"MODES\8\1600,1200",,,"60,70,75,85"
HKR,"MODES\8\1792,1344",,,"60,75,85,90"
HKR,"MODES\8\1800,1440",,,"60,70,90"
HKR,"MODES\8\1856,1392",,,"60,75,90"
HKR,"MODES\8\1920,1080",,,"60,75,100"
HKR,"MODES\8\1920,1200",,,"60,75,85,100"
HKR,"MODES\8\1920,1440",,,"60,75,85"
HKR,"MODES\8\2048,1536",,,"60,66,70,75"
HKR,"MODES\16\640,480"
HKR,"MODES\16\800,600"
HKR,"MODES\16\848,480"
HKR,"MODES\16\1024,768"
HKR,"MODES\16\1152,864"
HKR,"MODES\16\1280,768"
HKR,"MODES\16\1280,960"
HKR,"MODES\16\1280,1024"
HKR,"MODES\16\1440,900"
HKR,"MODES\16\1600,1200"
HKR,"MODES\16\1792,1344"
HKR,"MODES\16\1800,1440"
HKR,"MODES\16\1856,1392"
HKR,"MODES\16\1920,1080"
HKR,"MODES\16\1920,1200"
HKR,"MODES\16\1920,1440"
HKR,"MODES\16\2048,1536"
HKR,"MODES\32\640,480"
HKR,"MODES\32\800,600"
HKR,"MODES\32\848,480"
HKR,"MODES\32\1024,768"
HKR,"MODES\32\1152,864"
HKR,"MODES\32\1280,768"
HKR,"MODES\32\1280,960"
HKR,"MODES\32\1280,1024"
HKR,"MODES\32\1440,900"
HKR,"MODES\32\1600,1200"
HKR,"MODES\32\1792,1344"
HKR,"MODES\32\1800,1440"
HKR,"MODES\32\1856,1392"
HKR,"MODES\32\1920,1080"
HKR,"MODES\32\1920,1200"
HKR,"MODES\32\1920,1440"
HKR,"MODES\32\2048,1536"
HKR,"INFO\INFO\DAL",DALNonStandardModesBCD1,1,07,20,04,80,00,00,00,60,07,20,04,80,00,00,00,75,07,20,04,80,00,00,00,85,07,20,05,76,00,00,00,00,08,48,04,80,00,00,00,60,08,48,04,80,00,00,00,75,08,48,04,80,00,00,00,85,12,80,07,20,00,00,00,60
HKR,"INFO\INFO\DAL",DALNonStandardModesBCD2,1,12,80,07,20,00,00,00,75,12,80,07,20,00,00,00,85,12,80,07,68,00,00,00,60,12,80,07,68,00,00,00,75,12,80,07,68,00,00,00,85,13,60,07,68,00,00,00,60,13,60,07,68,00,00,00,75,13,60,07,68,00,00,00,85
HKR,"INFO\INFO\DAL",DALNonStandardModesBCD3,1,13,60,10,24,00,00,00,60,13,60,10,24,00,00,00,75,13,60,10,24,00,00,00,85,14,40,09,00,00,00,00,60,14,40,09,00,00,00,00,75,14,40,09,00,00,00,00,85,16,80,10,50,00,00,00,60,16,80,10,50,00,00,00,75
HKR,"INFO\INFO\DAL",DALNonStandardModesBCD4,1,16,80,10,50,00,00,00,85,16,80,10,50,00,00,01,00,19,20,10,80,00,00,00,30,19,20,10,80,00,00,00,85,12,80,09,60,00,00,00,00,16,00,12,00,00,00,00,70,17,92,13,44,00,00,00,00,18,00,14,40,00,00,00,00
HKR,"INFO\INFO\DAL",DALNonStandardModesBCD5,1,18,56,13,92,00,00,00,00
HKR,"INFO\INFO\DAL",DALRULE_ADDNATIVEMODESTOMODETABLE,1,00,00,00,00
HKR,"INFO\INFO\VxD",EnableDDC,0x10001,1
HKR,"INFO\INFO\DAL",IDCRegOptionDontUseOSMonitorInfo,1,01,00,00,00
HKR,"INFO\INFO\DAL",DALRULE_NOCRTANDDFPONSAMECONTROLLER,1,01,00,00,00
HKR,"INFO\INFO\DAL",GCORULE_IntTMDSReduceBlankTiming,1,01,00,00,00
HKR,"INFO\INFO\DAL",HDTVRULE_HDTVGDOENABLE,1, 01,00,00,00
HKR,"INFO\INFO\DAL",HDTVRULE_HDTVSIGNALFORMAT,1, 01,00,00,00
HKR,"INFO\INFO\DAL",GCORULE_ENABLERMXFILTER,1,01,00,00,00
HKR,"INFO\INFO\DAL",DALRULE_RESTRICT2ACTIVEDISPLAYS,1,00,00,00,00
HKR,"INFO\INFO\VXD",DisableAGPWrite,0x10001,1
HKR,"INFO\INFO\DAL",UseCentredCVTiming,1,01,00,00,00
HKR,"INFO\INFO\DAL",DALRULE_ONEDISPLAYBOOTDEFAULT,1,01,00,00,00

3. Reinstall it.

Share this post


Link to post
Share on other sites

By "Reinstall it", do you mean going into Device Manager, removing the device, and then installing it again with the modified .inf?

I tried modifying that .inf file, and reinstalling it several times, but it still doesn't add those registry entries for the other resolutions. I'm not sure why. I could maybe create a .reg file to add them manually. What does HKR refer to in that file? I don't really know the structure of .inf files very well.

Edited by CamTron

Share this post


Link to post
Share on other sites

I found that my monitor would do as you proclaim 1280 x 768 was fine though and 1920 x 1080 was working but in between had sync problems. My big screen TV will not sync at all, it momentarily goes blank then says no signal, so it is close to working but doesn't. Plugging in another monitor and it is fine on 1920 x 1080. You might be able to try 1920 x 1080 on your monitor?

If your monitor is not syncing at higher resolutions with a nVidia card, then go into nVidia display panel menu to the nView Display Settings; Device Settings; Device Adjustments; and select "Display adapter scaling", before adjusting up the resolution. If it is already selected then try selecting "Monitor scaling", but I have to select "Display adapter scaling" every time I install a nVidia card.

If anyone has got a new AGP AMD video card, any later than X850, needed the reverse side AGP interface "ralo" (not sure of its name now) chip heatsinked. This is necessary to prevent motherboard damage and of course the "ralo" chip from destroying itself. I have glued a strip of 3 x 25 mm copper on mine, onto some plastic packers to keep the correct parallelity, full length of board, painted black.

 

 

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites
20 hours ago, CamTron said:

By "Reinstall it", do you mean going into Device Manager, removing the device

No, you need to completely uninstall and remove all files and settings from previous Catalyst installation.

I think some version of "DriverCleaner" can be used for this task.

 

For Registry entries look there http://toastytech.com/guis/miscb.html

Share this post


Link to post
Share on other sites
On 5/14/2009 at 1:02 PM, dencorso said:

Do try the nVidia drivers 77.72. But don't remove nVidia drivers with add/remove or unistall. Do it using the great freeware Driver Cleaner Pro Version 1.5 (*NOT* Driver Cleaner .NET !!!). The Add/Remove applet or nVidia's own uninstallers don't do quite a perfect job in removing previous nVidia drivers, only Driver Cleaner Pro is able to remove them completely.

Obviously, it does equally work for ATI, too. Why is it nobody ever searches the forums?  :dubbio:

Share this post


Link to post
Share on other sites

Before I change a video card I update to a Standard Graphics Adapter first. This is to avoid hardware configuration differences between cards. If you can not update to a Standard Graphics Adapter then after the driver is installed do not reboot, progress into windows and then in device manager update driver to the Standard Graphics. Then reboot and update to the driver you want from device manager once working as the Standard Adapter. If you have installed driver prior with problems the configuration errors as I was talking about then safe mode uninstall the offending graphics card or you could use scanreg /restore (starting from within the "Command" directory), to go back in time depending if the device was just installed. 

"Universal Vesa Drivers" are helpful does not have 3D acceleration but has mini port drivers for any card. It has not let me down yet, works good. You could test your monitors compatibility at different resolutions?

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites

Completely uninstalling and reinstalling the driver software added the registry keys, but I am STILL unable to choose 1440x900 as my screen resolution. I don't know what determines the list of resolutions that shows up in the display properties. Going to try hacking an .inf file and try to force it into 1440x900.

Share this post


Link to post
Share on other sites

The set of resolutions that shows up is the intersection of the set supported by the display adapter and the set supported by the monitor. If the display driver thinks the monitor can't really do the requested mode or can't actually do the mode itself because of the connection type (VGA/DVI/HDMI) or bitdepth, virtual mode results.

If selecting "Automatically detect plug & play monitors" isn't working for you, then you must deselect it and install a proper monitor driver. Then you will have to uninstall the display driver (possibly in safe mode) and then reboot. (You may also need to reinstall Windows; see below.) Make sure the proper monitor driver is (still) installed before reinstalling the display drivers.

This problem was already discussed and solved on this forum six years ago:
  "I just reinstalled windows and installed the monitor driver first. So I can't say exactly what solved the issue, but I think it's the driver installation order."

Edited by jumper

Share this post


Link to post
Share on other sites

@XPocalypse Survivor: You could try the monitor drivers from WinMEs' precopy1.cab I have no trouble with selecting 1440x900. HKR; Handle Key Relative to what's specified in the inf. If you open regedit then all registry sections start with HKEY which is Handle Key. Curious your signature; did you motherboard get better or gradually worse? Mine just started it AMD, when using nVidia AGP.

https://docs.microsoft.com/en-us/windows-hardware/drivers/install/inf-addreg-directive

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites

OMG! This is WRONG!

First. It has nothing with Monitor "driver" and second Monitor "driver" is not really a driver! Also it has nothing with cable types - that's just speculations on various tech forums -

i other words : it's a myth!

Resolutions list is added by Video Card Driver and driver uses this list from its .inf file. And if needed resolution is not listed there you can not use that resolution!

Only way to use unsupported resolution is to modify the .inf file from video card driver.

End of story.

 

 

https://nvidia.custhelp.com/app/answers/detail/a_id/2054

Share this post


Link to post
Share on other sites

Still no dice. sigh...

I installed PowerStrip and generated a .inf file from my monitor and installed it. I've attached the file if anyone wants to look at it. Then I completely removed all ATI driver software from my computer (Well, except for the setup files at C:\ATI\SUPPORT\6-2_wme_dd_cp_30314 which also has the modified C9_30314.inf). After rebooting, I installed the ATI driver, but I still can't get 1440x900. The resolutions I have available are 640x480, 800x600, 848x480, 1024x768, 1152x864, 1280x768, 1280x960, 1280x1024. Just like before, when I set a resolution over 1024x768, it pans with a 1024x768 window.

Where in the registry can I find what resolutions the monitor and graphics card support?

 

@Goodmaneuver My computer shows that message if I hold a bunch of keys down while the BIOS is loading. It's always done that, and it's not really an issue, but I find the error amusing.

ps_mon.inf

Share this post


Link to post
Share on other sites

Umm...DX-LCD19-09 is a 19" LCD TV, not a PC Monitor! That would be useful to write in the first place!

Here's what the manual for this TV says about its VGA input for reference to others:

VGA input

D-Sub 15-pin terminal

E-EDID compliant

Suggested scan rates:640×480 /60 Hz,

800×600 /60 Hz, 1024×768 /60 Hz,

1440×900 /60 Hz,

Audio input: Headphone mini-jack for

stereo

Can you test on a different display with the 1440x900 resolution?
Can you try a different VGA cable? (does your existing VGA cable have all pins in it?)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...