Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


nuhi

nLite 1.4(.1) - - ->

Recommended Posts


Yeah ... i'm gonna have a party for that. And all of you are invited :lol: .

Thanks again Nuhi !

Edited by iuli_kyle

Share this post


Link to post
Share on other sites

Total newb here. I'm having problems with nLite 1.4. I keep getting a unhandeled exception error when I select the directory I copied my XP disc files to and it is being evaluated for it's version. I'm not running the Dot Net frameworks so I installed the nLruntime pack after installing nLite. I was originally doing this on a laptop and got nLite to integrate SP2 successfully but then I was getting the UHE message when tring to create the ISO. I uninstalled and reinstalled nLite several times to try and clear this up but no luck. So I moved all of this to a different PC and am getting the same prob. Here is the error message.

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.IO.FileLoadException: Could not load file or assembly 'CabLib, Version=7.0.0.0, Culture=neutral, PublicKeyToken=5c790c52ffa26522' or one of its dependencies. This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)

File name: 'CabLib, Version=7.0.0.0, Culture=neutral, PublicKeyToken=5c790c52ffa26522' ---> System.Runtime.InteropServices.COMException (0x800736B1): This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)

at ..(String , String )

at ..(String )

at ..(String , StringCollection& , Boolean , Boolean )

at ..()

at ..()

at ..WndProc(Message& )

at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************

mscorlib

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.42 (RTM.050727-4200)

CodeBase: file:///C:/Program%20Files/nLite/v2.0.50727/mscorlib.dll

----------------------------------------

nLite

Assembly Version: 1.4.0.4

Win32 Version: 1.4.0.4

CodeBase: file:///C:/Program%20Files/nLite/nlite.exe

----------------------------------------

System

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.42 (RTM.050727-4200)

CodeBase: file:///C:/Program%20Files/nLite/System.DLL

----------------------------------------

nLite

Assembly Version: 1.4.0.4

Win32 Version: 1.4.0.4

CodeBase: file:///C:/Program%20Files/nLite/nlite.exe

----------------------------------------

System.Windows.Forms

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.42 (RTM.050727-4200)

CodeBase: file:///C:/Program%20Files/nLite/System.Windows.Forms.DLL

----------------------------------------

System.Drawing

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.42 (RTM.050727-4200)

CodeBase: file:///C:/Program%20Files/nLite/System.Drawing.DLL

----------------------------------------

nlgw

Assembly Version: 1.1.0.0

Win32 Version: 1.4.0.4

CodeBase: file:///C:/Program%20Files/nLite/nlite.exe

----------------------------------------

Accessibility

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.42 (RTM.050727-4200)

CodeBase: file:///C:/Program%20Files/nLite/Accessibility.DLL

----------------------------------------

MCDBNET2

Assembly Version: 1.32.0.0

Win32 Version: 1.32.0.1302

CodeBase: file:///C:/Program%20Files/nLite/MCDBNET2.DLL

----------------------------------------

msvcm80

Assembly Version: 8.0.50608.0

Win32 Version: 8.00.50727.42

CodeBase: file:///C:/WINDOWS/WinSxS/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.42_x-ww_0de06acd/msvcm80.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

This is becoming a bigger pain than installing all of this normally.

Any ideas?

Thanks

Share this post


Link to post
Share on other sites

NaDer_GenKO, no and I don't have plans to do it. IE7 was problematic enough and I don't have to do everything (not annoyed just saying).

Crash And Burn, using Framework Lite? Try full one. But uninstall that one and reboot before that.

Share this post


Link to post
Share on other sites

Did my first tests.

First on an HFslipped source with and without IE, OE and other unnecessary stuff.

Second same as above with addons.

PERFECT !!! :thumbup

Same tests, just using nlite :

PERFECT !!! :thumbup

as well.

Checked with and without COM+ and NetDDE removed in different constallations.

Still can´t produce the hanging while "saving settings" :)

Have to do some deeper tests though.

Forgot to check, if the HDDs are running PIO only, instead of "auto" UDMA and couldn´t check the removed writeprotection, yet. :blushing:

But seems like a perfect job so far.

Thank you Nuhi !!!

Agi

P.S.:

Used the regular .NET2, ´cause I didn´t know about the status of the FrameworkLite 2.0 R3 and wanted reliable testresults.

Share this post


Link to post
Share on other sites
I just figured out that WindowsUpdateAgent3.0_7.0.6000.381 still is not supported for direct integration - okay, but then it isn't even integrated in svcpack. :unsure:

Never thought about it coz I'm using the HotfixPack with WUAgent in it.

What do you mean? I am installing the WUA via SvcPack without problems. Or at least that's what I thought. Where did you see it doesn't install in your case?

And about direct integration. Are you sure that should be possible? AFAIK this installer doesn't support the /Integrate option.

When u manually add it to svcpack.inf that should be possible but I tried some installs and it did not work.

It does support /wuforce /quiet /norestart in running OS but doesn't work in svcpack.

Direct integration support does not depend on /integrate switch. It's on nuhi if he supports direct integration or not.

I am using (and building) the german-nlite hotfix-pack and herein are the newest WUA files so it is no problem for me but maybe others like to integrate it directly w/o hotfixpacks.

Share this post


Link to post
Share on other sites

I get to make another hotfix integration error report, yippee !!

It looks like the W2K KB917008 integration flaw is back.

Also KB927779 fails to integrate (well, at least not added to svcpack) with 1.4 Final, they both worked fine under 1.4 beta.

Eh, you win some, you lose some.

EDIT:

Opps, my bad. It turns out that nLite must be run with administrator privileges in order to integrate those 2 hotfixes.

Edited by Kurt_Aust

Share this post


Link to post
Share on other sites

Minor bug report, since I didn't see this mentioned before. When you add a hotfix or addon, nLite generates a duplicate entry for "1980 = PCHealth\HelpCtr\Binaries" in txtsetup.sif under the section [WinntDirectories]. It's very easy to reproduce.

Edit: Forgot to mention that this happens with WinXP/SP2 ENU.

Edited by beats

Share this post


Link to post
Share on other sites

I make 3 cd and 3 installation with this version with IE7 and SFC enabled and I don't have SFC popup like others version :thumbup :thumbup :thumbup :thumbup

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...