Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


nuhi

nLite 1.4(.1) - - ->

Recommended Posts


Some x64 updates cannot be integrated under XP x86. FlashPlayer integrates (to x64) incorrectly under x86.

Under XP x64 everything seems to be OK.

And IE7 is not set as default browser after integration...

Hi nuhi,

can this versoin integrate the new DirectX ?

Sure it can! Well, with an addon. :ph34r:

http://www.ryanvm.net/forum/viewtopic.php?t=5239

Seems like it's just for x86 systems

Share this post


Link to post
Share on other sites

@Legas2

I see that you are new here, but everybody know here that is not possible to integrate into X64 Windows if you are under x86. You need to have installed x64 to be able to integrate x64 updates and vice-versa.

Cheers ;)

Share this post


Link to post
Share on other sites

I have never before had any errors in nlite, but here's an error report. I get it while trying to remove any of the visual themes from the list in desktop themes tab. The template was originally made on nlite rc2, I think. I am able to remove the themes, although the obviously nonfatal error comes up every time.

system: xp pro sp3 3180. the xp base had integrated the latest sp3, 3203.

Unhandled exeption has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue.

InvalidArgument=Value of '3' is not valid for 'index'.
Parameter name: index.

details:

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentOutOfRangeException: InvalidArgument=Value of '3' is not valid for 'index'.
Parameter name: index
at System.Windows.Forms.ComboBox.ObjectCollection.RemoveAt(Int32 index)
at ..(! )
at ..2(Object , EventArgs )
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
nLite
Assembly Version: 1.4.0.5
Win32 Version: 1.4.0.5
CodeBase: file:///C:/Program%20Files/nLite/nLite.exe
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
nLite
Assembly Version: 1.4.0.5
Win32 Version: 1.4.0.5
CodeBase: file:///C:/Program%20Files/nLite/nLite.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
nlgw
Assembly Version: 1.1.0.0
Win32 Version: 1.4.0.5
CodeBase: file:///C:/Program%20Files/nLite/nLite.exe
----------------------------------------
MCDBNET2
Assembly Version: 1.32.0.0
Win32 Version: 1.32.0.1302
CodeBase: file:///C:/Program%20Files/nLite/MCDBNET2.DLL
----------------------------------------
msvcm80
Assembly Version: 8.0.50727.163
Win32 Version: 8.00.50727.163
CodeBase: file:///C:/WINDOWS/WinSxS/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.163_x-ww_681e29fb/msvcm80.dll
----------------------------------------
cablib
Assembly Version: 7.0.0.0
Win32 Version:
CodeBase: file:///C:/Program%20Files/nLite/cablib.DLL
----------------------------------------
msvcm80
Assembly Version: 8.0.50727.762
Win32 Version: 8.00.50727.762
CodeBase: file:///C:/Program%20Files/nLite/msvcm80.DLL
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Could it be because of sp3? You tell. :hello:

Update: This error did not repeat itself the next time I tried, neither have I seen it before. And as it wasn't exactly lethal anyway, I guess it is not important.

Edited by Gompedyret

Share this post


Link to post
Share on other sites

Security Center gives false error-messages, either AVG Antivirus is not installed

or it is not up to date.

Of course I had not removed Security Center.

Tried using only the first half of the options in the nLite menu,

then only the second half, made no difference.

Share this post


Link to post
Share on other sites

Hi all!

I have "nLite 1.4.0.5". I ticked two tasks: Hotfixes and Update Packs, Create a Bootable ISO. Then I integrated all hotfixes (including WMP11 and IE7) to WinXP SP2 Pro. The problem is: Internet Explorer is lacking in the Desktop Items. What is the problem here?

(Hungarian Windows)

post-137380-1196283068_thumb.jpg

Edited by janos64

Share this post


Link to post
Share on other sites
Internet Explorer is lacking in the Desktop Items. What is the problem here?

Oh common! Are you kidding me?! :wacko:

This weird MS tool is needed only once, when you first install Windows and need to go to mozilla.com or opera.com to download an Internet browser.

Share this post


Link to post
Share on other sites

In fact IE is not needed anymore: you can integrate Firefox and/or Opera with nLite.....

The only need are for Windows Update and activeX applications.

Feedback : no problems on nLite 1.4; great app !

Share this post


Link to post
Share on other sites

HUGE, HUGE BUG found!

Hi Nuhi,

I found what I think is a big showstopper in the way nLite handles corrupted or incomplete CAB archived addons! Because CABs store the file list and details at the beginning of the file AND lack of CRC support, you can still open most corrupted and incomplete CAB files with your favorite utility and see what's in it (extracting will, of course, fail miserably).

The problem lies in the way nLite (and the RyanVM Integrator as well) handle these corrupted files. Neither program will report any failures or halt the integration process when a bad CAB is encountered. Invariably, the resulting CD will be totally broken (IE will not work, many crashes, instability, etc.)

You can very easily test this by mangling a CAB file with a file splitter (keep the CAB extension, though), perform an integration, and you'll see the result sucks horribly!

This happened to me with an old addon, and due to this it took me forever to find the culprit. It was a file date of 1980 which gave the crappy file away, but by then I had already wasted days trying to get the CD to work.

You could possibly fix this by making nLite's extraction sub-routines read the file listing in the CABs and make sure all the listed files were extracted successfully, and if not halt the process. Or even better, just *skip* the bad addon and continue (this will also be useful for other addon errors which stop the integration and waste time when they could just as easily be skipped.

Hope this report is useful!

Share this post


Link to post
Share on other sites

Breezer, games use that dll to detect some stuff.

“small pictograms in menu start”, be sure that you're checking Start Menu (classic), not Panel, or vice versa depending what is tweak for.

System Restore can't be set less than 10%, if it can for you let me know. Be sure to check first after install.

SlimShady, did you select the user on the right in the Autologon dropdown? If you just leave it at None then that will happen what you said.

Gompedyret, gonna check that, I think I know what it could be.

Pistolero, what bug? All I see is a suggestion. Gonna do it btw. nLite already does check for corruption of system CAB files like Driver.cab or SP2.cab.

Share this post


Link to post
Share on other sites
Pistolero, what bug? All I see is a suggestion. Gonna do it btw. nLite already does check for corruption of system CAB files like Driver.cab or SP2.cab.

Thanks for the reply, Nuhi. I consider it a bug because it still integrates incomplete, missing and/or corrupted files out of a bum CAB without giving any kind of feedback or errors. The resulting Windows CD is useless as IE ends up broken, and another very weird symptom of a broken install: Normally, you should be able to ping the install-in-progress computer right after it installs the networking components at around T-25 or so... a broken CD will not return pings (even after it joined a domain) until the box is at a login prompt.

Fixing this would be really appreciated, as it will save a ton of time when troubleshooting bad nLitings.

Share this post


Link to post
Share on other sites
SlimShady, did you select the user on the right in the Autologon dropdown? If you just leave it at None then that will happen what you said.

Yes, the new username was selected. After it failed a couple of times I set it to 'None' so it won't even try.

But can you verify that it works on your setup (rename and autologon) ?

Share this post


Link to post
Share on other sites

Pistolero, still you're talking about fixing when it's upgrading to be more convenient. I'm not corrupting your CAB.

SlimShady, I remember now why it could be. Do you use some other winnt.sif (unattended settings) than what nLite creates? Make sure that nlite.cmd runs during the install as it is intended to. Maybe something else fails before it then it aborts, check the Windows\setuperr.log for errors.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...