Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Search the Community

Showing results for tags 'WinPE'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • The General Stuff
    • Announcements
    • Introduce Yourself!
    • General Discussion
  • Microsoft Software Products
    • Windows 10
    • Windows 8
    • Windows 7
    • Windows Server 2008/2012/2016
    • Older Windows NT-Family OSes
    • Windows 9x/ME
    • Other Microsoft Products
  • Unattended Windows Discussion & Support
    • Unattended Windows
    • Other Unattended Projects
  • Member Contributed Projects
    • Nuhi Utilities
    • Member Projects
    • Other Member Contributed Projects
    • Windows Updates Downloader
  • Software, Hardware, Media and Games
    • Forum Categories
    • Mobile Devices
  • Customizing Windows and Graphics
    • Customizing Windows
    • Customizing Graphics
  • Coding, Scripting and Servers
    • Web Development (HTML, Java, PHP, ASP, XML, etc.)
    • Programming (C++, Delphi, VB/VBS, CMD/batch, etc.)
    • Server - Side Help (IIS, Apache, etc.)
  • X's Concepts
  • The Compaq Computer Corporation Club's Discussion

Forms

  • Contact MSFN
    • Your Name
    • Member Name
    • Email Address
    • Subject
    • Contact Message
  • Submit News
    • News Title
    • Your Mail or Member Name
    • News
    • News Link/Source

Calendars

There are no results to display.

There are no results to display.


Found 15 results

  1. I am in the downloading the updates and the insider preview, I am going to create a answer file, like this one : <?xml version="1.0" encoding="utf-8"?> <unattend xmlns="urn:schemas-microsoft-com:unattend"> <settings pass="windowsPE"> <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <DiskConfiguration> <Disk wcm:action="add"> <CreatePartitions> <CreatePartition wcm:action="add"> <Order>1</Order> <Type>Primary</Type> <Extend>true</Extend> </CreatePartition> </CreatePartitions> <ModifyPartitions> <ModifyPartition wcm:action="add"> <Active>true</Active> <Format>NTFS</Format> <Label>Ten</Label> <Letter>C</Letter> <Order>1</Order> <PartitionID>1</PartitionID> </ModifyPartition> </ModifyPartitions> <DiskID>0</DiskID> <WillWipeDisk>true</WillWipeDisk> </Disk> I would like to run a batch file right here! which will create directories , apps installs and driver installs all which have silent and where to install them on the command line, but I need to know what I need to do this before it calls the batch file, How do I call the batch file and what do I put in this spot? John
  2. The PEBakery Team are proud to present the ChrisPE project. Use this project to create WinPE from a range of 32-bit and 64-bit Windows sources, including - Windows 7 Windows 7 (SP1) Windows Server 2008 R2 SP1 Windows 8 Windows 8.1 Windows 8.1 Update Windows 10 Windows RTM source files are recommended. The sources in the above list have been tested, other source files may also work. This project has been internally tested and developed over the past two months and is now ready for a public beta release. The PEBakery Team anticipate ongoing development and the ChrisPE project is likely to continue to evolve. This may result in changes to some of the core features such as the menu system and supported shells. Some of the current features include - No caching of Windows source files - resulting in reduced storage space requirements on the Host OS used to build the project. .wim support using internal PEBakery commands - the wimlib library is used for managed wim support. The full contents of the the Windows source and WinPE .wim files are not applied (extracted) to a local directory - resulting in significant time savings. Support for a range of shells including bblean, CMD, LaunchBar and WinXShell. WoW64 support. This project has been developed as a base from which to add additional features. Please note that it's been developed for use with the PEBakery builder and will not work in winbuilder as a number of commands are not supported. Please download from the ChrisPE github repository - https://github.com/pebakery/chrispe Instructions are included - please check the documentation in the download (readme.htm). If you are not familiar with github - use the Clone or download button and select the Download ZIP option to download the project. Feedback is welcome. Please have fun. The PEBakery Team (ied206, alacran, Atari800XL, homes32 and Misty) Screenshot of ChrisPE with WinXShell - EDIT: Not all the programs are in the basic download, there is a complementary pakage of scripts, I have it almost ready for upload and will be available for download very soon, new scripts are finished and working now, but under test to prevent any malfuntion, the pakage contains 25 new scripts. alacran
  3. WinPE PAE

    Hello! I am developing an app for WinPE. And I want to run WinPE 10.0.16299.15 on older PC. But always when I run it on an old PC I always get an error about Physical Address Extension. I am using x86 WinPE and Pentium 4 with 512MB ram. How can I disable it in DISM? Thank you for help! PS: Sorry for my bad English.
  4. Hi, hoping someone can help. I have a WinPE USB drive that I boot various devices from in order to deploy bespoke images (All Windows 10 Pro 64 Bit) .. I would like to have the bespoke image contained onto a 32GB MicroSD Card .. however, on all but 2 of the 5 different devices I want to do this for WinPE does not pick up the SD Card. ie running DISKPART - LIST DISK shows only the main HD and the USB, on one of the other devices I can force load the Realtek driver using DRVLOAD.EXE, I was hoping to do the same with the other devices .. but none of the others use the Realtek driver, they all use the standard Microsoft Driver and I have no idea what .INF file to use in conjunction with DRVLOAD in order to force load the driver and gain access to the SD Card.
  5. Flashing BIOS from WinPE

    Hi, guys, I need some help. I am trying to resurrect an old PC, an Acer Aspire 5315. It used to run Vista, but that's been wiped out now, and it didn't come with installation disks. I need to flash the BIOS, so I got it from the Acer site. It's an .EXE file. I tried FreeDOS, but it refused to run "in DOS mode". So I have created a WINPE disk. It boots into a command line, but if I run the .EXE file I got from the Acer site, it fails silently. I just get the prompt back, no windows pop up and the BIOS remains in its old version. A "VER" in the command line shows "Microsoft Windows [Version 6.2.9200]". Any ideas? Do I have to install a full-fledged Windows just to run this file? I plan to install Linux in it after flashing the BIOS... Any legal way to run Windows just for a couple minutes?
  6. WinPE automated wim deployment

    Hallo, I try to make bootable usb ssd with few windows images for my company. I found somthing like this: http://www.peppercrew.nl/index.php/2015/02/automated-usb-wim-deployment/. This would be perfect, but I have wim images that are 20 Gigabyte (fat32 is only for 4GB files). I made two partitions on usb drive one for boot.wim etc and other for other files. Can someone help me with scirpt in startnet.cmd. I have to modify the script so that not only detect usb drive but also the name from volume with wim images and install chosen form menu os. Thank you in advance for your help! Bing wpeinit @ECHO OFF C: CD\ CLS :MENU ECHO ============= Installeren Thin Image ============= ECHO ————————————————– ECHO 1. Thinclient T5740 ECHO ————————————————– ECHO 2. ThinPC 8200 ECHO ————————————————– ECHO ==========PRESS ‘Q’ TO QUIT========== ECHO. SET INPUT= SET /P INPUT=Please select a number: IF /I ‘%INPUT%’==’1’ GOTO Selection1 IF /I ‘%INPUT%’==’2’ GOTO Selection2 IF /I ‘%INPUT%’==’Q’ GOTO Quit CLS ECHO ============INVALID INPUT============ ECHO ————————————- ECHO Please select a number from the Main echo Menu [1-2] or select ‘Q’ to quit. ECHO ————————————- ECHO ======PRESS ANY KEY TO CONTINUE====== PAUSE > NUL GOTO MENU CLS :Selection1 for /F "usebackq tokens=1,2,3,4 " %%i in (`wmic logicaldisk get caption^,description^,drivetype 2^>NUL`) do ( if %%l equ 2 ( echo %%i is a USB drive. ) Diskpart /s %%i\diskpart\diskpart.txt cd\ %%i\Imagex.exe /apply %%i\Thinclient\TC.WIM 1 C: ) :Selection2 for /F "usebackq tokens=1,2,3,4 " %%i in (`wmic logicaldisk get caption^,description^,drivetype 2^>NUL`) do ( if %%l equ 2 ( echo %%i is a USB drive. ) Diskpart /s %%i\diskpart\diskpart.txt cd\ %%i\Imagex.exe /apply %%i\Thinclient\TC2.WIM 1 C: ) :Quit CLS ECHO —————————————————- ECHO =============PRESS ANY KEY TO CONTINUE============== ECHO —————————————————- PAUSE>NUL EXIT
  7. Hi, actually I have a win 7 OS installed machine. I want to boot from a D drive by copying the winpe bootable files into D drive without formatting the hard disk or disturbing the OS in the machine. Is it possible to boot to the machine from the D drive? Is there any settings I can specify in the BIOS settings. If I check the BIOS settings, there are options like boot from DVD drive, boot from USB disk, boot from the hard disk are available. How can we do this? please help if any solution is there for this Need your help regarding this. appreciate your help in this.Thanks in advance.
  8. Hi, hoping someone can help me out. I need to inject a reg entry into the windows 8.1 HKEY_LOCAL_MACHINE RunOnce registry tree from within a WinPE 5.0 environment. So far I have the following as part of a command file; REG LOAD HKLM\TEMP c:\windows\system32\config\software (To load the correct hive into a temporary subkey) REG ADD HKLM\TEMP\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce /v Act /t REG_SZ /d "%Drive%\Activate.cmd" /f (to add the reg entry) REG UNLOAD HKLM\TEMP (to unload the hive from the subkey) Where %Drive& is the USB drive letter ... this all works .. but .. When checking the reg entry (using REG EXPORT to a file) is shows up as [HKEY_LOCAL_MACHINE\TEMP\software\microsoft\windows\currentversion\runonce] "Act"="D:\\Activate.cmd" Entry has two \\ instead of a single \ and does not execute the command file upon booting into Windows 8.1 Where have I gone wrong? Cheers in advance for any help.
  9. Hello All, I created a Windows 7 x64 based WinPE image with basic drivers for SSD. This WinPE image is primarily used to capture/deploy Windows 7 image on a monthly basis. I have DOS commands in startnet.cmd to automate this process. When booting from USB flash drive, the script reads drive letter from "PEBootRamdiskSourceDrive" registry value in HKLM\System\CurrentControlSet\Control. This has been working fine on existing USB flash drives - both USB 2.0 and 3.0. I bought couple Kingston DTR3.0 G2 64GB flash drives recently... when I boot to these flash drive, the registry value with drive letter in PEBootRamdiskSourceDrive is not seen. Registry value in PEBootType says Ramdisk:SourceUnidentified. I am puzzled with this behavior and looking for clues. Appreciate any tips / pointers. Thanks!
  10. winpe boot from HDD

    Hello every body Is it possible make winpe on HDD without Ram disk or VHD(exactly boot from c: of HDD)? Thanks
  11. Wifi over win pe 5.0

    I’m trying to activate wifi device over win pe 5.0. I used this page to start: http://www.msfn.org/board/topic/162453-winpe-40-enable-wireless-support/ I used the files from Win 8. The problem is that I’m failing to start the “wlansvc” service, I’m getting this error: ERROR_SERVICE_NOT_IN_EXE 1083 (0x43B) The executable program that this service is configured to run in does not implement the service. I saw that someone run into similar problem here: http://reboot.pro/topic/4022-vistape-and-wireless-update-35/page-3 Do you know why this error occurs? Do you know how I should add and start wlansvc correctly?
  12. WinPE does not recognize Harddrive

    Hi guys, this is my first post here and i was really hoping it would give me results. So. I need to capture a custom image on a machine and figured i would do this simply with a USB stick with enough memory and winpe/imagex. I have no problems booting from the USB but I can't seem to find the harddrive of the host computer. It is a RAID harddrive but I made sure to install the Intel RAID drivers on my winpe image. (Still didn't help) I used DISKPART and command "list vol" and command "list disk" to no avail. It shows the thumb drive, the dvd-rom drive (2 of them actually) and nothing else. I used the instructions from this webpage http://www.windows-noob.com/forums/index.php?/topic/2349-guide-adding-drivers-to-a-custom-winpe-30/ in order to install the drivers to my winpe image. Please and thanks in advance.
  13. WinPE 4 and Windows 7 storage driver (critical) problem Hi @all i'm triyin to create a universal staging platform. As base i want ot use a WinPE 4 x64 image which gets delivered via PXE and then start the setup process in unattend mode from a network share. The installation works fine on VMWare or machines where the hardware is already supported. i've only a problem with hardware which needs driver included. The setup starts but stops with the Error "Windows cannot locate the disk and partition specified in the unatted answer file's <ImageInstall>. Make sure the setting references a valid partition and restart the installation" Further investigation shows that the setup needs a driver to continue the installation. The same behaviour is shown if i use a DVD as installation media. After providing the driver Required, the installation will complete without any interruptions. But i would like to do this in unattend mode. The logfile "setupact.log" shows me the installation cannot continue because of the missing driver: 2013-12-18 11:01:56, Info IBSLIB DiskRegionSupportsCapability:Disk [0] is BLOCKED against capability [CanInstall] for the following reasons... 2013-12-18 11:01:56, Info IBSLIB LogReasons: [bLOCKING reason for disk 0: CanInstall] Windows needs the driver for device [intel® C600 Series Chipset SATA RAID Controller]. Click 'Load Driver' and load the required device driver. Usually the driver needed for the setup are taken from the boot.wim. As using WinPE 4 for booting, the drivers are incompatible to the OS getting installed. Injecting the Win 7 drivers into the WinPE 4 image will cause the WinPE stop from working (stuck at boot). What i've tried so far: - including the dirver in pass "windowsPE" <driverpath> ... --> setup start and "expands Windows sources" but fails with error: "windows cannot continue because a reqiuired driver could not be installed" setupact.log says: 2013-12-18 13:45:37, Error [0x0602a9] IBS CallBack_AddDriverPackageIntoDriverStore:Failed to install the driver package [c:\drivers\storage\iaAHCI.inf]. Driver package is [Critical]. Error code is [0x32][gle=0x00000032] 2013-12-18 13:45:37, Error [0x0602ab] IBS CallBack_AddDriverPackageIntoDriverStore:An error occurred while installing the driver package [] offline GLE is [0x32][gle=0x00000032] 2013-12-18 13:45:37, Info [0x0640ae] IBSLIB PublishMessage: Publishing message [Windows installation cannot continue because a required driver could not be installed.] - inject the driver into install wim --> failed - same error - combining both steps above --> fails too Is there any possibility to provide the drivers needed for the installation? thanks!
  14. Hello! There are many similar topics regarding Windows 8 deployment... I tried to google and check out as many as I could. Wasn able to solve my issue though. I'm writing here, hoping that someone might be able to help me out. I am trying to deploy Windows 8 put problems with starting it. I have new Samsung laptop, where I have installed Windows 8 Pro. Iinstalled programs, created user-accounts etc.Then I bootel laptop from USB WinPE media and captured C:\ drive as a *.WIM file. So far everyting OK. I got second laptop (same model). Booted it also from Winpe USB media and used Diskpart to clean-create partition and format it as NTFS. I created just this one partition. On that partition I applyed the wery-same image that I previously created. Image was applyed and then started problems. --> bcdboot c:\windows is not working. --> Failure when attemting to copy boot files. --> I also tried bcdboot c:\windows /s c: --> Boot files successfully created. But after this OS isnt booting, still. Anyway, this is where I got stuck. Please help me out.
  15. I recently build a network boot thumbdrive for installing and recovering windows 7 how would i go about intergrating wpi into this thumbdrive i know how to do the coding for network instalations i would like tohave wpi autolaunch win pe i tryed to open it and got a script error line 223 char: 4 Error The specific module could not be found Code 0
×