Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Leaderboard


Popular Content

Showing content with the highest reputation on 07/02/2020 in all areas

  1. 5 points
    Default settings just spoof the user agent, which you can replicate by setting general.useragent.override.youtube.com in about:config to: Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
  2. 3 points
    youtube: someone figured out that useragent googlebot still gets classic layout https://msfn.org/board/topic/180462-my-browser-builds-part-2/page/91/?tab=comments#comment-1183430
  3. 2 points
    ... Being slightly pedantic, but the URL query parameter should be: disable_polymer=1 Be that as it may, the query no longer works for the main YT homepage, https://www.youtube.com/?disable_polymer=1 (classic style is not restored), but still works for independent video URIs: https://www.youtube.com/watch?v=W-z7hoEWaH4&disable_polymer=1 A Google-bot SSUAO however does, as of this writing, work in both cases... [I'm using just "Googlebot/2.1 (+http://www.googlebot.com/bot.html)"]
  4. 2 points
    Heads up about Firefox installers (78.0.1 to be exact). To install, add "setup.exe" to the list of applications in Application Verifier x86 and adjust version settings accordingly. Firefox 68.9 ESR is mostly working, except for a quirk involving the address/search bars. There are no default search engines and no way to add them. Thus, if you want to load pages directly from the address bar, you have to specify the protocol (like http;// or ftp://). Please note that the uxtheme.dll I'm using is a little stubby, but it does seem to be a far-fetched link. And I'd think that uxtheme would be OK being stubbed as, much like with dwmapi, uxtheme only needs to accommodate themes compatible with Windows Vista and not those for Windows 7. Perhaps some more debugging is needed. As for 78.0.1, it appears we will now need K32GetPerformanceInfo in kernel32.dll. The Firefox executable now also calls for RtlQueryPerformanceCounter in ntdll.dll. The thing is that, ntdll seems to be untouchable in NT 6.0! There's tonnes of extra data beyond the specified sections, which CFF Explorer does not handle gracefully. Stud_Pe does recognize the extra data, and makes new sections beyond it. But I still haven't tried adding any code since, as RtlQueryPerformanceCounter can easily be substituted for something like NtQueryInformationProcess. In fact, now that I extended kernel32.dll and modified firefox.exe, it seems to work similar to 68.9 ESR with the same bug. I'll get to the bottom of this! UPDATE: Turns out that windbg still works with my kernel extensions. So, this is what happens with Firefox 68.9 ESR: Where is search engine information stored in modern Firefox? Furthermore, it thinks I have no Windows Media Foundation. Maybe if I extended it (mf and mfplat.dll) it would work. Maybe. And now for Visual Studio Code: to install it, add VSCodeUserSetup-x64-1.46.1.tmp (or whatever the exe is called, just with a tmp at the end) to Application Verifier x86. It needs these functions: shell32 Shell_NotifyIconGetRect user32 ChangeWindowMessageFilterEx SetWindowDisplayAffinity kernel32 PowerClearRequest PowerCreateRequest PowerSetRequest QueryUnbiasedInterruptTime RaiseFailFastException K32GetMappedFileNameW (this one is for Brave browser based on Chromium 83) But apparently Office 2016+ and MS Edge installers (click-to-run) don't like local files, so they won't install.
  5. 2 points
    I could see them calling reg keys like HKLM\Software\Microsoft\Windows NT\CurrentVersion and calling KeBugCheck or something similar if they saw (or did not see) a certain version. But I don't think that happened in that case. https://docs.microsoft.com/en-us/windows-hardware/drivers/debugger/bug-check-0x139--kernel-security-check-failure Yours had a 3 in parameter 1, so a corrupted LIST_ENTRY. But the issue seems to only be restricted to Windows 8's dxgkrnl.sys; there seem to be no issues with the ones in 7 and 8.1. Perhaps the last working and first broken driver need to be compared, or dxgkrnl.sys needs to be replaced with a 7 or 8.1 version (preferably 8.1). There must be some differences in 8's dxgkrnl.sys compared to the 7 and 8.1 versions, and perhaps the driver no longer accommodates for that one since it's no longer a targeted/supported platform. More specifically, DXGCONTEXT::SubmitPresentHistoryToken needs to be compared between the three OSes. Going back to Vista, I admit that the road to an extended ntoskrnl.exe/dxgkrnl.sys/etc will be tricky. Even with Windows 2000's kernelmode driver extension, some XP display drivers were quite unstable in certain games; BWC had to edit the drivers further to improve functionality. But it will be interesting to see how far we go.
  6. 1 point
    Fullscreen mode - F11, or Auto Fullscreen + browser.fullscreen.autohide false OpenGL compositing and multiprocess in the browser are not compatible. I tested: FX5200 OpenGL - winXP and 7, FF47, very slowly, non-hardware (CPU) OpenGL FX5200 DirectX9 - WinXP, FF48, fast, driver 175.16, layers.acceleration.force-enabled, layers.max-active 1 or 2, layers.enable-tiles true for multiprocess. WebGL - webgl.force-enabled, webgl.disable-angle GF6100 OpenGL - WinXP, FF47, fast, hifts parts of GUI up (fix F11 + browser.fullscreen.autohide false). WebGL ANGLE GF6100 DirectX9 - WinXP, driver 307.83, FF52, fast. WebGL ANGLE GTX260 OpenGL - Win7, FF58 and Waterfox Classic (FF56), fast, hifts parts of GUI up (fix Auto Fullscreen + browser.fullscreen.autohide false). WebGL ANGLE ATI Radeon x700 OpenGL - driver Catalyst 10.2, WinXP, FF47, fast, hifts parts of GUI up (fix F11 + browser.fullscreen.autohide false). WebGL - webgl.force-enabled, webgl.disable-angle ATI Radeon x700, Radeon 9550 DirectX9 - WinXP, FF52, compositing Basic (no). WebGL - webgl.force-enabled, webgl.disable-angle Intel GMA3150 OpenGL - WinXP, FF47, compositing Basic (no). Radeon 9550 OpenGL - WinXP/7 non test Maybe the developer MyPal (Feodor2/zzz528) will be fix OpenGL http://forum.ru-board.com/topic.cgi?forum=5&topic=50547&start=160#15 developer "radio.garden"
  7. 1 point
    Thank you for confirming. And just an FYI that I know of several Vista SP2 users performing a clean reinstall of their OS who have reported that your suggestion <here> to apply the MicrosoftRootCertificateAuthority2011.cer certificate file fixed the error 800B0109 ("A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider") that Windows Update now throws when it tries to install KB4014984 (Security and Quality Rollup for NET. Framework 2.0, 3.0, 4.5.2, 4.6 on Windows Vista SP2 and Server 2008 SP2: April 11, 2017). I decided to add a footnote to my instructions in the MS Answers thread Updates not working, it has been searching for updates for hours (where I post as user Great White North) in April 2020 and alert users to your solution since this problem installing KB4014984 has become so common.
  8. 1 point
  9. 1 point
    found the problem, and a fix was pushed to git repo.
  10. 1 point
    I found that firefox extension YouTube Classic by Mirza Brunjadze https://addons.mozilla.org/en-US/firefox/addon/youtube-classic/ is working in roytam1's Basilisk. Old good YouTube without psychotic Polymer. Unfortunately, there is no XUL analogue known to me for New Moon.
  11. 1 point
    That happened to me in Windows 7 when also trying to install recent .NET updates. I think W7 actually received some update about outdated certificates as opposed to Vista. I solved it by importing a MS certificate that Vista and 7 don't ship with. http://download.microsoft.com/download/2/4/8/248D8A62-FCCD-475C-85E7-6ED59520FC0F/MicrosoftRootCertificateAuthority2011.cer Run the following command with Admin rights to install it (replacing the path with the one where you downloaded the certificate) certutil -addstore "Root" "c:\cacert.cer"
  12. 1 point
    As I've posted in a previous thread, it is possible to get Ryzen working on Vista, but drivers are kind of a pain to get working. Windows 7 USB3 drivers do work on Vista, but don't try and slipstream them, because they're not signed for NT 6.0. I would recommend first installing using a PS/2 keyboard and a DVD, if possible.
×
×
  • Create New...