Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


nuhi

nLite 1.2.1 Final - Finish him!

Recommended Posts

:(

121ay3.png

after "Processing setup files" step.

nLite work to the finalizing step, but don't finish the nLitening process, on the runtime error OK click, nLite crash, the process dead.

I have used the 1.2.1 version also on a machine with PentiumM, on this Laptop, centrinoDuo... :(

theSLug

Share this post


Link to post
Share on other sites

The nlite switch options have been very usefull to me processing the builds.

Unfortunatly the function seems to be broken after nLite 1.2RC, later versions just end up at the screen showing the source older and OS info and stops there.

Unfortunately I can confirm this issue.

Share this post


Link to post
Share on other sites

I just tested Ie7 integration using nLite 1.2.1 and I have to say it works great but I have a few minor requests:

1. Can nLite make the files 8.3 compliant ? I see multi-dot extensions now in i386 (.exe.mu_) and LFN CAT files in the SVCPACK folder. I think the same occurs in Windows Media Player 11 but I haven't tested direct integration with nLite yet.

2. After installation IE7 reported that it was not set as the default browser despite the fact it appears correctly and runs when double-clicking on a html page, perhaps there's a missing registry entry ?

- I was testing a clean source base with only RyanVM's 2.1.3 pack and no installers of any kind included.

Share this post


Link to post
Share on other sites

@boooggy,

Tested your wmp11 addon for 2 days (vanila and tweaked) and can say for sure the integration is BAD. Try watching movies and you will see that resize does not work properly. Fit player to video on start is NOT working as it should. Player works like after hacked beta install I tried once. Only legit install does not give this error.

At the beginning I thought it was MS fault, but after installing full version normally I found it works as expected.

All those suggestions to install WMP11 without validation with a few reboots will give the same fault as this hacked integration.

So the question is - can You fix it????

Surely good that You removed this network service from wmp11, but wmp still checks to server every time You start it. This check starts 2 services at least: Universal Plug and Play Device Host and SSDP Discovery Service which You cannot remove with Nlite so you should be able to check it. As well under certain configs this can start telephony and Remote Access Connection Manager services what is absolutely unacceptable. If those services are disabled You will get dcom error in event viewer. All this behaviour is not the case in WMP 10.

I believe nobody needs to put those resourses for wmp11 and would be nice if You could take a closer look at this. Why wmp11 needs to start Universal Plug and Play Device Host? Most probably to connect all those ext devices. But why it should start each time even if I just want to launch player?

I am using xppro sp2 original so nothing what could amaze You.

One more interesting finding for legit users. Try to delete any exe component from unpacked wmp11 and install (not runtimes and player itself) and You will find it installs all what You wanna leave. This is just great.

And let presume that this call for Universal Plug and Play Device Host is done by player component.

Good luck to all,

Alex

Share this post


Link to post
Share on other sites
ASMS Compression is found by clicking Advanced on the Hotfixes page. Additionally, because more components are available from 1.0.1 to 1.2.1, the most likely explanation would be that more components have been divided up to better take away only the functionality you desire to get ride of. For example, Floppy Support (in the hardware section), used to remove Format Drive support. With version 1.2.1, they are now separate, allowing further customization than before.

Cheers for that tap52384 and MarcJ .. I'll go back to the drawing board and remake the iso from scratch I understand why the problem may have occured now. Still seems strange why the Time Zone Settings, PC name and CD Key are lost though!

Hopefully get time to try it tomorrow, will report back!

Plasma

Share this post


Link to post
Share on other sites

\i386

\$OEM$\$$\System32\wmdrmsdk.dll, mfplat.dll

Code for working wmp11 integration. Works flawlessly!!!

Take those two files from wmp11 installer.

Integrate 4 .exe files from unpacked installer. The smallest one will be integrated automatically. Use normal install sequence for integration. You can skip driver framework integration as it is unnecessary crap.

Good wind,

Alex

Edited by Alex

Share this post


Link to post
Share on other sites

well that's a good find, but instead of using $OEM$ to integrate the dll's nuhi would just add them to txtsetup and the other files so its copied to the correct place :)

Share this post


Link to post
Share on other sites

post-110058-1162703521_thumb.jpg

I do not get this error in old nLite versions. Only in nLite 1.2.1.

It is a minor problem, what I can workaround changing the names in path, but it is a bug.

Share this post


Link to post
Share on other sites
post-110058-1162703521_thumb.jpg

I do not get this error in old nLite versions. Only in nLite 1.2.1.

It is a minor problem, what I can workaround changing the names in path, but it is a bug.

May be the add on you want to integrate is not nLite compatible? or try to use a fresh files of XPCD

Share this post


Link to post
Share on other sites

I do not get this error in old nLite versions. Only in nLite 1.2.1.

It is a minor problem, what I can workaround changing the names in path, but it is a bug.

May be the add on you want to integrate is not nLite compatible? or try to use a fresh files of XPCD

No, the addon is ok. It is a Ricktendo64 addon and I use in 1.2RC or 1.0.1 without problem.

Share this post


Link to post
Share on other sites

I notice with my latest ISOs that Windows Management Instrumentation is nowhere to be found, despite not selecting it for removal. I have tried the steps on nliteos.com and have successfully 'reinstalled' it, however, 3DMark06 refuses to function. I have considered resorting to a vanilla copy of XP just to give in to all the hassle. Does anyone know of a command or something I can put in my WINNT.SIF to ensure the proper/complete installation of WMI?

Share this post


Link to post
Share on other sites

Hi nuhi,

IE7 integration is just brilliant, thank You very much.

2 questions:

1. file for start navigation is missing. Is it the small mistake and it's easy to tune to navstart, o there is new sound file by design in IE7 or no sound at all for start mavigation?

2. I remember that small bug with ealier versions of nlite

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer

4. On the Edit menu, click Permissions.

5. In the permissions for Installer dialog box, click Administrators in the Group or user names list, and then make sure that the Full Control permission is set for the Administrators group. If this permission is not set, click to select the Full Control check box under Allow.

6. Click OK.

7. Repeat steps 5 through 6 for the SYSTEM group.

8. Repeat steps 5 through 6 for the Everyone group.

This helps skip mistakes while opening exel or word files in explorer. Why those permissions are skipped?

Can You reply on that?

Fanatstic job!!!

Thank You very much,

Alex

Edited by Alex

Share this post


Link to post
Share on other sites

Come on Nuhi stop concentrating on a Windows Vista version, its supposed to be much faster setup and all you have to do to integrate updates it place them in the update folder.

Read here: http://www.winsupersite.com/reviews/winvista_03.asp

Waiting for the next version for XP.

nLite does work with .net v3.0 right?

The some Vista experience is already available if you can integrate these in to the XP CD without problems:

- Windows Defender

- Internet Explorer 7

- Microsoft .NET Framework 3.0

- Windows Media Player 11

If all of these can be integrated without problems, that would be perfect. With nLite NOT separate add-ons.

Edited by sonu27

Share this post


Link to post
Share on other sites

Hello

ii am trying to have my setting of desktop themes on my Unattended but i have try few things but it dosent work...

i hope anyeone can help me.

First i have started Nlight and the go to Desktop Themes and change it Windows-XP Layout and Silver and then next and finish.

Winnt.sif

[shell]CustomDefaultThemeFile="%WinDir%\Resources\Themes\Luna.theme"

then i have install it on Vmvare but then i get classic.

Then i have try to export my setting and then inport it but then i still get Classic.

Winnt.sif

[shell]CustomDefaultThemeFile="%WinDir%\Resources\Themes\Luna.theme"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...