Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Editing WINNTBBU.DLL For Dummies


Recommended Posts


Crusher,May 3 2004, 08:47 PM]is there somewhere to find some pre-modded winntbbu.dll files?

I can host them on my web server if anyone is worried about bandwidth or space issues (unlimited space, unlimited bandwidth)

if you wan't your setup screen hosted, Private Message me with a valid download link for it, then I can upload it

Being no good at doing this sort of thing myself, (can't "paint" for crap,) I would love it if someone could possibly do one to accentuate the theme I use for my desktop, Royal Black v1.1 by "Cavador", the theme can be found at "ThemeXP". Basically it's a black theme using the original M$ Luna themes, just colored more of a dark greyish black. I hate the friggen blue/green/silver colors that come standard and use this one instead, but I would love to be able to see it from the get go if that is possible. I'm not looking for the stupid "Bliss" design, but the black coloring instead. Somewhat how <SparTacuS> done his, except a little more towards the black shades.

TIA for whomever is able to pull this off for me.

Grab wallpaper here: "Red Moon Desert"

For anyone who's interested, here's what my destop looks like:

post-70-1092551875_thumb.jpg

Edited by DisabledTrucker
Link to post
Share on other sites
How can I make them go away? Can I make them transperant (with that purple color)? If i make them 1x1 pixels will the installation strech them? Anyone tryed?

I've made bitmaps 100, 101 and 102, 1x1 pixel images and they work fine.

Changing them to the transparent purple color makes them come up purple and removing them causes setup to default to the classic Windows 2000 mode.

Link to post
Share on other sites

I edited my WINNTBBU.DLL and changed my background image...

During setup when the GUI section starts, I get an error:

Error:

The signature for Windows XP Professional Setup is invalid. The error code is 800b0100.

***

Fatal Error:

Setup failed to install the product catalogs. This is a fatal error. The setup log files should contain more information.

My Windows XP version string is

Version 5.1 (Build 2600.xpsp_sp2_rtm.040803-2158 : Service Pack 2)

Anyone know why?

Link to post
Share on other sites
I edited my WINNTBBU.DLL and changed my background image...

During setup when the GUI section starts, I get an error:

Error:

The signature for Windows XP Professional Setup is invalid. The error code is 800b0100.

***

Fatal Error:

Setup failed to install the product catalogs. This is a fatal error. The setup log files should contain more information.

My Windows XP version string is

Version 5.1 (Build 2600.xpsp_sp2_rtm.040803-2158 : Service Pack 2)

Anyone know why?

I had exactly the same issue aswell JCarle, anyone have any ideas on this as it's really frustrating.

I replaced four files in total after running NLite (safe settings):

SYSSETUP.DL_

WINNT32U.DLL

WINNTBBU.DLL

SFC_OS.DL_

I also edited hivesft.inf to disable WFP incase that was the problem.

Thanks in advance

Smudge

Link to post
Share on other sites
  • 4 weeks later...

ok.

i DLed one completed one. but then changed the background.. but the old background still shows.

anyone else have this problem?

i KNOW the .dll was updated.. because it opens up with the new pix (in Resource Tuner)

:unsure:

------------

ah it works now................ after rebuilding 4 times!!!! argg. :realmad:

Link to post
Share on other sites

I have a working winntbbu.dll but I have the 640x480 resolution problem that has been discussed before in this thread. This is an appeal to anyone who may know a solution. When doing a fresh install from an XPCD (not an upgrade) with SP2 slipstreamed my new winntbbu.dll displays the appropriate graphics but not at the appropriate resolution. I have an ATI 9700 pro video card, so bare minimum SP2 will provide a fairly recent version of drivers capable of 1024x768. Are other people completely conviced that their installs progress at higher resolutions? I know that mine is 640x480 becuase I run XPlode on top of it with graphics sized and placed for 640x480. Any help or direction would be greatly appreciated.

Relevant winnt.sif resolution entries:

[Display]
   BitsPerPel=32
   Xresolution=1600
   Yresolution=1200
   Vrefresh=85

The correct resolution is displayed following the 2nd reboot.

Link to post
Share on other sites
that display section refers 2 WITHIN windows... not during setup

Yes I know that is the final resolution in windows, but there had been some discussion (earlier in this thread) that it might have something to do with fixing this problem, so I included it for completeness. Thank you becuase your post completely clears this up: the winnt.sif resolution does not play a role in the gui setup resolution.

Link to post
Share on other sites
I edited my WINNTBBU.DLL and changed my background image...

During setup when the GUI section starts, I get an error:

Error:

The signature for Windows XP Professional Setup is invalid. The error code is 800b0100.

***

Fatal Error:

Setup failed to install the product catalogs. This is a fatal error. The setup log files should contain more information.

My Windows XP version string is

Version 5.1 (Build 2600.xpsp_sp2_rtm.040803-2158 : Service Pack 2)

Anyone know why?

Modifype may help if it was not used, to correct the crc header, after editing. I see no mention of it, in these latest posts.

:rolleyes:

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...