Jump to content

Integrating drivers with HFSLIP?


Recommended Posts


You could follow the instructions here:


Scroll down to the post of zen69x

The thread is about XP but it just works fine for Windows 2000 as well.

I've integrated an adaptec U320 SCSI controller and now it works just fine for me without having to press F6.

This method works only for mass storage controllers I think.

I've tried Oleg II's method for a gf2_mx videocard driver and it gave me an error - one like Tomcat76 described. I'm not using FDV's file set. For me I got no success with Oleg II's method - maybe it only works with FDV's file set.

Link to comment
Share on other sites

I have a problem integrating drivers with last HFSLIP. But it works with a CMD file I've made to automate the process described in the first post. Investigating.

For your note (I got it somewhere in our Forum, sorry, can't remember in which topic):

I will post what I changed to get my Adaptec 2930U2 SCSI controller recognized during the install without having to use a floppy. I would imagine that the changes required for your device should be pretty similar.

First, what you will want to use the makecab utility found in the \winnt\system32 directory to make cab files of your .sys (driver) and .inf (setup) files. Mine were 2930U2.sys and 2930U2.inf which in turn became 2930U2.sy_ and 2930U2.in_ respectively. You will need to copy these files to the i386 directory that will be burned on your CD.

There are only 2 files that you will have to edit:


Under DOSNET.INF I made the following changes:

I added:

I added:
2930U2 = "Adaptec 2930U2 Ultra2 PCI SCSI Controller"

(Be careful, there are two sections labeled this, you want the 2nd, it also has a very long list after it.) I added:

Under TXTSETUP.SIF I made the following changes:

I added:
2930U2.inf = 1,,,,,,,20,0,0
2930U2.sys = 1,,,,,,3_,4,1

I added:
PCI\VEN_9005&DEV_0011&SUBSYS_01819005 = "2930U2"

I added:
2930U2 = 2930U2.sys,4

I added:
2930U2 = "Adaptec 2930U2 Ultra2 PCI SCSI Controller"

The stuff in quotes is just a text string so nothing special there that I can tell. The only item I see that would be a problem is the PCI\Ven... etc. part. I got the value by opening the registry on a box that already had the adapter installed and went to the HKLM\System\ControlSet001\Enum\PCI key and searched through the values until I found the key that had the adapter that I was looking for.

Alternately, there was a similar setting in the .inf file that is provided with your hardware, I'm not sure if that would work, but I'd bet that it probably would. Mine showed PCI\VEN_9005&DEV_0011 vs. what I entered above.

Link to comment
Share on other sites

  • 3 weeks later...


You suggest modding the inf files using HFDRF, but your script creates MYDRV.

Also, your script needledly renames the compressed INF files to mydrvx. Or are you just renaming to keep track of the files added? Also, you include the inf files inside the cab file.

Is there some case where they are needed, because normally, they won't be read from inside the cab?.

(Or am I missing something?) None of the cab's included 'au natural' have the inf's inside. If naming the cab WAS enough, then I could move the inf's out of i386 to exist only in the cab. Would that work?

Anyway, I used your idea/technique and a modinfied form of your script to build a version that has my intel driver files in a cab {they used to exist individually as compressed files in i386}. -inf's outside-

The darn thing is 11MB 11.3 counting the inf files. :o

Works like a charm! :thumbup

Link to comment
Share on other sites


I have to modify my first post. Please use HFSLIP - it handles drive integration now and rename all MYDRV names to HFDRV in my instructions.

No reason for INFs in CAB. Just don't think they are worth deleted and I like all my drivers in one CAB just in case ;)

Still have issues:

- my CDMA modem is not installing at all (asks for distributive disk);

- Intel graphic driver asks for distributive disk too, but installs fine without providing it :wacko:

Edited by Oleg_II
Link to comment
Share on other sites

  • 3 weeks later...

Oleg II,

I don't have any probs with intel installs. (always the VIA and AMD that are the pain).

I like hfslip, but prefer to keep some mods my own way.

I can add seperate mobo sets by using dif cabs, or leave off if I get squeezed for space. besides, I can update drivers sets if need be .

btw: You gotta have the inf files avail outside the cab. I tried with them ONLY in a cab and the install played stupid. figures.

Link to comment
Share on other sites

  • 3 weeks later...


I am experiencing the following setback. Upon installation I receive the

The following value in the .SIF file used by Setup is corrupted or missing:

Value 0 on the line in section [sourceDisksFiles]with key "driver.cab."

Setup cannot continue. To quit Setup, press F3.

All drivers were extracted according to the [sourceDisksFiles] directive within each Driver's INF. Then copied to the HFDRV directory under HFSLIP. Each INF in the HFDRV directory were then manually edited to add

1. "1 = %W2Kcd%,hfdrv.cab,,"I386"" under the [sourceDisksNames] directive and

2. All files mentioned under [sourceDisksFiles] where amended to have the "= 1" at the end

e.g. e1000nt5.din = 1

This did not improve the problem, so I furthermore edited the Source TXTSETUP.SIF to add

1. Drivercabname=HFDRV.CAb,driver.cab under [setupData] and

2. HFDRV.CAB=16 under [FileFlags]

This has allowed the reading of the HFDRV.CAB situated under \Sourcess\I386.

May I ask wether I am in the correct direction? :wacko: Getting there though...

Textsetup requires all INF's (and SYS files for NIC's) in the \386 folder

The newer HFSLIP solved the above problem.

Only the Intel Graphics Accelerator Drivers goes MIA on required files

HFSLIP is way kewl.


Edited by StormRage
Link to comment
Share on other sites

  • 2 weeks later...

Hi folks!

Unforunetely I have to confirm the error mentioned above... I get the same message about missing value in .sif file. I've prepared HFDRV folder as Oleg said to. I tried installing from source with and witout fdv's file set. Txtsetup.sif files look the same in both cases:

(Here is a loooooong list of files)

HFDRV.CAB = 2,,,,,,_x,39,0,0

There are such lines in layout.inf from nonFDVed source, and not in FDVed one:


Dosnet.inf is the same in both sources:


Please help us with it! Best regards!

Btw. Am I wrong, or Oleg hasn't been visiting the board for a long time?

Edited by januh
Link to comment
Share on other sites

For hfslip_60307.cmd all is fine with HFDRV - folder. (example attached)HFDRV.zip

the example includes only svga and mouse for vmware-machine... just for testing. editet as told in the former posts:

[sourceDisksNames]1 = %W2Kcd%,hfdrv.cab,,"I386"

display works fine, already while setup(gui). for the mouse setup selected the standard-ps/2-driver. vm-mouse was selectable as a new driver and works fine after restart...

don't wait for an other hfslipversion for solving your problems, solve your problems:

  1. try one driver and then the next and then the next...
  2. expand all the files with an underline in your hfdrv - folder (use 7zip or expand)

edit on august 2006: the HFDRV - folder is the same level as hfcabs, hf, source, ...

and HFDRV.CAB is only build if you have *.inf in your hfdrv-folder

Edited by murvun
Link to comment
Share on other sites

  • 2 weeks later...
  • 5 months later...

Hi everyone.

I sucessfully used HFDRV folder with the vmware drivers... the I decided to place some more stuff inside it ( intel lan drivers, gfx card driver, audio driver ) wich I modified as instructed...

The thing is that while installing windows the installer says "cannot copy hfdrv.cab"... so I searched for it inside the CD and I'm pretty sure I didn't found one.. I found HFDRV1.IN_, HFDRV2.IN_, HFDRV3.IN_, and some more of these, but no HFDRV.CAB...

Well, I've redone the CD with just the vmware drivers and intel lan drivers and it seems ok now... I found the HFDRV.CAB inside HFSLIP\SOURCESS\I386, and windows installed without problems now.

Anyone has an ideia of what could be preventing HFDRV.CAB from beeing build? I've found no usefull log about this folder, maybe we can turn up log verbosity top find out what could be wrong?

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...