Jump to content

[WIP] Windows Vista Extended Kernel


win32
 Share

Recommended Posts


24 minutes ago, winvispixp said:

java 17 worked even before this release, tho i can't remember if it was 32 bit

Java 17 (64 bit) worked fine in previous releases, and 32 bit is the first time that I test. And that 32 bit jdk is not provided by Oracle, is the zulu version. The requirements of that jdk says Server 2012 or higher, but it might work in Windows 7 too.

Link to comment
Share on other sites

8 hours ago, Sergiaws said:

For XP probably not, it's a more modern computer so I wouldn't expect XP to work. Just know that there are an ACPI.sys for Windows 7 that might work. There's even the procedure to modify it, but I'm not sure if the procedure can be applied to Vista's ACPI.sys, and don't know a lot about editing such files to modify these lines.

I patched acpi.sys it and it didnt bsod on the acpi, instead it bsod on the error 0xc0000098 which is probably the NVMe so the mod might be working. Using Windows 7 for the time with the patched acpi, hoping i can do that with vista soon.

Edited by burd
Link to comment
Share on other sites

My findings after testing the new version on a somewhat period correct machine:
- msi afterburner is still broken, no error code, just "MSIAfterburner has stopped working"
- furmark 1.31 installer does not launch and every version higher than 1.21.1.0 the installer glitches so you basically have no buttons and can't do anything besides stop it from task manager
- in prime95, cinebench r15 and r20 my core 2 quad q9550 is being recognized as a 1 core 4 threads cpu but cinebench r11.5 and cpu-z do recognize it correctly; the performance isn't affected in r15 (r20 launches but fails the test) but it is quite odd (i did manually set it to 4 processors in system configuration and it is the same)
- kaspersky is back (don't care about other peoples opinion on this kgb virus or whatever they call it and i'm not russian:D), but i don't use firefox anymore and i remember it crashing only when using this specific browser 
- minecraft 1.18+ still fails to load into worlds (this starts to happen with snapshot 21w42a of minecraft 1.18)

I need some software that works the way msi afterburner does because my gtx 770 gets hot and i can't set the fan speed to what i want

  • Like 2
Link to comment
Share on other sites

This will be the last time I harp on this, but since this ties into the Extended Kernel, that's why I mention all this. Anywho, I created an AMD Driver pack that is compatible with AMD Radeon's such as R4 Stoney Ridge and Rx xxx (Rx 570, etc). This includes everything needed to run Vista (and even XP 64-bit) on Radeon hardware. To run all this (except for the Realtek, chipset and touchpad drivers), Extended Kernel must be installed. You can get all of this here: https://www.mediafire.com/file/lxzpv2afvxzzy6h/AMD_Assorted_Drivers_Pack.zip/file

P.S. The graphics driver is in Beta. I'll open a new, separate thread for further discussion on this.

 

Edited by Jakob99
  • Like 1
Link to comment
Share on other sites

18 hours ago, winvispixp said:

My findings after testing the new version on a somewhat period correct machine:
- msi afterburner is still broken, no error code, just "MSIAfterburner has stopped working"
- furmark 1.31 installer does not launch and every version higher than 1.21.1.0 the installer glitches so you basically have no buttons and can't do anything besides stop it from task manager
- in prime95, cinebench r15 and r20 my core 2 quad q9550 is being recognized as a 1 core 4 threads cpu but cinebench r11.5 and cpu-z do recognize it correctly; the performance isn't affected in r15 (r20 launches but fails the test) but it is quite odd (i did manually set it to 4 processors in system configuration and it is the same)
- kaspersky is back (don't care about other peoples opinion on this kgb virus or whatever they call it and i'm not russian:D), but i don't use firefox anymore and i remember it crashing only when using this specific browser 
- minecraft 1.18+ still fails to load into worlds (this starts to happen with snapshot 21w42a of minecraft 1.18)

I need some software that works the way msi afterburner does because my gtx 770 gets hot and i can't set the fan speed to what i want

MSI Afterburner 4.5.0 works. Version 4.6.0 and newer are broken.

  • Like 1
Link to comment
Share on other sites

On 10/19/2022 at 4:15 PM, win32 said:

I just reviewed all changes:
-Windows 7/8 functions added to kernel32 to support Firefox 106+, a couple of games, and Blender
-DXGI extension added to run newer WxWidget x64 version of PCSX2 and others asking for CreateDXGIFactory2
-ole and user32 extensions to run many Qt 6 applications
-Extension to bcrypt: add support for PBKDF2 hashing algorithm
-PowerShell Core up to at least version 7.0.1 working
-Several applications such as x64dbg and Telegram will now run if spoofed to Windows 7 (the fault of the VC++ 2012/13 runtime)
-NTOSKRNL extension added, compatible with NVIDIA drivers 378 (adds support for all Pascal except GT 1030) in full, and 398 on some systems (supports all Pascal plus OpenGL 4.6). A modified version of 378 (and 398, which may not work properly on some systems) will be made available through the extended kernel website.

Feedback :

1- Wonderfully working kernel, as usual. I don't use questionable software, so can't comment on the kgb viruses. Everything else (normal soft) works fine ! 

I just got back and tested only for several hours on a spare machine with 780 Ti.

2- In the driver 398, I had no conflicts ... but , a big "but" , NVCPL doesn't work and pretty much everything else is missing , like HD audio and even the colour settings ,

Is it possible to make that driver with the control panel ? Thanks .

BTW , I added a newer driver in my new tutorial,  and all functions work , including the NVCPL. 

https://msfn.org/board/topic/184056-breakthrough-p2-new-pascal-special-microsoft-nvidia-driver-port-for-vista-x64/

 

Link to comment
Share on other sites

Several days 24/7, all is fine so far on the dedicated kernel testing PC, some weirdness with chrome's explorer, no icons, look at the pic. And in local mode still can't open any explorer window, like I wrote some time ago.

 

Screenshot_20221104_183112.png

Link to comment
Share on other sites

On 10/30/2022 at 10:02 AM, D.Draker said:

Is it possible to make that driver with the control panel ? Thanks .

I was wondering the same thing for AMD Radeon. We have the graphics driver working, but not the control panel for it. Also of note, if you have AMD Radeon mixed with anything Intel Haswell and newer, the AMD driver will not work unless the Intel graphics can be made to work as well.

Link to comment
Share on other sites

12 hours ago, Jakob99 said:

I was wondering the same thing for AMD Radeon. We have the graphics driver working, but not the control panel for it. Also of note, if you have AMD Radeon mixed with anything Intel Haswell and newer, the AMD driver will not work unless the Intel graphics can be made to work as well.

No, I don't have. Jakob, there's a topic dedicated to the CPL here.

https://msfn.org/board/topic/184056-breakthrough-p2-new-pascal-special-microsoft-nvidia-driver-port-for-vista-x64/page/2/

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...