Jump to content

My Browser Builds (Part 2)


Recommended Posts

1 hour ago, Sampei.Nihira said:

My view of the Opera website:

100.jpg

(I will never use Opera 36 with Windows XP).:no:

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.3987.132 Safari/537.36

~Off Topic~

Yes, with that string, I was able to download that exactly as your screenshot. However, it didn't install at all once downloaded. So, I grabbed a portable copy of both: Opera GX and Opera Neon and neither will work at all??

Opera GX

1629254405_operagx.thumb.JPG.4f6e2028535a59483f6b87245d3a4a92.JPG

Opera Neon - https://www.opera.com/computer/neon

582708645_operaneon.thumb.JPG.a0d6862cebcaac51f027c71cb148948a.JPG

 

10 hours ago, VistaLover said:

OT: Opera 36.0.2130.80 dates back to August 2016 (!); is anyone among you (still) using it? And if yes, how does it cope with the 2021 web (the one Google single-highhandedly have created) ? :dubbio:

I only use Opera 36.0.2130.80 when I absolutely have no choice. If I need to use Chrome, I'll either go with Vivaldi (Chrome49) SlimJet (Chrome V50) or Iron (ChromeV49) or Chromium 49, because Opera 36 skips and youtube doesn't look right at all. But Opera (all 5 browsers) do work for me, nonetheless. However, UC Browser gives me way too much trouble than its worth so I refuse to use that one. I know, though, sometimes we need Chrome when our UXP browsers are limited.

~Off Topic~

Edited by XPerceniol
Link to comment
Share on other sites


NM27 :bug.
Right-click > open link in new tab, not working.
Also most other option of "right-click" not working.

XP sp3

Last working version :palemoon-27.9.7.win32-git-20201128-b383d6bc2-xpmod.7z

Link to comment
Share on other sites

1 hour ago, XPerceniol said:

...I only use Opera 36.0.2130.80 when I absolutely have no choice. If I need to use Chrome, I'll either go with Vivaldi (Chrome49) SlimJet (Chrome V50) or Iron (ChromeV49) or Chromium 49...

~Off Topic~

OT: Do any of those have built-in support for TLS 1.2 or do they all rely on systemwide protocol support (i.e. IE)?

  • Like 1
Link to comment
Share on other sites

7 hours ago, TRX101 said:

NM27 bug.
Right-click > open link in new tab, not working.
Also most other option of "right-click" not working.
XP SP3

I tried to reproduce with latest NM27 v27.10.0 (32-bit) (2021-03-05) here (Vista SP2 32-bit) and I couldn't; everything works fine in that regard ... Unless this bug is selectively targeting XP, in your case I would troubleshoot further by checking in a new pristine NM27 profile; chances are one of your installed extensions broke in builds past the 2020-11-28 one, manifesting the issue...

<OT>

7 hours ago, XPerceniol said:

So, I grabbed a portable copy of both: Opera GX and Opera Neon and neither will work at all??

Hint:

17 hours ago, VistaLover said:

when I hit the "Download now" button, while with the second UA I'm offered an online (stub) installer of Opera 74.0.3911.203 (requires Win7+).

... all versions/flavours of Opera past v36 require Windows 7 SP1 and higher (portable v37 can also launch under Vista SP2, but not on XP SP3).

7 hours ago, XPerceniol said:

If I need to use Chrome, I'll either go with Vivaldi (Chrome49) SlimJet (Chrome V50) or Iron (ChromeV49) or Chromium 49, because Opera 36 skips and youtube doesn't look right at all.

Opera 36 is also based on a Chromium 49 core/engine; I hadn't launched my portable copy of Op36 in ages, but. by the looks of it, it manages to open/render Youtube fine:

pn4jWwm.jpg

However, under XP, Opera (unlike Google Chrome 49) can't use patented decoders (h264, aka avc1, and aac), so only the other HTML5 codecs (vp8/vp9/opus/vorbis) can be used, possibly taxing resources and causing playback skips...

</OT>

Edited by VistaLover
  • Like 1
Link to comment
Share on other sites

<OT>

5 hours ago, Vistapocalypse said:

OT: Do any of those have built-in support for TLS 1.2

According to

https://www.ssllabs.com/ssltest/viewClient.html?name=Chrome&version=49&platform=XP SP3

Google Chrome 49 under fully updated XP SP3 should support the TLSv1.2 protocol, BUT with a limited number of cipher suites; supporting the protocol natively is one thing, but supporting ciphers to go with it is another :(; Chrome 49 relies on OS crypto libraries for ciphers and the OS cert store for root certificates; XP doesn't support ECC suites and SNI, these two handicaps limit even more the amount of HTTPS sites that can be accessed... :no:

PS: Just compare the record of Ch49/XPSP3 (above) to Ch49/Win7 (below):

https://www.ssllabs.com/ssltest/viewClient.html?name=Chrome&version=49&platform=Win 7

</OT>

Edited by VistaLover
  • Like 2
Link to comment
Share on other sites

Request: @dencorso or another moderator, would you kindly move our postings (pertaining to Opera) over to a thread better dedicated to Chromium discussion so we can further discuss this -  I feel we're being disrespectful to Roy1 - thank you in advance.

Well.. Chromium V54.20.6503 does work, but youtube is all blank?

https://archive.org/download/advancedchromev54.20.6530.0/Advanced_Chrome_v54.20.6530.0.zip

untitled2.thumb.JPG.e051b1099bcc7e45859589477d0e5f34.JPG

untitled3.JPG

untitled1.JPG

Edited by XPerceniol
  • Like 1
Link to comment
Share on other sites

<OT>

4 hours ago, XPerceniol said:

Official link from author:

http://browser.taokaizen.com/download/Advanced_Chrome_Windows_v54.20.6530.0.zip

4 hours ago, XPerceniol said:

Chromium V54.20.6503 does work, but youtube is all blank?

I'm out of breath in these forums saying that, in reality, Advanced Chrome v54 is NOT actually Chromium 54, but more of Chromium 48 under the hood... The percentage of Ch54 in it is quite small (just like Serpent 55 is actually, originally, a fork of Firefox 53.0a1, not Firefox 55.0!) ...

Also, from

https://browser.taokaizen.com/

05 - Jan - 2018 .- Updated Custom Build to 54.20.6530.0

New on version 54.20.6530.0:

    Crash bug fix.
    Removed dynamic user agent, you can install Chrome UA Spoofer extension to change it.
    Not vulnerable versus Meltdown and Spectre.

... meaning that AdvChr54 advertises itself to YT as Ch54, not Ch48/49, and is thus being served incompatible polymers...

I have an existing old installation of User-Agent Switcher for Chrome v1.1.0, by setting up a new custom UA of

Mozilla/5.0 (Windows NT 6.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

naming it Chrome 49 [C49] and using that as a general UAO, yt then loads (after a wait of 10 - 20s, that is...) : 

n2FujvP.jpg

However, if you haven't installed said extension in the past, you're just out of luck: Evil Google have recently (2021-01-19) re-uploaded it on CWS as a CRX3 only package, meaning it won't install now (you can try the archived file on https://www.crx4chrome.com/crx/515/ ).

If the XP people want a current-ish Chromium engine, please use the Chinese-made, Russian re-packed, versions of 360 Extreme Explorer 11/12/13 (see relevant XP forum threads) ...

</OT>

Edited by VistaLover
  • Like 2
Link to comment
Share on other sites

20 minutes ago, VistaLover said:

If the XP people want a current-ish Chromium engine, please use the Chinese-made, Russian re-packed, versions of 360 Extreme Explorer 11/12/13 (see relevant XP forum threads) ...

<OT/>

Ahh.. I knew it couldn't have been that easy Lol

TY @VistaLover for all your hard work digging up all that information about Advanced Chrome - I won't bother with it then and will someday have to take the leap to 360EE should I need to. But for right now, Roy's builds do everything I need so I'm 'Chillin' Like a Villain' :D

~Off Topic~

Edited by XPerceniol
Link to comment
Share on other sites

<OT>

2 hours ago, XPerceniol said:

TY @VistaLover for all your hard work digging up all that information about Advanced Chrome - I won't bother with it then

.... well, one related thread I did not manage to dig up in time... :P

https://msfn.org/board/topic/181267-chromium-v-54-not-displaying-youtube-properly/

</OT>

Edited by VistaLover
  • Like 1
Link to comment
Share on other sites

Here's a really weird bug: As of today, you can no longer type a space in YouTube on any legacy-Firefox-derived browser, in either the search box or when typing a comment -- it's reserving the space bar exclusively for pausing/unpausing the video. Typing Alt-032 to generate ASCII 32 or pasting in a space character from the clipboard works, but pressing the space bar doesn't. I've tried Serpent/Basilisk 52.9.0, New Moon 27.10.0, and Mypal 28.14.2 on XP, and Firefox ESR 52.9.1 on my Mac, and they all do the same thing. The space bar works normally in Chromium-based browsers.

Edit: I just updated Mypal to 29.1.0 from their Github page and now the space bar works in YouTube. So it appears that Pale Moon 29.x-based browsers should not have this problem.

Edited by vwestlife
updated information
  • Like 1
Link to comment
Share on other sites

44 minutes ago, vwestlife said:

Here's a really weird bug: As of today, you can no longer type a space in YouTube on any legacy-Firefox-derived browser, in either the search box or when typing a comment -- it's reserving the space bar exclusively for pausing/unpausing the video. Typing Alt-032 to generate ASCII 32 or pasting in a space character from the clipboard works, but pressing the space bar doesn't. I've tried Serpent/Basilisk 52.9.0, New Moon 27.10.0, and Mypal 28.14.2 on XP, and Firefox ESR 52.9.1 on my Mac, and they all do the same thing. The space bar works normally in Chromium-based browsers.

Edit: I just updated Mypal to 29.1.0 from their Github page and now the space bar works in YouTube. So it appears that Pale Moon 29.x-based browsers should not have this problem.

Off topic, but are you the real vwestlife?

Edited by asdf2345
Deleted wrong word before posting the comment
  • Like 1
Link to comment
Share on other sites

I posted a song this morning and later in the day I couldn't use the space bar (Serpent / New Moon / FF 52.9.1) ... So now everything is "normal" here, well, at least re the computer ... HA :D

Edited by XPerceniol
Link to comment
Share on other sites

  • Dave-H changed the title to My Browser Builds (Part 2)
  • dencorso unpinned this topic
  • dencorso locked and pinned this topic
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...