Jump to content

Browsing the web on 98/ME in 2019 and beyond


Recommended Posts

Loblo you have something special with your ME OS. I was referring to missing export functions in Kernel32 being set to 'SetLastError' in the call file. KEX latest is better but I would still try it on a backup because I cannot explain why a program using NetFramework stopped working after swapping up from 4.5.2. I do not recommend to use Glarry Utilities because reg cleaners usually make errors eg resource files could have differing internal file reg referencing numbers between OS's and application versions. The context manager is dangerous as there is no backup ASAIK. I did the testing of Java7 and Burp on 4.5.2 then tried it on latest KEX.

Edited by Goodmaneuver
Link to comment
Share on other sites

I use CometBird 9 as it is a slimmer make of FireFox but GreaseMonkey is not compatible. I had made some alterations to the greprefs.js within the omni.jar, an attempt to make it perform a bit better. I have removed some mail and accessibility settings and enabled pipelining and slimmed up buffers and made JavaScript one bigger. There may be some mistakes as some additions may not work but I have uploaded it here, just unzip. It can be viewed and edited with a text editor. You need to install JDK and the JDK bin mapped as an environmental variable. The path can be set in AutoExec.bat where JAR.exe is located. The original omni.jar is extracted to same folder then the greprefs.js is swapped with my one. With the active extracted OMNI window open load Command from the run launcher. Type jar -cf ..\omni.jar * this will compress back to a new omni.jar. You might want to rename original first so it does not get overwritten. That's it, can test different settings if not any better just delete omni.jar and rename original back to omni.jar Remember this grepref.js is for CometBird 9 and if comparing some items are not in order to that of the original sorry about that. I have JDK 6U29 installed but will not matter what you choose that works. I am using these settings in my system at the moment, it will not check for updates nor have plugin out of date nags. If you already have CometBird installed then it may be best to start a new profile to eliminate user settings effecting outcome. Remove or rename CometNetwork folder in %ApplicationData% folder.



Edited by Goodmaneuver
Original post for Miki altered Improved greprefs removing vulnerable ciphers and adding better user agent
Link to comment
Share on other sites

  • 2 weeks later...

Late to the party but for the records, with WinME using Opera and Retrozilla more lately. I try to not browse bloated sites like facebook, but even youtube works in Opera (but not in Retrozilla). 

Link to comment
Share on other sites

Goodmaneuver said:

I had made some alterations to the greprefs.js within the omni.jar, an attempt to make it perform a bit better

Sounds like a similar project as the 'UOC-patch'
But makes me wonder, why edit so complicated inside omni.ja?
greprefs.js only contains default prefs too, they can be overriden outside in normal ways (about:config, or prefs.js, or placing a modified js-file in the defaults/pref folder to get own default values)
But perhaps works differently in CometBird, no idea.

Something else I wondered for a long time:
am I the only one who has (now had) major trouble seeing those embedded crosslink iframes to other msfn-postings, with older Mozilla browsers?? Finally got them visible now with a little css-tweak.
Link to comment
Share on other sites

Yes web pages are getting more complex on the whole of late. This is why we must try and speed up WinME as best we can & I should start a new thread about this. See MSFN_Here & MSFN_Here . It is important to have a constant HDD access times like SCSI for speed comparison. FutureMark 3DMark03 CPU test is one that was dismal but now the results are better. I have mentioned that Mozilla has the speed over Opera but this turns out to be false now. I found that if cstore.exe 5.0.1573.1 utilizing msvcrt as ntdll and using activeds from DSclient for Win9x is running then it seemed to help with download speeds. Activeds.dll needs NT40 setting also will need wldap32.dll; dnsapi.dll; & adsldpc.dll which may need logonsrv.dll or radmin32.dll. Also give KEX22 Win2K multi thread a go on all 2K set modules. Make sure reg has not many errors after checking with reg checker do not include ActiveX & manually address each error just in classes at first.

If your mother board system devices has got mother board resources as a system device then this is not the best configuration I believe as this device is probably not a real device like reserved memory. Try and remove PCI bus and ACPI devices and start again with device install installing PCI bus manually first. It is important to get all devices working that can not be disabled. The Hyper Transport Clock LDT settings may need to be reigned in a bit especially if the super IO chip is not working the PS2 port correctly. (I am using 1.5GB ram with AMD X2 4600+ at the moment.) 

It is best to alter settings in Jar as the user settings can be overwritten and also imagine trying to alter settings like ones I have. If Retrozilla's files are employed in CometBird namely freebl3.dll; nss*.dll; smime3.dll; softokn3.dll; sqlite3.dll; ssl3.dll then more sites can be accessed including Source Forge. The navigation bar does not update though when changing addresses in same window with these files. The rest of DLLs I use from SeaMonkey10 except (mozutils - FF10esr12) (xpcom, mozjs & xul originals)

@Miki, what parts do you need more clarity on. I changed other modules in omni.ja other than greprefs.js when referring to MSFN_Here 


Edited by Goodmaneuver
Added missing info
Link to comment
Share on other sites

@ Siria >am I the only one who has (now had) major trouble seeing those embedded crosslink iframes to other msfn-postings, with older Mozilla browsers?? Finally got them visible now with a little css-tweak.

Wyzo 3.6.4 works I have updated to 3.6.28. What Mozilla browsers are you talking about; Retrozilla does not work. What was the css-tweak?

Edited by Goodmaneuver
Wyzo 3.6.16 was not correct version
Link to comment
Share on other sites

  • 1 month later...

I now have KG76 working again. Pages render much faster than KG74, but scrolling lags and menu text is mainly garbage.

KG74 can't post to MSFN.org (no submit button with or without JS), KG76 can (no JS).
KG74 can edit a post and attach files (JS), KG76 can't.

I continue to use SM 2.0.14 for most web browsing at home.

This post was created and edited with KG76 (KM-Goanna-20180128).

Edited by jumper
KG76 attachment test failed
Link to comment
Share on other sites

  • 4 weeks later...

Windows 98 SE, official updates, no kernel extensions:
- Tiny Personal Firewall v2.0.14
- TCPOptimizer v308 to tweak ethernet speed
- Dillo v3.0
- Dual boot GNU/Linux with SeaMonkey and NoScript

Dillo works well for speed, images and downloads. No hang-ups with certs and SSL like the outdated full featured Windows 98 browsers. Actually prefer the lack of JavaScript support.

Link to comment
Share on other sites

These posts are actually from Windows 98 and Dillo. Amazingly able to sign into msfn.org and post without JavaScript, thought the site was captcha protected . Still using Gmail's HTML only version, old Dillo might work there too, may try later. See ya.

Link to comment
Share on other sites

Dillo was ported to Windows once, now defunct.

Confirmed download and executable from:

Read more here:

My version doesn't have the plugins directory/content but works fine.

Once run, the config file is C:\WINDOWS\.dillo\dillorc.

Hope this helps.

PS Dillo with Gmail didn't work but this site still does.

Link to comment
Share on other sites

> Dillo was ported to Windows once, now defunct.

Three times that I know of, so still not clear. Do you mean:
1) The real Windows port "dillo3.exe" ("This version of Dillo was built on Nov 28 2011 using GCC 3.4.5 (mingw-vista special r3).")?
2) the Dillo fork "dillo-win32-3.0p9.exe" (December 5, 2009, ten years old!)
3) D+ Browser / Dplus (version 0.5b, October 15, 2013)

Link to comment
Share on other sites

Hi jumper. Believe i am using the original, definitely not D+.

Properties indicate The Dillo Project, Dillo Web Browser, dillo.exe v3.0, 1297920 bytes, date stamp November 28, 2011.

PS Going to stop posting from Dillo, too painful. Even SeaMonkey v1.1.19 hurts.

Edited by Wunderbar98
Correct error and Dillo breakage repost.
Link to comment
Share on other sites

Once Java runtime is working. I have it working now, thanks to those who made this possible,  I found this: - https://gngr.info/

& then there is LOBO 0.99.3 released last year : - 

https://sourceforge.net/projects/loboevolution/files/Lobo Evolution 0.99.3/LoboEvolution-0.99.3.zip/download

The CometBird using Retrozilla files is really turning out a good move. The navigation bar does update in the same window now and browser page rendering is speeding up quite good apart from the odd web page. CometBird as similar to what Loblo said with Burp proxy, SourceForge downloads are initiated but the timer does not decrement and therefore not savable/downloadable. last Jre8 vs to just use Msvcr100 is jre-8u51-windows-i586.tar.gz

jdk-7-windows-i586.exe fully installs on WinME with KernelEx this is vs Jdk1.7u0, it installs as a system installation. Give it time do not cancel & do not click on JVM error until the finish window appears. It may take a few minutes. Best to remove old Java first. Do not get confused with MSJava iJava probably can re-register dlls if need be. There should be 4 options to install on the install menu, the last one is called public Jre. Install all to the same folder, later on may will ask where to place the public Jre and place it in a different folder to that of the Jdk as the files will be different. If JDK was installed in a different root directory than default, it may ask where to find the public Jre msi file, usually in the Jdk install directory, if not, try looking in %programFiles%\Java\ . JVM does not load without PSAPX modification even if placed as PSAPI in the JVM folder as it would have to be in the application launch folder. Once Jre from Jdk7u0 package is installed, place extracted files from jre-8u51-windows-i586.tar.gz into the public Jre install folder. The missing reg settings for 8u51 have to be obtained from another install from another OS. Java control panel then indicates Jre1.8u51 as system install. Still may need further investigation. If Java7u0 is OK then that part is confirmed. To download from Oracle now requires a registered business name for an account but a download might still work through a 3rd party web site.

PS latest PSAPI will not have any JVM errors, see next few posts.

Edited by Goodmaneuver
Link to comment
Share on other sites

Latest GNGR doesn't want to run because, it says, it is more than 6 months old.

Latest Lobo Evolution runs but it's still in the pre-alpha stage IMO, nothing really useable for now.

For the Sourceforge timer, click on the "Problem Downloading?" button and you'll get a page with a direct link to your file.

I don't need to resort to the PSAPX trick to run Java 7 or 8 on my system but then I only have a very old KernelEx + KexStubs installed. ;)

Edited by loblo
Link to comment
Share on other sites

  • Dave-H changed the title to Browsing the web on 98/ME in 2019 and beyond

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...