Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Instagram videos not working in Firefox 52 ESR?


Recommended Posts

I've just noticed today that videos don't now seem to be appearing on Instagram pages with Firefox ESR 52.9.0.
There isn't even a placeholder, they are completely missing, all that's there of the posts is the text that should be beneath the video frame!
Static images are still displaying fine.
Is anyone else seeing this? They were fine yesterday!
The videos are still fine in Firefox 65 on Windows 10 needless to say.
I've tried spoofing the browser user agent using an extension, which I already have to do to get Facebook HTML5 videos to work, but none of the ones I've tried make any difference on Instagram.
:no:

  • Like 1
Link to post
Share on other sites

I can reproduce the issue.

Instagram:

- doesn't even load on Chromium 54

- it loads on Firefox 52.9.1 ESR but it doesn't play videos

- it loads and plays videos on Palemoon.

 

Please note that I don't use Instagram and I clicked on random things to test it. (I ended up on the profile of a speaker that works for CapitalFM, then on Taylor Swift and finally on a video made by some weird kinky youngsters about Shawn Mendes, which I didn't really care about).

 

cDQc2yX.png

WuzhlJO.png

wU6n6f1.png

 

Link to post
Share on other sites

At the moment instagram still kindly allows all users to see their videos, even on Win98se.
The catch is just that you cannot watch them directly inside a browser, but first have to download the mp4 files, from the direct link in the html source (metatag "og:video"), and then watch them with a local player. For me that's fine enough, considering it's the only chance - hundred times better than no access at all. Glad they still allow that, but they can stop it any day of course, like most other sites already did.

By the way there are tons of interesting "og:..." tags in the sources, also direct links to the big main image etc., very useful for users on old systems. And not only contained by instagram and facebook but also a few other services.

For frequent use the access can be made easier with a little javascript, like
(function() {var vidurl, metaTags = document.getElementsByTagName('meta'); for (var i=0; i < metaTags.length; i++) { if (metaTags.getAttribute('property') == 'og:video') vidurl=metaTags.content; } return vidurl;})()

Edited by siria
Link to post
Share on other sites

Thanks everyone, so Instagram presumably changed something yesterday to cause this?
The videos were working fine for me up until then.
They never played automatically like they do on my phone, I always had to manually start them by clicking on the white play icon in the centre of them, but it's like that on Firefox 65 on Windows 10 as well, so I guess that's a "feature" of the desktop browser version of Instagram.
Very annoying, I wonder if there is a workaround for this like there is with Facebook, where the HTML videos do work if you have the Primetime plugin installed.
:dubbio:

Link to post
Share on other sites
11 hours ago, FranceBB said:

it loads and plays videos on Palemoon.

I assume you mean @roytam1's New Moon, or maybe you're testing on Win 7 - anyhow, in compatibility mode, New/Pale Moon both spoof FF 60.9.

25 minutes ago, Dave-H said:

Instagram presumably changed something yesterday to cause this?
The videos were working fine for me up until then.

Have you tried setting general.useragent.override to "Mozilla/5.0 (Windows NT 6.1; rv:60.9) Gecko/20100101 Firefox/60.9"?

Link to post
Share on other sites

Just tried changing the user agent, but absolutely no difference I'm afraid.
:no:
Facebook videos still seem fine with -
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
Should I change that to the later one?
:dubbio:

Addition: I've just tried with Google Chrome 49, and Otter, and the Instagram videos still work fine there!
Very strange, as Google Chrome 49 is far more out of date than Firefox 52ESR!
:lol:

Edited by Dave-H
Addition
Link to post
Share on other sites
4 hours ago, Mathwiz said:

I assume you mean @roytam1's New Moon, or maybe you're testing on Win 7 - anyhow, in compatibility mode, New/Pale Moon both spoof FF 60.9.

Have you tried setting general.useragent.override to "Mozilla/5.0 (Windows NT 6.1; rv:60.9) Gecko/20100101 Firefox/60.9"?

Yes, I mean New Moon by roytam1. I should have specified that.

I didn't change the user agent on Firefox 52.9.1 ESR. I did, however, spoofed my Chromium 54 as 74.0.3706.7 to no avail. (I do it every time I use Chromium).

"C:\Programs\Chrome\chrome.exe" --user-agent="Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3706.7 Safari/537.36"

 

Quote

Addition: I've just tried with Google Chrome 49, and Otter, and the Instagram videos still work fine there!
Very strange, as Google Chrome 49 is far more out of date than Firefox 52ESR!

That's weird. You are telling me that you don't have any issues with Chrome 49 but I can't even load it with Chromium 54?

Link to post
Share on other sites

Yes, my normal installation of Google Chrome 49 (the last that works on XP of course) displays the Instagram videos fine, as it always did!
Even more strangely, if I look at the Instagram "Page Info" on the right click in Firefox 52, on the media tab the videos are still listed there, and if I click on them they appear in the preview pane below, and can even be played there.
They just no longer appear on the actual Instagram pages!
This is very strange indeed, as they obviously aren't actually blocked, they are just not displaying any more on the pages as they should do.
:dubbio:

Link to post
Share on other sites

Thanks, that's very interesting as I was having some problems accessing Instagram earlier on today intermittently, and that's probably why.
It doesn't explain the problems with the videos displaying though, as they have carried on working in other browsers, just not on Firefox!
:)

Link to post
Share on other sites
14 hours ago, Mathwiz said:

I wouldn't think an outage would affect one browser but not another on the same PC. Appears it's not the user agent either.

@FranceBB, I assumed you tested with NM 28. Was that assumption correct?

Yes, absolutely. 28.5.0a1.

Link to post
Share on other sites

Also works in Serpent 52, so probably not Javascript either. I don't think the PM team made any changes to Javascript since they forked FF ESR 52. (Unfortunately Instagram's pages are just an indecipherable mass/mess of Javascript.)

Video appears to just be an ordinary .mp4 file, so you'd think the Primetime module would work. Anyone know the MIME type of these Instagram videos?

I suppose one way to debug the problem would be to go back to @roytam1's first build of NM 28. If it doesn't work there, do a sort of "binary search" until we figure out where it starts working again, then see what was changed in that build. Sounds really tedious though.

Edit: I've narrowed it down; NM 28 from July 14 shows the same problem as FF ESR 52; NM 28 from July 21 onward works. (Both 7/14 and 7/21 were beta versions of NM 28.) Here's a link to the 7/21 version in @roytam1's blog: one of those changes must have fixed it. https://rtfreesoft.blogspot.com/2018/07/weekly-browser-binaries-20180721.html

Edited by Mathwiz
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...