Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


ruthan

[SOLVED] Win98 short annoying freeze every 20-30 second, very bad for gaming, how to fix it?

Recommended Posts

Hello,
im have know nice Unraid Win98 SE machine with

Geforce 7950GT passthrough and
1 core from Core i7 5960X
512 MB
very cheap USB sound card - could be source of issue but its
all paches instaled even official update 2007
CPU i its powerful enough, problem is that i have in every game which i have tested (Quake 3,Unreal Tournament 99 etc) short freeze every 20-30s, i had similar issue with Windows 98 physical machine.
Question is how to debug it, its this simply Windows 98 architecture issue or how to fix?

  In other Virtualized OS on same HW, i have such issue even in much more demanding games like Skyrim.

Edited by LoneCrusader

Share this post


Link to post
Share on other sites

12 hours ago, ABCDEFG said:

Enable DMA and install SP

These relinks, what is lastest version? DMA for which device? I already have - some unofficial SP - Auto-Patcher_for_Win98se_June2007sp2_Full.exe - its ok, compatible, better or what?

Share this post


Link to post
Share on other sites

So i have updated to SP3 3.5.2 and its fixed, so it means that Windows 98 has from design broken not stable framerate? I dont remember that from old times, but i never had highend hardware.

  What is know biggest save ammount of Ram? Make sense install KernelEX too (from gaming stability point of view). 

Edited by ruthan

Share this post


Link to post
Share on other sites
On 7/12/2017 at 8:59 PM, ruthan said:

so it means that Windows 98 has from design broken not stable framerate?

No!

For Win98SE DMA is disabled by default, but when you install drivers for motherboard usually it will offer an option to enable DMA automatically.

If DMA is not enabled it causes stuttering in games and other slowdowns.

In Win95 and Win98 First Edition there is no such problems.

Share this post


Link to post
Share on other sites

Why DMA was disabled for Win9x? It was advertised in Dos Age as big improvement and Dos expansion cards used it heavily. 

Share this post


Link to post
Share on other sites

Apparently enough controllers did not work properly, so they turned DMA off by default.
When you turn it on, a warning is displayed saying that turning DMA on may cause problems.

Share this post


Link to post
Share on other sites

try to disable audio to your games and unplug the usb audio device just to eliminate the sound device issue. try with dma on and off. also see if multiple device are sharing the same irq. i had the same problem as you and the problem was diferent device share the same irq the so called interupt conflict a fix from @rloewwas needed and the issue ends.

Share this post


Link to post
Share on other sites
1 hour ago, truemaster said:

i had the same problem as you and the problem was diferent device share the same irq the so called interupt conflict

Interrupt conflicts on Virtual Machine?

Games without sound?

Commercial Fixes?

Really?

:lol:

Did you even read what the man who ask the question said? ->

On 7/12/2017 at 8:59 PM, ruthan said:

So i have updated to SP3 3.5.2 and its fixed...

Edited by ABCDEFG

Share this post


Link to post
Share on other sites

I was getting the same sort of issue and it was annoying the heck out of me! I'd be using the computer and every so often the computer would soft-lock with the hard drive light illuminated. Even the mouse pointer wouldn't move. Then it would "catch up" and start working again. But it did this with two different computers so I figured it couldn't be the hardware. Low and behold, DMA was unchecked. I checked it and rebooted and now the problem seems to have gone away. Now it's not as much of a headache to use anymore!

Share this post


Link to post
Share on other sites

Does anyone know if Auto-Patcher or USP3 enable DMA? If Auto-Patcher doesn't and USP3 does, enabling DMA might very well have been the actual solution.

In my experience, DMA in Windows often works best when DMA in BIOS is disabled.

Title should be prefixed with "[Solved] ".

Share this post


Link to post
Share on other sites
Quote

Does anyone know if Auto-Patcher or USP3 enable DMA? If Auto-Patcher doesn't and USP3 does, enabling DMA might very well have been the actual solution.

USP3 - check box, for installation or noisntallation of DMA IDE patch.

Share this post


Link to post
Share on other sites

Was the checkbox enabled by default or did you have to check it?

Share this post


Link to post
Share on other sites
45 minutes ago, jumper said:

Was the checkbox enabled by default or did you have to check it?
 

Nothing is checked by default. You get to choose what to install. Its 42 options and none are checked.

Edited by PROBLEMCHYLD
  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...