Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Windows/Microsoft Update Not Working on Windows 2000/XP/2003


MrMaguire
 Share

Recommended Posts

i reformatted my harddrive around march 3rd/4th and ran into the problem with the "microsoft update" website, again, when i tried to install the windows-updates..

 

several other people also noticed the problem with the "microsoft update" website when they tried to install windows-updates this past (march) windows update-tuesday..

 

replacing the "muweb.dll" file, version 7.6.7600.257, with version 7.6.7600.256, resolved the problem..

Edited by redwolfe_98
Link to comment
Share on other sites


Is there any potential problem with just keeping the 7.6.7600.256 version of muweb.dll installed?

I rolled back to that version to fix the MU site when it first failed last November, but when it was apparently fixed at the other end I put the original version back.

Now  it's failed again I've had to revert to the older version again.

I'm thinking to just leave it like that now!

:)

Link to comment
Share on other sites

I will dare to guess that 2000/XP/2003 users would be not only unaffected but also pretty much indifferent by the troubles a Windows 7/Server 2008 update may cause .... :whistle:

http://support.microsoft.com/kb/3033929/en-us

 

Article ID: 3033929 - Last Review: March 10, 2015 - Revision: 1.0

Applies to

Windows Server 2008 R2 Service Pack 1, when used with:

Windows Server 2008 R2 Datacenter

Windows Server 2008 R2 Enterprise

Windows Server 2008 R2 Standard

Windows Web Server 2008 R2

Windows Server 2008 R2 Foundation

Windows 7 Service Pack 1, when used with:

Windows 7 Ultimate

Windows 7 Enterprise

Windows 7 Professional

Windows 7 Home Premium

Windows 7 Home Basic

Windows 7 Starter

 

 

jaclaz

Link to comment
Share on other sites

My XP SP3 system (x86) with the POS registry change is having no problem with the KB3033395 update. It installed fine, shows up in my update history on Windows Update and does not keep showing up again and again on Windows Update to be reinstalled.

This makes 11 months of of POS 2009 updates (May 2014 patch Tuesday through March 2015 patch Tuesday) applied to my XP system with no problems (except of course for the well known font corruption from the Feb 2015 KB patch).

Link to comment
Share on other sites

  • 2 weeks later...

Good news!

So, should I replace muweb.dll with the "right" version again, or leave it as it is with the earlier version which will hopefully be insurance against future failures?

Any security implications leaving the older version?

:)

Link to comment
Share on other sites

Is there any potential problem with just keeping the 7.6.7600.256 version of muweb.dll installed?

 

None at all. I'm keeping it in place, too. And keep a copy of v. 257 handy, just in case it becomes needed again, of course. :D

Link to comment
Share on other sites

  • 5 months later...

I'm experiencing a curious defect with my XP pro SP3 (with the "POSready hack applied) :

automatic update notification & OS driven updates work, but Internet Explorer has become

unable to browse to the online sites, Windows Update (resp. Microsoft Update).

More details : until nov, 2014, I used to have automatic updates /de/selected, and visited the online

update site periodically (using IE6) to pick and install my updates.

For some reason then I tired and neglected to check for updates ...until recently.

When I got to try again, /something/ had changed (at Microsoft, or here, or both)

that it had become /impossible/ to access the online update sites using the browser : keeps redirecting

to an error page (kb2497281) which does not help solving the particular instance !

The KB advised installing IE8, which I did without changing anything to the issue : the Windows update

links (from IE or Start Menu) untiringly redirect the browser to that same KB error page !

The good news is, after much hair pulling, I installed /automatic/ updates (well, semi-automatic : notify but

let me select what to download) and, to my surprise, this WORKS ! I get a nice yellow shiel and am able to review,

select and install my updates. :=)

Yet, I'd like to sort out the problem with it being impossible to visit (browse) Windows update !

I can confim I have the lastest components of the updater.

Sorry I /can't/ remember whether I was opted in to "Microsoft update" versus "Windows update"

before the problem started. Actually, could it be part of the problem ? /maybe/ I opted for

Windows update the last time I used the web updating site (november 2014).

Any ideas ?

Edited by Ninho
Link to comment
Share on other sites

I'm not really undertanding you. Let's clarify something right away -

wuweb.dll - (WU) Windows Update = Windows Updates Only

muweb.dll - (MU) Microsoft Update = Windows Update + Microsoft Non-Windows Updates (e.g. MS-Office)

The second is where you would Opt-In, which is *supposed* to install the ActiveX (muweb.dll).

 

Have you read this whole thread?

What version of MUWEB.DLL / WUWEB.DLL do you have?

You can determine if you have them "registered" by -

1 - Start Internet Explorer

2 - Go to "Tools->Manage Add-ons" and change from "Addons Currently.." to allow ALL listed.

3 - Scroll down to find "MU..." listed and (possible) "WU..."

Remember the difference between the two.

 

Let us know after you've read the entire thread.

Link to comment
Share on other sites

Hi Submix8c, and thanks for chiming in !

Yes, I had read - but probably dot digested - the whole thread ,=)

I have /both/ DLL files sitting in the system32 folder, muweb and wuweb,

both reporting version 7.6.7600.257.

Internet explorer add-on management, Toolbars and extensions, Show All...

is showing MUWebControlClass, status : enabled.

It is /not/ displayed among "currently loaded" extensions however.

Does it make sense ? Please kindly suggest what I should try next !

Could it be the wuweb.dll is in need of a quick registerDLL32 ?

Edited by Ninho
Link to comment
Share on other sites

v2.57 of MU is (probably) the culprit, as has been stated in this thread. You'll need to find MU v2.56 (somewhere) to "get back to" a good starting point. You're "stuck" in MU and can't get back to (basic) WU.

 

See http://xdot.tk/

Note: there is a CABARC problem in the script (can't find it).

See this for "fix".

http://www.msfn.org/board/topic/174350-udc-not-connecting-to-microsoft-site/#entry1106826

Basically, you can "rip out" everything but the WUA creation portion and you'll get the v2.56 of WU.

 

I'm a bit foggy on all of this, so here's an Attached Text note of a bunch of info I had saved.

7.6.76000.256_instructions.txt

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...