Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Tihiy

Revolutions Pack 9.7

Recommended Posts

AkelPad is my default text editor on Windows 98. I think it has best functionality/size ratio (with some plugins, of course). I never had problems with it and RP, may be I just never used the problem plugin.

Share this post


Link to post
Share on other sites

Installation

Latest version is here: http://tihiy.net/files/RP9.exe

Previous version is here: http://tihiy.net/files/RP9.0.exe

Revolutions Pack 9 is compatible with all system updates. I would recommend Unofficial Service Pack' date=' 98SE2ME and IE6.

Revolutions Pack 9 may require updating system files in order to use all features. Installer will point you to this page. But it is broken.

Download required updates from here: [b']http://tihiy.net/files/RP9Updates.exe

Tried RP967, and now have a huge problem with the taskbar, and just find no way to get it unfixed again :-(

My system is a german win98se, some updates over the years, and KernelEx4.5RC installed.

So first I installed the RP9.exe, trying to get cleartype (and hoping RP9 might possibly also fix some icon problem in another program, but didn't). It didn't help for cleartype either. Now it looked like my quickstart icons were a bit cut at the bottom, so I tried pulling up a bit the taskbar to get more space. As usual, the quickstart bar was now full-width above the "windows"-bar (no idea how that's all called correctly). That's normal, but not normal that I couldn't move those bars around anymore, side by side! Whether the menu was set to "locked" or "unlocked", they stayed firmly locked.

So I decided to try also those "required updates" from above. Guess that's where my trouble started. After a few restarts due to crashes, can't remember if that was only after or also before the "system" updates, the ClearType suddenly worked! Unfortunately that seems to disable the bold text for "user-defined" settings in the about:config page of my gecko browser, so that was a killer for me.

The even bigger killer: The taskbar still was messed and locked, with the quickstart icons all over the screen width!

So no go, decided to uninstall RP9.

That seemed to work, but no idea if that cured also the additional "system updates"? Guess probably not...

Problem is now: The taskbar still remains locked, and doesn't even have the "lock" menu any more - how to fix that, please...?

Here are some screenshots, that I first took planning to report that text style prob in about:config, and then the taskbar prob too, didn't think at first this would turn out so unsolvable! Noticed only afterwards that RP9 had replaced my german "lock" menu with an english one. And now there's none at all anymore.

http://user.xthost.info/siria/windows/revpack9/RevPack1__CantMoveTaskbars__ClearTypeNoBoldInAboutConfig_tx2.png

http://user.xthost.info/siria/windows/revpack9/RevPack2__NoClearType__BoldWorks_tx.png

http://user.xthost.info/siria/windows/revpack9/RevPack3__AfterUninstall_TaskbarsStillFixed__NoUnlockMenu_tx.png

http://user.xthost.info/siria/windows/revpack9/RevPack4__AfterUninstall_TaskbarsStillFixed__EvenInSafeMode_tx.png

Yeah I know, should have done a system backup or at least the registry!! Sigh. But never enough time and ten other reasons, and definitely never suspected my last registry backup is already a whole year old!! :shock:

Now I'm just assuming/hoping that RP9 uninstalled okay but perhaps the system updates may still be there and cause probs. So I unzipped that second exe and looked which files are in it, then restored comctl32.dll and dibeng.dll from an ancient system backup. gdiplus.dll I had not overwritten anyway, when asked at the installation, because my own version was younger. ctras.dll I just removed from the system folder and deleted that MS-ebook entry in the registry. stopsfp was nowhere to be found, so guess that's okay.

Any idea how to fix???

post-259287-5169_thumb.png

Edited by siria

Share this post


Link to post
Share on other sites

I guess reinstalling IE6 may fix your missing "lock taskbar" menu item.

Share this post


Link to post
Share on other sites

I never updated to IE6, only to 5.5, and the taskbar always worked so far...

Share this post


Link to post
Share on other sites

I'm very sorry to heard about this. I see that RP9 has serious problems due to bad documentation.

Now how to fix this? I guess by installing IE6; i don't know how taskbar works with IE5.5.

You can also try to delete all taskbar settings. To do that, delete "Taskbar" & "Toolbars" values from

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Streams\Desktop. Make sure they're not recreated and hard-restart explorer.

Share this post


Link to post
Share on other sites

Thanks for helping! :-)

So what I did now:

Started regedit, deleted that key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Streams\Desktop

and right afterwards imported that same chapter from my 1-year old backup, then restarted.

Didn't help yet, nothing changed, but very well possible that I'm doing something wrong?

And there seem to be many keys that appear double or even triple in different branches of the registry, perhaps overwriting one of the others might help...? Perhaps I should also mention that this box has always been configured as 'single-user' version, this 'multi-user' account stuff never activated at all. No idea if that has any influence either.

But I'd really hate having to install IE6, too afraid that this would mess hundred times more than it might cure :-/

Share this post


Link to post
Share on other sites

Don't worry about installing IE6 (SP1), it's painless. I finally upgraded to it only a couple of months ago because I needed it to run foobar2000 0.9 series properly (in conjunction with KernelEx) and this fixed the missing "lock taskbar" and "lock toolbars" which I was also suffering from but did not really care about. Actually I don't even think I ever had those with the IE 5.5 shell.

Share this post


Link to post
Share on other sites

Oops... you made me realize something, and verified it:

By default win98 doesn't have any (un)lock menu, because it actually doesn't have any lock function for the toolbars! Had not realized that before, since I'm (un)locking browser toolbars all the time here, and at the job am working on XP. So that menu entry hasn't really vanished, it really wasn't there before ;-) But RP had added it, in english, it's just that clicking it had no function on the taskbar that RP had suddenly locked.

The toolbars in IE5.5 are still unlocked, seems only to affect the taskbar stuff...

Edited by siria

Share this post


Link to post
Share on other sites

Hello!

I spent some time making a theme for RP9. It's called Whistler 98. I hope you like it ;)

Screenshot:

th_Whistler98screenshot.png

(click for larger image)

Download: http://www.mediafire.com/?ud1md13rxrf44y8

Extract to %windir%\resources\themes and run the .reg file.

I also made a start menu banner: http://www.mediafire.com/?0yee23nenjfdm24

For this you'll need a resource editor, such as resource hacker. Make a copy of Explorer.exe, and edit it with resource hacker. Find the bitmap 157 and replace it. Save the file and boot into DOS. Replace the original explorer.exe. Reboot.

Share this post


Link to post
Share on other sites

Hello!

I spent some time making a theme for RP9. It's called Whistler 98. I hope you like it ;)

Hi Svenne,

nice work :thumbup

but not very different from the original 'Watercolor Emico: Ergo Blue' of Tihiy.

Share this post


Link to post
Share on other sites

Yes, it is; mainly because Watercolor Emico is based on the original Whistler theme. My theme is sort of a mix between them.

Share this post


Link to post
Share on other sites

Yes, it is; mainly because Watercolor Emico is based on the original Whistler theme. My theme is sort of a mix between them.

Anyway, it is definitely nice. :D

Share this post


Link to post
Share on other sites

Hi Tihiy,

Feels like this project is the best thing happened to Win98 after onofficial Win98 SP was released. I have tested RP9 for two days and after installing IE6 and the newest RP, things are working fine. So far, only a couple of issues:

- Updating icons to XP/Vista-style, only "My Documents"-icon will be updated, but "My Computer" and "Network Area" icons will stay old. I guess this doesn't happen with English version of Win98. (I have Finnish-version.) (Of course they can be manually updated, but of course the program should update them all automatically after changing.)

- "RP9-Icons"-package gives the following error during installation: "Registry Editor: C:\Systemicons.reg: cannot be imported. System may have a disk failure or file system error." Icons will be unpacked, but themes cannot be activated.

Thanks for good work.

Edited by t6ti00

Share this post


Link to post
Share on other sites

Yes, it is; mainly because Watercolor Emico is based on the original Whistler theme. My theme is sort of a mix between them.

Anyway, it is definitely nice. :D

Thanks :)

I released an updated version. It fixes some issues with the caption buttons.

http://www.mediafire.com/?ud1md13rxrf44y8

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...