Jump to content

Revolutions Pack 9.7

Recommended Posts


This happens when you do a right click on a titlebar of any windows. It appears momentairly for the most part. It happened on 2 different PCs, only things in common between the 2 are same OS setup and ATI video card.

Link to comment
Share on other sites

A little compilation of some small bugs I still have:

Some icons have black edges or seem to be 16bit or are pale / fade.

I'm very contented about RP9.6.5 - great software!

OS Win ME KEX 4.5 RC1 themes: Win 7 superbar, Vista, 32 bit

     effects: only smooth edges of screen fonts






Edited by schwups
Link to comment
Share on other sites

it's not so hard to do it yourself!

For Crystal dlb Blue, open the file 'TASKBANDBUTTON.bmp' in Paint (for instance) and save it in 24-Bit (it is in 256 colors) and you will get back transparency.


For Ubuntu Human, you delete all the part [scrollArrows] in the 'skin.ini'.

It's not the scroll arrows, but the thumb itself which is not showing up.

Link to comment
Share on other sites

For Ubuntu Human, you delete all the part [scrollArrows] in the 'skin.ini'.

It's not the scroll arrows, but the thumb itself which is not showing up.

I'm not sure to understand.

Do you mean the thumb in the scrollbar?

The scrollbars are defectives in this theme because a few sections are lacking.

You repair them by writing all the missing sections & bitmaps (including thumbs),

OR simply delete the lonely section referring to the scrollbars (what I did) and you will get back the default scrollbars.

They are not eye candy like a skinned scrollbar, but it works. :D

Link to comment
Share on other sites

You know im loving this, got my Dell 2400 installed with Windows ME for some games that have issues with XP, eating CPU to 100% but only in 2k and XP lol. But I have a second desktop that im actully tring to sell, it uses 2k, mainly because I'm selling it and the key is already on the case. But is there a similar thing out there for 2k, i like the ease of use with this on my ME/XP box and just wondering if anyone made something simiar for 2k

Also this isnt to fool anyone into thinking its more than 2k, its advertised as 2k, its just ive noticed people are attracted to shiny

Edited by candle86
Link to comment
Share on other sites

Hi Tihiy,

I have a minimal Windows 98 installed (Win98 FE Lite, IE4), because

I do a lot of video conversion with mencoder/ffmpeg to create Flash

movies. While viewing my videos, I have to stick to IE4, because IE5

and higher suck away a lot of CPU power.

Although I have only IE4 installed, RP9 works beautifully (see

screenshot). I circled the diffences with RP9 on a IE6 system.

The drawback is that I have to install IE5 first, then install RP9, and

revert to IE4 again. Otherwise I get an error during RP9 installation

because the z7 module in your installer needs BROWSEUI.DLL, wich is

part of IE5.

Why do you recommend to have IE6 installed anyway? If I want to view

"modern" websites, I would have to install IE8. But I use FireFox for

that. Windows itself does not need BROWSEUI.DLL. It's only for IE5 and

up, because M$ had to separate the browser from the operating system.



Link to comment
Share on other sites

Why do you recommend to have IE6 installed anyway?
1) Latest comctl32.dll.

2) Updates for taskbar code. Also i'm in love with browseui.dll.

1) The latest comctl32.dll is included in your RP9Updates pack

2) Ah.

Link to comment
Share on other sites

  • 2 weeks later...

I've been using 98SE in VMware and was inspired to check out Revolution Pack 9.6.5 by viewing the youtube techsnap 10 years later videos.

There are problems as explorer.exe crashes on startup. I can ctrl-alt-insert (VMware's way of ctrl-alt-delete) and run explorer.exe and systray.exe to get the desktop up and functional. It seems however, that most of my startup processes and systray icons and programs aren't able to startup.

The ones not running from the systray are openofficetraystarter, ClamWin, ClamSentinel, the Roland VSC-MP1 tray icon and the afterdarktraystarter. I also don't see the rest of the usual startup processes in the ctrl-alt-delete task manager panel running, with only the Roland VSC-MP1 adding itself after running systray.exe.

I'm wondering whether the 16 bit calls made by the AfterDark Screensaver stuff is the chief culprit in this or if it is something else that is wrong.

I've tried with and without KernelEx installed and that hasn't made a difference. The system was fully updated with the Gape latest Service Pack, the Maximus-Decim Internet Explorer and MDAC packs, fully autopatched by AutoPatcher, 98SE2ME option 2, and 98MP10.

I've attempted experiments of restoring the original explorer.exe, user.exe and user32.dll (with system file checker) and that didn't fix, so I've applied EXPLOR98.exe and the latest unofficial 891711 updates to restore the 256 icon colors and the patched user stuff and actually like those 98SE versions better than the 98SE2ME versions as I get the Windows shutdown bitmaps again. Installing RevolutionPack before or after any combination of these files still results in the explorer.exe crash and processes not starting up problems.

The Windows 7 skin crashes that rev8.dll and the system is then totally unresponsive, and the XP skin does apply but the same problem results on startup with the additional problem that restarting explorer.exe DOES NOT work as it immediately crashes and all I can do is use VMware to end the machine, reboot into safe mode, and uninstall Revolution Pack. So any skin does not allow explorer.exe to be manually restarted, but using the default 98SE skin allows use of the computer but without my startup processes and the rest of the usual stuff running in the background.

I suppose I could try installing 98SE2ME option 3 (the Windows Me explorer shell). That's something I've never played with in all the years so it could be interesting anyway. But I'm still not sure whether that alleviates the problems with stuff that (perhaps?) Revolution Pack might not be compatible with, like the ClamAV stuff and the ancient AfterDark Screensaver 3.2XP packages.

All the GDIPlus and ole update things have already been applied through those service packs and autopatcher updates. The dibeng.dll is the version installed by RevolutionPack and the one it replaced that was from 98SE2ME is gone.

Not sure why it's not working. Uninstalling RevolutionsPack restores everything to working order, so at least that works nicely so I can continue to experiment if there are any suggestions I might try.

Link to comment
Share on other sites

Well that's a nice story, but i need at least some details about crashes (module, crashing address).

NOTE: tihiy.ahanix.org is now terminated as i abused good pal Ahanix too much. RP9 is quite popular it seems!

I promise to restore some proper hosting asap, meanwhile you can download them from another Ahanix hosting.

Really what a kind man he is. ;)

Link to comment
Share on other sites

Okay! I'll go back in and install it again, this time taking note of what the details say in Windows's explorer.exe will now be closed message. I'll post back with the information. Something must be awry in this setup since no one else appears to have reported similar.

Link to comment
Share on other sites

EXPLORER caused an invalid page fault in

module RP8.DLL at 016f:bf9b676f.

EAX=0000c02a CS=016f EIP=bf9b676f EFLGS=00010246

EBX=0000c02a SS=0177 ESP=00d2fb50 EBP=00d2fb58

ECX=00000000 DS=0177 ESI=00000000 FS=2f87

EDX=00002074 ES=0177 EDI=8353a1d0 GS=2f17

Bytes at CS:EIP:

8b 17 85 d2 76 10 8d 77 08 66 39 06 74 0e 41 83

Stack dump:

00d2fb7c 00000000 00d2fb74 bf9b69d9 829938cc

0000c02a 00d2fb7c 00008be2 00d2fbbe 00d2fb8c

bff7363b 000208cc 0000c02a 8bbc2f9f 00000177


That's from the details section of the Windows Explorer.exe will now be closed box. Since I haven't applied a theme yet, on first run after using Taskmgr to run explorer.exe and systray.exe a few of my systray icons show up as the taskbar reappears but the ones that don't show. according to task manager, aren't even running. If I apply a theme... oh well I took too long because vmwareservice crashed and I had to shutdown before even that wouldn't let me.

But I think it was a similar crash in RP8.dll that happens if I apply a theme. Again, the XP theme will apply and after reboot be there (but explorer.exe crashes the same way and crashes again if I restart explorer.exe). And the Win7 themes, although changing things to that theme, don't allow continuing or even allow ctrl-alt-insert to bring up the task manager and I have to reset VMware instead.

Does that help?

Link to comment
Share on other sites

Sadly the installation of 98SE2ME Option 3, although that works perfectly and I'm getting the snazzier Windows Me themed stuff, had no effect on the explorer.exe crash when Revolution Pack is present.

As an aside, I reinstalled KernelEx and it's amazing how much stuff I've been able to upgrade that works great! Hope that the printing problem in Firefox 6 as well as the latest Java problem it has in Firefox (works fine in Internet Explorer) get solved.

I've upgraded Firefox, Thunderbird, Flash, Java, go-oo.org all to the latest versions.

I know there's got to be something running here or some file mis-match to upset Revolution Pack. I don't know how to find out which of the thousands of system files or programs is the bottleneck. Explorer looks like it crashes before anything is loaded into the system tray if that helps at all.

Link to comment
Share on other sites

I'm unable to find the source of your problem. It is caused by some 16-bit driver loading before RP or program which has undocumented hacks. Try to narrow it down as well as create drwatson crash log.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...