Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

All Activity

This stream auto-updates     

  1. Today
  2. Could be, but as Windows 7, and certainly Windows 8.1, are still supposedly fully supported systems, why do they not have the necessary certificates for IE11 to display all current websites? I hadn't heard anywhere that IE11 is not now considered to be a current supported browser, and it does still work on Windows 10!
  3. Sorry I skimmed too quickly that I did not notice your reversion line! As to video playing, there is one site that do have problems, which I have filed a bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=1414792 ,but firefox devs think it's website's fault. Edit: I rechecked the link in the bug and surprisingly find Serpent has fixed the bug! The site works now. Thanks roytam!
  4. Part IV: Windows 98se on Grub4Dos Memdrive with full USB 2.0 access In this part, after booting Windows on the Memdrive, there will be full access to the USB-bootdrive – mounted as regular USB 2.0. After renaming USB.IN_ back to USB.INF, installation of NUSB 3.3, and adding mbrint13.sys ; Grub4dos to IOS.INI [safelist], the Memdrive should be booted first to “Command prompt only” with changed MENU.LST: ------------------------------ MENU.LST ------------------------------ # comments always BEFORE a command title Boot IO.SYS chainloader (hd0)+1 rootnoverify (hd0) title Win98se on Memdrive with USB 2.0 access # only one USB-drive allowed during boot errorcheck off # "usb --init" is not ment to be used on an USB-hub (Grub4Dos Readme) usb --init # for one “real” floppie-drive; if needed map (fd0) (fd1) map (fd1) (fd0) # USB-bootdrive (hd0)should be “outmapped” by Memdrive map --mem (hd0,0)+1 (hd0) map --hook # without second mapping 3½” floppie can be seen as 5¼” by Explorer; if needed map (fd1) (fd0) map (fd0) (fd1) map --rehook # mandatory, without changed UUID “open files blue screen” while mounting USB boot-partition # USB boot-partition not visible from “Command prompt only” anymore uuid --write (hd0,0) B00D-1D20 vol --write (hd0,0) U20MEMDRIVE # not critical, for other possibilities see Jaclaz 09-22-2017: # https://msfn.org/board/topic/177102-solved-as-is-windows-95-issues-with-grub4dos/?do=findComment&comment=1145058 root (hd0,0) chainloader /io.sys title Reboot IO.SYS on Memdrive uuid --write (hd0,0) B01D-1D20 vol --write (hd0,0) R20MEMDRIVE # critical, otherwise Memdrive can be rebooted only once (experimental) root (hd0,0) chainloader /io.sys ------------------------------ After booting Windows on the Memdrive, all USB-Controllers and already attached USB-Devices can be installed in Device Manager. If not there yet: SYSTRAY can be started from START --> RUN. All changes can be copied “down” to the Windows USB boot-partition. It should be possible to remove the USB 2.0-bootdrive, or insert it again, in the normal way. Without Memdrive, Windows can only be started in Normal Mode after disabling USB-Controllers (in Safe mode, or with a REG-file from “Command prompt only” before booting Windows). See attached REG-file as example (machine-specific). USBCTLNO.REG To enable USB-controllers again, following REG-file has to be imported in the Registry before booting Windows on the Memdrive. Example in attached Reg-file (machine-specific). USBCTLYS.REG Importing REG-files can be automated with attached batch-file (together with batch-commands for one logical drive already). USB20.BAT BTW: After booting Windows on the Memdrive, it’s important - according to my experience - to wait ALWAYS before starting any program until Mouse’ Hour-Glass has been vanished. Also it’s a good habit to run Scandisk before copying anything from the Memdrive back to the USB boot-partition. BTW2: Max 400-500MB, more space with Drivespace and/or logical partition (fixed drive-letter for logical partition on Memdrive has to be obtained with Device Manager). BTW3: If no CD/DVD-drive available, Windows 98se files should be copied to USB-bootdrive before. Other possibility: at least all files mentioned in in USB.INF, MSMOUSE.INF and KEYBOARD.INF has to be copied to their destination first. Afterwards they can be skipped ("missing files" installation-dialog). USB-Mouse/Keyboard is not available during installation of USB-Controllers (one PS/2 Input-Device should be available during install).
  5. I've read around here that most browsers are using the SSL/TLS capabilities of the system, except Mozilla Firefox family, which has that important certificate stuff embedded itself. So thought the site may just require some very modern cert. But interesting then that SRWare Iron runs too. If certs not culprit, perhaps different settings between the IE11 profiles, or some other OS module required?
  6. Yesterday
  7. The following ones from your screenshot are added by Aero Glass GUI tool: BlurDeviation ColorizationColorBalanceInactive GlassOpacity
  8. Got a corrupt Reycle Bin after some crazy file management. Selecting Empty Recycle Bin would not fully empty the bin or reset the desktop icon. This was associated with an error popup. Deleting more files and re-emptying the bin did not work. Neither did emptying the bin from Safe Mode or running ScanDisk. The solution was simple, no reboot needed. Run COMMAND.COM and CD C:\RECLYCLED. Run DIR to check for rogue files or directories. Switches like DIR /AH (attribute hidden) may be useful, not required in my case. Run applicable DEL or DELTREE commands to purge the bin without mercy using the fiery power of DOS.
  9. Hi deomsh and Goodmaneuver. Thank-you for your responses, there's lots of crossover in these threads. Just wondering deomsh why you settled on this web proxy, any advantages? The ones i've tried, the biggest drawback is an ability to download even smallish software files (<20 MB). From the old RetroZilla thread, my understanding is rn10950 is no longer actively working on RetroZilla. IIRC roytam1 has also moved on to Windows XP browser development.
  10. Microsoft's documentation on selecting a device in Direct3D 9 The 2nd step of needed tasks for a Direct3D application running in a window: I haven't seen the highlighted effect on newer systems (Win7+, haven't tested Vista), but on XP, even running Serpent browser on the second screen with a video playing made things so bad that even the mouse cursor started lagging; that and the general choppiness. Hacking xul.dll to make it select a different adapter restores the performance on the second screen, but that only helps if one prefers to have it on the particular screen exclusively. Similar with Direct3D games running in a window, turn on the FPS display or some 3rd party overlay displaying it if game doesn't have its own. When on main screen, everything is fine, move it to another screen; bam, FPS count drops, CPU usage goes up.
  11. Thanks very much @bphlpt, that confirms what I found. I don't use IE now either, but this actually came up on a friend's Windows 7 laptop, where he does still use IE11 as his browser. I was surprised to find the same problem on Windows 8.1, and even more surprised to find that the problem isn't there on Windows 10, all apparently with the same IE11. Very strange.
  12. I wasn't implying that there was anything wrong with OpenGL, but there's not much difference in the end for the end user; one party messes up and that's it. Someone compiled the runtime libraries for XP, but the actual implementation in the driver is missing. Vulkan 1.1 is out since March 2018, when no company is writing graphics drivers for XP anymore.
  13. Windows embedded Posready 2009 is installed in a real hardware, and some apps which works before now show errors. The Os is installed from the MS ISO trial, instalation minimal, All the hotfixes was applied until april 2019 via WU All netframework and Visualc++ installed the system is fast and stable but Virtualbox 5.2.x cant start a Virtual machine show a stop error. same error is present in older versions Software with inno installer refuse to install. P.e: Minitool Partition Wizard 11.5 (11.4 is ok), wondershare PDFElement 6.8.x, 7.x I learn that inno 6.x is not compatible with xp anymore, i wonder what can do, maybe has a solution for these problems other software that run excelent: Audacity 2.3.3 RC03r Potplayer 1.7.20538 Gom PLayer free Totald 1.5.8 and Mipony 3.0.5 blocking 2 IPs (ads) zd screen recorder Windows 7 USB DVD Download Tool cpu-z 1.90.1 Notepad++ 7.8.1 Telegram 1.8.15
  14. I NEVER use IE these days, but, just for you I tried it ( IE11 on Widows 7) and got a similar result to what you did, but it connected fine using SRWare Iron, a Chrome variant. IE11 indicated that I should "Turn on TLS 1.0, TLS 1.1, and TLS 1.2", but those were already turned on, and I did not pursue it further. If you can get it to work, I'll see if I can replicate it on my end. Cheers and Regards
  15. For months I've been unable to successfully install updates (see attached [heavily compressed] screenshot). They're monthly roll-ups, so they render my laptop useless when applying whilst perpetually failing (15 mins trying to install after reboot, 15 mins reverting to login screen). I've tried the Windows update troubleshooter, which says it fixes "incorrect configuration" but will say that every time to no discernible benefit. I've tried manually installing from Microsoft's catalogue. SFC finds no corruption to fix; but there's one interesting thing I've spotted (see bodged path on below image for Teams, which installed itself in mid-August), but as you'll have seen I've had consistent failures since July:- I really don't want to have to refresh my PC and lose 5 years worth of configuration, but I'm at a complete loss. I don't know if there's any log I can post that goes into further detail to help pin-point exactly why my updates are failing and what course of action I need to take (FWIW it's mostly throwing up the error code 800F0922, but occasionally I get 80246013 & 8007045B). Whether I should system restore to June and see if I can get it working or whether I should just try running the W10 installation tool that apparently still upgrades and successfully activates older Win versions.
  16. Thanks, but I'm Nightly tester since few years, I know about that I found solution, there is small entry in about:config need to flipped to enable Mozglass working again in userchrome. My Nightly Firefox have glass again since few weeks
  17. does anyone know if this browser will ever been released? @Dibya
  18. I think the readme idea would make more sense. Not everyone knows how to open a JS file.
  19. Just a handling suggestion again ;-) After reading again the install-instructions on page1, those really look a bit complicated if someone doesn't already know by himself where prefs are stored. Especially if his browser is portable or is not installed in the usual locations. As we've seen, normal users can be completely lost then, start blind guessing and land in completely wrong folders, not even aware that program and profile folders are completely different things. I keep thinking some screenshots of the file explorer would be easier... And perhaps include install instructions inside the zips, as a UOC_readme.txt? That wouldn't require to visit the forum (which may not always be possible or easy for everyone, or just too lazy) and search through long, long text to find the crucial paths. Additionally the paths could be included at the start of the js-files too... Or the readme could just say "Installation instructions also found in file.....js (right-click file and edit to read as txt) Am not quite sure what the system does if users just "open" js-files... Just as idea, in UOC_Patch_38.js something like... // UOC_Patch_38.js for Firefox 38 ESR based browsers // Developed by Looking4awayout - Version vN2I - 2019-11-16 // Forum: https://msfn.org/board/topic/178306-uoc-patch/ // //======= INSTALLATION: // Copy THIS file to your PROGRAM folder, where your browser creates DEFAULT settings: // FIREFOX: C:\Program Files\Mozilla\Firefox (contains FIREFOX.EXE) // \defaults\pref\UOC_Patch_38.js // PALEMOON: C:\Program Files\Moonchild... \palemoon (contains PALEMOON.EXE) // \defaults\pref\UOC_Patch_38.js // K-MELEON: C:\Program Files\K-Meleon\(KM-Goanna?) (contains K-MELEON.EXE) // \browser\defaults\preferences\UOC_Patch_38.js // // ATTENTION: after next browser start this will change your OWN settings in profile // //======= BACKUP your PROFILE settings first: // FIND PROFILE: // Open address "about:support", click on button or link to PROFILE FOLDER. // Copy 2 files "prefs.js" (has date of today if correct folder) and "user.js" to a safe place. // (prefs.js will be modified by THIS file after next browser start) // (user.js gets replaced completely by the 2nd UOC file "enforcer") //======= And in "Enforcer" file... //======= INSTALLATION: // FIND PROFILE: // Open address "about:support", click on button or link to PROFILE FOLDER. // BACKUP: 2 files "prefs.js" (has date of today if correct folder) and "user.js" to a safe place. // Replace "user.js" with THIS enforcer file and restart browser. //=======
  20. I just tried accessing the website of a UK restaurant chain using IE11 on Windows 7, and it would not connect, saying there was some sort of security error, which couldn't be overridden. The address is https://www.cote.co.uk I thought perhaps this was because IE11 is now becoming obsolete, especially when I tried it on my Windows 8.1 netbook too, and got the same error. However, I just tried on IE11 on Windows 10, and it worked fine! Can anyone else confirm this, and has anyone any idea why it would work on Windows 10, but not on 7 or 8,1, using apparently the same Internet Explorer version? Thanks, Dave.
  21. Yeah that's the crux, max privacy and max features are mutually exclusive. One just cannot block at the same time all sorts of privacy related functions and still have all features working, if those require some of those functions. It's a dilemma. We understand this here but unfortunately, when looking around the web, most users still don't have the slightest clue! They keep thinking they could get a set of "flawless" privacy settings, then after adding some more magical prefs are soon disappointed to discover "bugs". They keep fiddling with new settings, only to fall into another trap shortly after. Never quite understanding it's simply not possible to block lots of stuff and still get everything working at the same time. And of course by far the best privacy protection is to just block javascript completely (causing a few 'bugs' too as expected 8-) Privacy settings are such a giant subject, a separate thread wouldn't be nearly enough. At least not for the endless jungle of Mozilla prefs, IIRC current browsers have over 3000 prefs already (yikes!) Makes probably a million possible combinations... many cross-influencing each other, and additionally users have different hardware and browsers, complicating things yet more... Can't imagine there's even just 1 expert left who still understands all of this with all cross-effects too. There are already lots of projects out there trying to find at least a good compromise of permanent settings for most users, although not really possible, considering everyone has different needs too (needing stuff like facebook and gmail or not etc). But still better than nothing. Like the famous ghacks user.js, or german site privacy-handbuch.de (oh great, which now blocks old browsers too, no TLS1.2) The only real solution for this dilemma is to toggle some settings only TEMPORARILY when needed. It keeps surprising me how few people even consider doing this. Although admittedly not quite easy, it requires some knowledge what those toggles are doing. Still it's the method that works best, and one of the reasons I absolutely love K-Meleon with my long row of toggle buttons, many self-created (mainly macros Blockeria and priv3buttons). Although I can only toggle a few prefs too, among the 3000, but as mentioned, blocking javascript (completely or partly) goes a very long way towards privacy already, and blocking 3rd party iframes etc. too.
  22. @Matzwiz > Unfortunately, I don't have a system capable of building these browsers myself. > So I wrote that comment in the hope that @roytam1 will do a test build of both browsers, > and revert my changes if there are any problems. If it's only normal xml/html/js files, not CPP, you can most likely find and exchange those inside omni.ja In K-Meleon works fine, just not sure if those other/newer browsers allow changing omni.ja too or if it breaks some signature or whatever.
  23. It was in this thread https://msfn.org/board/topic/178283-how-you-really-browse-the-web-on-98me-in-2019/page/3/#comments https://github.com/rn10950/RetroZilla/releases/tag/2.2
  24. Yes on occasion with UXP, with the most recent being Fox Video. https://video.foxnews.com/playlist/featured-latest-news/ The problem for me is when the user agent is IE11 but changing it for that specific site resolves it. With Twitter I set it to the latest firefox ua and with Fox Video specifically I had to set static.foxnews.com.
  25. @blackwingcat: I apologize. "ä" - cmd problem is not a problem of exkernel. It also exists in wxp32 and 64, and also in win7. Is it a microsoft bug? I tried a workaround: Result: As you can see, all of the characters are displayed wrong. Furthermore, ">" is displayed "1>". But the result seems to be OK. I can use it to get the "Eingeschränkter Zugriff" done. Anyone knows a better solution? Greetings Joe
  26. UXP XULRunner is not used by K-Meleon(I hope I can make changes to make KM use UXP, but for now KM uses Tycho.)
  27. can't tell as they're reverted in my tree.
  1. Load more activity
  • Create New...