Jump to content

Nero v7.0.5.4


Recommended Posts

I know how to disable it, that was not my question

i know that your question was not this

i just found that on the net and i thought it would be nice to post it here for anyone who doesnt know it...

Edited by InViSibLe Gr
Link to comment
Share on other sites

I tried this method for the first time with the new Nero version and it rocks. I got Nero down to 18.6mb :thumbup

Oh dear sir, will you kindly share it (sans serial, of course)? I've been trying to get a copy of Nero down to 18MB for so long. :(

Got it down to 16.4mb :D. Import the serial before running setup.


Thanks a bunch. I'll give it a shot later on VMW. :)

Link to comment
Share on other sites

Language problem solved.

The component switches seems to be unique to each language, so you need to grab the component ID's from conf.txt. Extract this file by using winRAR to extract the original installer and look in Redist\Config.

The component ID is shown in bold below.

INCEXCFTR (B035464E) (NeroStartSmart) NeroStartSmart INCLUDE

For each component you would like to exclude add componentID=0.

As for NeroScout the component ID is not given in the above file, I found it by searching the registry and found it in NeroScout's CLSID. (The first 8 chars).

The componentID I use with the Norwegian installer is: A82BBCBD

As an example the following would install Norwegian Nero 7, with only NeroBurning ROM.

( you still need to disable nero scout with the regsvr32 /u method )

Nero- /qn /norestart SERIALNUM_USERVAL="XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX" A82BBCBD=0 B035464E=0 2FF8B816=0 57D52359=0 D773A6E2=0 6035F00C=0 53BEFA20=0 CB9D5429=0 7CE8D626=0 ED1EAF52=0 FA3A3F7B=0 716FE146=0 E38B9E06=0 82602EE0=0 7DFFCC12=072CC518F=0 E72D824A=0 C5AB9CFD=0

You are wrong ! The component ID's are not language specific , as far as I can see in your post component ID's from conf.txt Norwegian are the same with the one from my conf.txt which is English

I didn't say that the component ID's from conf.txt ARE THE UNIQUEID I'M USING IN MY BATCH FILE

Link to comment
Share on other sites

UniqueID's for Dutch language are the same as the English.. so I don't think they are language specific.

Even double checked it in the msi file under property with orca.

The ones that are all capital characters are the only property's you can pass to the MSI. The only thing related to Nero Scout was the NERO_SCOUT property wich doesn't seem to do anything :}

The rest works without a problem. so I'll stick with the reg keys to disable nero scout

Edited by Glowy
Link to comment
Share on other sites

Okey, I stand corrected. Then I really have no clue. Sometimes it works, sometimes it does not. The search continues.... /qn /norestart always work and installs in Norwegian, so I was guessing it was the switches.

Mercury how did you find the ID's? I can't seem to find any of the ID's you posted in my registry.

Edited by BoardBabe
Link to comment
Share on other sites

Okey, feels like I've tried everything! I've had nero install in Norwegian, I just can't figure out what happens, I believe now it's in the registry.

I'm using Mercury_22's method.


pleease help me out...

Link to comment
Share on other sites

Thanks, that solved it :D


For some reason "CC5AB9CFD NeroFastCDDVDBurningPlugin" will cause Nero to install in English.

If I remove "CC5AB9CFD=0" from my switches it will install in Norwegian.

I found out by looking in %temp%\nro.log\log\nsi.nrd.log.txt, after an install including the switch "CC5AB9CFD=0", that resultet in en english installation.

14:10:59 DEBUG: RefreshLngStates started
14:10:59 DEBUG: Installed Langs:;NOR;ENG;;
14:10:59 DEBUG: Language IS selected: NOR
14:10:59 DEBUG: Feature 'NeroApiLanguageTxt_NORA0FD55F1012122A0FD55F1': Condition is TRUE (CC5AB9CFD=0)
14:10:59 DEBUG: MsiSetFeatureState setting feature 'NeroApiLanguageTxt_NORA0FD55F1012122A0FD55F1' to 'REMOVED'
14:10:59 DEBUG: Language IS selected: ENG

If that is infact the NeroFastCDDVDBurningPlugin then it's very strange, but this is really what happens...

Edited by BoardBabe
Link to comment
Share on other sites

Hiya all,

hm, a thought, did anybody ask AHEAD about a silent install for Nero? Could be worth a try.... :blink:

Tried that got no reply...

but as I look at the MSI they don't understand it very wel..

It's a pretty dirty MSI.

As for now (can't see why to change) I'm using Mercury_22's method, by passing the MSI Property's through the installer (You can find these by opening the MSI with Orca, and go to the table Property)

And additionally I changed the comment Silent=2 to Silent=1 in the installer (It's an unprotected WinRar) to hide the unpacking dialog.

The Property's can possibly be added to the comment of the archive too (after Setup=setupx.exe) but I did not try that yet. that is how I installed nero 6 (just editing the comment of the archive)

Edited by Glowy
Link to comment
Share on other sites

if anyone wants to run nero with Mercury_22's way

and run the command that removes nero scout

add the attacked files to your $OEM$\$1\install\Nero Folder

nerowait.exe is to force runonce to wait for SetupX.exe to finish and NOT continue to the next prog

because after Nero- finish with the extracting runonce continues to the next prog

and does not waiting for setupx.exe to finish

i thing its better from sleep because this just wait for setup.exe to finish

and runonce will continue to the next prog only if setupx.exe process finish

you dont have to set time only add it there and add it to batch file right after the nero.exe

RegSvr32close.exe is to close the popup window that opens after the command that removes nero scout

start /wait %systemdrive%\install\Nero\Nero- /qn /norestart SERIALNUM_USERVAL="xxxxxxxxxxxxxxxxxxx" NERO_SCOUT=FALSE etc etc ...

start /wait %systemdrive%\install\Nero\nerowait.exe

regsvr32 /u "%COMMONPROGRAMFILES%\Ahead\Lib\MediaLibraryNSE.dll"

start /wait %systemdrive%\install\Nero\RegSvr32close.exe

nero.rar 226KB MD5 : 1B49E7338B0C13A6B6C2D75BF8EAB59E

Edited by InViSibLe Gr
Link to comment
Share on other sites

What command line do you use to install this file? I can't get anything to work!
You just run the exe, it's supposed to be silent.
Good try , but LOTS of errors.
What exactly? It's working for me in VMWare as well as in my unattended CD. Well use the Inno Setup then or make an installer on your own :P
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...