Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Extreme Explorer 360 Chromium 78-86 General Discussion


Recommended Posts

Posted (edited)

Now that I've blocked these sites in the hosts file...


0.0.0.0 browser.360.cn
0.0.0.0 cloud.browser.360.cn
0.0.0.0 dd.browser.360.cn
0.0.0.0 qurl.f.360.cn
0.0.0.0 chrome.360.cn
0.0.0.0 ext.chrome.360.cn
0.0.0.0 u.qurl.f.360.cn
0.0.0.0 puv.tt.browser.360.cn
0.0.0.0 p.ssl.qhimg.com
0.0.0.0 p0.ssl.qhimg.com
0.0.0.0 p1.ssl.qhimg.com
0.0.0.0 p2.ssl.qhimg.com
0.0.0.0 p3.ssl.qhimg.com
0.0.0.0 p4.ssl.qhimg.com
0.0.0.0 p5.ssl.qhimg.com
0.0.0.0 p.ssl.qhmsg.com
0.0.0.0 p0.ssl.qhmsg.com
0.0.0.0 p1.ssl.qhmsg.com
0.0.0.0 p2.ssl.qhmsg.com
0.0.0.0 p3.ssl.qhmsg.com
0.0.0.0 p4.ssl.qhmsg.com
0.0.0.0 p5.ssl.qhmsg.com

 

it tries to connect to 36.99.170.110

Something it didn't do before...

Even though it no longer tries to connect to 36.110.236.41

But nevertheless, there is much less going on as with the original version of the browser so it really is true: The russians DID remove quite a bit.

 

Edited by NoNameNeeded
Link to comment
Share on other sites


2 minutes ago, NoNameNeeded said:

it tries to connect to 36.99.170.110

Something it didn't do before...

Perhaps something in your Options -> Advanced settings?

Link to comment
Share on other sites

Posted (edited)
4 hours ago, ArcticFoxie said:

I technically only download from https://lrepacks.net/repaki-programm-dlya-interneta/182-360-extreme-explorer-amp-portable.html

But they only keep the link to the most recent.

So unless I upload my own copies downloaded from above link, then I don't know of any better place to find the "betas".

@Dixel - when you refer to your preference for one of the early betas, which build number by chance?

I have tried mostly these two betas (shown below) , and I removed the telemetry by myself . Why ? They have less chinese junk.

If you care to read , I'll explain . Do you think I have tons of spare time ? No , I don't and there are two reasons . First , I do not trust Russians and/or any Eastern block countries , including Chinese (but not limited to) , yes this my choice and my right (no need to argue on that , please). And , as I said earlier , I do not have much time or maybe I was a bit lazy and tried the russian repack first , but I soon noticed they didn't remove the most important telemetry blocks , like the chinese DNS (that I discovered) , it is still NOT removed , I do not know what is the previous user talking about , it is still there, in their repack. Read the 1st post from the top.

https://msfn.org/board/topic/182304-extreme-explorer-360-chromium-78-86-general-discussion/page/22/

Second reason , I like to do things myself , when I have enough time, so I did it. And I think I wrote earlier , I created a program to start it in something like sandbox mode with lots of chrome features disabled, right at the start .

13.0.1106.0 (sorry , lost the link to it) and 13.0.1032.0 . The one below should be the official chinese link. Proceed with caution ! For God's sake , do not use the installer , unpack it with any popular (free) unpacker and make a portable version yourself !

http://down.360safe.com/cse/360cse_13.0.1032.0.exe

P.S.

I think some 360 users may find this website to be of interest . No warez there . There are two versions inside of the archive (mega link) - 11 and 12. I did not try any files from there myself and I do not know if russians have something to do with it !

You've been warned !

https://retrosystemsrevival.blogspot.com/2019/05/360-extreme-chrome-browser.html

Edited by Dixel
added link
Link to comment
Share on other sites

Did you remove the Russian Language setting in the Preferences file?

<excerpt>

C) Changes made to the file "Preferences" (in Chrome/User Data/Default)

- I searched for the "accept_languages" entry and then modified the line "accept_languages": "ru-RU,ru,en-US,en" and replaced by "accept_languages": "en-US,en".

This action allows to display websites in English and not in Russian.

</excerpt>

  • Upvote 1
Link to comment
Share on other sites

3 hours ago, NoNameNeeded said:

Now youtube is in russian.

Anyway to change this without having to log in to my google account?
The chinese version comes with youtube in english

There you go , problems with the russian repack again! I've noticed this pattern in their behaviour , seems quite obsessive how they stuff everything with their language, even though it wasn't even developed by them . Have you tried the flag --disable-translate ?   

Link to comment
Share on other sites

5 minutes ago, ArcticFoxie said:

Did you remove the Russian Language setting in the Preferences file?

<excerpt>

C) Changes made to the file "Preferences" (in Chrome/User Data/Default)

- I searched for the "accept_languages" entry and then modified the line "accept_languages": "ru-RU,ru,en-US,en" and replaced by "accept_languages": "en-US,en".

This action allows to display websites in English and not in Russian.

</excerpt>

Thx a lot. That did the trick.

 

Link to comment
Share on other sites

Add --disable-translate flag to the .ini file and try . This junk is also not needed --disable-glsl-translator , disable too , just in case.

 

Link to comment
Share on other sites

4 minutes ago, Dixel said:

There you go , problems with the russian repack again! I've noticed this pattern in their behaviour , seems quite obsessive how they stuff everything with their language, even though it wasn't even developed by them . Have you tried the flag --disable-translate ?   

I think it's actually ok but they should have created their own russian language pack, leaving the english one untouched, instead of "russifying" everything.

This would have made more sense.

 

  • Like 1
Link to comment
Share on other sites

@NoNameNeeded , still it doesn't explain why I have everything in English (even when I'm on the repack version) . I tried it , just out of curiosity , all is in English , except the gugle.ru search (which they forced , but I quickly fixed it). BTW , I think youtube may use your IP to detect the location and set the language , no ? Perhaps it has something to do with the IP ? Also , as I wrote before , I do not have this line "accept languages" at all . Because of the flag , perhaps. 

Link to comment
Share on other sites

Posted (edited)

No, I'm not in Russia neither is my IP russian.

I think they must have configured something to display pages in russian if possible.

I don't use the loader so the loader.ini flag would'nt really help anyway.

I haven't really tested the browser thoroughly yet, so I don't know which webpages will (or would) also show up in russian.

I did notice however that it crashes more often on youtube than it does with the regular chinese version.

At first I thought it has to do with the cyrillic characters but now that youtube is in english, that can't be the reason.

Strange.

 

Update: No, it's not the russian version, it's also the chinese version that crashes frequently on youtube.

Maybe it's a problem with version 2250 of the browser because with the older one that didn't happen.

 

 

 

Edited by NoNameNeeded
Link to comment
Share on other sites

3 hours ago, NoNameNeeded said:

No, I'm not in Russia neither is my IP russian.

I think they must have configured something to display pages in russian if possible.

I don't use the loader so the loader.ini flag would'nt really help anyway.

I haven't really tested the browser thoroughly yet, so I don't know which webpages will (or would) also show up in russian.

I did notice however that it crashes more often on youtube than it does with the regular chinese version.

At first I thought it has to do with the cyrillic characters but now that youtube is in english, that can't be the reason.

Strange.

 

Update: No, it's not the russian version, it's also the chinese version that crashes frequently on youtube.

Maybe it's a problem with version 2250 of the browser because with the older one that didn't happen.

 

 

 

Told ya , use betas . They are far more stable. I have no crashes. Oh , and I see you want to be on the safe side and not use the russian loader , in that case you can add any flag to the shortcut , as simple as that.

Link to comment
Share on other sites

Posted (edited)

  

2 hours ago, NoNameNeeded said:

Maybe it's a problem with version 2250 of the browser because with the older one that didn't happen.

I stopped updating at build 2206.

I've spent a lot of time with how there are "lookup strings" as far as how the language "locales" (ie, "en-US.pak") work and several of these "lookup strings" stopped working after build 2206 (unless 2250 fixed them, I have not checked).

I'd have to review my modifications to recall where they are at and how they were fixed, there were several typos that once you see them, you can't not see them.

I know one of them was in the Speedup / Optimize Memory tool info dialog boxes.

There are also several typos like uplaod instead of upload but I don't recall when those show up.

Once those "lookup strings" did not function as they did in previous releases, I stopped updating.

 

It is on my to-do list to benchmark/compare build 2206 with the beta versions that @Dixel uses but I have not done that as of yet.

 

edit  --  for purposes of my archive, was there any version 13 builds between build 2220 and build 2250?

 

Edited by ArcticFoxie
Link to comment
Share on other sites

Posted (edited)
9 hours ago, Dixel said:

I've tried several betas of 13 version , the first betas , to be precise. I'm sorry, I don't have the links anymore , it was almost a year ago , in September of 2020 , but I'm sure I didn't use the russian warez website, linked here by the user who "strongly" suggests using it. Oh , and I launch with the flag --disable-translate , perhaps this helps.

Ok. I tried but it did not work. Well it is not that a big deal. Thanks for the answer.

 

5 hours ago, NoNameNeeded said:

But I used Windows 7 to unpack it and NOW I can confirm that the Russians DID remove quite a bit of the telemetry stuff.

 Nice to hear that. I was going to mess with the original v13.

 

5 hours ago, ArcticFoxie said:

I have not removed those HOSTS file entries to see if the latest fixes submitted by @Humming Owl prevents those connections or not.

Yesterday I discovered that when I open the bookmark manager, the browser connects to a cloudflare IP address (in version 13.0.2250.0). Apparently that IP is related to China. I don't know how to remove that connection. I have searched with the developer tools (on the bookmark manager page) for the link that might be related to that IP address and there is an image that loads from a link ("p7.qhimg.com"). The image is minimal and it's a bit odd that I don't see it in the bookmark manager when it loads (maybe it's because of how small it is?). I was then trying to find the bookmark manager files among the browser files and I still can't find them.

Maybe this is one of the connections you are blocking on your hosts file.

Edited by Humming Owl
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...