Jump to content

Read GPT hard disk on Windows XP


Recommended Posts

On 3/1/2024 at 5:09 PM, Dave-H said:

Thanks, but does the Driver Signature Enforcement Overrider work on XP?

I'm sorry, I only used XP for no more than a month in 2006, but the below solution should actually work for older OS, even 32bit ones.

This is what I sometimes use for my own custom drivers' signing. The procedure is described in details,

Seeing you, Dave, have an Win 10 installation, it shouldn't be a problem to do it there, and then use the signed driver on your XP.


Link to comment
Share on other sites

On 3/1/2024 at 9:10 PM, mina7601 said:

You can find its location with the tool Everything. It is a very great tool, and it runs on Windows XP up to Windows 11.

@Dave-H Any results yet? Are you able to find that sneaky file? :dubbio:

Edited by mina7601
Link to comment
Share on other sites

8 hours ago, jaclaz said:

Well, you are missing a large number of settings then (not only the Administrative templates/System).

Check that you have all the .adm files in the right directories, this experiment to add gpedit to Home edition - as a side effect - provides all the needed info:


This is more or less how it should look

That was really quite worrying, to see so much missing there on my system!
It turned out that three of the four files which should have been in the \system32\GroupPolicy\Adm folder were not there!
Only wmplayer.adm was there, conf.adm, inetres,adm, and system.adm were not.
I have no idea why that would have been!
I've restored them, and it now looks much better.


I found the setting specified, and set it to 'enabled' and 'ignore', but again no difference, the wretched prompt still pops up when I mount a drive.

One thing I have done as a test is restoring the three files I changed back to their originals, so things should now be standard.
I was amazed (and annoyed) to find that the 'unsigned driver' prompt is still popping up!
It can't be because of the files now, as they are the originals, so why is it still querying the driver?


Link to comment
Share on other sites

2 hours ago, mina7601 said:

@Dave-H Any results yet? Are you able to find that sneaky file? :dubbio:

Sorry, I haven't had a chance to look.
I suspect that it isn't actually an individual file, it's probably hidden inside another file.
I did look for disk.sys and scsidisk.sys with no luck.

Link to comment
Share on other sites

  • 2 weeks later...

Back again!
Still not really getting anywhere with this I'm afraid.

It seems that the warning about drivers is happening on all drivers, not just the ones for disks.
That explains why it's still there with the original disk driver files reinstalled.
I have no idea why it's putting up a prompt for all drivers, even ones which are said to be digitally signed.
I'm thinking that the problem is probably in the bit of the message which says "not signed in the appropriate manner", but I've no idea what the problem could be.


Anyway, I'm now trying with the Paragon GPT driver again, and I've run into another problem!
The Paragon HFS+ program appears to install OK, as it did before, but when I reboot I'm now just getting a 7B BSOD (inaccessible boot drive).
It won't boot into Safe Mode either, and the 'last good configuration' gets as far as almost loading the desktop, and then just reboots!
Anyone any ideas?
This did not happen the first time I installed the paragon software.
The only clue I have is that when I tried a second time I didn't reboot straight away when I was told to by the installer, and in the event log there was an entry which said -

"The HFS+ File System Driver service failed to start due to the following error: Access is denied. "

I didn't think that "Access is denied" was something you often got in XP!

Anyone any ideas as to what's wrong?
As I said, it didn't do this the first time I installed it.

Link to comment
Share on other sites

Generally speaking access is denied should be actually called "insufficient permissions".

These can be either permissions related to the file (so NTFS permissions on the file or the folder containing it) or to  an operation performed on its settings (Registry permissions on involved/related keys).

You should check both.



Edited by jaclaz
Link to comment
Share on other sites

46 minutes ago, Dave-H said:

Thanks, but this is actually installing on a FAT32 drive, where there are no permissions involved!

For XP in FAT32 you need to modify the registry as reported by @Cixert in the following post:

In step 1. and 2. you will also find the solution to avoid automatic replacement of disk.sys v5.2.3790.4006 with XP version.

Link to comment
Share on other sites

@jaclaz @Andalu

Back again.

I was thrown for a while by hardware malfunctions, which were causing  a lot of problems it turns out unrelated to this one.
My Silicon Image eSATA card chose now to develop a fault, which was causing intermittent disk access errors on some of my drives, which was no help whatsoever when I was trying to find the best hardware configuration!
What's actually wrong with it I have no idea, but fortunately I had an identical new spare, which I've now put in and everything seems to be stable again, touch wood.

The original issue still remains however.
I only have the 3TB disk connected to the Asmedia card now, nothing else.

I'm still getting the annoying unsigned driver prompt whenever I mount the disk in XP (it doesn't happen in 10) which I have had no luck at all in suppressing.
The option in the system hardware properties works in that if I set it to block unsigned drivers, it does exactly that, prevents the driver from being installed.
The 'warn' setting also works of course, but the 'ignore' setting seems to be being completely ignored, the warning still pops up.
I'm now using the Paragon GPT driver again, which seems to be functioning fine.

The disk seems to mount as a removable drive when first connected, which looks fine, but it then always wants to install a driver for the disk, which isn't really necessary. If I say to ignore it, it still work fine. If I say go ahead the disk spins down and there's then a pause while the driver installs, and then it's there again.
I don't understand why it isn't happy to just stay as a removable drive. OK, I can always just say no to the prompt, but that's not ideal.

The main issue is still the file system corruption which is occurring when I change operating systems.
I've been trying for a while not using the disk on Windows 10 at all, but using it at will on XP (living with the annoying prompt, which makes it take ages to mount).

That seemed to be fine, I was running chkdsk on the drive before and after every use, and it seemed to be OK.
However, mounting the disk in Windows 10 and doing a check, without even knowingly doing anything to the drive, not even opening it explorer, on running chkdsk, a huge number of errors, mainly corrupt attribute records.

This is obviously not usable, so I'm getting close to just giving up.
It seems to happen both ways, using the disk in XP produces a corrupt file system on Windows 10, and using it in Windows 10 produces a corrupt file system on XP.
Yes, it could be a faulty disk, but I still think that's not the problem.

I will try again with another (500GB) disk in the enclosure, but I seem to remember that I couldn't even get that to work the last time I tried it!
I'll report back.........

Link to comment
Share on other sites

OK, I have done some more tests again with other drives.

The 500GB disk, which is MBR FAT32, seemed to be OK until I started actually trying to write to it, then it was immediately in serious trouble, and it all came back to me from when I tried to use it before!
Huge numbers of controller errors.


I still can't understand why this does not happen at all with the 3TB disk connected!

I suddenly had a thought. What if the Asmedia card is actually faulty? Not likely as it's brand new, but you never know.......

If you remember, the supplier sent me the wrong card initially, the version without eSATA ports on it, and I've still got it as they didn't want it back.
I put it in and tried again with the same disk, no errors!

I tried using the card, writing to the drive with QuickMirror in XP and 10, no problems!
So, was this the issue all along?
Obviously I wasn't comparing like for like, as I was comparing a 500GB MBR FAT32 drive with a 3TB GPT NTFS drive.

So, I then tried with my old 2TB backup drive, which is still MBR, but NTFS.
A few controller errors, in both operating systems, even with the other card, but nothing like as bad as before.
Tried writing to that with QuickMirror, and no chkdsk errors.

So, is the problem of the file corruption only with GPT disks?
I'm a bit loathe to convert my old backup drive to GPT to check, but is this the only way to tell for sure?

Link to comment
Share on other sites

Very old disks (500GB and the such) have "usual" 512kb clusters, and the newer ones - "advanced format" with bigger clusters.

And by that I mean physical, hardware clusters.

EDIT, prolly the board isn't tailored well enough to work with the old ones, but could also be the firmware bug.

Edited by Dixel
Link to comment
Share on other sites

The 500GB disk isn't very old though.
As the two Asmedia cars I now have produce very different results with that (and other) disks, I do suspect some sort of bug.
I'm will see if I can determine what firmware versions the two cards have. If they are different, that's probably the answer.
I still can't explain why there is no trace of the controller error problem with the 3TB disk connected to either card.

Link to comment
Share on other sites


Not really.

Clusters are a feature of the file system and they represent a set of sectors of the hard disk, "physical clusters" do not exist..

The disk has only the sectors, that can be physical (actual size on disk) or logical (the size that is exposed to the OS or its driver).

Older disks had 512 bytes sectors (physical) that were exposed as 512 bytes (logical)

More modern disks have 4096 bytes sectors (physical) that are exposed (logical) either as 512 bytes (so called AF drives) or as 4096 bytes (so called Native 4K, still pretty much rare).

AF disks have (internally, physically) 4096 bytes sectors, that are converted by the controller to 8x512 bytes sectors.


Link to comment
Share on other sites

4 hours ago, jaclaz said:

More modern disks have 4096 bytes sectors (physical) that are exposed (logical) either as 512 bytes (so called AF drives) or as 4096 bytes (so called Native 4K, still pretty much rare).

AF disks have (internally, physically) 4096 bytes sectors, that are converted by the controller to 8x512 bytes sectors.


jaclaz, what you talk about is called 512-Byte Emulation (512e), I'm aware of it.

"A hard disk that is configured with 4K physical sectors with 512-byte logical sectors, the so-called 512e, comes out. It is coupled with 512-byte conversion firmware so that the 4K physical sectors used in Advanced Format are translated into 8 traditional 512-byte logical sectors compatible with host computing systems."

However - "The Windows versions supporting 512e hard disk are as follows: Windows Vista, Windows Server 2008, Windows 7, Windows Server 2008 R2".

I don't see Windows XP on that list.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...