Jump to content

On decommissioning of update servers for 2000, XP, (and Vista?) as of July 2019


Mcinwwl
 Share

Recommended Posts

12 hours ago, Dave-H said:

But why is your new one issued to *.update.microsoft.com as well as to ProxHTTPSProxy CA?

@Dave-H Ok, your screenshot was a bit misleading. The certificate to the right is in your ProxHTTPSProxy's certs folder and the one to the left is your system root certificate. Therefore you have two ProxHTTPSProxy CA certificates due to the fact that you haven't deleted the old one before installing regenerated certificate. Is that right?

Now I have two suggestions for you. First delete both ProxHTTPSProxy CA certificates and generate a new one from 2017 to 2027 following the guess of @Mathwiz. Delete all certificates in your ProxHTTPSProxy certs folder and let ProxHTTPSProxy generate new certs for all MU related sites (www.microsoft.com, download.windowsupdate.com, fe2.update.microsoft.com, www.update.microsoft.com, update.microsoft.com and so on; you can use Wireshark or more simple NirSoft's HTTPNetworkSniffer for finding all connected sites) by using New Moon browser or Mypal. Then try to access MU using IE and look if it works. Check your settings in Internet Zone too (relevant for accessing http://fe2.update.microsoft.com). The idea is letting a new browser generate these MU relevant certificates. If that doesn't work for you you can go back to ProxHTTPSProxy CA certificate valid until 2025 which was the one originally provided. Of course you can do  this all using HTTPSProxy at first too.

Due to the fact that HTTPSProxy and ProxHTTPSProxy is working flawlessly for me and for other members it will work for you too. There is one thing or more you have missed and you have to find it. Don't give up! :thumbup

Edited by AstroSkipper
addition
Link to comment
Share on other sites


2 hours ago, AstroSkipper said:

@Dave-H Ok, your screenshot was a bit misleading. The certificate to the right is in your ProxHTTPSProxy's certs folder and the one to the left is your system root certificate. Therefore you have two ProxHTTPSProxy CA certificates due to the fact that you haven't deleted the old one before installing regenerated certificate. Is that right?

That's right about the certificates shown, but I did delete the system root ProxHTTPSProxy certificate with the program closed before I moved my system clock back and then ran the program again.
Why I then ended up with two certificates I'm not sure, but I can try it again and watch more closely this time!
:)

Link to comment
Share on other sites

52 minutes ago, Dave-H said:

Why I then ended up with two certificates I'm not sure, but I can try it again and watch more closely this time!

I think it's not unimportant to have only one ProxHTTPSProxy CA certificate in your system. If regenerating a new one leads to getting two of them then something is going wrong. Maybe your system restores this second old one. So delete all ProxHTTPSProxy CA certificates, make a reboot at first and have a look if your system has restored the old one before regenerating a new one. And only if you want try my suggestion two posts above:

"Now I have two suggestions for you. First delete both ProxHTTPSProxy CA certificates and generate a new one from 2017 to 2027 following the guess of @Mathwiz. Delete all certificates in your ProxHTTPSProxy certs folder and let ProxHTTPSProxy generate new certs for all MU related sites (www.microsoft.com, download.windowsupdate.com, fe2.update.microsoft.com, www.update.microsoft.com, update.microsoft.com and so on; you can use Wireshark or more simple NirSoft's HTTPNetworkSniffer for finding all connected sites) by using New Moon browser or Mypal. Then try to access MU using IE and look if it works. Check your settings in Internet Zone too (relevant for accessing http://fe2.update.microsoft.com). The idea is letting a new browser generate these MU relevant certificates. If that doesn't work for you you can go back to ProxHTTPSProxy CA certificate valid until 2025 which was the one originally provided. Of course you can do  this all using HTTPSProxy at first too."

 

Edited by AstroSkipper
correction
Link to comment
Share on other sites

22 hours ago, AstroSkipper said:

@Dave-H Ok, your screenshot was a bit misleading. The certificate to the right is in your ProxHTTPSProxy's certs folder and the one to the left is your system root certificate. Therefore you have two ProxHTTPSProxy CA certificates due to the fact that you haven't deleted the old one before installing regenerated certificate. Is that right?

Now I have two suggestions for you. First delete both ProxHTTPSProxy CA certificates and generate a new one from 2017 to 2027 following the guess of @Mathwiz. Delete all certificates in your ProxHTTPSProxy certs folder and let ProxHTTPSProxy generate new certs for all MU related sites (www.microsoft.com, download.windowsupdate.com, fe2.update.microsoft.com, www.update.microsoft.com, update.microsoft.com and so on; you can use Wireshark or more simple NirSoft's HTTPNetworkSniffer for finding all connected sites) by using New Moon browser or Mypal. Then try to access MU using IE and look if it works. Check your settings in Internet Zone too (relevant for accessing http://fe2.update.microsoft.com). The idea is letting a new browser generate these MU relevant certificates. If that doesn't work for you you can go back to ProxHTTPSProxy CA certificate valid until 2025 which was the one originally provided. Of course you can do  this all using HTTPSProxy at first too.

Due to the fact that HTTPSProxy and ProxHTTPSProxy is working flawlessly for me and for other members it will work for you too. There is one thing or more you have missed and you have to find it. Don't give up! :thumbup

Hello? I have just stuck at where the MU only threw 0x80072F78... I tried everything include certificates regeneration from 2019 to 2015.

NOTHING WORKED OR EVEN CHANGED THE SITUATION! ONLY 0x80072F78!

Anyone who can offer assistance?

Link to comment
Share on other sites

46 minutes ago, Jonuarl Reden said:

NOTHING WORKED OR EVEN CHANGED THE SITUATION! ONLY 0x80072F78!

@Jonuarl Reden Hi, the suggestion you've quoted is related to error code 0x800072F8F so different to yours. Have you already read the whole thread? I have made a little guide to get MU working. Look here:

 

Link to comment
Share on other sites

17 minutes ago, AstroSkipper said:

@Jonuarl Reden Hi, the suggestion you've quoted is related to error code 0x800072F8F so different to yours. Have you already read the whole thread? I have made a little guide to get MU working. Look here:

 

-Time/Time zone is correct.

-Removed WSUS.

-Configured IE correctly.

-Updates and regs already exist in my machine.

-"rootsupd.exe" is executed for several times already.

-"Restore_WU_XP_2003" has already installed in safe mode before.

-Using "config.ini" provided by you.

-Updated root certificates.

-Renamed "SoftwareDistribution" to "SoftwareDistribution.old". No security software exists in my computer.

-HTTP links is what I use to open MU.

-ProxHTTPSProxy is enabled.

But, when I have checked the all instructions...

12367355_2022-01-26192627.thumb.png.5b737c964265325d0880bd7cc908ce8c.png

...0x80072F78.

What should I do? Every time I went through a operation-needed step I went back to MU, only to be filled with 0x80072F78 without exception, even until now.

Any solutions?

Link to comment
Share on other sites

On 1/26/2022 at 12:30 PM, Jonuarl Reden said:

What should I do? Every time I went through a operation-needed step I went back to MU, only to be filled with 0x80072F78 without exception, even until now.

Any solutions?

The only thing I can say in your case you have to check systematicly and seriously what is missing or going wrong. When I had all error codes someone can get and yours too I did all from scratch i.e. you have to reinstall the mentioned updates although they already exist in your system or you have to check deeply if "Restore_WU_XP_2003" has been installed actually properly and so on. It will cost more time but for me it was the only way.

By the way I can't see where you come from. There is no flag in your profile but your screenshot tellls me from Asia so maybe it is country related too.

And here is a link with information to your error code from Microsoft: https://web.archive.org/web/20130316104325/http://support.microsoft.com/kb/836941

And a bit older version of this article I attach below.

There you can find your error code 0x80072F78  "ERROR_WINHTTP_INVALID_SERVER_RESPONSE".
https://www.mediafire.com/file/gu3q9b8gtpxwblr/q836941.htm/file

 

Edited by AstroSkipper
deletion
Link to comment
Share on other sites

1 hour ago, AstroSkipper said:

The only thing I can say in your case you have to check systematicly and seriously what is missing or going wrong. When I had all error codes someone can get and yours too I did all from scratch i.e. you have to reinstall the mentioned updates although they already exist in your system or you have to check deeply if "Restore_WU_XP_2003" has been installed actually properly and so on. It will cost more time but for me it was the only way.

I carefully checked again and nothing wrong in my operation.

1 hour ago, AstroSkipper said:

By the way I can't see where you come from. There is no flag in your profile but your screenshot tellls me from Asia so maybe it is country related too.

Yep I comes from China... but that shouldn't matter because there is no ban from visiting WU service.

Maybe I should use alternatives however...:}

Link to comment
Share on other sites

OK, I've had another go!
Removed all the ProxHTTPSProxy and Microsoft Update certificates, removed the ProxHTTPSProxy "Certs" folder, and set the clock back to 2017.
I now have just one ProxHTTPSProxy certificate in the Trusted Root Certification Authorities certificate store valid from 26/01/17 to 26/01/27.
The new certificates for Microsoft Update in the ProxHTTPSProxy "Certs" folder (www.update.microsoft.com.crt and fe2.update.microsoft.com.crt) are both dated 26/01/22 to 26/01/32 though.
Still getting the same error that the system clock is wrong.
:(

Link to comment
Share on other sites

21 minutes ago, Dave-H said:

OK, I've had another go!
Removed all the ProxHTTPSProxy and Microsoft Update certificates, removed the ProxHTTPSProxy "Certs" folder, and set the clock back to 2017.
I now have just one ProxHTTPSProxy certificate in the Trusted Root Certification Authorities certificate store valid from 26/01/17 to 26/01/27.
The new certificates for Microsoft Update in the ProxHTTPSProxy "Certs" folder (www.update.microsoft.com.crt and fe2.update.microsoft.com.crt) are both dated 26/01/22 to 26/01/32 though.
Still getting the same error that the system clock is wrong.
:(

The virus scanner could also be to blame. Try disabling it.

Link to comment
Share on other sites

LOL, more than I could possibly remember!
Before you ask, no I'm not going to do a clean install to see if that works.
I'd like to have MS Update working again of course, but I'm not that desperate!
:lol:
 

Link to comment
Share on other sites

On 1/26/2022 at 5:14 PM, Dave-H said:

OK, I've had another go!
Removed all the ProxHTTPSProxy and Microsoft Update certificates, removed the ProxHTTPSProxy "Certs" folder, and set the clock back to 2017.
I now have just one ProxHTTPSProxy certificate in the Trusted Root Certification Authorities certificate store valid from 26/01/17 to 26/01/27.
The new certificates for Microsoft Update in the ProxHTTPSProxy "Certs" folder (www.update.microsoft.com.crt and fe2.update.microsoft.com.crt) are both dated 26/01/22 to 26/01/32 though.
Still getting the same error that the system clock is wrong.

@Dave-H This is bit disappointing. So @Mathwiz's guess has been disproved and my suggestion doesn't help too. At next I've made a screenshot of my Root Cerificate Authorities in my system beginning with "Microsoft". So you can compare if one or more are missing. There is less German so I think it won't be a problem to read. :lol:
https://imgur.com/hX3nGr4

 

Edited by AstroSkipper
deletion
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...