Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


FranceBB

uBlock Origin, Chromium 54 and Firefox 52.9 ESR

Recommended Posts

Hi,

I've been using uBlock for quite some time, but I started to notice that it's no longer blocking ads. I googled and I found out that it has been replaced by uBlock Origin, so I uninstalled it and I moved to uBlock Origin, but it didn't solve the issue. I moved to the development branch and I tried to surf the web again, but it didn't work either. Strangely enough, I tried to install uBlock Origin on Firefox and it blocks the ads correctly, which leads me to the question: why?

It was working fine 'till a few weeks ago and I have no idea why it stopped blocking ads out of the blue. I thought it was because I didn't update it, but I'm now using the very latest version (uBlock Origin development build v1.17.1b1).

Do you have uBlock Origin? What do you use to block ads? Could it be ProxHTTPSProxyMII that somehow makes ads impossible to block? @heinoganda

 

Thank you in advance.

Chromium 54 spoofed as 71.0.3554.0

U5Wo0fv.png

Firefox 52.9 ESR

yk5EIIA.png

 

Edited by FranceBB

Share this post


Link to post
Share on other sites

I do not have any problem.

Use the "advanced user" option you have more control.

If you need, I can indicate a series of recommended filters.

To improve a basic setting of UBO.

Edited by Sampei.Nihira

Share this post


Link to post
Share on other sites
8 hours ago, FranceBB said:

Do you have uBlock Origin? What do you use to block ads? Could it be ProxHTTPSProxyMII that somehow makes ads impossible to block?

It was only a matter of time before older Chromium versions are no longer supported by μBlock (last version which supports Chromium 49 is version 1.16.20). For this reason, you can download an older version from Github in the following link and run it in developer mode under Extensions.

https://github.com/gorhill/uBlock/releases

:)

  • Like 2

Share this post


Link to post
Share on other sites

@FranceBB

If you use Advanced Chrome for XP (?), the version of UBO you installed is not supported.

Also in this case the option "I am an advanced user" of UBO would have highlighted the problem.

Edited by Sampei.Nihira

Share this post


Link to post
Share on other sites
7 hours ago, Sampei.Nihira said:

I do not have any problem.

Use the "advanced user" option you have more control.

If you need, I can indicate a series of recommended filters.

To improve a basic setting of UBO.

Care to share the filters? You can export the settings in the dashboard.

Share this post


Link to post
Share on other sites

I have made use of the HOSTS file in Windows for many years to block ads and tracking cookies.   I am extremely pleased with using this method and recommend it to anyone who wants to try it........  here is an excellent resource for a comprehensive HOSTS file that is continually updated with the newest and latest sites to block.   Of course, you can also add any of your own to the HOSTS file as well or manipulate it to your own specs.   

Blocking Unwanted Connections with a HOSTS file

This is applicable for all versions of WINDOWS

Just download the hosts.zip file, extract and run the MVPS.Bat file which will install the file automatically into the target  C:\WINDOWS\SYSTEM32\DRIVERS\ETC 

You can open the HOSTS file using a text editor such as notepad and modify the entries if you so desire.

Edited by Dclem
additional info

Share this post


Link to post
Share on other sites
1 hour ago, PROBLEMCHYLD said:

Care to share the filters? You can export the settings in the dashboard.

Hi.

In "My Filters" use | | cm ^ for the reason given below:

 

 

https://github.com/ghacksuserjs/ghacks-user.js/issues/393

I can not insert the rules in "My Rules" for reasons of my privacy.:rolleyes:

In "Filter list" I use the lists below:

vbIuVfau_o.jpg

EA0YU20L_o.jpg

 

The "Custom" List can be found at the link below:

 

https://filterlists.com/

P.S. It is not easy to add Custom lists to New Moon.:no:

 

Edited by Sampei.Nihira

Share this post


Link to post
Share on other sites

I always used Ublock Origin on chrome 49.0.2623.112 but since today i cannot install it anymore from the extension site: the button is overshadowed "not compatible".

Thanks to Heinoganda link i realized that if anyone want to use this app nowadays on chrome 49 (for XP-Vista) only 1.16.20 Aug 27, 2018 release can be manually installed.

Share this post


Link to post
Share on other sites
3 hours ago, Sampei.Nihira said:

Hi.

In "My Filters" use | | cm ^ for the reason given below:

 

 

https://github.com/ghacksuserjs/ghacks-user.js/issues/393

I can not insert the rules in "My Rules" for reasons of my privacy.:rolleyes:

In "Filter list" I use the lists below:

vbIuVfau_o.jpg

EA0YU20L_o.jpg

 

The "Custom" List can be found at the link below:

 

https://filterlists.com/

P.S. It is not easy to add Custom lists to New Moon.:no:

 

Thanks

Share this post


Link to post
Share on other sites

Since Chromium is being further developed and also JavaScript, it remains clear that various plugins are no longer compatible with Chromium 49. In Advanced Chrome, the JavaScript is older than by Chromium 49. On Google Chrome 49, I could to persuade μBlock 1.17.0 still working , for this which I have adapted the file manifest.json ("minimum_chrome_version": "49.0") and have taken over the file "asset-viewer.js" from the μBlock version 1.16.20.

:)

  • Upvote 2

Share this post


Link to post
Share on other sites

A big fat "thank you" to @heinoganda. I just installed version 1.16.20 and it works perfectly on Advanced Chrome (Chromium 54).

What tricked me was that I expected non-compatible extensions not to be "installed" at all, instead they do get "installed" and they also display settings and so on, but they just don't work (In fact I installed version 1.17.1.1 just fine but it didn't work).

@Sampei.Nihira thank you for sharing your list as well. ^_^

n6ntYmf.png

Edited by FranceBB

Share this post


Link to post
Share on other sites

Versions of uBlock Origin > 1.16.20=1.16.18 for Google Chrome now require Chrome version >=52.0; Advanced Chrome will advertise itself on Google Store as v54.20.6530.0, so it will allow the download and install of latest version of uBlock0; but because, in essence, AdvChr is Chrome v48.0+51.0, it does not support the Javascript functions of uBlock0 > 1.16.20 (as already explained by heinoganda).

The problem with Google Store is, unlike the Firefox extensions repository (AMO), that it does not offer previous versions of an extension, so once you upgrade to a non-working version of an extension, you can't revert back (at least easily) :realmad:

Chromium will allow for installation of unsigned extensions, so installing from uBlock0's GitHub repo is an option in this case; while in developer mode, you can convert the github downloaded 1.16.20 zip file into a proper .crx one:

https://www.datafilehost.com/d/c5a80c4a

In the case of Google Chrome 49 (and 50, for Vista users), you should be stuck at version 1.16.18 (IDK whether v1.16.20, identical to 1.16.18, was properly released in Google Store), so no problem with upgrading to an incompatible version there; but what if you want to install uBlock0 v1.16.18 for the first time/re-install?

Release branch Chrome will disable any non-signed extension (i.e. not coming from their store), even installed during dev mode, at next browser restart :angry:; I have managed to track down a signed version of uBlock0 v1.16.18, at the admin's discretion, I have uploaded it to:

https://www.datafilehost.com/d/dff0eb77

Maybe @sdfox7 is interested in permanently archiving it onto his server... ;)

19 hours ago, Sampei.Nihira said:

https://filterlists.com/

P.S. It is not easy to add Custom lists to New Moon.:no:

This is a limitation of the legacy version of uBlock0 v1.16.4.4 (XUL) installable on Pale (New) Moon; while I find that some sites work OK (e.g. https://adblockplus.org/subscriptions), the one you linked to requires a more recent, WebExtension, version of uBlock0; but, as you probably know, you can manually install from there by copying raw filter URLs (Details -> View) :yes:

Edited by VistaLover
  • Like 3

Share this post


Link to post
Share on other sites

@VistaLover

Correct.
I use this method.

_____________________

Out uBlock Origin Legacy 1.16.4.5.

Who uses New Moon can install the extension "Ublock Origin Updater" which updates UBO from GitHub automatically.:thumbup

 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, Sampei.Nihira said:

Correct.
I use this method.

___________________________________

Out uBlock Origin Legacy 1.16.4.5.

... and with uBlock0 v1.16.4.5 legacy (XUL), you can now properly subscribe to filter lists on https://filterlists.com:cheerleader:

This is because issue #3737 was fixed via commit git-80f8f3b

Great news! :yes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...