Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


mixit

Enable MP4 (H.264 + AAC) HTML5 video in Firefox on Windows XP without Flash

Recommended Posts

3 hours ago, Dave-H said:

I'm less concerned about websites generally thinking you're not using XP as I am about Mozilla thinking that, as they haven't yet said whether they will keep on supporting 52ESR beyond its normal life expectancy.
They did say they would make a decision based on the number of users that they detected were still using XP or Vista.
I assume that changing the user agent will not change the data that Firefox sends back to Mozilla, so hopefully this will have no impact on that.
Going to Mozilla's website now tells me I'm using a pre-release version of Firefox!
:)

We should find another fix soon . As reducing xp market share will kill us faster. Have you tried newmoon? 

Share this post


Link to post
Share on other sites

@Dave-H: Do please try this, insead:

Mozilla/5.0 (Windows NT 5.1; rv:57.0) Gecko/20100101 Firefox/57.0

Does it work as well or not? :dubbio:

 

Share this post


Link to post
Share on other sites

Sadly not, Facebook wants to use the Flash Player for videos again with that UA.
I guess it's sniffing the OS version as well as (or instead of) the Firefox version.
:no:
Is there any way, preferably without using an extension, of changed the UA just for a specific site?
You can to do that with Opera 12, but of course you can do a lot of things with Opera 12 that you can't do in any other browser!
:)

Share this post


Link to post
Share on other sites
On 8/3/2017 at 11:11 AM, patclash said:

Just try to switch the user agent to W7 and it work !!!

(using Firefox 52.3.0esr with User Agent Switcher extension :D)

So that's a limitation from the site for XP :crazy:

I changed my user agent to

Mozilla/5.0 (Windows NT 6.1; rv:53.0) Gecko/20100101 Firefox/53.0

and http://www.bbc.co.uk/html5

now plays video. How has it been working for the others here who use XP  (Windows NT 5.1) in the firefox useragent string??

 

Share this post


Link to post
Share on other sites

Doesn't work for me with Windows NT 5.1 in the UA.
Like Facebook, it then wants to use Flash.
Do extensions like User Agent Switcher allow site by site UA changes?
:dubbio:

Looks like Firefox 52ESR has a short stay of execution until next June.
:yes:

Edited by Dave-H

Share this post


Link to post
Share on other sites
6 hours ago, Dave-H said:

I'm less concerned about websites generally thinking you're not using XP as I am about Mozilla thinking that, as they haven't yet said whether they will keep on supporting 52ESR beyond its normal life expectancy.

Unfortunately, they have. As was to be expected, the ealier September 2017 deadline was just a "clever" PR tactic, support will end when ESR 52 ends in June 2018.

13 hours ago, Dibya said:

Spoofing ua as 7 may reduce xp market share. 

3 hours ago, Dibya said:

We should find another fix soon .

If you can come up with other (feasible) ways to work around this (with FF itself, without switching to New Moon), we'd all be happy to hear them! :yes:

44 minutes ago, Dave-H said:

Do extensions like User Agent Switcher allow site by site UA changes?

Some do. I don't have any specific recommendations to give out as I haven't used them, so I'll have leave it to you to investigate the add-ons site. ;)

 

Edited by mixit

Share this post


Link to post
Share on other sites

One thing I've found straight away with the new arrangement is that going to the Firefox add-ons page now tells me that most of the add-ons aren't compatible with my version of Firefox!
It fact is was quite frightening to find out just how many add-ons will not work with Firefox 57.
There's going to be tears and tantrums from many Firefox users later this month mark my words!
I will try to find an add-on that will allow UA spoofing on a site by site basis, as that seems to be the best answer.
I can then change the UA only on sites that need it changed, as I used to do with Opera 12.
:yes:

Share this post


Link to post
Share on other sites

The "Custom UserAgent String" add-on seems to do the job!
I now have the default UA set to normal, and just send a different one to Facebook, so the videos work properly.
All seems fine, but I'll be back if I find any other problems, and thanks for everyone's help as always!
:yes:

  • Upvote 2

Share this post


Link to post
Share on other sites

This guide doesn't tell you that you can't manually instal this if you have FF set to never remember history.  Uncheck that and restart firefox before you try.

Edited by Destro
spelling

Share this post


Link to post
Share on other sites

I wonder if it would be possible to use LAVSplitters instead of Primetime thing.

Edited by hotnuma

Share this post


Link to post
Share on other sites
1 hour ago, hotnuma said:

I wonder if it would be possible to use LAVSplitters instead of Primetime thing.

IIRC Primetime can work with encrypted stream while LAV doesn't.

Share this post


Link to post
Share on other sites

Hi there, thanks to all for all this gathered information! I'm using FireFox 52.5.0 ESR on Windows XP x64 Edition SP2 and having an odd issue which I didn't see others having while scanning through the thread.

I can install the plugin by modifying the about:config as specified and dropping the plugin in the profile folder, going to youtube.com/html5 reveals that it's working, but then when I close and re-open FireFox, the plugin is removed! I'll close FireFox, re-open it, and as FireFox opens the 17 folder is deleted from within the gmp-eme-adobe folder, and many of the flags set in about:config are completely gone.

I'm wondering if this has anything to do with being signed in to my FireFox account, so I'll probably wipe FireFox clean and try again without signing in and let you know how it goes. Thanks for reading!

I found out what was causing my issue. For Windows XP Pro x64, the media.gmp-eme-adobe.abi string must be set to x86-msvc-x64 as opposed to x86-msvc-x86, otherwise the plugin is removed when FireFox is relaunched and the version, abi, and lastUpdate lines are all removed from the config. If another human being exists in the world that uses Windows XP x64, hopefully that's useful ;)

Edited by TeconMoon
Issue resolved
  • Like 3

Share this post


Link to post
Share on other sites
On 11/15/2017 at 3:03 AM, TeconMoon said:

I found out what was causing my issue. For Windows XP Pro x64, the media.gmp-eme-adobe.abi string must be set to x86-msvc-x64 as opposed to x86-msvc-x86, otherwise the plugin is removed when FireFox is relaunched and the version, abi, and lastUpdate lines are all removed from the config. If another human being exists in the world that uses Windows XP x64, hopefully that's useful ;)

Thanks for discovering this! :thumbup I don't use XP x64, so this obvious-in-hindsight difference never occurred to me. I added this point to the guide.

Share this post


Link to post
Share on other sites
On 11/8/2017 at 6:47 AM, Destro said:

This guide doesn't tell you that you can't manually instal this if you have FF set to never remember history.  Uncheck that and restart firefox before you try.

I keep forgetting to mention that I wasn't able to make this problem appear with the latest ESR update and a clean profile, so it likely only manifests in case of some combination of other settings and maybe extensions. Just setting FF to never remember history didn't cause me any problems with manual installation. In any case, thanks for reporting this and hopefully your workaround will work if anyone else should experience something similar.

Share this post


Link to post
Share on other sites

There is an addition for YouTube "Byffox YouTube Downloads", works only with the old interface of YouTube. The processor can be without support of SSE2 (AthlonXP). Video can be played in any player capable reproduction of a stream (MPC-HC or another).

It is necessary to select and transfer the left mouse button in a player window

image

The player not hidden -

 MPC-HC : "View" --- "On top" --- "Always"

 

 

 

 

Edited by grey_rat

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×