Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Recommended Posts

Just to be clear...to install this on 10240 for the first time, we need to install the 1.3.1 version for 8.1 and then replace the files with the ones in the debug build?

 

That's what I did, install 1.3.1, kill aerohost and desktop window manager. Then replace the files and run the aerohost task from the task scheduler.

  • Upvote 1

Share this post


Link to post
Share on other sites

Ah perfect. Thanks. Wanna try this on my laptop first since Im working and dont wanna go all black screen.

Share this post


Link to post
Share on other sites

This build is not intended for working computer. If you don't know how to install it then don't use it.

  • Upvote 1

Share this post


Link to post
Share on other sites

This build is not intended for working computer. If you don't know how to install it then don't use it.

Yes its always been the case to:

1. Install Only on a test machine

2. Install Only if you know what the heck your doing and don't wine if you don't and it's not working.

Sure there will be a installer in the future for those that don't want to deal with the manual install method..

~DP

Share this post


Link to post
Share on other sites

This build is not intended for working computer. If you don't know how to install it then don't use it.

Lol BM you misunderstand. Ive donated to you for both of my computers so I could use this software. I am not afraid of trying it. My point was is that I use this computer for work and I don't wanna apply any changes like this that could interfere with me working.

 

With that being said, I'm going to try it on my laptop first and if all goes well, I will install it tonight after work.

 

This software has been great and I loved it on 8.1. I just have been away from it since Ive been using Windows 10 and was waiting until Win10 was closer to finished to try using Aero again.

Share this post


Link to post
Share on other sites

 

This build is not intended for working computer. If you don't know how to install it then don't use it.

Yes its always been the case to:

1. Install Only on a test machine

2. Install Only if you know what the heck your doing and don't wine if you don't and it's not working.

Sure there will be a installer in the future for those that don't want to deal with the manual install method..

~DP

 

There are instructions in the forum for novices to read.

Share this post


Link to post
Share on other sites

here a blue atlas for 10240.

post-381472-0-88461300-1438037671_thumb.

Edited by Scopeman
  • Upvote 2

Share this post


Link to post
Share on other sites

Thanks bigmuscle! It's working great so far :)

Share this post


Link to post
Share on other sites

That little bit of colour & blur it puts back into the title bar... eradicating the polar bear in a snow storm look.

 

A softer, kinder, less offensive look.

 

I don't even use alternate theme, its all I need. Why can't M$ see the difference a bit of title glass makes.

 

Thanks BigMuscle.

 

I guess an updated modernframe.dll would finish it off, but I'm sure that is in the pipeline.

 

Cheers!!!!

  • Upvote 3

Share this post


Link to post
Share on other sites

Thanks bigmuscle! The new debug version took care of the issue I had with the glass transparency disappearing after a minute or two. Seems perfect so far.

  • Upvote 2

Share this post


Link to post
Share on other sites

Nice job, seems to hang together here.  Seems to work with my theme atlas (which by the way you're welcome to distribute with the product if you want).

 

I seem to have lost the ability to adjust my FrameMargin setting somewhere along the way.  Borders are all very thin now.

 

Here's the debug.log, if it's useful to you:

 

[2015-07-27 23:13:18][0x628:0x62C] Installing DWM hook...
[2015-07-27 23:13:18][0x628:0x62C] User: SYSTEM
[2015-07-27 23:13:18][0x628:0x62C] Module: C:\AeroGlass\DWMGlass.dll
[2015-07-27 23:13:18][0x90:0xC84] Machine ID: ...
[2015-07-27 23:13:18][0x90:0xC84] Checking key ...for ID ......
[2015-07-27 23:13:18][0x90:0xC84] Hook (USER32.dll!DrawTextW from udwm.dll) installed
[2015-07-27 23:13:18][0x90:0xC84] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed
[2015-07-27 23:13:18][0x90:0xC84] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed
[2015-07-27 23:13:18][0x90:0xC84] Aero Glass for Win8.1+ v1.3.2 DEBUG x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).
[2015-07-27 23:13:18][0x90:0xC8C] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols
[2015-07-27 23:13:19][0x90:0xC8C] Loading settings (flags = 0x1) from HKEY 0x0000000000000000 for session #1
[2015-07-27 23:13:19][0x90:0xC8C] Settings reloaded
[2015-07-27 23:13:19][0x90:0xC8C] dwmcore.dll version 10.0.10240.16397
[2015-07-27 23:13:19][0x90:0xC8C] udwm.dll version 10.0.10240.16384
[2015-07-27 23:13:19][0x90:0xC8C] Symbols loaded from patterns: 0x7FF
[2015-07-27 23:13:19][0x90:0x224] Message 0x31A, wparam = 0, lparam = 0
[2015-07-27 23:13:19][0x90:0x224] Loading settings (flags = 0x4) from HKEY 0x0000000000000000 for session #1
[2015-07-27 23:13:19][0x90:0x224] Settings reloaded
[2015-07-27 23:13:19][0x90:0x224] Delayed hook (UxTheme.dll!GetThemeStream from udwm.dll) installed
[2015-07-27 23:13:19][0x90:0x224] Delayed hook (UxTheme.dll!GetThemeRect from udwm.dll) installed
[2015-07-27 23:13:19][0x90:0x224] Delayed hook (ext-ms-win-uxtheme-themes-l1-1-0.dll!GetThemeMargins from udwm.dll) installed
[2015-07-27 23:13:19][0x90:0x224] Hook (USER32.dll!SystemParametersInfoW from udwm.dll) installed
[2015-07-27 23:13:19][0x90:0x224] Hook (GDI32.dll!ExtCreateRegion from udwm.dll) installed
[2015-07-27 23:13:19][0x90:0x224] Atlas resource loading (custom: )
[2015-07-27 23:13:19][0x90:0x224] GetThemeStream 0,0,213
[2015-07-27 23:13:19][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:13:19][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:13:19][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:13:19][0x90:0x224] Message 0x320, wparam = 1157636154, lparam = 1
[2015-07-27 23:13:19][0x90:0x224] Loading settings (flags = 0x2) from HKEY 0x0000000000000000 for session #1
[2015-07-27 23:13:19][0x90:0x224] Settings reloaded
[2015-07-27 23:13:19][0x90:0x224] Message 0x15, wparam = 0, lparam = 0
[2015-07-27 23:13:19][0x90:0x224] Message 0x1E, wparam = 0, lparam = 0
[2015-07-27 23:13:19][0x90:0x224] Message 0x2B1, wparam = 5, lparam = 1
[2015-07-27 23:13:19][0x90:0x224] Loading settings (flags = 0x1) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:13:19][0x90:0x224] Settings reloaded
[2015-07-27 23:13:19][0x90:0x224] Message 0x320, wparam = 3808452062, lparam = 1
[2015-07-27 23:13:19][0x90:0x224] Loading settings (flags = 0x2) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:13:19][0x90:0x224] Settings reloaded
[2015-07-27 23:13:19][0x90:0x224] Message 0x31B, wparam = 0, lparam = 0
[2015-07-27 23:13:20][0x90:0x224] Message 0x31A, wparam = 2359298, lparam = 1
[2015-07-27 23:13:20][0x90:0x224] Loading settings (flags = 0x4) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:13:20][0x90:0x224] Settings reloaded
[2015-07-27 23:13:20][0x90:0x224] Atlas resource loading (custom: C:\AeroGlass\RoundedCornersBlueActive.png)
[2015-07-27 23:13:20][0x90:0x224] Failed to load custom atlas layout (0x2 - The system cannot find the file specified.), using system theme layout...
[2015-07-27 23:13:20][0x90:0x224] GetThemeStream 0,0,213
[2015-07-27 23:13:20][0x90:0x224] Message 0x31B, wparam = 2359298, lparam = 1
[2015-07-27 23:13:20][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:13:20][0x90:0x224] Message 0x15, wparam = 0, lparam = 0
[2015-07-27 23:13:20][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:13:20][0x90:0x224] Message 0xC0AC, wparam = 4, lparam = 0
[2015-07-27 23:13:20][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:13:20][0x90:0x224] Message 0x219, wparam = 7, lparam = 0
[2015-07-27 23:13:20][0x90:0x224] Message 0x320, wparam = 3808452062, lparam = 1
[2015-07-27 23:13:20][0x90:0x224] Loading settings (flags = 0x2) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:13:20][0x90:0x224] Settings reloaded
[2015-07-27 23:13:20][0x90:0x224] Message 0x15, wparam = 0, lparam = 0
[2015-07-27 23:13:20][0x90:0x224] Message 0x219, wparam = 7, lparam = 0
[2015-07-27 23:13:20][0x90:0x224] Message 0x1A, wparam = 24, lparam = 282264861480
[2015-07-27 23:13:20][0x90:0x224] Message 0xC0E5, wparam = 0, lparam = 0
[2015-07-27 23:13:24][0x90:0x224] Message 0x219, wparam = 7, lparam = 0
[2015-07-27 23:13:24][0x90:0x224] Message 0x219, wparam = 7, lparam = 0
[2015-07-27 23:13:25][0x90:0x224] Message 0xC08A, wparam = 0, lparam = 0
[2015-07-27 23:13:25][0x90:0x4C0] Allocating class CBlurEffect for D2D 0x00000041BA515940
[2015-07-27 23:13:25][0x90:0x4C0] Allocating blur buffer 683 x 41 [pixelFormat: 87, 3]  (D2D 0x00000041BA515940)
[2015-07-27 23:13:25][0x90:0x4C0] Allocating class CReflection for D2D 0x00000041BA515940
[2015-07-27 23:13:35][0x90:0x4C0] Allocating class CGlassSafetyZoneLayer for D2D 0x00000041BA515940
[2015-07-27 23:13:35][0x90:0x4C0] Allocating glass safety zone 1920 x 18 (D2D 0x00000041BA515940)
[2015-07-27 23:13:35][0x90:0x4C0] Allocating glass safety zone 18 x 1200 (D2D 0x00000041BA515940)
[2015-07-27 23:13:35][0x90:0x4C0] Allocating glass safety zone 18 x 1200 (D2D 0x00000041BA515940)
[2015-07-27 23:13:35][0x90:0x4C0] Allocating glass safety zone 1920 x 18 (D2D 0x00000041BA515940)
[2015-07-27 23:13:35][0x90:0x4C0] Allocating blur buffer 685 x 356 [pixelFormat: 87, 3]  (D2D 0x00000041BA515940)
[2015-07-27 23:13:38][0x90:0x4C0] Allocating blur buffer 683 x 41 [pixelFormat: 87, 1]  (D2D 0x00000041BA515940)
[2015-07-27 23:15:17][0x90:0x224] Message 0x219, wparam = 7, lparam = 0
[2015-07-27 23:15:17][0x90:0x224] Message 0x219, wparam = 7, lparam = 0
[2015-07-27 23:15:17][0x90:0x224] Message 0x1A, wparam = 0, lparam = 282264861480
[2015-07-27 23:15:17][0x90:0x224] Message 0x219, wparam = 7, lparam = 0
[2015-07-27 23:15:17][0x90:0x224] Message 0x1A, wparam = 0, lparam = 282264861480
[2015-07-27 23:16:12][0x90:0x4C0] Allocating blur buffer 1043 x 1016 [pixelFormat: 87, 1]  (D2D 0x00000041BA515940)
[2015-07-27 23:16:12][0x90:0x4C0] Allocating blur buffer 1043 x 1016 [pixelFormat: 87, 3]  (D2D 0x00000041BA515940)
[2015-07-27 23:17:56][0x90:0x4C0] Allocating blur buffer 1777 x 1016 [pixelFormat: 87, 1]  (D2D 0x00000041BA515940)
[2015-07-27 23:17:56][0x90:0x224] Message 0xC219, wparam = 0, lparam = 0
[2015-07-27 23:17:56][0x90:0x4C0] Allocating blur buffer 1694 x 1016 [pixelFormat: 87, 3]  (D2D 0x00000041BA515940)
[2015-07-27 23:18:22][0x90:0x224] Message 0x31A, wparam = 0, lparam = 0
[2015-07-27 23:18:22][0x90:0x224] Loading settings (flags = 0x4) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:18:22][0x90:0x224] Settings reloaded
[2015-07-27 23:18:22][0x90:0x224] Atlas resource loading (custom: C:\AeroGlass\RoundedCornersBlueActive.png )
[2015-07-27 23:18:22][0x90:0x224] Failed to load custom atlas layout (0x2 - The system cannot find the file specified.), using system theme layout...
[2015-07-27 23:18:22][0x90:0x224] GetThemeStream 0,0,213
[2015-07-27 23:18:22][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:18:22][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:18:22][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:18:22][0x90:0x224] Message 0x320, wparam = 3808452062, lparam = 1
[2015-07-27 23:18:22][0x90:0x224] Loading settings (flags = 0x2) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:18:22][0x90:0x224] Settings reloaded
[2015-07-27 23:18:22][0x90:0x224] Message 0x15, wparam = 0, lparam = 0
[2015-07-27 23:18:22][0x90:0x224] Message 0x31A, wparam = 0, lparam = 0
[2015-07-27 23:18:22][0x90:0x224] Loading settings (flags = 0x4) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:18:22][0x90:0x224] Settings reloaded
[2015-07-27 23:18:22][0x90:0x224] Atlas resource loading (custom: C:\AeroGlass\RoundedCornersBlueActive.png)
[2015-07-27 23:18:22][0x90:0x224] Failed to load custom atlas layout (0x2 - The system cannot find the file specified.), using system theme layout...
[2015-07-27 23:18:22][0x90:0x224] GetThemeStream 0,0,213
[2015-07-27 23:18:22][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:18:22][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:18:22][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:18:22][0x90:0x224] Message 0x320, wparam = 3808452062, lparam = 1
[2015-07-27 23:18:22][0x90:0x224] Loading settings (flags = 0x2) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:18:22][0x90:0x224] Settings reloaded
[2015-07-27 23:18:22][0x90:0x224] Message 0x15, wparam = 0, lparam = 0
[2015-07-27 23:18:37][0x90:0x224] Message 0x320, wparam = 0, lparam = 0
[2015-07-27 23:18:37][0x90:0x224] Loading settings (flags = 0x2) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:18:37][0x90:0x224] Settings reloaded
[2015-07-27 23:18:37][0x90:0x224] Message 0x15, wparam = 0, lparam = 0
[2015-07-27 23:18:41][0x90:0x224] Message 0x31A, wparam = 0, lparam = 0
[2015-07-27 23:18:41][0x90:0x224] Loading settings (flags = 0x4) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:18:41][0x90:0x224] Settings reloaded
[2015-07-27 23:18:41][0x90:0x224] Atlas resource loading (custom: C:\AeroGlass\RoundedCornersBlueActive.png)
[2015-07-27 23:18:41][0x90:0x224] Failed to load custom atlas layout (0x2 - The system cannot find the file specified.), using system theme layout...
[2015-07-27 23:18:41][0x90:0x224] GetThemeStream 0,0,213
[2015-07-27 23:18:41][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:18:41][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:18:41][0x90:0x204] GetThemeStream 0,0,213
[2015-07-27 23:18:41][0x90:0x224] Message 0x320, wparam = 3808452062, lparam = 1
[2015-07-27 23:18:41][0x90:0x224] Loading settings (flags = 0x2) from HKEY 0x000000000000038C for session #1
[2015-07-27 23:18:41][0x90:0x224] Settings reloaded
[2015-07-27 23:18:41][0x90:0x224] Message 0x15, wparam = 0, lparam = 0
[2015-07-27 23:21:30][0x90:0x224] Message 0xC23B, wparam = 269484032, lparam = 1
[2015-07-27 23:21:30][0x90:0x224] Message 0xC23B, wparam = 269484032, lparam = 2
[2015-07-27 23:21:30][0x90:0x4C0] Allocating blur buffer 1777 x 1057 [pixelFormat: 87, 1]  (D2D 0x00000041BA515940)
[2015-07-27 23:21:30][0x90:0x224] Message 0xC235, wparam = 0, lparam = 0
[2015-07-27 23:21:30][0x90:0x4C0] Allocating blur buffer 1694 x 1057 [pixelFormat: 87, 3]  (D2D 0x00000041BA515940)

 

-Noel

Share this post


Link to post
Share on other sites

This stability-testing debug build for 10240.

It contains some internal changes, new features etc. but it is not fully finalized yet so I don't describe it now. The only intention is to test the stability now.

 

(Win8-like atlas theme is distributed with it)

10240.jpg

 

http://glass8.eu

Thanks BigMuscle.

It's working fine for me also.

Even got ModernFrame working with it, although not with MS Edge.

Share this post


Link to post
Share on other sites

Just find U'r link to 10240... All seems to be stabile so far. Good Work and Thank U!

KPDzSCm.jpg

Share this post


Link to post
Share on other sites

New version is good, but theme win8cp work not correct for me:

 

0821c74fc261t.jpg

 

Theme from Noel is fine:

 

6f09c488536ft.jpg

Share this post


Link to post
Share on other sites

New version is good, but theme win8cp work not correct for me:

 

 

 

Are you really using the provided win8cp theme in the root of the zip-file? You seem to be using an old version.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...