Jump to content

WinNTSetup v5.3.1


Recommended Posts

Thanks!! WinNTSetup=Perfect!

[bTW: Nice touch to only diplay the "bits" when there's actually two different types. No need to "clutter" the list when they're all the same... Hadn't even thought about that. Shows us who's the genious....]

Edited by Atari800XL
Link to comment
Share on other sites

  • 4 weeks later...

Update: Version

- full Windows 8 support

- rewritten command line parsing

- rewritten WIM file operations (up to 10% faster NT6.x install)

- System Reserved partition now hidden in new installation

- added system menu tools

- automatically creates a pagefile if not enough RAM available

- new file patching engine, 5 times faster

- UEFI support

Thanks to Atari800XL for reporting so many bugs :thumbup


Edited by JFX
Link to comment
Share on other sites

I check this page often for updates, and to be honest I don't really understand why not more (much more!) people write here to thank you for this wonderful software. I'm sure there must be other ways that people thank you? Fresh flowers must be delivered to your door every day?

But seeing as it is relatively quiet around here, I was wondering if I could ask you USB-boot pro's (including Wimb) a little question that might be a little off-topic from WinNTSetup:

Last week I received a few PC's from about 2008. One was a Core2-E4500. My first step was to boot them with my WinPE_SE USB, because I wanted to use PE with WinNTSetup from this same USB to partiton/ format/ reinstall W7 and W8 (a grub multiboot setup I use often, sometimes also with XP).

But booting from USB gave me some very weird problems that I never really experienced before: The USB-boot was TOTALLY unreliable: sometimes it worked, other times it didn't. Sometimes it booted in USB-low-speed (1.1), other times fullspeed, but it was stuck at the very last stage of booting. This happened with different USB sticks. Now for the last couple of days things seem to go OK, but I really don't understand what was going on then. Now these PC's came from a school, and I was wondering if maybe this could have something to do with dust or other dirt (corrosion even?) collecting in the USB ports? There's no visible evidence of this however... And I used both the front *and* back ports!?? The system has been running perfectly for a coupe of days now, no USB or memory, or whatever problems anymore. Isn't this REALLY strange?

Sorry again for asking this slightly unrelated question in here, but I figured that if *anybody* would know about stuff like this, it would be you guys. Have you ever experienced something like this before?

Link to comment
Share on other sites

Strange USB Boot behaviour might be related to USB-stick.

Please try small size Portable USB-harddisk instead. Is much faster and stable.

Western Digital 320GB Elements Portable 2.5"


Edited by wimb
Link to comment
Share on other sites

Thanks Wimb, I know what you mean. But I tried different sticks on this system on that "fatefull day", all of which NEVER had problems before (used on dozens of systems). That's why I thought about a dirty or corroded connector (now if that's the case, a USB HD would also have problems, no?) Also, a 2,5" drive still doesn't fit in my wallet...

But from your answer I conclude that you *did* see some weird problems like these before? Thanks again for your reply!!

Link to comment
Share on other sites

Thanks a lot JFX,

Knowing such a power tool at hand is quite enjoyable to me,

Although I've never got chance to use myself ;) ( using same windows since 2007 :> , and it still works very well) I will have a chance some months later to install w7 (as a 2nd os :>)


ufd boot problems differs, up to main reason bios (long story, shortly bios fails to identify ufd as disk but as floppy), and to workaround (if possible, up to bios) a set of ways exists.....

Workarounds I know:

using small sized ufd, (wimb already mentioned)

using 2 partitioned ufd,

using grub4dos mbr OR nt5x mbr OR nt6x mbr (my personal experience, ntldr5x mbr caused trouble on my old hardwares, grubdos works, but I remember I had read opposite results too )

having boot file (grldr-ntldr whatever) close to disk map (I personally copy these files first to achive this, I am not sure but there was a size limit for that, maybe on cd or also on disk...)......

check bios settings and update bios if possible.....

and of course, using usb-harddisk (this should solve :)

and even better of course, using usb-cd (I use my dvdw this way with a box (converter) more than five years now)

none of both good for vallet

ps: converting ufd to cd (by using ufd chip settings) does not help solving this problem, I personally tested...

ps: if there is a solution of booting ufd first as floppy than doing things on dos, maybe grbldr.exe forcing floppy to disk, I do not know

My general personal solution that works so far good is (with 4gb kingston): preparing ufd disk with bootice using grld mbr option and double partition (1 of them very small). (made a newbie tutorial for that on Gena ufd prepare besides I do not think you are newbie :whistle: )

for usb1.1 case:

try your chance using different usb-slots, sometimes one of them works with 1.1. and other with 2.0 (I believe manufacturer going cheap with assuming 1.1 is for keyboard/mouse ) or maybe starts 1.1 at boot time (whatever...)

There is also plop http://www.plop.at/ that forces ufd work with 2.0 speed at boottime,

my personal choice so far is, starting plob from grub4dos and get back to grub4dos menu and boot from other stuff, still I did not have a chance to test this on a real hardware that fails that way.....

That is nearly all I know, which may help or not :angel

Link to comment
Share on other sites

@Lancelot_Real: Thanks! Of course it will help (if not in one way, then in another!)

I guess you guys have said all there is to say about this (slightly off-topic) matter, thanks! (and thanks to JFX for letting us go a little OT).

All the alternatives you mentioned will come in handy one day, but the original "strangeness" of the problem still stands: **WHY** would it boot in one case, but not in the other, with the same stick, on the same PC, etc. Something like black magic, powercrumbles, etc.?

[EDIT: I *did* make a test-CDRW of my WinPESE.iso, which *did* boot in 100% of the cases on that particular PC. But in the meantime, the USB port hasn't given me any more problems -- which is also strange as the problem seems unreproducable now....]

Edited by Atari800XL
Link to comment
Share on other sites

Hmm, that really strange, but remember I also had a funny board that act often different.

It often switched between USB 1.0 and 1.1 Speed, even with same USB disk.

On a cold boot, it never was able to boot from USB.

Guess most problems are related to stupid BIOS,

Lately had one machine that could not boot an XP boot sector on a 2K aligned partition.

After changing some BIOS settings it worked.


Edited by JFX
Link to comment
Share on other sites

I'm just wondering, do you solved the issue with Drive letter preassignment (to remind, it works perfect, except as it also assign the S letter to System partition what make it visible and not hidden)?

Everything else works perfect, great tool.

P.S. Is it possible to add (much) more tweaks (it is lot of the available sources), as it can make it really highly customizable tool for every installation (more personal targeted tool), e.g. change users drive, public drive, system wide right click extender, etc. (so, see e.g. Win Toolkit tweak & service menu)?

Run; RunOnce, RunOnceEx and FirstLoad (Active Setup Component - it execute just once after first login load) will be nice to be added.

Link to comment
Share on other sites

But from your answer I conclude that you *did* see some weird problems like these before?

...and much more than those, this aging page of mine still contains valid points (FAQ #10):


For the record just recently I found an (old) EPIA 5000 motherboard that for *whatever* reasons does need USB ZIP geometry AND NOT *any* grub (grub legacy/grub4dos/grub2) (but boots with the standard 2K/XP MBR+bootsector and with the Syslinux bootsector. Though I haven't done all the possible tests, I made quite a few (and then let it aside since I managed to solve the actual issue and needed to put back the machine to work).

But usually the issue (if USB/BIOS related) is in the very first phases of boot, what you reported does sound a lot like the motherboard needing a good clean (particularly the RAM sockets and the RAM be reseated).


Link to comment
Share on other sites

I'm just wondering, do you solved the issue with Drive letter preassignment (to remind, it works perfect, except as it also assign the S letter to System partition what make it visible and not hidden)?

Well, there is no real way to detect a "system" partition. Until Vista properly nobody has hidden his active partition, so i don't think the boot partition should be hidden by winntsetup in general.

Currently it checks if the drive label is called ""system reserved" and if the partition is smaller than 1 GB. If both true it will be hidden for the new installation.

Personally, I would suggest the change the partition id with diskparts setid command.

This way, any windows will never assign a drive letter to it

@lama & komital

I don't plan to add anymore tweaks to it. It's a simple setup tool not a tuning and tweaking suite :)

It should be possible to get most of these things done with the "Runafter" switch.


Edited by JFX
Link to comment
Share on other sites

  • JFX changed the title to WinNTSetup v5.3.1
  • wimb featured this topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...