Jump to content

schwups

Member
  • Posts

    1,212
  • Joined

  • Last visited

  • Days Won

    3
  • Donations

    0.00 USD 
  • Country

    Germany

Everything posted by schwups

  1. CTR: Extension ClassicThemeRestorer. It can be used to improve or to fix some icon glitches as well as the TabBar glitch. content.azure.backend: The config string is "gfx.content.azure.backends". The left value is used. Default is "direct2d1.1,skia,cairo" (Firefox52). ME doesn't support direct2D, so that in this case skia is used. https://www.slideshare.net/SotaroIkeda1/firefox-os-graphics-inside
  2. KM76.4.4 (changelog): - Bug 1154322 - Allow using skia for content rendering. r=jrmuizel (26413363e) Thanks RoyTam for allowing testing, if the change is for me. K-Meleon fails to start with skia ContentBackend on ME and XP. Is skia, in context to your builds, discussed somewhere? Date 06/24/2021 Time 13:47 K-MELEON caused an exception 03H in module MOZALLOC.DLL at 0177:016210bd. Registers: EAX=00000000 CS=0177 EIP=016210bd EFLGS=00000202 EBX=0347a34c SS=017f ESP=00feea70 EBP=00000001 ECX=00500ed3 DS=017f ESI=00000000 FS=5eff EDX=81ddcfbc ES=017f EDI=004f2425 GS=0000 Bytes at CS:EIP: 6a 03 c7 05 00 00 00 00 25 00 00 00 ff 15 04 20 Stack dump: 01f79d69 00feea88 016211f0 0664b180 00000000 0832d100 37392d5b 31393430 2323205d 21212123 4f424120 203a5452 6c756f43 6f6e2064 6e692074 61697469
  3. No, Palemoon has caused an error in <unknown>. PALEMOON caused an invalid page fault in module <unknown> at c239:00020001. Registers: EAX=8000ffff CS=0177 EIP=00020001 EFLGS=00010286 EBX=00000000 SS=017f ESP=0064fa30 EBP=024a4dd4 ECX=00000000 DS=017f ESI=024a4de3 FS=5de7 EDX=00000004 ES=017f EDI=0064fa01 GS=0000 Bytes at CS:EIP: 23 00 cd 31 5a 66 58 66 5b 66 59 0f 82 c6 01 8e Stack dump: 01f2809b 00000034 0000000b 02342052 011f75c8 0115d104 024a4dd4 00000000 024a4dd4 0115d104 00000000 011aba3c 04232f20 023422a0 0115d104 024a4dd4
  4. I'm sorry to say that I haven't a workaround to run RT's browsers NewMoon, Serpent, ArcticFox and IceApe so far. All versions crash on start. The reasons are different between NM26.5/27/ArcticFox and NM28/Serpent.
  5. Today I tried to run FF 52, Centaury ... on my other three active Win ME machines to verify that it works, to better isolate possible problems and to find out the exact requirements. So far I wasn't able to run these browser versions on my oldest system, Via PT880Ultra (P4V800D-X), P4 C Northwood which meets SSE2, NV5900XT (AGP). The highest FF version I can run is 48.0.2, here. There were no problems on the other two computers (iG31,P5KPL/1600, Core2Duo E8500, NV7900GS and i915, MS-7058, P640 Prescott, NV7800GT). Requirements: First get Firefox 48 running. - Kexstubs.ini - reg file APISets/Knowndlls - The UCRTBASE.DLL version 10.0.14393.33 of Firefox 52.9 or 10.0.14393.795 must be in the system folder! Don't use version 10.0.16299.397 of MyPal or Centaury. The DependencyWalker also misses the concrt140.dll. So it can be added, too. - dependentlibs.list A note on Cyberfox 49 - 52.9.1: The portable launcher needs Windows 7SP1 mode and the Cyberfox.exe Win XPSP2. no workaround for versions 50.x.x. Version 51.0.0 and 51.0.1 -> OK. 51.0.2 - 52.9.1 Problem - start in e10s mode by default. Multi process mode causes a crash on start. Solution - Simply add "user_pref("browser.tabs.remote.autostart", false);" to the prefs.js. Issues: * Low GDI resources - Possible problems with programs starting/running at the same time. Most affected MyPal. Go to about:memory and press "Minimise memory usage" under "Free memory" or restart the browser. * Sporadic letters that were slightly out of place and reduced in size. Open about:memory and press "Minimise memory usage". It fixes it for a short time only. * Sometimes error in Kexstubs on start - second start always OK. Most affected Cyberfox. * Seldom: Firefox starts without UI. Open the Taskmanager and close firefox.exe and firefoxportable.exe. The second start is always OK. MyPal: * Updater doesn't work ( Update check works - update fails after download) * Sometimes I can't close Tabs after a while. * "Input in address bar doesn't work on second browser start anymore / Search Engine List is empty". See issues Firefox 28 - 44 and here Centaury: Fixed with version 0.17: https://github.com/Feodor2/Centaury/issues/32 Boolean must be added: svg.in-content.enabled;true (not only issue on ME) The Search (Navigation Toolbar) doesn't work, if you set it back to "Old Search" with the ClassicThemeRestorer (Search Bar > Page 1). Centaury/MyPal: Sometimes - Error in Xul (browser restart required) And see FF issues on first page. I checked e10s on FF48 of my oldest machine (single core), too. But it was also completely unstable and unusable.
  6. e10s: FF52.9esr on XP => probably OK Multiprocess Windows: 2/2 (Enabled by user) FF52.9esr on ME => doesn't start without message IceDragon 52 on XP => probably OK Multiprocess Windows: 2/2 (Enabled by user) IceDragon 52 on ME => doesn't start "IceDragon has caused an error in IceDragon.exe" Centaury on ME => Multiprocess Windows: 2/2 enabled by user, but got an endless connecting (Tabs) with blank pages.
  7. The appropriate topic on MSFN: (https://msfn.org/board/topic/178466-force-multiprocess-mode-in-ff-52/) So far I only have read the first page. MyPal: e10s may not exist or is removed. Centaury: e10s is disabled by default. I enabled it for the check. I had all extensions enabled and later I also had them disabled (PlainOldFavorites, CTR, CAA, GitHub Web Components Polyfill), but this haven't made a difference. The first try was the worst. The Kext prompt appeared, because USER32.dll: RegisterTouchWindow (win7 API) was called and the user ressources (TaskManager) went down. I had to reboot. Then I disabled this API in the stubs.ini and I also tried different stubs, with the result that Electrolysis apparently basically works here (Multiprocess Windows: 2/2 enabled by user), but got an endless connecting (Tabs) with blank pages. Now I will finish reading Force "multiprocess mode" in FF 52 first.
  8. Hallo Jumper. So far, I have not examined or considered e10s in detail. Because of your request I have just tinkered with some settings on 52.9. browser.tabs.remote.autostart browser.tabs.remote.force-enable=true => FF doesn't start extensions.e10sMultiBlockedByAddons 52.9 haven't this boolean dom.ipc.processCount extensions.e10sBlockedByAddons extensions.e10sBlocksEnabling (default true) => Troubleshootinginfo: "disabled by addons") when set false => Info "WindowsXP" I will test different settings more closely in the next days. Quite a bit about Electrolysis: https://www.ghacks.net/2016/07/22/multi-process-firefox/ It remains exciting.
  9. Centaury 0.16 could have not only problems on ME. Logos (icons) are also missing on XP. It doesn't run very long here. At some point it encountered a problem and I must restart Centaury. https://github.com/Feodor2/Centaury/issues/32
  10. Obviously the Firefox default APISet dll loading of dependentlibs.list doesn't get along with forwarding dll's in the registry by knownDlls here. In details: The file "dependentlibs.list" is in the Firefox program folder. MSVCP140.dll api-ms-win-crt-runtime-l1-1-0.dll api-ms-win-crt-string-l1-1-0.dll api-ms-win-crt-heap-l1-1-0.dll api-ms-win-crt-stdio-l1-1-0.dll api-ms-win-crt-convert-l1-1-0.dll VCRUNTIME140.dll api-ms-win-crt-math-l1-1-0.dll api-ms-win-crt-filesystem-l1-1-0.dll api-ms-win-crt-environment-l1-1-0.dll mozglue.dll api-ms-win-crt-utility-l1-1-0.dll api-ms-win-crt-time-l1-1-0.dll api-ms-win-crt-multibyte-l1-1-0.dll nss3.dll lgpllibs.dll api-ms-win-crt-locale-l1-1-0.dll xul.dll => New: dependentlibs.list for Firefox 49 - 52.9 and Cyberfox 49 - 52.9.1 mozglue.dll nss3.dll lgpllibs.dll xul.dll ---------------- I also had Thunderbird 52.9 running. Still to be noted - the account wizard doesn't open (it freezes on start). MyPal: The "address bar workaround" to set search.json to read only may not work. I want to investigate further. The AzureContentBackend skia probably works fine on it. dependentlibs.list for MyPal (28 / 29) and Centaury: mozglue.dll nss3.dll gkmedias.dll lgpllibs.dll mozsqlite3.dll xul.dll Screenshot MyPal 29.2 on ME Centaury crashed with skia AzureContentBackend. So stay with cairo and use CTR. dependentlibs.list for SeaMonkey (2.46 - 2.49.5) and Thunderbird (52 - 52.9.1): LDAP60.dll mozglue.dll nss3.dll PRLDAP60.dll lgpllibs.dll xul.dll Msvcp140.dll and vcruntime140.dll aren't knowndll's and may remain in the file.
  11. Finally, I've found the problem. I'm running Firefox 52.9 esr. FF49+ doesn't run with the ApiSet Dll's in the dependentlibs.list on ME so that the ApiSet Dll entries must be removed. Supplement and Explanation: The reason is almost all MS APISet dll's aren't loadable on ME/98! This means Firefox tries to load them, but can't and outputs the message "Couldn't load XPCOM" and discontinues the start. The problem can be worked around with forwarding in the registry to Kernel32.dll and ucrtbase.dll. MyPal 28 and 29 start and run, too, but I've the issue of FF 28 - 44 "Input in address bar doesn't work after a while or second start anymore / Search Engine List is empty".
  12. https://c.searspartsdirect.com/mmh/pd_download/lis_pdf/OWNM/L0802638.pdf
  13. Some tests on XP: I mean that CID49/52 runs as good as FF49/52 on XP. CID needs the api-ms-win files just like Firefox. I can add them to system32 or the program folder. These were simply removed. Basically it is a Firefox with some additional security features/extensions. At this point, I cannot say whether these extensions are working properly here. What doesn't work is the installer! And I started Firefox on XP to compare about:support > failure log regarding "Unrecognized feature WEBRENDER". I had set FF52 to Compositing Basic (Hardware Acceleration disabled) and this error info appeared here, too. Then on ME, I started CID50 without profile (first run), but with a prefs.js and Hardware Acceleration enabled/D3D9. With the result that the message did not appear at least for the time being. It could be a new message/info of any failure regarding to a failing WebGL Renderer or feature. More research is needed to make this message clear. Probably it will never possible to use webgl without driver support on ME/98.
  14. Do you mean the ImportPatcher to Vista? No, I think the exe. Icedragon is usually set to XPSP2. It also starts with XPSP3, but not with Vista and higher. I experimented with DX11 files and had set CID for this purpose to Win7. Those tests are still at the very beginning. Sorry, now it's late in Germany and I'll go to bed. Jumper, many thanks for looking at this. Tomorrow I'll try the redirection. "Cid starting doesn't mean that it works completely." Maybe not, but I think it reaches 90% of stability and functionality of Firefox 52 on XP.
  15. roytam1, thanks for the information. It seems to me that skia works better on WinME.
  16. My msvcrt is 7.0.9981.0. (VLC Player requires 7.0) I also had tried to run Firefox 49+ with version 6.1.9848.0 and the original, but always without success. I assume that ucrtbase works with IceDragon 49,50 and 52 (because IceDragon runs), but then apparently not with Firefox 49 - 52. Just tested IceDragon to start without these registry strings again. I deleted them and then CID didn't start anymore! "API-MS-Win-Crt-Conio-l1-1-0"="UCRTBASE.DLL" "API-MS-Win-Crt-Convert-l1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-ENVIRONMENT-L1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-FILESYSTEM-L1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-HEAP-L1-1-0"="UCRTBASE.DLL" "API-MS-Win-Crt-Locale-l1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-MATH-L1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-MULTIBYTE-L1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-PRIVATE-L1-1-0"="UCRTBASE.DLL" "API-MS-Win-Crt-Process-l1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-RUNTIME-L1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-STDIO-L1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-STRING-L1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-TIME-L1-1-0"="UCRTBASE.DLL" "API-MS-WIN-CRT-UTILITY-L1-1-0"="UCRTBASE.DLL" So isn't it a proof that it works?
  17. I found only two and I think minor differences (selected) in the tree view before the break. DW LOGS: Both bring up the message "Couldn't load XPCOM" during profiling. CID with line Unloaded "WINMM.DLL" at address 0xBFDD0000", FF with line "DllMain(0x10000000, DLL_PROCESS_ATTACH, 0x00000001) in "MOZGLUE.DLL" returned 1 (0x1)." much earlier. CID loads after this line WSock32.dll, but FF not. After OK check on message the profiling continues. I doesn't get the message on CID start. CID usually runs without an error message. I get the message on FF start and it is aborted. Kexstubs.log: FF nothing and CID "= ntdll.dll:RtlIpv6StringToAddressW=o3 =" , but this line is also logged when FF4x is running. KernelEXAPILog: "Couldn't load XPCOM" with 1 f0265bb5 [Firefox.exe]004087e8:<Kernel32.dll>LoadLibraryW bfc00000 FF KEXAPILOG.doc
  18. ComodoIceDragon doesn't start without the APISetStub-strings in key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\SessionManager\KnownDLLs. I attached it here once more. The UCRTBASE.DLL must be added into the program or system folder, too. That again to requirements. And I have just compared CID 50 with FF50.0.2 (both have the same Gecko version) with DW. The tree of Firefox breaks to early after kexbases. Before that, both are almost exact identical. Jumper, what do you think? Knowndlls.txt
  19. A small compilation of possible or useful browser settings: Datareporting disabled: user_pref("datareporting.healthreport.service.enabled", false); user_pref("datareporting.healthreport.uploadEnabled", false); user_pref("datareporting.policy.dataSubmissionEnabled", false); user_pref("toolkit.telemetry.unified", false); Awesomefonts for icons (example): Awesomefonts must be installed user_pref("font.name-list.sans-serif.x-unicode", "Arial, Symbola, FontAwesome, Font Awesome 5 Free Solid, Font Awesome 5 Free Regular, Font Awesome 5 Brands Regular, Segoe UI Emoji, OpenSansEmoji, Microsoft Sans Serif"); user_pref("font.name-list.sans-serif.x-western", "Arial, Symbola, FontAwesome, Font Awesome 5 Free Solid, Font Awesome 5 Free Regular, Font Awesome 5 Brands Regular, Segoe UI Emoji, OpenSansEmoji, Microsoft Sans Serif"); user_pref("font.name-list.serif.x-unicode", "Tahoma, Symbola, FontAwesome, Font Awesome 5 Free Solid, Font Awesome 5 Free Regular, Font Awesome 5 Brands Regular, Segoe UI Emoji, OpenSansEmoji, Arial"); user_pref("font.name-list.serif.x-western", "Tahoma, Symbola, FontAwesome, Font Awesome 5 Free Solid, Font Awesome 5 Free Regular, Font Awesome 5 Brands Regular, Segoe UI Emoji, OpenSansEmoji, Arial"); To try: user_pref("gfx.downloadable_fonts.enabled", false); user_pref("browser.display.use_document_fonts", 0); or 1 user_pref("gfx.downloadable_fonts.woff2.enabled", false); user_pref("browser.urlbar.clickSelectsAll", false); maybe a bit more pleasant to edit user_pref("browser.urlbar.doubleClickSelectsAll", true); user_pref("browser.urlbar.trimURLs", false); to see the whole URL user_pref("browser.cache.disk.capacity", 32768); small value saves HDD space (of course more easy to set in options>advanced>network) user_pref("loop.enabled", false); Hello extension disabled if not needed extensions.pocket.enabled;false Pocket extension disabled if not needed Tab and icon glitches: user_pref("gfx.content.azure.backends", "skia,cairo"); Skia unsuitable on RT's FF45 / KM76 and IceCat / direct2D not supported UserAgent: user_pref("general.useragent.override", "(..."); example: Mozilla/5.0 (Windows NT 5.1; rv:50.0) Gecko/20100101 Firefox/50.0 D3D9 Hardware Acceleration: user_pref("layers.acceleration.force-enabled", true); user_pref("layers.prefer-d3d9", true); Disabling or deleting unsupported features (but otherwise blocked): webGL, d3d11 and direct2D media.windows-media-foundation.allow-d3d11-dxva;false user_pref("webgl.angle.try-d3d11", false); user_pref("webgl.disable-angle", true); webgl.disable-extensions;true user_pref("webgl.disable-wgl", true); user_pref("webgl.disabled", true); user_pref("webgl.enable-webgl2", false); user_pref("gfx.direct2d.disabled", true); gfx.direct2d.use1_1;false gfx.canvas.azure.backends;direct2d1.1,skia,cairo gfx.content.azure.backends;direct2d1.1,cairo to install unsigned Addons: user_pref("xpinstall.signatures.required", false); Video - YouTube (if necessary): user_pref("media.mediasource.webm.enabled", true); NewTabPage: user_pref("browser.newtabpage.enabled", false); crashes of versions 2x and 3x are possible if enabled Cleartype: gfx.font_rendering.cleartype.always_use_for_content;true
  20. RT's KM76 and RT's FF45 crash with skia AzureContentBackend here and on IceCat 38.8 is nothing readable. Cyberfox 48 is OK.
  21. Tab and icon glitches: The AzureContentBackend was changed with 52 from cairo to skia. I found the change to skia works for lower versions, too. I've successfully tested it with versions 31 and higher. 28 - 30 don't accept skia and cairo remains. The matching setting is (added skia): gfx.content.azure.backends;direct2d1.1,skia,cairo. Direct2D doesn't work anyway - it needs DX11. Direct2D can be deleted. (Release notes FF52: When not using Direct2D on Windows, Skia is used for content rendering) A possible new glitch is probably sporadic letters that were slightly out of place and reduced in size. After browser restart the glitch is gone again. I observed it on CID 52. NewTabPage feature: The customising of the NewTabPage is basically possible, if I added the appropriate bookmarks on XP (not possible on ME) for the desired thumbnails on the NewTabPage. Then it's possible to drag the bookmarks on the NewTabPage. I tested this on CID version 50. I assume that this also applies to Firefox versions 42 and higher. But I haven't tried this so far. According to my experience lower FF versions 2x and 3x often instantly crashed when I tried to open the NewTabPage. So that I used to turn it off. Compositing CID 49/50 : Basic: There are still but rare menu glitches here. I get two messages in about:support/Failure log 1. unrecognised feature webrender 2. DrawTargetCairo::Snapshot with bad surface 1 (repeated) Then with Hardware acceleration enabled D3D9: I see only "unrecognised feature webrender"
  22. There is no UI glitch (window is not completely displayed) on CID 49 - 52 anymore. Compositing is Basic. So there is no need to enable Hardware Acceleration for this purpose. Moreover the tab and icon glitches are gone with version 52. And I think I don't have crashes with "browser.newtabpage.enabled";true on higher versions, but considering that it is useless, it's better to set an URL with CTR (ClassicThemeRestorer )anyway. Other issues must still be taken into account.
  23. Ok, I have read that CID 50.0.0.2+ isn't installable on XP anymore. So I installed 52 and 57 clean on Win7 for test and comparison purposes. The installer works initially on ME. I'm able to check portable and choose a destination folder, but when I click the install button a message "not enough free space" appears and I can't go any further. So there are two possibilities: A portable installation on Win7 (Vista) to use it afterwards on ME. Or as I said to extract the Setup with 7Zip and simply run the exe (XPSP2 mode). I have not yet eroded the exact requirements. I attached my current Kexstubs.ini. And see additional requirements for FF42 - 48. Kexstubs.7z
×
×
  • Create New...