Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


All Activity

This stream auto-updates     

  1. Today
  2. Thanks for all responses, even if things got a little sideways, members are passionate. Note to vanilla Windows 98 users that don't have the desire or energy to research out-of-scope software, the last page or so contain fairly obvious references to some web browsers that won't run on a vanilla Windows 98 system, as well as kernel extensions and other operating systems. FWIW i also agree RetroZilla in vanilla Windows 98 is awesome. The fact that a browser still connects using this old OS is amazing. Will keep tweaking it based on all the feedback. These were linked a long time ago if anyone wants to dig through the remaining extensions that could be found. http://users.skynet.be/fa258499/extensions.html http://xsidebar.mozdev.org/modifiedmisc.html In addition to siria's advice, anyone using 'newer' XUL-based browsers and wants to search extensions, it is possible without having to install an add-on. The link below will be included in the modern web browser emulation notes. https://msfn.org/board/topic/177106-running-vanilla-windows-98-in-2020/page/16/?tab=comments#comment-1175476 Thank-you siria for sharing your knowledge and experiences. Anxious to review and test out your notes. Disturbing that Mozilla removes valid configurations from about:config, empty placeholders (null value, empty string) would have been helpful. Created and currently testing a couple new entries. Wish large organizations like Mozilla and Microsoft did a better job of archiving old information, rather than push new and shiny. Obviously for those who can't or don't want to purchase new hardware every few years, but also to demonstrate leadership as stewards of the environment. The killer circle situation is unfortunate. Guess the onus has been with the end user for many years. Maybe i'm a bit extreme but holding on to precious software is important. OS and gaming files deemed important are backed up in sync on three separate USB sticks, one stored off-site. After a fresh Windows 98 install, either a Linux dual boot or Linux live-CD is used to bulk transfer my entire Windows 98 goodies directory to the new installation, which provides all the necessary software to get things up and running. Just a thought, if this forum goes down it will be a very sad day for these old operating systems. There does not appear to be a lot of active Windows 9x discussion anywhere else. Thanks for the feedback Deomsh, will check if the printer requires USB2 support. Based on your recommendation downloaded NUSB33 from below (no JavaScript needed, NUSB.EXE, 756 KB, English). http://www.mdgx.com/web.htm#NUS Found a NUSB tutorial. https://www.raymond.cc/blog/how-to-install-usb-mass-storage-device-on-windows-98/ Sorry to hear about your printer, always sad when old hardware dies. Reason i want to keep my Canon MX310 going, ink refills don't even require a reset.
  3. on my old dell inspiron 3531, bigmuscle's aero glass never had a watermark same goes for when installed it on my old acer laptop back in 2018 this is why the watermark seems strange to me
  4. No worries, it's all pretty self-explanatory batch. It's not hard to decipher. I mostly left what was there intact, modified a few things, and added others. I also forked my own fork to create a version that silently installs MailNews and the appropriate version of New Moon. In theory, I could use Group Policy to add that as a startup script and it would automatically update the browser everyday!
  5. yeah... few mins ago i was thinking first i should document the code more clearly...
  6. I found an extension for Firefox, edited its install.rdf to allow SeaMonkey to install it. Then I used it to rebrand as Netscape. It worked. Now SeaMonkey looks like Netscape... fun! I did something quick just to see if it works, but later I will do a proper clean rebranding. It requires some icons and images and a few texts that are optional. I will get the Netscape default theme for its icons and Resource Hacker for some texts inside the app. For now I will leave it as it is.
  7. Yesterday
  8. I wouldn't worry about it anymore. I was able to successfully fork your scripts to do everything I needed. Here is my CHANGELOG: echo 1) Support for multiuser installation and use echo - To this end, shortcuts are now created in Public Desktop. echo - Backwards compatible with NT 5.x echo 2) Program execution by non-administrative users allowed echo 3) Shortcuts also created in Start Menu echo - Backwards compatible with NT 5.x echo 4) Updated information about MailNews in the HELP echo 5) Updated installer tip: "XP/vista" now "XP/Vista/7" echo 6) The following shortcut was renamed: "Interlink" to "MailNews" If you or anyone is interested I can post the modified code, but I'm guessing most others are fine with how it is now. Gotcha. I tried 7Z but it didn't work. I just left it as a bunch of files, works for me. I did have to comment out the stuff that expected it to be in a tmp dir and deleted everything post-install. Don't ask how I found out it did that...
  9. After the problems with the DOSBox images, I used Jaclaz' guidelines to make a Hard disk from a Grub4Dos Ramdrive. It seems that Partnew doesn't write to cylinder boundaries. Although Windows 98SE Setup doesn't complain, my MS-DOS util's do. So I wrote a correction in a Grub4Dos batch file. Since the Grub Util FAT seems only good for floppies, I wrote some batch lines to format the drive to FAT16 too. It's al in ONE file. Will make and format ALWAYS (hd0,0), first attached real hdd will be mapped to last hd. --------------------------------------------------------------------------------------------------------------------------- rd2hdf16.g4b --------------------------------------------------------------------------------------------------------------------------- !BAT debug off echo Make FAT16 HDD in memory: range 32-2047 MB set /a SIZE= :asksize echo echo Disk size in range 32-2047, integer numbers only echo Actual image size will be adjusted to cylinder boundaries! set /p /a SIZE=Enter disk size and press ENTER: clear if %SIZE%=="" goto validate if %SIZE%>=2048 goto validate if %SIZE%<=31 goto validate goto makeimg :validate clear echo Input is not a valid number, try again set /p CONTINUE=Try again? choose Y or N and press ENTER: clear if /I "%CONTINUE%"=="N" goto eof if /I "%CONTINUE%"=="Y" goto asksize echo :makeimg set /a heads=128 if %SIZE%<=2016 set /a heads=64 if %SIZE%<=1008 set /a heads=32 if %SIZE%<=504 set /a heads=16 set /a sectmax=%SIZE% * 2048 set /a sectrack=63 set /a secthid=63 set /a cylinder=%sectmax% / %heads% / %sectrack% set /a sectbal=%cylinder% * %heads% * %sectrack% set /a sectpart=%sectbal% - %secthid% set /a rdsize=%sectbal% * 512 # Create Partition - check: (rdsize/512)-secthid=sectpart set rdbase=33554432 set partid=0x06 map --rd-base=%rdbase% map --rd-size=%rdsize% map (hd0) (hd) map --unsafe-boot --heads=%heads% --sectors-per-track=%sectrack% (rd)+1 (hd0) map --hook partnew (hd0,0) %partid% %secthid% %sectpart% makeactive (hd0,0) # Create FAT16 on (hd0,0) rootnoverify (hd0,0) set oemid=GRUB4DOS set mediadsc=\xF8 # Set Sectors/cluster according win95 standards set /a ptstart=*0x82A8 set /a ptlength=*0x82B0 set /a dsksect=%ptlength% + %ptstart% set /a dsksize=%dsksect% / 2048 if %dsksize%<=2047 set secclust=\x40 if %dsksize%<=1023 set secclust=\x20 if %dsksize%<=511 set secclust=\x10 if %dsksize%<=255 set secclust=\x08 if %dsksize%<=127 set secclust=\x04 if %dsksize%<=63 set secclust=\x02 if %heads%==128 set numheads=\x80\x00 if %heads%==64 set numheads=\x40\x00 if %heads%==32 set numheads=\x20\x00 if %heads%==16 set numheads=\x10\x00 # Set First FAT set writfat1=%mediadsc%\xFF\xFF\xFF # Set Second FAT set writfat2=%mediadsc%\xFF\xFF\xFF # Write Bootcode Jump write (hd0,0)+1 \xEB\x3C\x90 # Write Bios Parameter Block # write --offset=0x03 (hd0,0)+1 oemid bytesect secclust rsrvsect numfats rtdirent totsect mediadsc sectfat sectrack numheads write --offset=0x03 (hd0,0)+1 %oemid%\x00\x02%secclust%\x01\x00\x02\x00\x02\x00\x00%mediadsc%\x00\x01\x3F\x00%numheads% # Write HiddenSectors from MBR dd if=(hd0)+1 of=(hd0,0)+1 bs=1 count=4 skip=0x1C6 seek=0x01C # Write TotalBigSectors from MBR dd if=(hd0)+1 of=(hd0,0)+1 bs=1 count=4 skip=0x1CA seek=0x020 write --offset=0x24 (hd0,0)+1 \x80\x00 # Write Extended Boot Record write --offset=0x26 (hd0,0)+1 \x29\x78\x56\x34\x12NO\x20\NAME\x20\x20\x20\x20FAT16\x20\x20\x20 # Write Magic Bytes write --offset=0x1FC (hd0,0)+1 \x00\x00\x55\xAA # Write FAT's write --offset=0x200 (hd0,0)+2 %writfat1% write --offset=0x20200 (hd0,0)+258 %writfat2% echo FAT sub-type: FAT16 echo Number of FAT's: 2 if "%secclust%"=="\x40" set /a secpclus=64 if "%secclust%"=="\x20" set /a secpclus=32 if "%secclust%"=="\x10" set /a secpclus=16 if "%secclust%"=="\x08" set /a secpclus=8 if "%secclust%"=="\x04" set /a secpclus=4 if "%secclust%"=="\x02" set /a secpclus=2 echo Sectors per cluster: %secpclus% echo Sectors per FAT: 256 set /a clusters=%ptlength% - 256 - 256 - 1 - 32 / %secpclus% echo Total clusters: %clusters% echo FAT start sector: 1 set /a drvspace=%clusters% * %secpclus% / 2 set /a mbspace=%drvspace% / 1024 echo %drvspace% KB total disk space (%mbspace% MB rounded down). :eof --------------------------------------------------------------------------------------------------------------------------- The FAT part has some weaknesses: Volume ID is not according to standards. Can be changed easily with command uuid --write. If desired, a Volume Label can be written with vol --write, after running rd2hdfat16.g4b
  10. Additional links: 1. From a browser with a UA advertising XP/Vista (NT<= 6.0) : https://browser.yandex.com/download?full=1 2, Using any UA: http://download.cdn.yandex.net/browser/_xp_builds/int/en/Yandex.exe http://download.cdn.yandex.net/browser/update/17_4_1_1026_2644_w_s_m/yandex.exe FTR, the downloaded file has a digital signature (it's dual signed, i.e. both SHA1+SHA256) dating from September 24th 2017 (not Mar. 2017, as stated...) The above behaviour is by design; only per user installations (not global) are allowed by the installer: https://yandex.com/support/browser/about/install.html That means the global installation directory (%PROGRAMFILES%) is not used, only the current Windows account's HOME directory (%APPDATA%) is... Their documentation describes what, to me at least, appears to be a fairly standard way: Anyone following my posts, especially in this thread, will surely know I'm an avid fan of Portable software installations, especially in the PAF format; this "love-affair" with portables began a long time ago, when I had a very small C: drive and I thus had to try/install various apps in my second, external USB, drive (then D:); also, having both the program's core files and settings in the same directory becomes very handy when you want to "re-install" or carry the fully customised program to a different host... While currently I have ample disk space in my "OS" drive, the habit of portable installs has endured all these years... However, in the case of Yandex Browser 17.6, the portable "package" is the ONLY way, because the proper YB 17.6.0.1633 installer is very hard to come across, plus it's been (artificially) blocked from launching under Vista (and, as I recall, I did mention this fact somewhere previously in this very thread... ); so, the available 17.4 installer being only capable of "per user" installations was not the reason I had chosen "portable" in this case... Best regards
  11. yes. known bug, I will work on that. basically another part of that same bug. that is basically what the end goal is, I think. What you say seems to be about what I have, sans mentioned bug. I could easily add a "dont make shortcuts" or a "put shortcut in public/private folder only" option. I used winrar to """compile""" (not really, just packing).
  12. App window title name is usually a standard Mozilla preference menu option.
  13. Desktop version runs on Electron and thus is actually a chromium-based web browser limited to specific apps. Try opening shared excel or word file in browser in Office Online, and then in Teams and you'll quickly realize they're same breed. Maybe check service workers? Weren't they disabled in Basilisk by default? I'd also take a guess that M$ might be blocking it if you do not use multithreading. check those options too.
  14. Nothing like having one's privacy violated just by Google, MS, Amazon and Facebook, isn't it?
  15. Epson multifunction inkjet current model WF-4740 has drivers for Windows XP x86. They are there in the Epson website driver selection dialog. Tested and works 100%. Scan driver: epson634915eu.exe (contains EpsonScan2_WF4740_64850_41_Signed, seems to be from 18-02-2020) Printing driver: epson627759eu.exe (seems to be from 31-10-2016)
  16. I am not sure if you want to ask me something about NVT OSA. This software can also be installed with Windows XP, in my opinion it is fundamental for the protection of an OS especially if no longer supported by Microsoft. Moreover, it also has a basic Anti-Exploit functionality that integrates perfectly with MBAE. https://www.novirusthanks.org/products/osarmor/
  17. Thanks for clarifying that. Microsoft nevertheless rates the vulnerability's severity as Critical for IE 11 on Windows 7, but only Moderate for IE 9 on Server 2008 SP2. I'm not familiar with OSArmor, but you've got me wondering if it could offer a better solution for Vista, i.e. block any process from jscript but not jscript9 (sorry if OT).
  18. Nothing jscript9.dll in I.E.8 with Windows XP.
  19. Yes, "I have tried the Microsoft workaround" actually meant that I "tried the alternative solution provided by Microsoft," and there is nothing "elegant" about it. If anyone else wants to try that, I would suggest that you first read about "negative side effects" at 0patch Blog and create a restore point. By quoting that, are you implying that Windows XP has no jscript9.dll, or that IE8 does not use it by default? I'm not sure what you mean.
  20. I'm not really a fan of Chinese browsers to be fair... You know, I don't want Winnie the Flu spying on me...
  21. Ahh thanks. Would have been awesome if there was some facility to see the download address/activity or view/verify the MD5 on the files or something like that. But with the age of Winfdows 7 it's moot now anyways. With the end of support, I'm trying to build one last image with everything in it, mostly to use in vBox. But as anyone with the chutzpah to be using NTLite already knows, the size of a complete Windows 7 installation is huge compared to previous versions such as XP. I'm pretty rusty, but I'm assuming NTL can trim that down a lot with the slipstreams. Still working on it.
  22. Oh, well, then you might have to try Chromium browsers like "Yandex Browser" or "360 Extreme Explorer", seems Firefox-based browsers doesn't have the features it needs.
  23. The Microsoft notice page says something like "arbitrary code execution", so I expect a demonstration page could open my notepad.exe and write some text like "you've been stoned!". :P) Could the loading of jscript.dll be exploited to do this? I tried running the 0patch test html code. IE8 shows the "restricted" yellow warning bar upon opening and explicit allowance is needed. My security zones setting are default. I modified the test html to this (from js sample code): <html> <head> <meta http-equiv="X-UA-Compatible" content="IE=8"></meta> </head> <body> <script language="Jscript"> var WshShell = new ActiveXObject("WScript.Shell"); var oExec = WshShell.Exec("notepad"); WScript.Echo("You have been stoned!"); </script> </body> </html> After explicit allowance twice, IE8 does open notepad, but Wscript.Echo is not executed. Maybe IE8 do not support all Wscript methods. I write js scripts for file and data processing, and not familiar with html. I do not use IE8 and WMP, but maybe some other program module use them. I think a real threat should get executed without explicit allowance, in the default setting. Could that be demonstrated?
  24. Have you tried the alternative solution provided by Microsoft? https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-0674 For 32-bit systems, enter the following command at an administrative command prompt: For 64-bit systems, enter the following command at an administrative command prompt: It could probably be an elegant solution with Windows Vista.
  25. I tried what you suggested, but nope. Nothing to do. Not NewMoon nor Basilisk are updated enough to support Teams: the web app starts loading as I tricked Microsoft by faking the user agent as you suggested, however after a bit of time it stops loading and just says that there's an issue.
  26. Hi, Please add to kernel32: RaiseFailFastException Its required to run app: Garden Planner -> AIR (adobe air.dll) http://smallblueprinter.com/garden/trial/index.html
  1. Load more activity
×
×
  • Create New...