Jump to content

Windows 7 on the Intel Alder Lake/Z690 platform


Carlos S. M.
 Share

Recommended Posts

On 6/19/2022 at 12:21 AM, Poseidon said:

Could someone share the ISO? I have an Aorus B660M + i5 12400 motherboard. I've tried everything, updating the ISO with the USB 3.x drivers, using these software that update the ISO image, I've tried at least 10 different ISOs and nothing. It always starts the installation, loads the data and does the installation. On the first boot it hangs on the STARTING screen and that's it. I had the same problem on another computer, with an Asus H510M + i5 11400F motherboard, but I managed to solve it with a specific ISO. I really need to use Windows 7 on this machine. Someone please.

PM me for testing image

Link to comment
Share on other sites

  • 3 weeks later...

On 12/7/2021 at 2:29 AM, Carlos S. M. said:

Hello, i've been recently messing with a Z690 motherboard and an Intel Alder Lake CPU

Managed to get Windows 7 installed, but it was tricky, decided to try an updated Windows 7 ISO with drivers (USB3, NVMe... etc) slipstreamed and tried out, found out Intel USB3 got updated enough that current driver infs lacked the IDs for the new chipsets and didn't recorgnize it, so i had to install using from another PC with modern Intel AHCI, then carry the drive over the system after the first stage of setup. I ended forcing one of the AMD USB3 drivers with success on the system.

Test machine specifications:
Intel Core i7 12700K
32 GB DDR4 3200
MSI Z690-A PRO DDR4 (Budget Z690 with decent VRM, DDR4 and PS2 port)
GTX 1060 3 GB
120 GB SSD (Kingston SSDNow V300)

What i could get working:

  • SATA/AHCI
  • HDA Audio
  • Most chipset stuff
  • USB3 (After forcing AMD XHCI Driver), although there are issues


What didn't work:

  • Onboard LAN (unsupported Intel controller)
  • IGP (that is expected though)
  • Few unknown devices


Untested:

  • NVMe
     

Known issues:

  • USB stops working after resuming from suspend (at least with AMDXHCI driver)
  • Single thread workloads may not allocatte in the right cores


USB3 setup, first attempt:

spacer.png

Setup after doing 1st stage setup and moving the SSD to the ADL system:

spacer.png

spacer.png

After finishing setup:

spacer.png

spacer.png

End results:
spacer.png

WEI score:

spacer.png

Can you share your ISO win7 setup that bro ?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...