Jump to content

360 Extreme Explorer Modified Version


Recommended Posts


Hi

The chrome360 browser works fine, there is only one problem, when launching the chrome360 browser 13.2206 or 13.2250 it always connects to an external IP 239.255.255.250:1900. I look on wikipedia and the IP address 239.255.255.250 (SSDP) is reserved. this private IP address is located in a class D network with a reserved IP range 239.255.255.0/24,  IANA, and is used for a lot of strange things like advertising... this does not happen with New Moon. this IP 239.255.255.250 refuses to be filtered :dubbio:
https://en.wikipedia.org/wiki/Simple_Service_Discovery_Protocol

Link to comment
Share on other sites

That's technically not an "external" address.

That connection isn't really a connection, it is a network discovery and Mozilla-based browser perform a "network discovery" also (I'll provide a screencap if you don't believe me).

If they concern you, go to chrome://flags, search for media router, and disable the pertinent flag - I'm showing three, please report your findings on which of the three prevents this INTERNAL connection.

Link to comment
Share on other sites

I should further point out that I see some forums where some ESET (antivirus and firewall product) users have blocked that "connection" and it fully disabled their Vivaldi, Opera, and Chrome from connecting to the internet.

As I mentioned above, it is not an "external" connection.

I find it a rolling-on-the-floor-in-laughter read on one of the Vivaldi sites.

Several people name-calling other folks and tellilng them to put their tinfoil hat back in the closet.

 

Thanks, that was a very hilarious way to spend my lunch break  :roll1:

Link to comment
Share on other sites

On 7/21/2021 at 5:10 PM, UCyborg said:

They're recent enough and if they were a problem (haven't gone researching how the one I have ties to CA certificates), it would show in Chrome 49 as well, not just V13. V9 - V12 all OK on XP.

I'm having the same issue. Getting certificate/TLS issues for sites like Discord and Ecosia, and rootcert issues for an SSL test site mentioned on this board. I'm pretty sure my certs were already up-to-date, but I ran the updater from Windows Legacy Update listed here just in case. Regardless, the issue persists.

(I do thank you for including Ecosia though, to whoever made this contribution! :D)

prob1.PNG

prob2.PNG

Link to comment
Share on other sites

37 minutes ago, beansmuggler said:

I'm having the same issue. Getting certificate/TLS issues for sites like Discord and Ecosia, and rootcert issues for an SSL test site mentioned on this board. I'm pretty sure my certs were already up-to-date, but I ran the updater from Windows Legacy Update listed here just in case. Regardless, the issue persists.

(I do thank you for including Ecosia though, to whoever made this contribution! :D)

prob1.PNG

prob2.PNG

Are you using 360EE on Win10?

In general these kind of browsers have some problems with certificates, depending on the operating system they are running. For example, I am trying to modify TS browser (based on Chromium) and I got the certificates to work on Win7, but not on WinXP. However, I was able to avoid the problems with the certificates by using the "--ignore-certificate-errors" flag in a shortcut or a BAT file. These errors are related to the fact that Chromium stopped being compatible with WinXP a long time ago and wanting to make it compatible with WinXP again causes this kind of errors to arise.

TS Browser --> http://tsbrowser.xiangtatech.com/

Flag source --> https://xpforever.miraheze.org/wiki/TS_Browser

Cheers.

Link to comment
Share on other sites

I am using the 360chrome version provided in this thread on XP with uBlock Origin and NoScript. I tried the "--ignore-certificate-errors", but the issue persists.

I also forgot to mention in my post that 360chrome seems to default to http:// instead of https:// on all URLs. Would this be fixed with a flag?

Link to comment
Share on other sites

13 minutes ago, beansmuggler said:

I am using the 360chrome version provided in this thread on XP with uBlock Origin and NoScript. I tried the "--ignore-certificate-errors", but the issue persists.

I also forgot to mention in my post that 360chrome seems to default to http:// instead of https:// on all URLs. Would this be fixed with a flag?

Have you tried using it without extensions? Do you have a firewall working or something that could perhaps modify the network settings? Which version of the browser are you using?

In relation to forcing https see this --> https://www.howtogeek.com/217017/how-do-you-force-google-chrome-to-use-https-instead-of-http-whenever-possible/

Cheers.

Link to comment
Share on other sites

ps - regarding HTTPS Everywhere (which again I don't use but nor do I have the need to visit https instead of http, why do I need a "secure" connection to check the weather or read the news?)

<excerpt from Wikipedia>

Other criticisms are that users may be misled to believe that if HTTPS Everywhere does not switch a site to HTTPS, it is because it does not have an HTTPS version, while it could be that the site manager has not submitted an HTTPS ruleset to the EFF, and that because the extension sends information about the sites the user visits to the SSL Observatory, this could be used to track the user.

</excerpt>

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...