Jump to content

[WIP] Windows Vista Extended Kernel


win32
 Share

Recommended Posts

3 hours ago, win32 said:

In other news, I am getting a GTX 650

This is good , you could use much newer onces , obviously . The thing is they want them for 1000 series and that's not possible. See my test above. Just finished it.

Link to comment
Share on other sites


i noticed that if i have server 2008 updates i can't install office 2010 anymore, it just blue screens every time i run the installer. anyone with the same problem?

i don't have the kernel yet, i was going to install if afterwards

edit: i found the reason why kaspersky 18 crashes with the newer versions of ex. kernel

basically the web antivirus component (i guess) scans the web pages you visit while using firefox and that makes both of them crash

i had kaspersky installed with the newest version of the kernel without firefox and it ran fine (even completed a full scan) but as soon as i got firefox on that laptop it broke itself

i don't wanna hear any comments about my av decision, i know i could use something else and maybe be fine but just letting you know

Edited by winvispixp
Link to comment
Share on other sites

Does anyone know if it is possible to get the AMD Radeon R4 Stoney Ridge to work with Vista? It does have a 6.0 section, so I was wondering if anyone knows of a way.

Link to comment
Share on other sites

10 hours ago, winvispixp said:

i noticed that if i have server 2008 updates i can't install office 2010 anymore, it just blue screens every time i run the installer. anyone with the same problem?

i don't have the kernel yet, i was going to install if afterwards

First instinct tells me that they did something to win32k that doesn't work so good for you. What happens if you try installing without GPU drivers or in safe mode?
Maybe it is best to stick to a 2021 win32k, because late 6002 era win32ks are not the most stable either; they can cause the system to crash if you close Firefox windows. I believe this happens if they are not maximized.
This happened on both my main workstation with a Quadro FX 3800 and a laptop with Intel HD Graphics 3000.
 

9 hours ago, Jakob99 said:

Does anyone know if it is possible to get the AMD Radeon R4 Stoney Ridge to work with Vista? It does have a 6.0 section, so I was wondering if anyone knows of a way.

That 6.0 section is probably a big void. Hopefully I can get a stable ntoskrnl extension regime going, but I won't be able to do much for now.

Link to comment
Share on other sites

I released a new extended kernel.

"FirefoxFix" and "SuperVerFix" are removed from osver.ini. You can use BuildNumber=7600 for Firefox instead, and use the regular version spoofing in other places too where those options would have been used previously.

CPU-Z (and other hardware verification software) works again, as does PCSX2 (x86 versions; the newer x64 native builds are still a ways to go, due to reliance on DX 11.3 runtime) and some newer compilers/linkers should work too.

A new installer is also used, which lacks the path issues of the previous one.
It has a built-in backup facility, and the installer can restore backups from another OS install or a PE environment by specifying the path of the Windows directory of your Vista install.
 

It can be obtained through all the known channels.

  • Like 3
  • Upvote 4
Link to comment
Share on other sites

1 hour ago, win32 said:

That 6.0 section is probably a big void. Hopefully I can get a stable ntoskrnl extension regime going, but I won't be able to do much for now.

Oh, so even if I modify its .sys in a hex editor (to change the version from 7600 to 6003), it still wouldn't work? Seems weird AMD left a blank 6.0 section in the INF.

Link to comment
Share on other sites

3 hours ago, Jakob99 said:

Oh, so even if I modify its .sys in a hex editor (to change the version from 7600 to 6003), it still wouldn't work? Seems weird AMD left a blank 6.0 section in the INF.

You can however copy all contents of the 6.1 section in the inf file to the empty 6.0 section (or rename 6.1 section to 6.0). Drivers up to version 15.6 work if modified this way.

Edited by TSNH
Link to comment
Share on other sites

On 6/10/2022 at 5:24 AM, win32 said:

ksecdd.sys is in system32\drivers, unlike the two others. I presume the nvidia driver is not in system32\drivers, or it would be shown as present. You can adjust dependency walker's paths so it can look in system32\drivers as well.

Yes , but all official drivers up to 372.70 can "see" it in the rifgt place . Everything after says "not found file". 

Dixel's rare 373.19 for Siemens acts like the normal drivers. Mine rare MSI 373.93 too. But these are a big exception since they are *supposed* to work with Vista. 

 

Link to comment
Share on other sites

7 hours ago, win32 said:

I released a new extended kernel.

Splendid news ! GetThreadErrorMode and K32GetModuleInformation included ?

Link to comment
Share on other sites

4 hours ago, D.Draker said:

Splendid news ! GetThreadErrorMode and K32GetModuleInformation included ?

K32GetModuleInformation on x64 only. This release was mostly about fixing bugs and bringing WOW64/x86 up to x64 functionality (more x86 DLLs available than before, but that is not 100% yet either).

Link to comment
Share on other sites

3 hours ago, win32 said:

This release was mostly about fixing bugs and bringing WOW64/x86 up to x64 functionality

Any plans to add GetThreadErrorMode ? Can't play Mortal Kombat 11 without it... also wanted to ask what about the stupid win-7 api-ms-win-core-crap empty files . Any solution ? Placing them in the folder with the game doesn't help ... 

Link to comment
Share on other sites

Right as i restarted my laptop after running the new installer i got greeted by this message

"This application has failed to start because KERNELOL.dll was not found. Re-installing the application may fix this problem."

The app in question is IAAnotif.exe, Its a fresh install with almost nothing on it besides netframework 3.5 and 4.6.1, drivers and visual c++ redists, i have every server 2008 update

late edit: in fact I can't launch any app because of the same error

Also the restorer is "unable" to restore the things it did

On 6/11/2022 at 6:42 AM, win32 said:

What happens if you try installing without GPU drivers or in safe mode?

"Microsoft Office Professional Plus 2010 encountered an error during setup."

no blue screen this time, same settings as before running in safe mode

if i have it on my pc before installing server 2008 bs and then doing that it works

Edited by winvispixp
Link to comment
Share on other sites

I have a request. Could you make nightly builds of Process Hacker work on Vista? This is what I get when I try to run it. I would use stable build, but it's outdated, plus, nightly builds are newer. (the last stable release was in March 29, 2016)

I also don't want to use Windows Task Manager.

When opening Nightly Setup:

prochackersetupvista.png

Nightly Portable:

prochackerbinvista.png

Here's the site: https://processhacker.sourceforge.io/nightly.php

Of course after clicking OK on these above errors, a "stopped working" dialog appears too.

Also, I noticed when running the Resource Hacker setup (downloaded from website http://www.angusj.com/resourcehacker/), it opens then closes quickly. In the previous release, it would open the setup, but just a blank window and unresponsive.

Link to comment
Share on other sites

12 hours ago, winvispixp said:

Right as i restarted my laptop after running the new installer i got greeted by this message

"This application has failed to start because KERNELOL.dll was not found. Re-installing the application may fix this problem."

You have to rename your original kernel32.dll to kernelol.dll and put it in syswow64.

I also have one bug to report: The CFF Explorer (Explorer Suite) setup (32-bit) crashes with the following error:

obraz.png.4c8ab6d6d092b777c2493d810b65c1ba.png

Edited by TSNH
Link to comment
Share on other sites

1 hour ago, TSNH said:

You have to rename your original kernel32.dll to kernelol.dll and put it in syswow64.

doesn't work

even with dllredirectionenabler.reg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...