Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
sonicenforce

Net framework?

Recommended Posts

Hello

 i need install net framework 1.1 for XP? install net framework 2 or 3.5 ? Net framework 4 core or extended?

 

Share this post


Link to post
Share on other sites

Version 1.1 is already very old, and for many years I have not come across programs that require this version. There are a lot of programs that need 2-4 versions, so it is advisable to install them. 2.0 and 3.0 versions are included in the version 3.5 package, so you only need to install it. Version 4, I always put the extended so that there is no situation when something is missing.

 

Share this post


Link to post
Share on other sites

If you are going to install all of them, please do it sequentially. 

Anyway, as ED_Sln said, I haven't encounter any programs running on .NET 1.1 for years now as pretty much everything targets .NET 4.0 or newer (newer version can't run on XP).

I personally kept all of them on my computer just in case, anyway .NET Framework 4.0 is supposed to have superseded all the previous ones so it's probably the only one you need.

Share this post


Link to post
Share on other sites
10 hours ago, FranceBB said:

anyway .NET Framework 4.0 is supposed to have superseded all the previous ones so it's probably the only one you need.

No, a program, for example, requiring version 2.0 will not start if only version 4.0 is installed. Each version is separate and will not replace previous versions.

12 hours ago, sonicenforce said:

Oh in my other PC   i have net framework 1.1...is need really  remove ?

If already installed, then let it stay. But the new system no longer needs to be installed.

10 hours ago, caliber said:

coup d' oeil ici

From here you need to download: https://download.microsoft.com/download/6/0/f/60fc5854-3cb8-4892-b6db-bd4f42510f28/dotnetfx35.exe
This is a complete installer of version 3.5, it includes versions 2.0 and 3.0.
And version 4 can only be downloaded by the 32-bit installer: https://download.microsoft.com/download/5/6/4/5641DA81-E6FA-4550-9F80-A1D862D9CFAA/dotNetFx40_Full_x86.exe

Edited by ED_Sln

Share this post


Link to post
Share on other sites

@sonicenforce

do you install a lot of programs on your PC?

The best way to check if you need specific version of .Net Framework is not to install it and check if your software works.

If you do not install a lot of new software, You should be able to keep only these versions you really need installed on your PC.

Programs for .NET 1.1 are very rare, so you can safely uninstall it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...