Jump to content

Browsing the web on 98/ME in 2019 and beyond


Recommended Posts

You were right (of course!) I did have to replace sunmscapi.dll with the older version!
Although Burp initially appeared to run OK with the new version, it crashed when trying to load the main interface.
Now it's fine. :yes:

I set up the proxy on Burp, generated and installed the PortSwigger (great name!) certificate on Opera 12, and then ran into the problem that nothing would actually connect.
After a lot of head scratching, that was finally fixed by disabling all the "Intercept" functions on Burp!

Every site I go to now on Opera 12 I seem to have to manually dismiss a huge list of certificate errors.
It does seem to work OK once I've done that, although it doesn't help with the poor rendering of many sites of course!

I did see that Burp had an option to spoof the User Agent string, but was a bit surprised to find that the Internet Explorer spoof seems to be IE6 on Windows XP! :o
Just a bit out of date I would have thought. The other options seem to be just for Android or iOS.

Anyway, the site I really wanted to get to work is the site where I've always manually download pattern files for my old Trend AV on Windows 98.
It recently started to refuse to connect with Opera 12, which I mainly why I started taking an interest in this.

The page now loads, but the download links still don't work, saying it can't make a secure connection.
Could you see if they do the same thing with your Burp/Opera 12 setup?


Link to comment
Share on other sites

I thought intercept was disabled by default otherwise i would have mentioned it, sorry about that. 

You should get zero certificate errors popups when using the proxy if the certificate export/import has been done correctly, I never see any.

As you've probably figured out, you can edit or create your own user agent spoofs, these are just examples.

I can go on the Trend Micro site and download the file with Opera 12 without using the proxy.

This being said one limitation of Burp is that it's not really suited for downloading large files as it will load them entirely in memory before passing them to the browser.

Using Burp I had no secure connection error when clicking on the file link but nothing but an hourglass happened in Opera and a message telling me it failed to allocate memory was on the Burp dashboard log. (Java VM uses a max of 250MB of RAM by default).

One workaround is to set the download url  as a streaming link somewhere in the options but I never tried that myself as it doesn't seem too practical (only read about it on the Burp forums) and I use JDownloader 2 for such cases: https://www.videohelp.com/software/JDownloader

There are a variety of settings you can try to change in case of connection issues but an important one is to make sure that the Java SNI extension is not disabled (in User Options > SSL > Java SSL Options) otherwise a number of sites fail to connect including everything powered by CloudFlare apparently.

Edited by loblo
Link to comment
Share on other sites

One step here. I'm running 2.1.04 jre8u131. Now I'm the noob. I tried export and import to Opera 12. Only the PKCS#12 format with privat key seems to match. Opera 12 doesn't show DER format. My first import attempt failed. Think I'll try now azul.

Link to comment
Share on other sites

I'm running Opera 12.50.1583 via Burp 2.1.04 on jre8u131! The DER import was possible via drag and drop. And I tried zulu8.48.0.49-ca-jre8.0.262-win_i686, Burp starts, but I got an error on creating Burp Project. "Failed  to create Burp Project: NullPointerException

picture - Opera 12.50.1583 via Burp 2.1.04 on jre8u131


Edited by schwups
Link to comment
Share on other sites

Opera 12.50, what OS are you on?

I don't get this error with Azul Zulu but I'm using the JRE from the JDK, maybe there is some difference (unlikely).

They've released an update within a few days, might be worth trying it as it possibly fix this bug, who knows?

Edited by loblo
Link to comment
Share on other sites

Of course WinME. 12.50 (Snapshot) should rather be called 12.5. After I changed sunmscapi.dll by sunmscapi.dll of jre8u131 the Project was created, stupidly it isn't possible to complete the secure transaction anymore.

Link to comment
Share on other sites

I see you're all running Opera 12.50.
Unfortunately I'm running Opera 12.02, which is the last version which will run on Windows 98SE, even with KernelEx.
I'm now wondering if that's why I'm not getting as good results.

I cannot import DER certificates into Opera at all, even by drag and drop, it just says there's no key and won't accept the file.
"PKCS#12 format with private key" is the only option which works.

Link to comment
Share on other sites

I don't think it was ever actually released.
AFAIK the last release of Presto Opera was 12.18.
12.50 seems to have never got past the beta stage, and was presumably abandoned when they went the Chromium route instead.
I'm pretty sure it won't run on 98SE, and frankly I'm surprised that it will run on ME!

Edited by Dave-H
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...